Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server for Debian

yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
edited February 21 in Linux
UPDATED 14 Jan 2017
New key for the server please update by
sudo curl http://shell.ninthgate.se/packages/shell.ninthgate.se.gpg.key | sudo apt-key add -

I have also removed the squeeze repo. (NOTE it still works on squeeze but change squeeze for wheezy in /etc/apt/source.list.d/plexmediaserver.list
Origninal modified post --->
Plex Media Server Repo for Debian

Hi.
We have decided to lock the other Debian thread and start a new one so I can edit the first post since Origin is no longer and has not been maintaing this package for a while.

All credits goes to Tobias and the other at Plex for PMS and the init script for Debian were made by Origin. I have just taken all there work and efforts and repacked it for Debian since the ubuntu package is not compatible since the change to upstart.

Down here is the instructions for installing PMS from my repo. This packages is for now compatible with Debian Squeeze , Wheezy and OpenMediaVault 0.3 , 0.4

First Time install

sudo apt-get install curl

If you are running Squeeze,Wheezy or Jessie with SYSVINIT
echo "deb http://shell.ninthgate.se/packages/debian wheezy main" | sudo tee -a /etc/apt/sources.list.d/plexmediaserver.list

If you are using Jessie with systemd then use the Ubuntu package from plex and you will get their repo.

sudo curl http://shell.ninthgate.se/packages/shell.ninthgate.se.gpg.key | sudo apt-key add -
sudo apt-get update
sudo apt-get install plexmediaserver


Upgrading

sudo apt-get update
sudo apt-get upgrade



The init script Original by Origin with a minor modification by me

#!/bin/sh
### BEGIN INIT INFO
# Provides:          plexmediaserver
# Required-Start:    $remote_fs $syslog $networking
# Required-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Plex Media Server
# Description:       Plex Media Server for Linux,
#                    More information at http://www.plexapp.com
#                    Many thanks to the great PlexApp team for their wonderfull job !
# Author:            Cedric Quillevere / origin@killy.net
# Rewamped           Christian Svedin / christian.svedin@gmail.com
# Version:           1.2
### END INIT INFO
 
# Read configuration variable file if it is present
[ -r /etc/default/plexmediaserver ] && . /etc/default/plexmediaserver
 
test -f "/usr/lib/plexmediaserver/start.sh" || exit 0
 
plex_running=`ps ax | grep "\./Plex Media Server" | awk '{ print $1 }' | wc -l`
 
case "$1" in
    start)
        if [ "$plex_running" -gt 1 ]; then
                echo "Plex already running..."
                exit 0
        fi
        echo -n "Starting Plex Media Server: "
        su -l $PLEX_MEDIA_SERVER_USER -c "/usr/sbin/start_pms &" >/dev/null 2>&1
        sleep 1
        echo "done"
        ;;
    stop)
        if [ "$plex_running" -eq 1 ]; then
                echo "Plex Media Server is not running (no process found)..."
                exit 0
        fi
        echo -n "Killing Plex Media Server: "
        # Trying to kill the Plex Media Server itself but also the Plug-ins
        ps ax | grep "Plex Media Server" | awk '{ print $1 }' | xargs kill -9 >/dev/null 2>&1
        ps ax | grep "Plex DLNA Server" | awk '{ print $1 }' | xargs kill -9 >/dev/null 2>&1
        sleep 1
        echo "done"
        ;;
    restart)
        sh $0 stop
        sh $0 start
        ;;
    status)
        if [ "$plex_running" -gt 1 ]; then
                echo "Plex Media Server process running."
        else
                echo "It seems that Plex Media Server isn't running (no process found)."
        fi
        ;;
    *)
        echo "Usage: $0 {start|stop|restart|status}"
        exit 1
        ;;
esac
 
exit 0
 
«13456744

Comments

  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    edited November 2016

    FAQ:

    Q: Why is there a different repo for Debian?
    A1: Because the current Ubuntu repo does not support Debian because Ubuntu has changed to upstart from System-V init.
    A2 Long version:
    It is possible to use the Ubuntu packages if you convert your Debian box to upstart
    make your /etc/apt/source.list look like this with vim/nano/whatever

    deb http://ftp.se.debian.org/debian/ sid main
    deb-src http://ftp.se.debian.org/debian/ sid main

    Now run

    apt-get update
    apt-get dist-upgrade
    echo 'Yes, do as I say!' | apt-get -o DPkg::options=--force-remove-essential -y --force-yes install upstart

    Cross your fingers and pray to all mighty DEBIAN god.
    reboot system.
    If everything started you can install the ubuntu package and repo.
    I have tested this on a fresh install of wheezy and only did the steps provided here and PMS works ... ... ... but.
    There is always a but. This is highly DO IT ON YOUR OWN RISK stuff.

    Q: My PMS does not appear on my PMC located on the same network.
    A: This should work, I have tested this on Debian Squeeze, Wheezy & OpenMediaVault 0.4
    LocalServers.png
    Incase it does not work here are some Workarounds:
    1. In your PMC --> Preference --> Network --> Manually specify server and put in your servers ip.
    2. Sign in your server with myplex and publish it onto internet. Now login to myplex with everyone of your clients and it should be there waiting with all your glorious media.

    Q: Can i see if my PMS is running.
    A: Use ps command to check if it is running, see example below.

    yakumo@May:/etc/avahi$ ps aux | grep plex
    plex 4549 0.0 0.0 12580 652 ? S Dec03 0:00 /bin/sh /usr/sbin/start_pms
    plex 4556 0.0 0.5 447836 19952 ? Sl Dec03 0:37 ./Plex Media Server
    plex 4607 0.0 0.2 433616 10648 ? Sl Dec03 0:17 /usr/lib/plexmediaserver/Plex DLNA Server
    plex 19479 0.1 1.1 367144 44340 ? SNl 02:07 1:00 Plex Plug-in [com.plexapp.system] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/System.bundle
    plex 27998 0.1 0.8 317252 34048 ? Sl 11:37 0:01 Plex Plug-in [com.plexapp.agents.imdb] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/IMDB.bundle
    plex 28034 0.1 0.9 246196 36628 ? Sl 11:37 0:01 Plex Plug-in [com.plexapp.agents.localmedia] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/LocalMedia.bundle
    yakumo 28345 0.0 0.0 14172 980 pts/3 S+ 11:56 0:00 grep plex

    Q: What architectures are supported?
    A: x86 and AMD64 is supported.

    Q: Where is the repo for Wheezy

    A: It is the same as for Squeeze.

    Q: I cant login to my remote installed PMS

    A:

    To be able to acess your PMs remote you need to set it up localy (and with localy you need to connect to the webinterface from the same network as the server is located on) first.
    so if your server is located on 192.168.0.200 you should be able to manage it from any computer located on the same network by going to http://192.168.0.200:32400/web
    However if you are not on the same network you have to set up an ssh tunnel to the server so you fool it you are one the same network.
    For instance from my Linux or OSX laptop i write:
    ssh -L 32400:127.0.0.1:32400 user@myserverip
    Then when I am logged in I can in my local browser write http://127.0.0.1:32400/web and you should be on your server and be abe to manage it and set it up for remote access/myplex sign in.
    Then the next time you should be able to connect to it with your login without doing the tunnel.
     
    You can also do tunnels via putty in windows just google it to see how. 
    sudo su plex cd /usr/lib/plexmediaserver plex@debian-pht-i386:/usr/lib/plexmediaserver$ export PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6 plex@debian-pht-i386:/usr/lib/plexmediaserver$ export PLEX_MEDIA_SERVER_HOME=/usr/lib/plexmediaserver plex@debian-pht-i386:/usr/lib/plexmediaserver$ export PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000 plex@debian-pht-i386:/usr/lib/plexmediaserver$ export PLEX_MEDIA_SERVER_TMPDIR=/tmp plex@debian-pht-i386:/usr/lib/plexmediaserver$ export PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR="${HOME}/Library/Application Support" plex@debian-pht-i386:/usr/lib/plexmediaserver$ export LD_LIBRARY_PATH="${PLEX_MEDIA_SERVER_HOME}" plex@debian-pht-i386:/usr/lib/plexmediaserver$ export TMPDIR="${PLEX_MEDIA_SERVER_TMPDIR}" plex@debian-pht-i386:/usr/lib/plexmediaserver$ ./Plex\ Media\ Server
  • dimik2000dimik2000 Members Posts: 16
    Previous post

    Please note you have is the same thing as me:
    Plex Media Server is not running (no process found)...
    Page:
    192.168.xxx.xxx:32400/web/index.html....
    opens without problems. It worked before.
    The problem is this:
    no PlexMediaCenter sees running PlexMediaServer!
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    Well its saying no process found since there is no process running at that time. In the next line it clearly says that it starts PMS. And if you get to the web interface is clearly running.
    If your media center does not see your server it is a whole other issue.
    How is your setup?
  • dimik2000dimik2000 Members Posts: 16
    Yes, the web interface works fine, media library created \ edited \ updated without problems.
    But PlexMediaCenter does not see PlexMediaServer.
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    dimik2000 wrote:

    Yes, the web interface works fine, media library created \ edited \ updated without problems.
    But PlexMediaCenter does not see PlexMediaServer.

    Sorry you don't seem to get what I am asking. I asked for your setup to start pinpoint what the trouble is since there is no problem with the install of PMS.
    Is your PMS and PMC located on the same network?
    Do you run PMC on windows or OSX?
    Do you have any firewall software on either the openmediavault machine or on your pmc machine? Är you using myplex on server and client?
    This things we need to know to be able to help. Give us as much info as possible.
  • dimik2000dimik2000 Members Posts: 16
    PMC in the network two:
    1) on the TV LG (SmartTV)
    2) on a laptop with OS Windows 7

    All PMC and PMS are in one network.
    page:
    192.168.xxx.xxx: 32400/web/index.html ....
    opens without problems with TV and laptop.
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    dimik2000 wrote:

    PMC in the network two:
    1) on the TV LG (SmartTV)
    2) on a laptop with OS Windows 7

    All PMC and PMS are in one network.
    page:
    192.168.xxx.xxx: 32400/web/index.html ....
    opens without problems with TV and laptop.

    Yhea there is some "problem" (setting) with the avahi in OpenMediaVault so PMS is no announced correctly.
    There is 2 work arounds here.
    1. In your PMC --> Preference --> Network --> Manually specify server and put in your servers ipaddress.

    2. Sig in your server with myplex and publish it onto internet. now login to myplex with everyone of your clients and it should show.
  • oggieoggie Members, Plex Pass Posts: 35 Plex Pass
    I don't understand the need for this additional repo, when the one from plexapp.com is still ok:

    deb http://www.plexapp.com/repo lucid main

    Is it only so that it uses upstart and not the old etc/init.d script?

    Having more than one repo available is not a good thing.
  • tobiashietatobiashieta Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 5,524 Plex Employee
    oggie wrote:

    I don't understand the need for this additional repo, when the one from plexapp.com is still ok:

    deb http://www.plexapp.com/repo lucid main

    Is it only so that it uses upstart and not the old etc/init.d script?

    Having more than one repo available is not a good thing.


    Plex officially supports Ubuntu, moxz is building and maintaining Debian packages for you and hosting them. That's why.

    Follow me on twitter @tobiashieta or G+

  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    Repo updated with 0.9.7.7.339-5ec3b53
  • antdudeantdude Members Posts: 28 ✭✭
    Hi!

    Newbie here. Are these Debian packages fully compatible with Debian stable? I don't want to use testing and others. Also, when will Debian add Plex Media Server packages to its official Debian servers?

    Thank you in advance. :)
  • w00tw00t Members, Plex Pass Posts: 19
    Hm. I decided to remove my previously version of plex.

    su
    dpkg -r plexmediaserver
    rm -r "/var/lib/plexmediaserver/"

    echo "deb http://shell.ninthgate.se/packages/debian squeeze main" >> /etc/apt/sources.list
    curl http://shell.ninthgate.se/packages/shell-ninthgate-se-keyring.key | sudo apt-key add -
    apt-get update
    apt-get install plexmediaserver
    apt-get update && upgrade

    root@xxx:~# /etc/init.d/plexmediaserver start
    Starting Plex Media Server: done

    root@xxx:~# /etc/init.d/plexmediaserver status
    It seems that Plex Media Server isn't running (no process found).

    :huh:
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    antdude wrote:

    Hi!

    Newbie here. Are these Debian packages fully compatible with Debian stable? I don't want to use testing and others. Also, when will Debian add Plex Media Server packages to its official Debian servers?

    Thank you in advance. :)


    First post says this repo is compatible with debian squeeze.
    Squeeze is the latest stable Debian out there (6.x)
    PMS will probably never be in the official Debian repo since it is closed source and secondley the Debian PMS repo is not an official packages from Plex.
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    edited December 2012
    w00t wrote:

    Hm. I decided to remove my previously version of plex.

    su
    dpkg -r plexmediaserver
    rm -r "/var/lib/plexmediaserver/"

    echo "deb http://shell.ninthgate.se/packages/debian squeeze main" >> /etc/apt/sources.list
    curl http://shell.ninthgate.se/packages/shell-ninthgate-se-keyring.key | sudo apt-key add -
    apt-get update
    apt-get install plexmediaserver
    apt-get update && upgrade

    root@xxx:~# /etc/init.d/plexmediaserver start
    Starting Plex Media Server: done

    root@xxx:~# /etc/init.d/plexmediaserver status
    It seems that Plex Media Server isn't running (no process found).

    :huh:


    What does a ps aux show?
    yakumo@May:/etc/avahi$ ps aux | grep plex
    plex      4549  0.0  0.0  12580   652 ?        S    Dec03   0:00 /bin/sh /usr/sbin/start_pms
    plex      4556  0.0  0.5 447836 19952 ?        Sl   Dec03   0:37 ./Plex Media Server
    plex      4607  0.0  0.2 433616 10648 ?        Sl   Dec03   0:17 /usr/lib/plexmediaserver/Plex DLNA Server
    plex     19479  0.1  1.1 367144 44340 ?        SNl  02:07   1:00 Plex Plug-in [com.plexapp.system] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/System.bundle
    plex     27998  0.1  0.8 317252 34048 ?        Sl   11:37   0:01 Plex Plug-in [com.plexapp.agents.imdb] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/IMDB.bundle
    plex     28034  0.1  0.9 246196 36628 ?        Sl   11:37   0:01 Plex Plug-in [com.plexapp.agents.localmedia] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/LocalMedia.bundle
    yakumo   28345  0.0  0.0  14172   980 pts/3    S+   11:56   0:00 grep plex
    


    If it shows soething like this it is running and you should be able to access it.
    If not the we need to see some logs off what is happening when you are trying to launch PMS
  • w00tw00t Members, Plex Pass Posts: 19
    MoxZ wrote:

    What does a ps aux show?
    yakumo@May:/etc/avahi$ ps aux | grep plex
    plex      4549  0.0  0.0  12580   652 ?        S    Dec03   0:00 /bin/sh /usr/sbin/start_pms
    plex      4556  0.0  0.5 447836 19952 ?        Sl   Dec03   0:37 ./Plex Media Server
    plex      4607  0.0  0.2 433616 10648 ?        Sl   Dec03   0:17 /usr/lib/plexmediaserver/Plex DLNA Server
    plex     19479  0.1  1.1 367144 44340 ?        SNl  02:07   1:00 Plex Plug-in [com.plexapp.system] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/System.bundle
    plex     27998  0.1  0.8 317252 34048 ?        Sl   11:37   0:01 Plex Plug-in [com.plexapp.agents.imdb] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/IMDB.bundle
    plex     28034  0.1  0.9 246196 36628 ?        Sl   11:37   0:01 Plex Plug-in [com.plexapp.agents.localmedia] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.6.335-522430d /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/LocalMedia.bundle
    yakumo   28345  0.0  0.0  14172   980 pts/3    S+   11:56   0:00 grep plex
    


    If it shows soething like this it is running and you should be able to access it.
    If not the we need to see some logs off what is happening when you are trying to launch PMS


    No process. What I can tell, when re-installing it it doesn't create anything in /var/lib/. Any suggestion?
  • antdudeantdude Members Posts: 28 ✭✭
    MoxZ wrote:

    First post says this repo is compatible with debian squeeze.
    Squeeze is the latest stable Debian out there (6.x)
    PMS will probably never be in the official Debian repo since it is closed source and secondley the Debian PMS repo is not an official packages from Plex.
    Thanks. :) I was trying to avoid third parties. I guess I can't avoid them to use Plex. :(
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    edited December 2012
    w00t wrote:

    No process. What I can tell, when re-installing it it doesn't create anything in /var/lib/. Any suggestion?


    So you have no PMs library in your /var/lib.
    yakumo@May:/var/lib$ ls -la | grep plex
    drwxr-xr-x  4 plex    nogroup 4096 Nov 26 15:17 plexmediaserver
    

    That is really strange.
    What happens if you try to install it again?

    First remove the package like this.
    yakumo@May:/var/lib$ sudo apt-get purge plexmediaserver
    [sudo] password for yakumo: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED:
      plexmediaserver*
    0 upgraded, 0 newly installed, 1 to remove and 93 not upgraded.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 127901 files and directories currently installed.)
    Removing plexmediaserver ...
    Plex Media Server is not running (no process found)...
    update-rc.d: using dependency based boot sequencing
    Purging configuration files for plexmediaserver ...
    Removing user `plex' ...
    Warning: group `nogroup' has no more members.
    Done.
    Processing triggers for readahead-fedora ...
    


    Now check if any plex folder is in /var/lib (it should not be after a purge (and also yours were already gone) ).
    yakumo@May:/var/lib$ ls -la | grep plex
    yakumo@May:/var/lib$ 
    

    Also check/edit /etc/apt/source.list to see if you have any other repo for PMS then mine.
    yakumo@May:/var/lib$ nano /etc/apt/sources.list
    
    My source file:
    deb http://ftp.se.debian.org/debian/ wheezy main contrib non-free
    deb-src http://ftp.se.debian.org/debian/ wheezy main contrib non-free
    
    deb http://security.debian.org/ wheezy/updates main contrib non-free
    deb-src http://security.debian.org/ wheezy/updates main contrib non-free
    
    #Multimedia
    deb http://www.deb-multimedia.org wheezy main non-free
    
    #PMS
    deb http://shell.ninthgate.se/packages/debian squeeze main
    


    If you have done any changes to your file now is a good time to do a apt-get update
    yakumo@May:/var/lib$ sudo apt-get update
    


    Now time to install PMS
    yakumo@May:/var/lib$ sudo apt-get install plexmediaserver
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      plexmediaserver
    0 upgraded, 1 newly installed, 0 to remove and 98 not upgraded.
    Need to get 74.2 MB of archives.
    After this operation, 0 B of additional disk space will be used.
    Get:1 http://shell.ninthgate.se/packages/debian/ squeeze/main plexmediaserver amd64 0.9.7.7.339-5ec3b53 [74.2 MB]
    Fetched 74.2 MB in 9s (8,212 kB/s)                                                                                               
    Selecting previously unselected package plexmediaserver.
    (Reading database ... 122620 files and directories currently installed.)
    Unpacking plexmediaserver (from .../plexmediaserver_0.9.7.7.339-5ec3b53_amd64.deb) ...
    Processing triggers for readahead-fedora ...
    Setting up plexmediaserver (0.9.7.7.339-5ec3b53) ...
    update-rc.d: using dependency based boot sequencing
    Plex Media Server is not running (no process found)...
    Starting Plex Media Server: done
    

    Check if it is running.
    yakumo@May:/var/lib$ ps aux | grep plex
    plex     12067  0.0  0.0  12580   652 ?        S    01:14   0:00 /bin/sh /usr/sbin/start_pms
    plex     12071  2.1  0.3 388812 14664 ?        Sl   01:14   0:00 ./Plex Media Server
    plex     12170 67.3  1.2 381124 47748 ?        SNl  01:14   0:04 Plex Plug-in [com.plexapp.system] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.7.339-5ec3b53 /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/System.bundle
    plex     12207  1.6  0.2 236316  9632 ?        Sl   01:14   0:00 /usr/lib/plexmediaserver/Plex DLNA Server
    plex     12240 42.0  0.7 246808 29032 ?        Sl   01:14   0:00 Plex Plug-in [com.plexapp.agents.movieposterdb] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.7.339-5ec3b53 /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/MoviePosterDB.bundle
    plex     12242 59.0  0.9 252884 35088 ?        Sl   01:14   0:01 Plex Plug-in [com.plexapp.agents.thetvdb] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.7.339-5ec3b53 /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/TheTVDB.bundle
    plex     12244 60.0  0.8 251836 34024 ?        Sl   01:14   0:01 Plex Plug-in [com.plexapp.agents.lastfm] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 0.9.7.7.339-5ec3b53 /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/LastFM.bundle
    yakumo   12330  0.0  0.0  14172   980 pts/2    S+   01:14   0:00 grep plex
    


    Now you should be set to go.
  • selieselie Members Posts: 1
    Hi all!!
    I am trying to install PMS but I get the following error:

    root@raspberrypi:~# sudo apt-get install plexmediaserver
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package plexmediaserver


    Do u know any solution?
    Thanks in advance.
  • TrudgeTrudge Gone off to greener pastures.... Members Posts: 9,360 ✭✭✭
    selie wrote:

    Hi all!!
    I am trying to install PMS but I get the following error:

    root@raspberrypi:~# sudo apt-get install plexmediaserver
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package plexmediaserver


    Do u know any solution?
    Thanks in advance.

    did you add the repo?
    Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
    Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
    Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
    Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
    Airplay & PlexConnect Targets: 4 x ATV3
  • yakumoyakumo Members, Plex Pass, Plex Ninja Posts: 1,095 Plex Ninja
    selie wrote:

    Hi all!!
    I am trying to install PMS but I get the following error:

    root@raspberrypi:~# sudo apt-get install plexmediaserver
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package plexmediaserver


    Do u know any solution?
    Thanks in advance.

    You are trying to install Plex Media Server on a Raspberry Pi? This is correct?
    First the PI has an ARM CPU so my repo has no ARM support and will probably newer have.
    Secondly the Pi is not designed for running this kind of applications it is to slow to little ram.
    If you are after a thin client well the it is an whole other story and you should check this thread.

    Hope that cleared some things for you.
«13456744
Sign In or Register to comment.