Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Windows App Unable to Connect to Localhost Server

WaggersWaggers Members, Plex Pass Posts: 27 Plex Pass

I've just downloaded and installed Plex Media Server and the Windows 8 client onto the same PC.

 

Ran through the server setup without problems but the Windows 8 client (purchased from the Windows 8 store) can't find the server.

 

After spending a couple of hours playing, I've found that if I install the server on another machine the client will see it, or if I install the ordinary windows client (as opposed to the Windows 8 client) that will find the server.  To summarise:

 

Windows 8 Client & Plex Server on same machine - Server not found

Windows Ordinary Client and Server on same machine - Server found

Windows 8 Client and Server on different machines - Server found

 

Can anyone give me some pointers?  Or, failing that, how do I get a refund for the Windows 8 client?

 

Many thanks

 

Richard

Best Answers

  • WaggersWaggers Members, Plex Pass Posts: 27 Plex Pass
    edited March 2013 Accepted Answer

    Thanks for the response - I've also found another post the suggested opening an admin command prompt and run:

    checknetisolation.exe LoopbackExempt -a -n=caf9e577.plex_aam28m9va5cke

    That worked for me.

Answers

  • TrudgeTrudge Gone off to greener pastures.... Members Posts: 9,360 ✭✭✭

    restart the server software so it will auto add a "loopback exemption" to get around MS's retarded new security policies.

    if that doesn't work, you can add it manually -> http://forums.plexapp.com/index.php/topic/52889-cant-connect-to-server-solved/?p=321471

    Primary PMS: Ubuntu 13.10, i7-4771, 16GB Ram, Samsung 840 Pro 512GB
    Media Storage: 2 x ReadyNas Pro Business 18TB mounted by NFS to Plex Server
    Desktop Clients: 1 x Windows 7 27", 1 x 15.4 Retina MBP, 2 x17" MBP, 1 x 13" MB, 1 x13" MBA
    Mobile Clients: 2 x iPhone 5s, 3 x iPhone 5, 3 x iPhone 4s, 3 x iPhone 4, 2 x iPad 3, 2 x iPad 2
    Airplay & PlexConnect Targets: 4 x ATV3
  • WaggersWaggers Members, Plex Pass Posts: 27 Plex Pass
    edited March 2013 Accepted Answer

    Thanks for the response - I've also found another post the suggested opening an admin command prompt and run:

    checknetisolation.exe LoopbackExempt -a -n=caf9e577.plex_aam28m9va5cke

    That worked for me.

  • mfeingolmfeingol Members, Plex Pass, Plex Ninja Posts: 5,091 Plex Ninja

    Since you solved your own problem so nicely and even posted the command line, I'm going to pin this thread for others.

  • Puppaz1Puppaz1 Members Posts: 21 ✭✭

    From main command line I ran: checknetisolation.exe LoopbackExempt -a -n=caf9e577.plex_aam28m9va5cke

    "Error: Access Denied, run the command as an administrator"

    Huh? The user I'm running IS the Admin. Just checked... Any ideas?

  • Puppaz1Puppaz1 Members Posts: 21 ✭✭

    Go to cmd app. right click, and select run as administrator.

    That loopback workaround  didnt work for me. Might there be another reason My Plex media server keeps disconnecting if left idle >30minutes? 

  • Puppaz1Puppaz1 Members Posts: 21 ✭✭

    Maybe my problem is obvious, but not to me.

    I'm pretty new to PMS. I have the server running on a brand new Dell Windows8, with a local Windows8 client. Also have a Mac, ipad, Kindle, SamsungTV and Windows7 laptop apps for viewing. I was sooo excited after i installed and was able to watch everything around my house. But then.... PMS on my Windows 8 disconnects after about an hour of being idle. i can get it back if I click test or refresh over&over&over again. Most times if I reboot the PC, PMS will come back. That's obviously a horrible solution, and makes viewing videos from other places impossible.

     

    At first i thought it was because of the Windows8 app running local on the same machine as PMS, so I ran the quirky firewall fix: checknetisolation.exe LoopbackExempt -a -n=caf9e577.plex_aam28m9va5cke

    But that didn't fix any thing. I also changed my PC setting to always on, never go to sleep (I'm sure there's a better way). That didn't help. Is there something funky going on with the network I should check out.  I just don't know where to start debugging. I already tackled the logical stuff. Might there be another reason My Plex media server keeps disconnecting if left idle >30minutes? A few suggestions I should check?  I'd be more than happy to document a whatever workaround hack that gets me going here.

  • mfeingolmfeingol Members, Plex Pass, Plex Ninja Posts: 5,091 Plex Ninja

    Ramanonos:

    That sounds like the server is having issues.

    Are client and server on the same machine?

    When the client can't talk to the server, can other clients talk to the server?

  • Puppaz1Puppaz1 Members Posts: 21 ✭✭

    I have the local windows 8 app running on the same machine as the PMS. This is the only client that's useable, but i still have to reboot every day to use it (dreaded server can't connect). Once I reboot, it works, until the next day..

    I also have the windows flagship app running on a windows laptop, a mac app, an android app, and an iphone app.  Bottom-line is ALL of the app on every device EXCEPT for the local machine with the PMS is useless. Best case, I'll reboot the PMS machine to try to watch something in my livingroom on the laptop, and it poops out after a few minutes. Freezes, gone... Every other device acts the same way. Trying to connect outside the home is total joke.  I can't believe I'm the only one that thinks this Plex thing is completely unuseable. I really want it to work, and committed to do so, but very frustrated with this project.  And yes I've poured through these forums. Embarrassed to say how long I've spent on this.

  • zeteticelencherzeteticelencher Members Posts: 26 ✭✭
    edited May 2013

    Thanks for posting this thread Waggers. I just ran into this problem and I knew if I checked here someone would have posted a solution.

    If I could kiss you I would!

  • WaggersWaggers Members, Plex Pass Posts: 27 Plex Pass

    Aw shuks [blush]

  • Rickster128Rickster128 Members, Plex Pass Posts: 12

    @ Rammonos, I am having the same issue did you get it resolved?

  • c.cowlrick@gmail.comc.cowlrick@gmail.com Members, Plex Pass Posts: 63 Plex Pass
    Waggers wrote on March 9 2013, 2:40 PM: »

    checknetisolation.exe LoopbackExempt -a -n=caf9e577.plex_aam28m9va5cke

    running this command in elevated command prompt did not work for me.

    I then uninstalled/reinstalled and it works. 

    Hopefully it stays this way and I can actually consider using it on my desktop. 

  • StartkabelsStartkabels Members, Plex Pass Posts: 18 ✭✭

    what did you uninstall/reinstall?

  • stigmaleonstigmaleon Members Posts: 3
Sign In or Register to comment.