Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Blur update for Plex Home Theater?

salgasalga Members, Plex Pass Posts: 37 Plex Pass
edited March 2013 in Blur

Hi all.

 

Is anybody working on a Blur update for Plex Home Theater (PHT)?

 

Please don't let Blur die: it's still the best skin out there...

 

Thanks,

Luca

Comments

  • jaapsjaaps Members, Plex Pass Posts: 187 Plex Pass
    edited April 2013

    I hope to update this someday. I'm not totally sure what has changed and even if all the changes are in the final version of Plex.

    I currently have no subscription on the plex pass so I can't work on it myself (I do have access to the forums it seems even though I haven't been subscribed for a while)

    Edit:

    You may try copying the file MyVideo.xml in the 720p folder and name it MyVideoNav.xml. I'm not sure if this works but seems to do the trick with some other skins.

    Running PMS + PlexConnect on a headless Ubuntu server. Clients: Apple TV 3 and iPad.

  • salgasalga Members, Plex Pass Posts: 37 Plex Pass
    edited April 2013

    Hello Jaaps, and thank you for your response.

    Even though I am a lifetime PlexPass member, I am not using PHT yet.

    But I've been a devotee to Blur since it was available. IMHO it is still the best skin around: no frills, basic if you will, but extremely functional and quite elegant. I wish it would replace Mediastream as the default skin for Plex... But I'm digressing.

    I don't think it's by any means necessary for you or anybody else to update Blur for the beta versions of PHT, especially if you don't have much free time (who does? :-)

    What I'd kindly ask, if you have some time, is to update it so that it works correctly with PHT once it gets finally released.

    Thanks!

    Luca

  • quatrefuryquatrefury Members, Plex Pass Posts: 2

    Now that PHT is out, is anyone going to update this skin to work with it?

    The default skin does not work for my uses as the menu bar comes up when I pause and blocks the subtitles I wanted to read when I paused. Blur does not do this plus it has the very clean and simple UI that I like as well.

  • jaapsjaaps Members, Plex Pass Posts: 187 Plex Pass

    I'm currently using PlexConnect for my own use. I have tried PHT a tiny bit but waiting on PlexELEC before making a choice between PHT and PlexConnect.

    If everything works out with PlexELEC I might update this skin, but no promises. 

    But are there actually people still using blur?

    Running PMS + PlexConnect on a headless Ubuntu server. Clients: Apple TV 3 and iPad.

  • jj0076jj0076 Members, Plex Pass Posts: 105 Plex Pass

    Hi, I wanted to add my voice to this request and to answer your question "But are there actually people still using blur?"

    I'm new to plex but have bought a year plexpass after less than a month and blur is my skin of choice. I was planning to upgrade to PHT tonight but just found this thread....does the skin not work at all? If I go to PHT now do I have to do it without blur??

  • quatrefuryquatrefury Members, Plex Pass Posts: 2
    edited November 2013
    jaaps wrote on November 25 2013, 2:34 PM: »

    I'm currently using PlexConnect for my own use. I have tried PHT a tiny bit but waiting on PlexELEC before making a choice between PHT and PlexConnect.

    If everything works out with PlexELEC I might update this skin, but no promises. 

    But are there actually people still using blur?

    Yeah, I went through nearly every skin I could find and still ended up using Blur over all others. This skin is one was the reasons I chose to run Plex over any other app.

    I tried to just move the skin over and it changed it over but the menus were all broken.

  • salgasalga Members, Plex Pass Posts: 37 Plex Pass

    Jaaps, yes, I believe many of us would still choose the beautiful simplicity of Blur over anything. Please, bring us a Blur for PHT!

    Thanks,

    Luca

  • laskounelaskoune Members Posts: 1

    One more vote for Blur from me. It's my favourite skin, no contest!

    Please make a version for PHT.

  • RobSibyRobSiby Members Posts: 10 Plex Pass
    +1
  • chantalcoolsmachantalcoolsma Members Posts: 5 ✭✭

    +1

  • ryanmclaughlinryanmclaughlin Members, Plex Pass Posts: 9 Plex Pass

    +1

    This is the only skin that seems to be professionally designed.

  • info@danny-s.cominfo@danny-s.com Members, Plex Pass Posts: 82 Plex Pass

    And another +1 from me. PHT skins are thin on the ground...good ones even more so!

  • bigo72bigo72 Members, Plex Pass Posts: 71 Plex Pass

    My +1 is here, guys! And anyway, in general, it looks nobody is working on Plex Home Theater skin's porting..... I think .... there is quite a messy situation around the web and I can't figure out where is possible to download new skins

  • zombianzombian Members, Plex Pass Posts: 343 Plex Pass
    Would love an update for PHT.

    A lie can get half way across the world before the truth even gets its shoes on.

  • randomizerandomize Members, Plex Pass Posts: 3 Plex Pass

    PHT has been out of beta for a while now and I was wondering if there was any work being done on getting Blur working with it?  This is by far my favorite skin for Plex and I would love to start using it again.

  • PlexformPlexform Members Posts: 3 ✭✭

    Any news on this?

    I've updated my machine to 10.9 recently, and found out that Blur isn't working anymore. Preen is crashing on start, I've tried to install Blur manually (placing the folder in app/content), but no luck :(

    Please Jaaps, update it, its by far the best skin! I'm thinking to downgrade my machine, worked fine on 10.8

  • dlanordlanor Members, Plex Pass Posts: 2,215 Plex Pass
    Plexform wrote on June 23 2014, 4:06 PM: »

    Any news on this?
     
    I've updated my machine to 10.9 recently, and found out that Blur isn't working anymore. Preen is crashing on start, I've tried to install Blur manually (placing the folder in app/content), but no luck :(
    Please Jaaps, update it, its by far the best skin! I'm thinking to downgrade my machine, worked fine on 10.8


    10.8, 10.9 ???
    I'm not aware of any plex components using such version numbers, so please clarify what it was you updated.

    The latest version of PMC is v0.9.5.4 and it should be compatible to the old PMC versions of Blur.
    But that program is obsolete and is no longer supported by the Plex team.

    The latest version of PHT is v1.1.4.297 and it can not use the Blur skin (nor can the older PHT versions).
    This is the new 'flagship' Plex client, supported for Windows, OSX, and various Linux dialects.


    If the 10.9 refers to an OS version, then I guess the obsolete PMC is no longer fully compatible to that OS.
    This will not improve, as PMC has no further support, so your best option is to install PHT instead.
    If you want access to the newer Plex features you will need to do that anyway.

    But Blur is not available for PHT, which has only a few good custom skins (notably 'Amber' and 'Night').

    Best regards: dlanor
  • PlexformPlexform Members Posts: 3 ✭✭
    edited June 2014
    dlanor wrote on June 24 2014, 11:17 PM: »

    10.8, 10.9 ???
    I'm not aware of any plex components using such version numbers, so please clarify what it was you updated.

    The latest version of PMC is v0.9.5.4 and it should be compatible to the old PMC versions of Blur.
    But that program is obsolete and is no longer supported by the Plex team.

    The latest version of PHT is v1.1.4.297 and it can not use the Blur skin (nor can the older PHT versions).
    This is the new 'flagship' Plex client, supported for Windows, OSX, and various Linux dialects.


    If the 10.9 refers to an OS version, then I guess the obsolete PMC is no longer fully compatible to that OS.
    This will not improve, as PMC has no further support, so your best option is to install PHT instead.
    If you want access to the newer Plex features you will need to do that anyway.

    But Blur is not available for PHT, which has only a few good custom skins (notably 'Amber' and 'Night').

    Best regards: dlanor

    Thanks for responding. Guess I don't have that much knowledge Plex then…

    Both PMC and PHT are required for program to run, correct?

    I'm not sure which versions of PMC and PHT i had before when my MacBook was running on OSX 10.8.5, but both Preen and Blur skin worked fine.

    I needed to replace my hardrive with faster SSD, and I've clean installed OSX 10.9.3 Mavericks. I know that i have PMC v0.9.0.12.504 but I'm not sure which version of PHT is (I've downloaded both from https://plex.tv/downloads, so I guess they are the latest versions). I've installed Preen and its crashing on start. 

    Honestly I don't care for any new features, I just want to play movies and tv shows from my computer, like I did before, thats it.

    What would you recommend to me? To delete everything and install some older versions of PMC + PHT? Where can I find those, and how should I install Blur skin in that case if Preen is crashing on Mavericks?

    Thanks a lot for help, I appreciate it.

  • dlanordlanor Members, Plex Pass Posts: 2,215 Plex Pass
    edited June 2014
    Plexform wrote on June 25 2014, 10:32 AM: »

    Thanks for responding. Guess I don't have that much knowledge Plex then…
     
    Both PMC and PHT are required for program to run, correct?


    I think you're confusing PMC with PMS...

    Perhaps I'd better clarify the situation for you then, in regard to all these acronyms:

    PMS == Plex Media Server
    Such a server is required for ALL use of any Plex clients.
    (But you can share sections from such a server to users with a Plex account but no server of their own.)

    PMC == Plex Media Center == the old 'flagship' Plex client for PCs of all kinds, and it's now obsolete.

    PHT == Plex Home Theater == the new 'flagship' Plex client for PCs of all kinds, and has replaced PMC.

     

    I'm not sure which versions of PMC and PHT i had before when my MacBook was running on OSX 10.8.5, but both Preen and Blur skin worked fine.


    If Blur worked fine then it must have been PMC that you used.
    I've heard that Preen can install skins for PHT as well, but most of the skins available will only work with PHT versions which are equally old and obsolete as PMC is. (There have been MAJOR design changes in PHT in the last six months.)

     

    I needed to replace my hardrive with faster SSD, and I've clean installed OSX 10.9.3 Mavericks. I know that i have PMC v0.9.0.12.504


    I'm pretty sure you mean PMS v0.9.9.12.504, which is the latest release of the Plex Media Server.

     

    but I'm not sure which version of PHT is (I've downloaded both from https://plex.tv/downloads, so I guess they are the latest versions).


    I'm not sure how it works with OSX, but in Windows you can check the version of a program simply by selecting the program file in an 'Explorer' window, then right-clicking it and in the popup menu choosing "Properties" and in the properties dialog click the "Details" tab. In OSX the procedure is probably entirely different but some similar way of reaching version info should be available.

    In any case the current PHT version is 1.1.4.297, so if you downloaded just a few days ago, that is what you should have, but if you downloaded a week or longer ago then your version will be slightly lower. But all versions available are incompatible with Blur, and I strongly doubt that Preen has any suitable skins to offer for modern PHT versions.

     

    I've installed Preen and its crashing on start.


    Well, that seems to be a total 'show-stopper' as far as using Preen goes.
    Unfortunately I have no advice to give on this since I've never used an OSX computer, and Preen is not available for Windows.

     

    Honestly I don't care for any new features,


    That may be in part because you're unfamiliar with them. Still, that choice is yours to make.

     

    I just want to play movies and tv shows from my computer, like I did before, thats it.


    You should be able to do that with PHT too, though I guess you just don't like its default skin.
    There are some others around though, notably Amber and Night (there's even a PlexAeonPHT skin).
     

    What would you recommend to me? To delete everything and install some older versions of PMC + PHT?


    There should be no need to delete anything.
    You should always use a modern version of the PMS server in any case.

    The PMC client and the PHT client can both coexist on the same system.
    And the PMC client still works fine when coexisting with modern PMS and PHT installations.
    (At least it does under Windows OS, which is where I have these programs installed.)

    If you absolutely don't want it installed you can of course uninstall PHT,
    but it's not necessary to do so in order to use PMC as your main Plex client.
     

    Where can I find those


    One of the support pages linked on the main plex.tv pages has a 'Downloads Archive' section with several links to old versions of various Plex components. It can be a little hard to find though, as it is a small section far down on a huge page. As I see it you only need a link to the PMC archive page, so I'm providing that for you here.

    I just looked at that page, and apparently the latest version of PMC for OSX is 0.9.5.3, which is slightly older than the 0.9.5.4 that I use for Windows. But I suppose it will fill your needs.
     

    and how should I install Blur skin in that case if Preen is crashing on Mavericks?


    It has always been possible to install skins simply by copying a skin folder into the proper 'addons' folder of either PHT or PMC. But many people make mistakes in this, using the wrong folder (usually an 'addons' folder stored with the installed program, which is NOT the correct one).

    I've never done this on an OSX system myself, but I have collected the necessary information, for possible future needs:

    Where to install skin folders for PMC:
    for Mac use: ~/Application Support/Plex/addons/
    for Win7 use: c:\Users\your_user_name\AppData\Local\Plex\addons\
    for WinXP use: c:\Documents and Settings\your_user_name_1\Local Settings\Application Data\Plex\addons\

    Where to install skin folders for PHT:
    For Mac use: ~/Application Support/Plex Home Theater/addons/
    For Win7 use: c:\Users\your_user_name\AppData\Roaming\Plex Home Theater\addons
    For WinXP use: c:\Documents and Settings\your_user_name_1\Application Data\Plex Home Theater\addons
    For RasPlex use: /storage/.plexht/addons/

    Since I've never done it on OSX those paths are unverified by me, and the information I've gathered may be obsolete (in case Mavericks changed path usage, similar to how Win7 changed such things relative to WinXP). If you don't find an 'addons' folder in the specified location you may have to search for it by updated rules appropriate for Mavericks.

    Note also that while most skins are distributed as packed files (zip, rar, 7z or whatever), it is the unpacked folder inside those packages that needs to be copied into the appropriate 'addons' folder. And also remember to keep skins for PHT and PMC separate from each other, as they are never compatible. PHT can only use skins made for it, just like PMC can only use skins made for it. If you mistakenly install a skin of the opposite type, it will most likely crash the client when activated or in trying to use its GUI.

    Best regards: dlanor
  • surya_1-2-3-surya_1-2-3- Members Posts: 75 ✭✭
    edited September 2014
    dlanor wrote on June 25 2014, 10:14 PM: »

    I think you're confusing PMC with PMS...

    Perhaps I'd better clarify the situation for you then, in regard to all these acronyms:

    PMS == Plex Media Server
    Such a server is required for ALL use of any Plex clients.
    (But you can share sections from such a server to users with a Plex account but no server of their own.)

    PMC == Plex Media Center == the old 'flagship' Plex client for PCs of all kinds, and it's now obsolete.

    PHT == Plex Home Theater == the new 'flagship' Plex client for PCs of all kinds, and has replaced PMC.

     

    If Blur worked fine then it must have been PMC that you used.
    I've heard that Preen can install skins for PHT as well, but most of the skins available will only work with PHT versions which are equally old and obsolete as PMC is. (There have been MAJOR design changes in PHT in the last six months.)

     

    I'm pretty sure you mean PMS v0.9.9.12.504, which is the latest release of the Plex Media Server.

     

    I'm not sure how it works with OSX, but in Windows you can check the version of a program simply by selecting the program file in an 'Explorer' window, then right-clicking it and in the popup menu choosing "Properties" and in the properties dialog click the "Details" tab. In OSX the procedure is probably entirely different but some similar way of reaching version info should be available.

    In any case the current PHT version is 1.1.4.297, so if you downloaded just a few days ago, that is what you should have, but if you downloaded a week or longer ago then your version will be slightly lower. But all versions available are incompatible with Blur, and I strongly doubt that Preen has any suitable skins to offer for modern PHT versions.

     

    Well, that seems to be a total 'show-stopper' as far as using Preen goes.
    Unfortunately I have no advice to give on this since I've never used an OSX computer, and Preen is not available for Windows.

     

    That may be in part because you're unfamiliar with them. Still, that choice is yours to make.

     

    You should be able to do that with PHT too, though I guess you just don't like its default skin.
    There are some others around though, notably Amber and Night (there's even a PlexAeonPHT skin).
     

    There should be no need to delete anything.
    You should always use a modern version of the PMS server in any case.

    The PMC client and the PHT client can both coexist on the same system.
    And the PMC client still works fine when coexisting with modern PMS and PHT installations.
    (At least it does under Windows OS, which is where I have these programs installed.)

    If you absolutely don't want it installed you can of course uninstall PHT,
    but it's not necessary to do so in order to use PMC as your main Plex client.
     

    One of the support pages linked on the main plex.tv pages has a 'Downloads Archive' section with several links to old versions of various Plex components. It can be a little hard to find though, as it is a small section far down on a huge page. As I see it you only need a link to the PMC archive page, so I'm providing that for you here.

    I just looked at that page, and apparently the latest version of PMC for OSX is 0.9.5.3, which is slightly older than the 0.9.5.4 that I use for Windows. But I suppose it will fill your needs.
     

    It has always been possible to install skins simply by copying a skin folder into the proper 'addons' folder of either PHT or PMC. But many people make mistakes in this, using the wrong folder (usually an 'addons' folder stored with the installed program, which is NOT the correct one).

    I've never done this on an OSX system myself, but I have collected the necessary information, for possible future needs:

    Where to install skin folders for PMC:
    for Mac use: ~/Application Support/Plex/addons/
    for Win7 use: c:\Users\your_user_name\AppData\Local\Plex\addons\
    for WinXP use: c:\Documents and Settings\your_user_name_1\Local Settings\Application Data\Plex\addons\

    Where to install skin folders for PHT:
    For Mac use: ~/Application Support/Plex Home Theater/addons/
    For Win7 use: c:\Users\your_user_name\AppData\Roaming\Plex Home Theater\addons
    For WinXP use: c:\Documents and Settings\your_user_name_1\Application Data\Plex Home Theater\addons
    For RasPlex use: /storage/.plexht/addons/

    Since I've never done it on OSX those paths are unverified by me, and the information I've gathered may be obsolete (in case Mavericks changed path usage, similar to how Win7 changed such things relative to WinXP). If you don't find an 'addons' folder in the specified location you may have to search for it by updated rules appropriate for Mavericks.

    Note also that while most skins are distributed as packed files (zip, rar, 7z or whatever), it is the unpacked folder inside those packages that needs to be copied into the appropriate 'addons' folder. And also remember to keep skins for PHT and PMC separate from each other, as they are never compatible. PHT can only use skins made for it, just like PMC can only use skins made for it. If you mistakenly install a skin of the opposite type, it will most likely crash the client when activated or in trying to use its GUI.

    Best regards: dlanor

    Hi All,

       I have installed new version of Plex Home Theater.1.2.2 on ubuntu14.04 LTS.When i enter into this path(opt/plexhometheater/share/XBMC/addons/skin.plex/media) i haven't seen any png files.there is only one file that is texcture.xbt.

Sign In or Register to comment.