If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

FEATURE REQUEST: Custom Library Icons

124678

Comments

  • jackandjohnjackandjohn Posts: 417Members, Plex Pass Plex Pass
    It does not, however, currently work on iOS, and infact it does not show custom icons for local shares that are not restricted.

    Ubuntu 14.04.1 LTS x86_64 | sabnzb+, sickbeard

    i3-4330 OSX86 (edits only through clover) 10.9.4 Plex / Backup server / File Server
    ASUS RT-AC66U w/Stock firmware (physical connection to the server)

    FTTH (150/30)

    2x iPhone 4 w/Plex app, iPad Air 2 w/Plex app, iPad 1st Gen w/Plex app

    Roku2 XD w/Official Plex and RarFlix (And U.S DNS)
    Raspberry Pi - Testing RasPlex, OpenELEC and Raspbmc w/ PleXBMC V2 ; blog of this experience @ http://raspberrypihtpc.wordpress.com

    I've successfully run Two (then three) Plex Instances on the Same Server. Click here to learn more: https://raspberrypihtpc.wordpress.com/2015/10/01/two-or-more-plex-server-instances-on-the-same-server/

    *Constantly happy with how well Plex works, and where it's headed :)

  • ljunkieljunkie Plex Dev Team Posts: 4,841Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    It does not, however, currently work on iOS, and infact it does not show custom icons for local shares that are not restricted.


    What?
  • jackandjohnjackandjohn Posts: 417Members, Plex Pass Plex Pass
    ljunkie wrote on October 13 2013, 8:40 PM: »

    What?


    The iOS Plex client does not show custom library icons at all.

    Ubuntu 14.04.1 LTS x86_64 | sabnzb+, sickbeard

    i3-4330 OSX86 (edits only through clover) 10.9.4 Plex / Backup server / File Server
    ASUS RT-AC66U w/Stock firmware (physical connection to the server)

    FTTH (150/30)

    2x iPhone 4 w/Plex app, iPad Air 2 w/Plex app, iPad 1st Gen w/Plex app

    Roku2 XD w/Official Plex and RarFlix (And U.S DNS)
    Raspberry Pi - Testing RasPlex, OpenELEC and Raspbmc w/ PleXBMC V2 ; blog of this experience @ http://raspberrypihtpc.wordpress.com

    I've successfully run Two (then three) Plex Instances on the Same Server. Click here to learn more: https://raspberrypihtpc.wordpress.com/2015/10/01/two-or-more-plex-server-instances-on-the-same-server/

    *Constantly happy with how well Plex works, and where it's headed :)

  • ljunkieljunkie Plex Dev Team Posts: 4,841Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    The iOS Plex client does not show custom library icons at all.


    Understand. I concur, but this is the Roku forum :)
  • jackandjohnjackandjohn Posts: 417Members, Plex Pass Plex Pass
    ljunkie wrote on October 13 2013, 9:49 PM: »

    Understand. I concur, but this is the Roku forum :)


    Ah.
    Well met, sir; point conceded.

    Ubuntu 14.04.1 LTS x86_64 | sabnzb+, sickbeard

    i3-4330 OSX86 (edits only through clover) 10.9.4 Plex / Backup server / File Server
    ASUS RT-AC66U w/Stock firmware (physical connection to the server)

    FTTH (150/30)

    2x iPhone 4 w/Plex app, iPad Air 2 w/Plex app, iPad 1st Gen w/Plex app

    Roku2 XD w/Official Plex and RarFlix (And U.S DNS)
    Raspberry Pi - Testing RasPlex, OpenELEC and Raspbmc w/ PleXBMC V2 ; blog of this experience @ http://raspberrypihtpc.wordpress.com

    I've successfully run Two (then three) Plex Instances on the Same Server. Click here to learn more: https://raspberrypihtpc.wordpress.com/2015/10/01/two-or-more-plex-server-instances-on-the-same-server/

    *Constantly happy with how well Plex works, and where it's headed :)

  • Wilderness81Wilderness81 Posts: 22Members, Plex Pass Plex Pass

    I'm hoping someone might be able to help me with this, as I'm having trouble with it.  I did it no problem on my windows machine but I've recently moved over to Linux.

    When I went to open the database in SQLite it gave me an error, I figured it was probably a permissions issue.  The easiest thing seemed to just copy the db out to another location, like documents, and edit it there.  That works, and I can open and edit it to add the web locations of the icons I want to use.  However, when I copy that new database back to the original location Plex will not open.  If I revert back to my backup of the original database then everything works again.  Any ideas or suggestions?

  • jackandjohnjackandjohn Posts: 417Members, Plex Pass Plex Pass
    Wilderness81 wrote on October 24 2013, 10:27 PM: »

    I'm hoping someone might be able to help me with this, as I'm having trouble with it.  I did it no problem on my windows machine but I've recently moved over to Linux.

    When I went to open the database in SQLite it gave me an error, I figured it was probably a permissions issue.  The easiest thing seemed to just copy the db out to another location, like documents, and edit it there.  That works, and I can open and edit it to add the web locations of the icons I want to use.  However, when I copy that new database back to the original location Plex will not open.  If I revert back to my backup of the original database then everything works again.  Any ideas or suggestions?

    The question of permissions may be valid, if something funky is going on when you are moving the file around (Plex runs as it's own user on linux, so if a program along the way is setting the file permissions so that only the owner can read/write, and then setting the db file to be owned by you, not Plex, there will be issues. Sane programs should not do these things, but some do)

    Assuming your programs are sane; forgive me if this seems like an obvious question: Are you completely shutting down plex when you are copying the database file back and forth?

    On Ubunutu, for example, the command is 

    sudo stop plexmediaserver
    

    You may find some benefit in running through the article here from start to finish.

    Ubuntu 14.04.1 LTS x86_64 | sabnzb+, sickbeard

    i3-4330 OSX86 (edits only through clover) 10.9.4 Plex / Backup server / File Server
    ASUS RT-AC66U w/Stock firmware (physical connection to the server)

    FTTH (150/30)

    2x iPhone 4 w/Plex app, iPad Air 2 w/Plex app, iPad 1st Gen w/Plex app

    Roku2 XD w/Official Plex and RarFlix (And U.S DNS)
    Raspberry Pi - Testing RasPlex, OpenELEC and Raspbmc w/ PleXBMC V2 ; blog of this experience @ http://raspberrypihtpc.wordpress.com

    I've successfully run Two (then three) Plex Instances on the Same Server. Click here to learn more: https://raspberrypihtpc.wordpress.com/2015/10/01/two-or-more-plex-server-instances-on-the-same-server/

    *Constantly happy with how well Plex works, and where it's headed :)

  • ljunkieljunkie Plex Dev Team Posts: 4,841Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I'm hoping someone might be able to help me with this, as I'm having trouble with it. I did it no problem on my windows machine but I've recently moved over to Linux.

    When I went to open the database in SQLite it gave me an error, I figured it was probably a permissions issue. The easiest thing seemed to just copy the db out to another location, like documents, and edit it there. That works, and I can open and edit it to add the web locations of the icons I want to use. However, when I copy that new database back to the original location Plex will not open. If I revert back to my backup of the original database then everything works again. Any ideas or suggestions?


    You hit it on the head. You said you had to change permissions to edit it. Remember you will have to change the permission back so plex can read the DB.
  • Squintz82Squintz82 Posts: 67Members, Plex Pass Plex Pass

    So, is there still no way to add custom icons for Genres or Collections? Only Libraries?

  • dunamidunami Posts: 50Members, Plex Pass Plex Pass
    You Can. Look For (Instead Of Library Sections) Tags In The Same Db. Search FoR Id 2 For Collections, Id 1 For Genres.

    Sorry About The Caps, My Phone Does This Sometimes.
  • dunamidunami Posts: 50Members, Plex Pass Plex Pass

    It seems that whenever I add content to my PMS by refreshing that section in plex/web, i tend to lose some of my custom icons.  When I check the database, some of the links i previously added are gone.  And it's odd because it's not all of them, just some.  And I haven't identified any rhyme or reason to which custom images disappear.  I'm sure there may be some logic, I just haven't been able to test it enough yet.

    I'm definitely shutting PMS down before editing the db.  I've even going to shutting down pms before even opening the db to be sure, and I check the processes to confirm it's actually not running.

    Any ideas why this may be happening?  

  • dunamidunami Posts: 50Members, Plex Pass Plex Pass
    Squintz82 wrote on October 25 2013, 7:20 PM: »

    So, is there still no way to add custom icons for Genres or Collections? Only Libraries?

    dduross wrote on October 25 2013, 7:25 PM: »

    You Can. Look For (Instead Of Library Sections) Tags In The Same Db. Search FoR Id 2 For Collections, Id 1 For Genres.

    Sorry About The Caps, My Phone Does This Sometimes.

    Correction, that should be tag type 1 for genre and 2 for collection.  NOT tag id.

  • Wilderness81Wilderness81 Posts: 22Members, Plex Pass Plex Pass
    jackandjohn wrote on October 25 2013, 3:06 PM: »

    The question of permissions may be valid, if something funky is going on when you are moving the file around (Plex runs as it's own user on linux, so if a program along the way is setting the file permissions so that only the owner can read/write, and then setting the db file to be owned by you, not Plex, there will be issues. Sane programs should not do these things, but some do)

    Assuming your programs are sane; forgive me if this seems like an obvious question: Are you completely shutting down plex when you are copying the database file back and forth?

    On Ubunutu, for example, the command is 

    sudo stop plexmediaserver

    You may find some benefit in running through the article here from start to finish.

     

    Thank you for the response, and that was my first thought as well but I had been shutting down the server prior to doing anything.

    ljunkie wrote on October 25 2013, 3:25 PM: »

    You hit it on the head. You said you had to change permissions to edit it. Remember you will have to change the permission back so plex can read the DB.

    Thank you - I didn't follow my own thoughts out logically.  If it was a permission issue and I got around it by moving the file then of course I'd need to change the permissions back for it to work.  Doh :)

  • JamminRJamminR Posts: 2,715Members, Plex Pass Plex Pass

    Have any PlexPass users made a 'official' feature request in the PlexPass section of the forums?

    I did a half-hearted search and didn't find any obvious 'do this please' requests.

    And, thanks to you all who are discussing/finding links/doing the groundwork for how to go about changing the library thumbs.

    I'm now considering doing it if/when I find additional hobby time.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.7.4460
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • rlewrlew Posts: 3Members, Plex Pass Plex Pass
    edited October 2013

    i erased my post.  sorry guys.

  • dunamidunami Posts: 50Members, Plex Pass Plex Pass
    edited November 2013
    dduross wrote on October 25 2013, 10:46 PM: »

    It seems that whenever I add content to my PMS by refreshing that section in plex/web, i tend to lose some of my custom icons.  When I check the database, some of the links i previously added are gone.  And it's odd because it's not all of them, just some.  And I haven't identified any rhyme or reason to which custom images disappear.  I'm sure there may be some logic, I just haven't been able to test it enough yet.

    I'm definitely shutting PMS down before editing the db.  I've even going to shutting down pms before even opening the db to be sure, and I check the processes to confirm it's actually not running.

    Any ideas why this may be happening?  

    So this is still happening to me.  However, I have narrowed it down.  Whenever I add content, the custom icon for whatever genre or collection stuff is added to is lost.  Does that make sense?  So if I add a movie and it's tagged with the genres action and thriller, my custom icons (links) for those two genres go missing (in the database).  I can also see that the tags in question are being updated at the time the content is being added.  So it seems that when content is added to a genre, it's updated.  And it seems like it's wiping the custom user_thumb_url field in doing so.

    Any ideas on why this may be happening or how to prevent it?

    I'm running 0.9.8.4.125 on Windows XP Pro (yup, still using XP).

  • ljunkieljunkie Plex Dev Team Posts: 4,841Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    So this is still happening to me. However, I have narrowed it down. Whenever I add content, the custom icon for whatever genre or collection stuff is added to is lost. Does that make sense? So if I add a movie and it's tagged with the genres action and thriller, my custom icons (links) for those two genres go missing (in the database). I can also see that the tags in question are being updated at the time the content is being added. So it seems that when content is added to a genre, it's updated. And it seems like it's wiping the custom user_thumb_url field in doing so.

    Any ideas on why this may be happening or how to prevent it?

    I'm running 0.9.8.4.125 on Windows XP Pro (yup, still using XP).


    Yep makes sense. It's very possible the fields are updated (wiped) since it's not a supported feature. Whatever is "wiping" it could very well be fixed since it's not used yet, but the plex devs would have to make that happen. Nice find, but I don't have any good info for ya.
  • technology101technology101 Posts: 3Members

    that would be really nice please make it happen plex

  • tycho1974tycho1974 Posts: 246Members, Plex Pass Plex Pass

    Thanks for your walkthroughs, JamminR. I've followed your instructions, and was successfully able to change my sections thumbs. However, I've recently made some edits to the thumbs, and wanted to update the database. No matter how many times I edit the .db file, my old thumbnails persist. I've even deleted the actual PNG files for the original thumbnails, but they're still showing up! I don't know how this is possible, unless PMS somehow caches the files. I've made new directories (in my public dropbox folder, where I keep the PNG files), I've renamed the files, but nothing works. Any ideas?

    JamminR wrote on October 27 2013, 2:05 PM: »

    Have any PlexPass users made a 'official' feature request in the PlexPass section of the forums?

    I did a half-hearted search and didn't find any obvious 'do this please' requests.

    And, thanks to you all who are discussing/finding links/doing the groundwork for how to go about changing the library thumbs.

    I'm now considering doing it if/when I find additional hobby time.

  • JamminRJamminR Posts: 2,715Members, Plex Pass Plex Pass

    Tycho, I didn't write any walkthroughs, and haven't actually performed any of the steps in them (I update my libraries quite frequently, and read that  updates will overwrite customizations)

    I was simply thanking those users for writing any your ound, and asking if anyone had made official feature requests in the Plexpass feature requests area.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.7.4460
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
Sign In or Register to comment.