If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[resolved] AC3 in 0.8 with major problems

NODNOD Posts: 118Members, Plex Pass Plex Pass
edited May 2009 in Unsupported Versions
Here's my setup:

2 HTPC's running Plex (mac pro and mac mini), toslink out to Onkyo 875 and 905 receivers. I have 'audio output device' set to 'Built-in digital output,' with both AC3 and DTS capable receiver checked. I also have 'link system output' checked. This is the way I have ALWAYS had it set.

Since the latest update, when I start an AC3-encoded file, I get no audio when I start up the video file, and I also get stuttered or completely halted video playback (with no ability to skip forward or back). When checking the info on playback, I get a bitrate of 0 on the audio, and, even when the video playback has stopped (all on its own, mind you), the 'info' panel is registering that there is video playing.


If the only track is an AC3 track, the only way I can get it to play is to uncheck the 'Dolby capable receiver' box in the system preferences, and it is very low volume.

DTS passthrough works just fine.

I have never had this problem on any prior release.

Any clue wtf is going on?

Edit -- now I suddenly have trouble w/ a DTS track. Ugh

Comments

  • elanelan CTO and Co-founder MauiPosts: 9,392Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    This might be related to a couple of bugs we've been tracking down. Can you verify it works with an earlier version, and tell me if you have background music on? Or do you have Airfoil installed?

    instagram: @elan // the wife's photography site.
    the brother's photography blog // the dog's twitter feed.

  • NODNOD Posts: 118Members, Plex Pass Plex Pass
    edited May 2009
    elan wrote on May 20 2009, 02:57 PM:
    This might be related to a couple of bugs we've been tracking down. Can you verify it works with an earlier version, and tell me if you have background music on? Or do you have Airfoil installed?



    Thanks for the quick response man. It shows just how essential Plex has become in my life that I'm panicking right now.:D

    As for verifying that it works in an earlier version -- all the files I've been looking at today worked w/ earlier versions. If you'd like, I can uninstall 0.8 and check w/ 0.7.15. But I'm trying o set up a new Samsung LED (woot!!) and a Tivo right now. So it might be a while.

    Background music IS on.

    As for Airfoil -- nope.
  • peter893peter893 Posts: 105Members
    edited May 2009
    NOD wrote on May 20 2009, 08:30 PM:
    Thanks for the quick response man. It shows just how essential Plex has become in my life that I'm panicking right now.:D

    As for verifying that it works in an earlier version -- all the files I've been looking at today worked w/ earlier versions. If you'd like, I can uninstall 0.8 and check w/ 0.7.15. But I'm trying o set up a new Samsung LED (woot!!) and a Tivo right now. So it might be a while.

    Background music IS on.

    As for Airfoil -- nope.


    0.7.13 is the "safe" version. try reverting back to that version and confirm that the files play correctly there. .14 and up added the deal breaker ffmpeg 0.5 update.

    also, what is the video, encoding and container?
    My Blog - Mac OSX Home Theater HD Mac Mini 1.83Ghz
    Find out how to play your Blu-rays in Plex or XBMC: Blu-ray Ripping Tutorial
    A great place for Blu-ray info Blu-ray.com Bitrate/Codec/Audio info for BD here: Blu-ray Movie Bitrates

    OSX 10.5.8 Mac Mini 1.83ghz 4GB ram - 3 x MiniStack2.5 1GB HDs - Plex 0.8.5 - Panasonic TH-42PZ80U Plasma - Sony DTS/AC3 Receiver.
    Parallels 5 - Windows XP - AnyDVDHD
  • elanelan CTO and Co-founder MauiPosts: 9,392Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    peter893 wrote on May 20 2009, 12:33 PM:
    0.7.13 is the "safe" version. try reverting back to that version and confirm that the files play correctly there. .14 and up added the deal breaker ffmpeg 0.5 update.


    Let's please not exaggerate :) There is higher CPU consumption for decoding VC-1, but the new ffmpeg is not responsible for all evils, there are enough of my bugs in there to take some of the blame!

    Try turning off background music, as a bug was introduced in Plex/Eight which introduces audio issues with surround content when background music is playing.

    instagram: @elan // the wife's photography site.
    the brother's photography blog // the dog's twitter feed.

  • NODNOD Posts: 118Members, Plex Pass Plex Pass
    elan wrote on May 20 2009, 08:53 PM:
    Let's please not exaggerate :) There is higher CPU consumption for decoding VC-1, but the new ffmpeg is not responsible for all evils, there are enough of my bugs in there to take some of the blame!

    Try turning off background music, as a bug was introduced in Plex/Eight which introduces audio issues with surround content when background music is playing.



    If I weren't a paranoid southerner, I'd kiss you!! Everything is working wonderfully now in .8.1, but it was completely resolved by disabling bg music.

    :woot
  • cheekyboycheekyboy Posts: 145Members
    elan wrote on May 21 2009, 02:53 AM:
    Let's please not exaggerate :) There is higher CPU consumption for decoding VC-1, but the new ffmpeg is not responsible for all evils, there are enough of my bugs in there to take some of the blame!

    Try turning off background music, as a bug was introduced in Plex/Eight which introduces audio issues with surround content when background music is playing.

    I have noticed crackles in AC3 audio in 8.0, is this related to the bugs you mention Elan? I haven't taken 8.1 yet but sounds like its a must have, thanks for all you guys hard work :)
    I Finally bought a MAC, Simon made me do it! Now what the hell do I do with it?
Sign In or Register to comment.