If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

BDP-S370 Profile

NotMyEmailAddressNotMyEmailAddress Posts: 2Members
edited April 2013 in DLNA


I really like Plex and i'm trying to make my BD player to like it too :).
I have a problem with displaying mkvs/avis (some of them avi) files on the player. The player error message is: "No playable files".

The server profile (the one that comes with PMS) does not work at all on this player (for any movie). I've managed to read all the topics in the forum ( :) - not quite) and to get a profile working for most of the movie files, but i'm still having trouble with mkvs and some avis.

Here's my curent profile:

  <Client name="Sony Bluray">
    <!-- Author: fkick -->
    <!-- Based on PS3 Media Server, SonyBluRay.conf and Serviio Profile -->
      <Header name="X-AV-Client-Info" regex="(Blu-ray Disc Player|Home Theater System|Home Theatre System|Media Player)" />
      <Header name="X-AV-Physical-Unit-Info" regex="(Blu-ray Disc Player|Home Theater System|Home Theatre System|Media Player)" />
      <!-- Act as WMP so that devices doesn't show root categories, needed for older Sony Blu-Ray devices -->
      <Manufacturer>Microsoft Corporation</Manufacturer>
      <ModelName>Windows Media Player Sharing</ModelName>
       <VideoProfile container="mpegts" codec="mpeg2video" audioCodec="ac3" />
       <PhotoProfile container="jpeg" />
      <VideoProfile container="mpegts" codec="mpeg1video,mpeg2video,h264" audioCodec="ac3,aac,mp3,pcm_u8" />
      <VideoProfile container="mpeg" codec="mpeg1video,mpeg2video" audioCodec="ac3,mp3,pcm_u8,mpa" />
      <VideoProfile container="mp4,h264" codec="mpeg4,h264" audioCodec="ac3,aac,pcm_u8,mp3" />
      <VideoProfile container="avi" codec="mpeg4,h264" audioCodec="ac3,aac,mp3,pcm_u8" />
      <!-- Sony BDP requests all formats except mpeg-ps and mpeg-ts in 32KB chunks which works badly over wifi,
           hence mkv files are remuxed to mpeg-ts by default in this profile. If you have a European or Canadian player (not US),
           you stream over a wired connection and want mkv subtitles, dts support, and multiple audio tracks -
           but don't care that you can't seek - then uncomment the line below to have the player decode mkv natively. -->
      <!-- <VideoProfile container="mkv" codec="h264,mpeg4" audioCodec="ac3,aac,mp3,pcm_u8" /> -->
      <PhotoProfile container="jpeg" />
      <VideoCodec name="h264">
        <Setting name="MaxResolution" value="1920x1080" /><!--Deprecated-->
        <Setting name="MaxFps" value="30" /><!--Deprecated-->
        <Setting name="MaxBitRate" value="15360" /><!--Deprecated-->
          <UpperBound name="video.width" value="1920" />
          <UpperBound name="video.height" value="1080" />
          <UpperBound name="video.frameRate" value="30" />
          <UpperBound name="video.bitrate" value="15360" />
          <UpperBound name="video.level" value="41" />
      <VideoAudioCodec name="ac3">
        <Setting name="MaxAudioChannels" value="6" /><!--Deprecated-->
        <Setting name="MaxBitRate" value="320" /><!--Deprecated-->
          <UpperBound name="audio.channels" value="6" />
          <UpperBound name="audio.bitrate" value="320" />
      <!-- US Players require avi be set to the video/mpeg mime type. If you have a European or Canadian player, you can delete the line below
           (may help speed up avi load times on non-US players -->
      <VideoContainer name="avi" mimeType="video/mpeg" />
      <!-- For European and Canadian players, you can set the mkv mime type to video/divx to allow subtitle and multitrack audio  -->
      <VideoContainer name="mkv" mimeType="video/vnd.dlna.mpeg-tts" />
      <VideoContainer name="mpegts" mimeType="video/vnd.dlna.mpeg-tts" />
      <VideoContainer name="mov" mimeType="video/mpeg" />
      <VideoContainer name="mp4" mimeType="video/mpeg" />
      <!-- PMS already sets the following mime types, so they're commented out and left as documentation -->
      <!--VideoContainer name="mpeg" mimeType="video/mpeg" />
      <AudioContainer name="mp3" mimeType="audio/mpeg" /-->

      <PN name="WMA_BASE" remap="MP3" mimeType="audio/mpeg" />
      <PN name="WMA_FULL" remap="MP3" mimeType="audio/mpeg" />

      <PN name="MPEG_PS_NTSC_L2,MPEG_PS_NTSC_XAC3" remap="MPEG_PS_NTSC" mimeType="video/mpeg" />
      <PN name="MPEG_PS_PAL_MPEG1_L3,MPEG_PS_PAL_XAC3" remap="MPEG_PS_PAL" mimeType="video/mpeg" />
      <PN name="MPEG_TS_SD_AC3" remap="MPEG_TS_SD_NA_ISO" mimeType="video/vnd.dlna.mpeg-tts" />   
      <PN name="MPEG_TS_SD_AC3_ISO" remap="MPEG_TS_SD_NA_ISO" mimeType="video/mpeg" />
      <PN name="MPEG_TS_SD_NA_AC3,MPEG_TS_SD_NA_STD,MPEG_TS_SD_NA_STD_T" remap="MPEG_TS_SD_NA_ISO" mimeType="video/vnd.dlna.mpeg-tts" />
      <PN name="MPEG_TS_HD_NA_AC3,MPEG_TS_HD_NA_STD,MPEG_TS_HD_NA_STD_T" remap="MPEG_TS_HD_NA_ISO" mimeType="video/vnd.dlna.mpeg-tts" />      
      <PN name="AVC_TS_HP_HD_24" remap="AVC_TS_HD_24_AC3" mimeType="video/vnd.dlna.mpeg-tts" />  
      <PN name="AVC_TS_SD" remap="AVC_TS_HD_EU" mimeType="video/vnd.dlna.mpeg-tts" />
      <PN name="AVC_TS_HP_HD_24_AAC_LC" remap="AVC_TS_JP_AAC_T" mimeType="video/vnd.dlna.mpeg-tts" />



The problem i think is with <MediaProfiles> section. I've googled a lot and didn't find anything related with PN names, how it works, how to remap it, why, etc..

Do you think you can add this working profile in the next build (maybe a separate profile just for BDP-S370)? And also, make it so it can read mkvs and avis? Or at least help me find out where is the problem...



  • jamboukjambouk Posts: 42Members


    I also have this player (European version - which has native DivX support). 

    I have recently upgraded to Version of PMS and found that my 2010 Sony TV now works rather nicely over DLNA (nice work!!!).

    Sadly my Blu-ray player does not. With the DLNA profile supplied only a few of the hundred of video files I have stored are listed and playable (predominately DivX).

    Does anyone have a successful profile for this model? All help gratefully received.

  • brun064brun064 Posts: 4Members, Plex Pass Plex Pass

    I have the BDP-S370 and this profile didn't work for me.  The player didn't even detect the server.  I used the profile from:


    From post #13.  

    However, no media files were playable.  Did a recent firmware update break your DLNA?  I'm using PMC for OSX and the US version of the S370.  I verified that the correct profile is being used via the logs.  This player has given me nothing but problems with DLNA.  

  • NotMyEmailAddressNotMyEmailAddress Posts: 2Members

    Body is 7 characters too short.

Sign In or Register to comment.