If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Windows Phone 8 - Plex "Unable to download content"

I'm having a heap of issues with this app, and hope that someone here can either provide me a "magic setting" I must have overlooked, confirmation of bugs, or just some reassurance that things will be alright, eventually ;)

 

Here's the deal:

 

  • The app was able to find my "Media PC" using it's local address. So that works.
  • The "Servers" list shows the correct name, and if I edit the connection, I see that my LAN IP is listed as "available, local, discovered". All good so far.
  • I then realised that the "Media PC" was using a DHCP address, so I moved it to a new static address. The app then detected the new IP as "available, local, discovered". Great.
  • Except... now I had two "local, discovered" addresses. The old one was unavailable (as expected). But there is no option in the UI to delete "discovered" addresses. You can only "Test" discovered IPs.
  • I manually added an IP address as a test, and it appeared fine. I was then able to press-and-hold, get a menu, and there was a delete option available. So the issue is "discovered" IPs after all.
  • With an "unavailable" IP as "discovered", the app would constantly try to connect to it and display the "Error - Unable to download content from <NAME> (http://<OLD_IP>:32400/): message.
  • The only way to remove the old address, that I found, was to uninstall the app and then install it again (which sucks).
  • Moving on, I then signed in with my "MyPlex" account. This immediately added a second connection to my server - my external IP Address, listed as an "available, remote, myplex" connection. Excellent.
  • I then disconnected my Wi-Fi and attempted to use Plex. After several seconds of "loading dots" I receive the "Unable to download content from <NAME> (http://<EXTERNAL_IP:32400/):" error.
  • I back out of the app (close it) and try again. I very, very, briefly see the Library folders show up, before I get the error again (with an added "timeout" text). I tap "ok" and the Library screen is empty.
  • I backed out of the app again, and tried over... same thing: The Library folder flash up for a fraction of a second and then get replaced by an error message.
  • I then go to my "Server" settings... and find that the external IP is now listed as "unavailable". I tap-and-hold, then select the "Test" option from the menu. It instantly shows up as "available" again.
  • I then try refreshing the Library, and it shows up... YAY!
  • I browse to my "Recorded TV" folder and can see a list of my TV Shows and episodes. Great so far.
  • Then, as I am exploring the interface and scroll across to the "Recent" section, Error again.
  • Back on Wi-Fi again, I am STILL getting errors: This time, with my LAN IP not working. That is, until it magically works after a refresh.

I'm just getting far too many errors for this app. So many that, I can't believe for a second, that Plex would have released the app like this. My setup works perfectly using my iPad and app - so it doesn't seem to be my configuration (that I can tell). Could it be my handset (Nokia Lumia 920)? Any ideas?

 

Thanks

Comments

  • MoWebMoWeb Posts: 2Members

    Specifics:

    1. Plex Media Server v0.9.7.28-f80a4a2, running on Windows 8 Pro (Media Pack - v6.2.9200)
    2. Plex for Windows Phone 1.4.0.0 , running on Nokia Lumia 920 ( NOKIA RM-821_apac_australia_new_zealand_304 - v8.0.10211.0)
    3. Plex for iOS 3.2.2, running on  iPad 2 (iOS 6.1.3)
  • dmegatooldmegatool Posts: 25Members, Plex Pass Plex Pass

    Getting a lot of errors too. From "Unable to download content" to "Bad Gateway". Sometime I think it's fixed and then it stops working. 

    This is on my Lumia 520. My 3GS's still working perfectly... 

  • teamgoolteamgool Posts: 1Members

    Same on my Lumia 925.  Guess the app doesn't work.  I can still access it via the phone's browser though.

  • VictorE01VictorE01 Posts: 2Members Plex Pass

    I'm getting the same error on both my Lumia 1020 (WP8) and Lumia 900 (WP7). Both are running Plex for Windows Phone 1.4.

  • SpasmSpasm Posts: 16Members, Plex Pass Plex Pass
    edited August 2013

    Oh good, thought I was the only one.  Thought I messed it up a few weeks ago when I got a new router, hadn't had time to fix my ports until today.  Same problems.

    I can connect to my server.  I can even see all my content.  But if I try and play any of it, I get a couple of different errors.  Timed out connecting... Can't play video... Error playing video 3100.

    Also, my Surface Pro Win8 native app can play from the same server over the same network without issue.

    Edit2:  This worked great back when I first bought the app around May/June.

  • mikaelsondellmikaelsondell Posts: 1Members

    My Plex app for Windows Phone 8 (Nokia Lumia 920) stopped working after I updated the phone with the new Amber update from Nokia. I tried to reinstall the app but it doesn't work anymore.

  • yodatacoyodataco Posts: 5Members, Plex Pass

    Same issue here...

  • RmhannemanRmhanneman Posts: 10Members

    I can't even get that far, it says the servers unavailable. I'm running it on a Nokia Lumia 928, and I have Windows 7, same version of PMS as MoWeb.

  • lonixlonix Posts: 4Members, Plex Pass Plex Pass

    Im having all sorts of trubbles connecting with the client on My Lumia 920. Luckely i keep my SGNexus around for that still. 

  • terminicterminic Posts: 1Members, Plex Pass Plex Pass
    I am having the same issues. Do any of the developers have an update? I mean we paid $5 for the app so I would hope that they are taking the time to fix these issues.
  • ZeffZeff Posts: 4Members, Plex Pass Plex Pass

    I am unable to connect with WP8 client on Lumia 920 as well.

  • MvrolixMvrolix Posts: 2Members
    I would love to pay for the app if it would work on a microsoft phone lumia 820.
    In my case, it works on ios and android, but the wp8 always says "unable to connect to this address. Please verify connectivity and try again.
  • GHouseGHouse Posts: 88Members, Plex Pass Plex Pass

    Same thing. I get this error when connecting to Plex server from outside my home network. Running on Windows Phone 8 OS.

    Error

    Unable to download content from [server name here] (http://nnn.nnn.nnn.nnn:port/)

    [OK]

    nnn.nnn.nnn.nnn is the internal ip address for my home network

    To fix this I have to:

    tap [OK]

    library screen is blank

    tap the applicationbar [three dots at the bottom of the screen]

    tap refresh icon

    library icons now show up

    The app should just try the external ip address for the Plex Media Server that is registered with myplex before displaying the error message that it can't connect to the Plex Media Server's internal ip address on the home network.

  • ZipTBMZipTBM Posts: 16Members, Plex Pass Plex Pass

    Still an error for every Windows Phone tested.  I've even setup port forwarding on my router to ensure the connection is available, however it still is "unable to download" and unauthorized.

    What's the deal?

  • dmcbrooklyndmcbrooklyn Posts: 1Members, Plex Pass Plex Pass

    Same issue. Worked flawlessly for a couple of days and then stopped.

  • jdbrookesjdbrookes Posts: 454Members, Plex Pass Plex Pass

    GHouse's instructions above (aka fecking around with menus until it connects) is a workaround that still works for me when I'm outside my home network. It will have to do until the new Plex for WP8 is released. For WP7 users I'm not sure what to say except you'll probably still have to use the workaround, unless the devs are kind enough to do a small maintenance fix release for the old WP7 client in future..

  • peppy431peppy431 Posts: 2Members, Plex Pass

     The solution that worked for me was to sign out of plex on windows phone. Remove it from myplex devices (https://my.plexapp.com/devices). Then sign back in to plex on windows phone. Make sure you remove all instances of windows phone from myplex devices.

  • ZipTBMZipTBM Posts: 16Members, Plex Pass Plex Pass

    Randomly today I'm getting the "authorized to download" error.  I've uninstalled the app, removed all instances of Windows Phone from my devices, and then reinstalled it on WP, logged in again, but same issue repeats.

    Is a new version being published?   The Windows Phone Store shows version 1.4 was published on Dec 5, but I think this was the same version we were using before as nothing appears to have changed.

Sign In or Register to comment.