If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plexconnect DNS shutting down randomly

vallis599vallis599 Posts: 9Members ✭✭

I'm having a problem with the Plexconnect DNS randomly shutting down, here's a copy of my log: http://pastebin.com/fTPVizjY and my system information:

 

OS: Windows 8 x64

Apple TV version: 3

Apple TV firmware: 6.0

Apple TV IP: 192.168.1.178

DNS server: 192.168.1.131

Plex Media Server IP: 192.168.1.131

Plex Media Server: 0.9.8.6

Plexconnect version: 0.2

 

My Settings.cfg file:

port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = ./assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
enable_dnsserver = True
logpath = .
ip_pms = 192.168.1.131
enable_plexgdm = False
port_ssl = 443
enable_webserver_ssl = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
port_dnsserver = 53
enable_plexconnect_autodetect = True
 

This crash/shut down has happened multiple times and always ends with the following in the log file. 

 

10:09:32 DNSServer: DNS request received!
10:09:32 DNSServer: Source: ('192.168.1.178', 51646)
10:09:32 DNSServer: Domain: atv.plexconnect
10:09:32 DNSServer: ***intercept request
10:09:32 DNSServer: -> DNS response: 192.168.1.131
10:09:32 DNSServer: Shutting down.
 
I have tried a few things with no success: turning off PlexGDM as suggested in another thread, making sure both the computer and the aTV have static IPs, have tried both Plexconnect version 0.2 and the latest Github version.
 
I can't seem to isolate why it happens, it seems to happen when I'm in the middle of accessing things on the aTV (like after a video was finished), or after the aTV wakes from sleep. I should also note that Plexconnect works perfectly fine before the DNS shutdown and a restart of the computer/restarting the python program fixes the problem. Any help in resolving this issue would be greatly appreciated. 

Comments

  • RedUlfRedUlf Posts: 11Members, Plex Pass ✭✭

    Hi!

    Any resolution. I have exactly the same issue and it starts to get very annoying!

  • moody_bluemoody_blue Posts: 2,899Members, Plex Pass, Plex Ninja Plex Ninja

    It is unlikely that you are using SW versions from 3 years ago... So please post your current version (Python, PlexConnect, Operating system), Settings.cfg, and log (with loglevel = High)

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

Sign In or Register to comment.