If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Home screen "on deck" not updating?

jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
edited January 2014 in Plex Classic for Roku

If I start a show by pressing play directly from the home screen, the home screen DOES NOT update when the show finishes or I stop it part way through (ie I return directly to the home screen).  It is as though I have not watched the show at all - no "partially watched" or update to the next episode.  The only way to get the home screen to update is to exit and restart plex on the roku.

 

If I start a show by pressing OK from the home screen, and then play once in the show details, everything works/updates as expected.

 

If I start a show from the library section home screen "on deck" everything also works as expected.

 

BUT If I disconnect from my.plex - playing directly from home screen starts updating as normal!

 

Am I the only one this is happening to?

Any suggestions how to fix without disconnecting from my.plex?

 

Edit - addtnl info - using both rarflixtest & plextest - same behaviour in both.  PMS runs on my readynas ultra 2.

«1

Comments

  • Allan CameronAllan Cameron Posts: 528Members, Plex Pass Plex Pass
    I have not had this issue myself,
    but have you tried manually marking the show on the roku as watch or unwatched to see if that updates it without exiting the app?
  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Noted. I have noticed the refresh being intermittent, but haven't pin pointed or really dug deeply into it as it was pretty rare. I'll put it on my list to look into. Thanks!
  • schuylerschuyler Plex Dev Team Posts: 3,786Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited January 2014

    There's actually an open pull request to address this: https://github.com/awg0020/roku-client-public/commit/50a355fabb79f02b3a75454e4d955a0bd7b15d2a  Things have just been too hectic with holiday travels and catching up, I haven't taken the time to understand the issue yet.

  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
    a1b2c3 wrote on January 4 2014, 5:32 AM: »

    I have not had this issue myself,
    but have you tried manually marking the show on the roku as watch or unwatched to see if that updates it without exiting the app?

    Just tried this.

    With myplex connected - mark a show as watched from the home screen (rarflix) and no update.  Go to the library on deck and it has updated.  Back to home screen still no update.

    Disconnect from myplex - mark a show as watched from on deck on the home screen and it updates to the next episode.

    Reconnect to myplex and OK to enter show details screen.  Mark as watched.  Back to home screen and same episode is still there - but it is now showing as watched ie no update to the next episode.

  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
    ljunkie wrote on January 4 2014, 5:39 AM: »

    Noted. I have noticed the refresh being intermittent, but haven't pin pointed or really dug deeply into it as it was pretty rare. I'll put it on my list to look into. Thanks!

    schuyler wrote on January 4 2014, 5:52 AM: »

    There's actually an open pull request to address this: https://github.com/awg0020/roku-client-public/commit/50a355fabb79f02b3a75454e4d955a0bd7b15d2a  Things have just been too hectic with holiday travels and catching up, I haven't taken the time to understand the issue yet.

    Thanks guys.  Nice to know that it is not just me at least.

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited January 2014
    As Schuyler said the pull request may fix it, but I wanted to mention I tried to replicate your issue and couldn't. I played directly from the home screen on deck with the play button on the remote. After the show finished, it was marked as watched, reloaded and was removed from on deck. This show didn't have a next episode, so maybe that's the key? I'm trying another show/episode to confirm. Edit: looking at the pull request.. It doesn't really make much sense after glancing at it. It wouldn't fix an issue after the home screen has already been created and in this case (almost always) it already has been. Edit 2: another episode finished tonight and the global on deck updated just fine. Still on the list, but I cannot replicate your exact issue.
  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    jillybean, might I ask, are you using RARflix with a myPlex user other than the main PMS account? I have have been able to replicate this issue with the said scenario, but it should only be related to RARflix. The reason it only related to my fork is the fact I enabled the global OnDeck/Recently  Added rows for "shared" users. Those rows are not available if you are using the Official channel as this scenario is not officially supported (yet).

    If this is the scenario, then yes, you will experience the home screen failing to update because, by default the home screen will only refresh the items from "owned" servers. "Owned server" means it's either local without using myplex account on the roku or the myplex user configured on the Roku is the same as the one signed into the PMS. 

    Either way, I have found a bug related to shared users and global onDeck in RARflix, which will be fixed in the next Test update. Please let me know if this is the case. 

    jillybean wrote on January 4 2014, 5:22 AM: »

    ...

  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
    ljunkie wrote on January 4 2014, 9:46 PM: »

    jillybean, might I ask, are you using RARflix with a myPlex user other than the main PMS account? I have have been able to replicate this issue with the said scenario, but it should only be related to RARflix. The reason it only related to my fork is the fact I enabled the global OnDeck/Recently  Added rows for "shared" users. Those rows are not available if you are using the Official channel as this scenario is not officially supported (yet).

    If this is the scenario, then yes, you will experience the home screen failing to update because, by default the home screen will only refresh the items from "owned" servers. "Owned server" means it's either local without using myplex account on the roku or the myplex user configured on the Roku is the same as the one signed into the PMS. 

    Either way, I have found a bug related to shared users and global onDeck in RARflix, which will be fixed in the next Test update. Please let me know if this is the case. 

    I only have one myPlex user so definitely the same user on both PMS and RARflix.

    I spent some time yesterday setting up a new PMS on a spare laptop and have this morning done a factory reset on my roku.  Still the same thing happening in both RARflixtest and Plextest.  For now I will simply not connect RARflix to myplex.

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    I did just release another version today, v3.0.17 for the test channel. Can you force a Roku update and verify once more it's still not working?

    jillybean wrote on January 5 2014, 2:44 AM: »
    I only have one myPlex user so definitely the same user on both PMS and RARflix.

    I spent some time yesterday setting up a new PMS on a spare laptop and have this morning done a factory reset on my roku. Still the same thing happening in both RARflixtest and Plextest. For now I will simply not connect RARflix to myplex.
  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
    ljunkie wrote on January 5 2014, 2:46 AM: »

    I did just release another version today, v3.0.17 for the test channel. Can you force a Roku update and verify once more it's still not working?
     

    Done - the updated version was the one that installed after the roku reset.

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    jillybean wrote:
    Done - the updated version was the one that installed after the roku reset.


    Thanks. Are you familiar with how to retrieve the Roku logs? That could definitely help explain what's happening.
  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass
    ljunkie wrote on January 5 2014, 3:05 AM: »

    Thanks. Are you familiar with how to retrieve the Roku logs? That could definitely help explain what's happening.

    Not familiar, but if you point me in the direction of some instructions I should be ok.

    Just for kicks I set up a second myplex account, shared my server library with the new account, and connected rarflix to it - main screen on deck updating fine.

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited January 2014
    jillybean wrote on January 5 2014, 3:47 AM: »

    Not familiar, but if you point me in the direction of some instructions I should be ok.


    focus on the "Roku Logs" part ( not remote logging) -- https://forums.plex.tv/topic/37215-frequently-asked-questions/?p=369076

    Please include two log results if you can.

    1) open the channel as the main user, focus over an ondeck item, click the * key and mark as watched. It should now, refresh the row and remove that item ( we expect it not too with your issue). Only include the log file with this result if it doesn't refresh. We can only fix the issue if the issue actually happens, which I'll expect it does since you mention it seems to always happen.

    2) do the same with the "shared user". Follow the same steps above, we expect this one to work as you stated it did.
     

    Just for kicks I set up a second myplex account, shared my server library with the new account, and connected rarflix to it - main screen on deck updating fine.


    That is interesting. It's the "same code" so it's interesting why it wouldn't work with the Main User.
  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass

    I read the instructions, connected to myplex as the main user, enabled logging, marked an 'on deck' show as watched.....  and it worked!  I swear it wasn't before.  I will keep using it as is and report back with logs if (when?) the problem resurfaces.

    Thanks

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    NO!!!! Well I guess that's a good thing :) but I was hoping we'd get to the bottom of this rare issue. If it starts to happen, please follow the instructions without exiting the channel so we can get some logs.

    Glad it's working for you though!


    jillybean wrote on January 10 2014, 1:19 AM: »

    I read the instructions, connected to myplex as the main user, enabled logging, marked an 'on deck' show as watched.....  and it worked!  I swear it wasn't before.  I will keep using it as is and report back with logs if (when?) the problem resurfaces.
     
    Thanks

  • jillybeanjillybean Posts: 34Members, Plex Pass Plex Pass

    On deck stopped updating again tonight so logs are attached.

    Log1.txt - signed in to myplex normally - % watched/marking as watched not updating (although it had been working fine for the last couple of weeks).

    Log2.txt - signed in as shared user - marked a couple of things as watched and updated ok

    Thanks

  • petr9999@gmail.competr9999@gmail.com Posts: 18Members, Plex Pass Plex Pass

    i have the same problem, it NEVER updates, i need to exit the app and go back in so that it does... should i post any logs? where do i get em?

  • walkthewaywalktheway Posts: 75Members

    I have a similar problem.  I wrote a VLC_channel for Plex.  Because it can control the VLC player, I change the titles under the icons so I can always see what the current state is. These changes are not present on return from the message popup that acknowledges the change using -> ObjectContainer(header="...", message="...").  Changing directory levels does not change anything.  I must exit the channel and re-enter to see the update.  I am running the "roku-client-public-refresh-home-on-view" version of Plex on Roku.

    Does schuyler have any suggestions?

    Thanks.

  • ljunkieljunkie Plex Dev Team Posts: 4,944Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited February 2014
    This isn't related. This is a channel thing. Isn't this more related to how channels are cached - I.E. This would also happen on any client including plex/Web? Either way I'd suggest to create a new thread.

    walktheway wrote on February 25 2014, 2:30 AM: »

    I have a similar problem. I wrote a VLC_channel for Plex. Because it can control the VLC player, I change the titles under the icons so I can always see what the current state is. These changes are not present on return from the message popup that acknowledges the change using -> ObjectContainer(header="...", message="..."). Changing directory levels does not change anything. I must exit the channel and re-enter to see the update. I am running the "roku-client-public-refresh-home-on-view" version of Plex on Roku.

    Does schuyler have any suggestions?

    Thanks.

  • walkthewaywalktheway Posts: 75Members

    Thanks for the response.

    I do not experience the same problem in the Plex Media Manager.  It reloads the icons etc every time I change directory levels or click on an icon that display a message.  So it looks like it was working correctly (at least in PMM).  I have set the ObjectContainers to no_cache=True.

    However, on Roku, it works completely differently.  Nothing updates until I exit the channel and re-enter.

    I presume that what the Roku displays is a pull from PMS, not a push by PMS.  Which would place the refresh obligation on the Roku plugin, not PMS or my channel.  Is this correct?

    Is this still a channel issue or a Plex Roku plugin issue?

    It appears that the difference is being caused in the Plex plugin for Roku, not in the channel I wrote (as far as I can tell).

    I can post this in the channel development section if appropriate.

    Please confirm.

    Thanks.

«1
Sign In or Register to comment.