If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Are you having Stuttering/Buffering Issues? Look Here

1457910

Comments

  • lchazg4lchazg4 Posts: 5Members, Plex Pass Plex Pass

    For users experiencing issues since the 0.9.12.8 release of Plex Server, please also see my post in the "Windows" forum. I was able to downgrade to 0.9.12.4 and the issue disappeared completely. The problem with downgrading is that my upgraded iOS app will no longer connect to my server stating that an update is required, using Plex/Web as a remote for now. For those of you looking for a solution which doesn't disable security features this may be a good temporary alternative until the Plex devs find a permanent solution.

    Download previous releases:

    https://plex.tv/downloads/1/archive

    Windows forum discussion:

    https://forums.plex.tv/discussion/175784/no-longer-able-to-stream-1080p-now-even-720p-stuttering

    Here are my posts:

    https://forums.plex.tv/discussion/comment/997928/#Comment_997928

    https://forums.plex.tv/discussion/comment/997937/#Comment_997937

  • morsokmorsok Posts: 1Members, Plex Pass ✭✭

    Downgrading fixed it for me too. Hope a fix will be committed soon.

  • decast25decast25 Posts: 2Members, Plex Pass Plex Pass

    Hi

    I deactivate the secure connections and the problem solves without need for downgrading

  • scottjf8scottjf8 Posts: 5Members, Plex Pass Plex Pass

    I think I figured what was my cause (transcoding settings.) I switched it to "Make my CPU hurt" and then it seems to play fine on my AppleTV.

  • dagingaadagingaa Posts: 8Members, Plex Pass Plex Pass

    For anyone else hoping the new Chromecast will finally fix the SSL stuttering issue: Nope. I just got mine and tested with the previously unplayable video file I have. While it could play the file (specifically the intro sequence which is very demanding) just fine, while the original Chromecast couldn't, it started stuttering immediately upon playback when I set SSL to required again. So it has somewhat better performance than before, but still not enough.

    Here's hoping the Chromecast 3 will be able to handle SSL and 1080p.

  • colmar13colmar13 Posts: 6Members, Plex Pass Plex Pass

    Stuttering when streaming on cromecast. Started some time ago, probably with the implementation of SSL or new transcoder. Stuttering in fast moving scenes of heavy files, especially with a big change it picture. All preset stayed the same router/ server/ chromecast / places where they are.

    • I am absolutely sure it is not due to a wifi issue. Checked it 1m away from router, same problem.
    • Disabling SSL do not work and not an option for me (also I tried just for sake of curiosity, nowadays, as the people say it does not work).
    • I am not completely sure that the problem is not cpu horsepower related, however there are posts here that people with pretty fast cpus have same issues (i.e. i7-3930K, i7-4790).
      >I have plex serverside side on a dedicated server (not top notch but enough to transcode one 1080p stream, i5 4570), and have no issue of steaming with transcoding anything anywhere, except chromecast. Actually, a have a drop in transcoder speed in logs in the places where a have stuttering to 1 or 0.8, but the strange thing is that after a pause and some waiting time to let sever do the transcode, playback is ok only for 2-3 seconds. To my mind, if everywhere else I have 4-7 transcoder speed and 120 sec before throttling the transcoder, this one time drop in speed should not be critical. Especially when such fast moving scene is really short ( less that 60 sec, not even close to 120). Also, if I stream the same file to a plex web with force transcode or to iphone / ipad / ps4 with the highest bitrate availlible and in 1080p there is no problem at all.
      Recently, I found the solution: you can choose 720p in the app from which you are going to stream to chromecast, and everything works like a charm, no stuttering at all.
      This solution points me to the fact that there is not enough computing power in chromecast.
      And the problem is that ssl is too much for a 35$ device. Or there was some change in transcoder setting, which make it hard for chromecast to use. Or both.
      Personally for me the main pain in the … is that I change the settings all the time now, as I have chromecast in the kitchen and I usually watch only a part of the movie there, and later switch to other device.
      So, for me it would be a charm to have an option force 720p on chromecast no matter what settings are on the device that initiates the cast.
  • jsg2021jsg2021 Posts: 12Members, Plex Pass Plex Pass

    the chromecasts (both new and original) can play content just fine over ssl. the problem seems to be that plex is lying to the chromecast about the bit rate, so chromecast can't pre buffer correctly. on some local networks this is not noticeable... the starved buffer can refill fast enough to not cause a perceptible pause/stutter.

    So don't give up hope. they can fix this.

  • vitoozvitooz Posts: 3Members, Plex Pass ✭✭

    I have been having stuttering issues recently as well, specially on fast pace scenes.

    I mostly used Plex over wired network so never experienced that before but now I have been trying different alternatives.

    My setup:
    Plex server:
    iMac 27" i5 20GB RAM 500 SSD / 4TB Hybrid Drive (Where my media is located)

    Plex Players:
    PS4 wired - no problem here (always play 1080p Original regardless of MKV, MP4 or AVI)

    Chromecast 1 - Plays fine 720p, Starts playing fine 1080p Original but as soon as the first fast scene comes up everything slows down) Never buffers, it only stutters constantly.

    Smart TV - no problem here either, it plays 1080p original over 5GHz Wifi

    Modem/Router: Netgear Nighthawk D7000 - 1900AC

    So, I have tried a few different things last night and tested, nothing really fixed the CC stutter issue.

    1 - Disabled DLNA
    2 - Turned OFF Direct Stream
    3 - Turned OFF Direct Play
    4 - Found an empty frequency for my 2.4 GHz network which in my case was 13
    5 - Started playing the content from an iPad, Android phone as well as from my iMac and obviously it didn't matter
    6 - Rolled back 3 different versions for Plex Server installed each one of them and no luck

    So I am not a experienced user, in fact I have only started using Plex a few months ago and as far as I can see the problem for me is the communication between my modem and Chromecast or the Chromecast itself.

  • vitoozvitooz Posts: 3Members, Plex Pass ✭✭

    I'd like to add that I went and bought the new CC2 to try it out.
    So it works okay, it doesn't stutter as much as the original CC but I can still notice it doing specially when you have fast camera movement.

    So for now I'll stick to my Smart TV App, which isn't the most convenient option but it works really well.

  • junpitjunpit Posts: 5Members ✭✭

    I'm getting fed up of this. CC2 is stuttering st anything over 4mbps and 720p. The network connection is an ac router at 800 Mbps. A file transmits at about 50mb/s. My plex server is an i7.

    There is no reason that I can see for this.
    Please fix this plex.

    Regards

    Darren

  • rcosgrovercosgrove Posts: 36Members, Plex Pass Plex Pass

    @scottjf8 said: I think I figured what was my cause (transcoding settings.) I switched it to "Make my CPU hurt" and then it seems to play fine on my AppleTV.

    I've had serious, stuttering problem on a 1st gen Chromecast with Plex effecting random videos for a while a now.
    None of the factors in the OP's post were a factor, and none of it helped.
    However, Scottjt8's suggestion worked immediately.

  • junpitjunpit Posts: 5Members ✭✭

    @rcosgrove said:
    However, Scottjt8's suggestion worked immediately.

    I did this and it didn't make any difference. I've struggled for ages to get some thing that will play back my home videos correctly. They are 1080p mkv's at 50 fps with 5.1 audio. Kodi does this effortlessly. Plex struggles. I will accept a better bandwidth and lose some quality from native, but 4 mbps doesn't do them justice.

  • rcosgrovercosgrove Posts: 36Members, Plex Pass Plex Pass

    @junpit said: They are 1080p mkv's at 50 fps with 5.1 audio.

    My videos are regular 1080p and 720p files at 24fps.
    MKV isn't an audio-video file format: it's just a container. The actual encoding used may be causing Plex problems.

  • borochrisborochris Posts: 94Members, Plex Pass Plex Pass

    One point to consider. plex to chromecast used to work 100% perfect for me, whatever the file type. It is only since the recent upgrades (new ios client, new server version), that I started to have these problems so something has changed for the worse.

  • FliinFliin Posts: 1Members, Plex Pass Plex Pass

    @borochris said:
    One point to consider. plex to chromecast used to work 100% perfect for me, whatever the file type. It is only since the recent upgrades (new ios client, new server version), that I started to have these problems so something has changed for the worse.

    Exactly the same problem here. Worked like a charm before. Havent changed anything beside app/server versions

  • ButcherChopButcherChop Posts: 1Members

    I read somewhere that the Chromecast has been stuttering for many people. It has recently started with me for a few weeks. I don't use Plex like I used to, yet I'm still having issues streaming DLNA.

  • noelleesnoellees Posts: 4Members ✭✭

    I am also having stuttering issues on the Chromecast which has only recently started happening.

    I use the Chromecast every day however maybe just the last week it will no longer stream without stuttering, I always cast from my iOS device and it has worked flawlessly for well over a year until now, I have noticed when I do play a file it defaults to 64kbps, if I change it to unlimited or even 3mbps both of which have gone fine in the past it hits the same issue, sometimes even pausing and then when I press play it goes back to 64kbps, extremely frustrating!!

  • DrMagicWolfDrMagicWolf Posts: 12Members, Plex Pass Plex Pass

    My situation is exactly as noellees described, these issues have just started recently and were not there before.
    I have tried all the fixes in the plex forums that I could find, but none of them had any lasting effect until now.
    A few months ago I watched a movie on my CC that I ripped, like all of my other blurays (MakeMKV, no re-encoding), where people run around in blue embodyments, there was no stutter throughout the entire movie (@ 1080p Original Quality).
    Now I wanted to watch this movie again with some friends and it was stuttering/buffering from the first second on (@ 1080p Original Quality), pausing for a while helps, but only for a few seconds, on the exact same setup as a before.
    The only thing that helps is switching to 720p 4Mbps, then it runs fine.
    So how can it be that the identical setup used to run perfectly and now it doesn't at all?
    To avoid guess posts; it is the identical setup, nothing was added or removed, no components changed or other services installed on the server, it is the same file and the same settings and even the stream was initiated from the same device.
    The only thing that was changed was that the Plex server and Plex app software.
    To clarify further; the movie runs fine @ 1080p Original on all other devices (iPhones, iPads, Apple TV's, Roku's, Android Tablets and PC's, the CC is the only device that started struggling lately.
    My upgraded QNAP TS-870 Pro server runs an i7-3770S, 16GB RAM, 8x4TB in RAID5, it is dedicated for Plex alone and I have tested it before, with up to eight 1080p (BD-MKV Rip) to 720p transcoding tasks at once without a hitch.

  • mickeldaelmansmickeldaelmans Posts: 277Members, Plex Pass Plex Pass

    I can confirm that I have the same issue with my Chromecast 1, but not with my new Chromecast 2. My guess is that the Chomecast device profile has been updated to accommodate the improved specs/hardware of the Chromecast 2, but that PMS can't recognize (or switch to a fitting profile) for the old Chromecast, resulting into a too high bitrate for the Chromecast 1 to handle. This is pure speculation.

    My Plex setup: Synology DS916+ (8GB), RPI3 + Plex for Kodi, Oneplus 3 (Android 7), Chromecast 1st gen & 2nd gen, Samsung UE43KU6500

  • Eric.KrauseEric.Krause Posts: 11Members, Plex Pass Plex Pass

    I just wanted to add that I'm experiencing the same as DrMagicWolf and noellees. I hope this get's resolved soon as it is rather frustrating.

Sign In or Register to comment.