Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Some videos play in fast forward without audio?



  • hashworkshashworks Posts: 57Members, Plex Pass Plex Pass
    edited December 2013

    Using "export AE_ENGINE=SOFT" or just "AE_ENGINE=SOFT" before starting PHT didn't worked for me.

    In my case, it's the whole supernatural season 8, everything else plays just fine:


    • Video Auflösung 1080p
    • Dauer 40:45
    • Bitrate 11888 kbps
    • Width 1920
    • Height 1080
    • Seitenverhältnis 1.78
    • Container MKV
    • Video Bildfrequenz PAL
    • Accessible Yes
    • Exists Yes
    • Dauer 40:45
    • Datei /.../Supernatural - S08E21 - Metatron und das Wort Gottes.mkv
    • Size 3.38 GB
    • Container MKV
    • Codec H264
    • Bitrate 9529 kbps
    • Sprache Deutsch
    • Bit Depth 8
    • CABAC 1
    • Chroma Subsampling 4:2:0
    • Color Space yuv
    • Dauer 40:45
    • Bildrate 25.000 fps
    • Frame Rate Mode cfr
    • Has Scaling Matrix 0
    • Height 1080
    • Ebene 4.1
    • Profil high
    • Ref Frames 4
    • Scan Type progressive
    • Width 1920
    • Codec AC3
    • Kanäle 5.1
    • Bitrate 384 kbps
    • Sprache Deutsch
    • Bit Depth 16
    • Bitratenmodus CBR
    • Dialog Norm -31 dB
    • Dauer 40:45
    • Abtastfrequenz 48000 Hz
    • Codec DCA
    • Kanäle 5.1
    • Bitrate 1509 kbps
    • Sprache English
    • Bit Depth 24
    • Bitratenmodus CBR
    • Dauer 40:45
    • Abtastfrequenz 48000 Hz

    Rebooting or selecting the second audio line doesn't work.

    This occoures on XBMC / Plex Home Theater only.

    They play just fine in Win8-App or PlexWeb.

    When I tryed to set the fast forward manually, they go from x2 to x32, then to normal - which is x32 in this case.

    EDIT: I think I kinda broke my audio settings, after the export command I'm not having any sound at all...


    After fixing what the environment variable AE_ENGINE broke I was able to fix the fast forward on my system.
    Disabling AC3 under Settings->System->Audio-Output was the solution.

    This is kinda the same solution as disabling Direct Play, as seen on the first page on this thread. But with this I hope it transcodes the audio only.

    Edit: Needed to disable the other options as well for some videos.

    Edit 2: My Menu-Sounds still don't work, but thats ok.

  • whyride.comwhyride.com Posts: 1Members, Plex Pass

    None of the above helped my system; however, I could get audio via HDMI by unchecking the "Dolby Digital AC3 capable receiver" option.

    You may want to try a combination of the options in the Audio Output section to resolve the problem on your particular setup.

    Good luck.


  • BillyC333BillyC333 Posts: 9Members, Plex Pass Plex Pass
    edited March 2014

    The problem also exists in xubuntu 13.10 (i386) when using HDMI. I guess all flavors of ubuntu are effected. 

    I have not tried any of the above solutions yet. I will attempt drunkenm666 suggestion of editing the start up script.

    Is this related to the video cards we are using by any chance? I am using a nvidia GT440.

    Ok so editing the start up script + unchecking all the audio options worked for me. 

  • pehowellpehowell Posts: 1Members, Plex Pass Plex Pass

    I was having the same issues (fast forward video with no audio), but this thread ended up leading me to a solution that resolved all the issues I was having.  

    I added the environment variable "AE_ENGINE=SOFT", but was still having issues.  I tried disabling all of the audio capability options (AC3, DTS, etc), which slowed the video down to normal speeds and gave me stereo audio, but then I wasn't getting passthrough to my receiver.  

    At that point I noticed I was able to see new options under the Audio and Passthrough output device.  I chose my NVidia HDMI out (there are several and needed to experiment to find the right one) for both.  I changed Audio output channels to 2.0 (which I believe is only used if downmixing or PHT is decoding something like MP3).  On the "capable receiver" options, I checked Dolby Digital (AC3), DTS, and AAC.  The other capable receiver options are left unchecked.  I am now getting normal speed video and rich sounding audio on high bitrate videos with DTS and Dolby Digital 5.1 audio.  I have also tested video files with MP3 and Dolby Digital 2.0, and 1080p Youtube videos from my queue with success on all fronts.

    I tried enabling LPCM but was having issues when that option is checked, so now I'm leaving it unchecked.  Menu sounds are working for me.

    My setup:

    PHT 1.0.13dev-git running on a mid-2010 Apple Mac Mini (NVidia Geforce 320M) running Ubuntu 12.0.4.  It is connected via HDMI to a Pioneer receiver.

    Hope that helps someone out there.  If you need more details, just let me know.

  • andrewgrimbleandrewgrimble Posts: 2Members ✭✭
    drunkenm666 wrote on November 26 2013, 8:35 PM: »

    Hi Astralis!

    I also suspected the gstreamer plugins - no wonder, they have "bad" in the name... - and uninstalled them right away. Unfortunately that didn't help either.

    So, today I completely removed PlexHT again (also removed .plexht in my home dir) and reinstalled it. Problem was still there - UNTIL I deactived the audio options, like on your screenshot! Everything works like a charm!

    I really hope, that this gets fixed soon, and that I can take some load off my server, which is connected to a Pioneer VSX-922-K, which is more than capable of decoding AC3, DTS and whatnot. But it look like, that I'm stuck currently with the server having to decode the audio stream. Well, at least it works. :)

    Thanks again for everybody trying to help me and thanks for the Plex team for making this AWESOME piece of software (the server and the many clients for the different OSes)!!!

    P.S.: Too bad, that I like the old skin better, but on that one I didn't find these options! They must have been new to this version, that's why I still had no sound when I tried to reinstall the 0.9.x - it was probably saved in my .plexht folder and since I had no option in 0.9.x to disable them, I didn't realize that.

    I was having exactly this problem and had to unclick the Dolby options to get things to work....then I realised my Onkyo amp was set to work on zone 2 (not sure how I managed that) and when I changed that so it was just normal it seemed to work fine with the Dolby options ticked. Video speed went back to normal and sound worked ok. So might be a setting on your amp...

  • javrochjavroch Posts: 30Members, Plex Pass Plex Pass

    Just wanted to post to say that my issue was specifically with the "Dolby Digital (AC3) capable receiver" option.

  • Plexeej2Plexeej2 Posts: 10Members ✭✭

    Okay bitstreaming is working for me, even DTS-HD and TruedHD. I got my receiver alsa hdmi options.

    All I did was:

    $ sudo nano /usr/bin/plexhometheater.sh

    Here is the code:

    export XBMC_HOME=/opt/plexhometheater/share/XBMC
    #Use export AE_ENGINE=SOFT to disable pulse audio
    #export AE_ENGINE=SOFT

    Now, simply uncomment export AE_ENGINE=SOFT

  • notInKansasnotInKansas Posts: 3Members
    Thanks to chimera for the fix.
    I had the same issue - video playing at ~10x normal speed and no sound -  on an Intel NUC with the Celeron N2820 and Ubuntu 14.04, connected to a receiver over HDMI. Almost all my movies have DD or DTS soundtracks, and I have a 5.1 speaker setup, so transcoding the audio to plain stereo wasn't very tempting.
    AE_ENGINE=SOFT didn't do anything on its own. But changing the PHT "Audio output device" and "Passthrough output device" worked. The audio device was "play through PulseAudio" (default), and the fix is apparently to bypass PulseAudio altogether. In my case, by setting both the audio and the passthrough device to "HDA Intel PCH, marantz on HDMI". (Where HDA Intel PCH is the sound card, and marantz is the receiver.)
    BTW, this error
    libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
    libva: va_openDriver() returns -1
    is because that file doesn't exist. (There is a i965_dri.so, but symlinking *_dri.so to *_drv_video.so didn't help, I just got a complaint about a missing function instead. That is, whatever libva is looking for, it's not *_dri.so.)
    The terminal shows the same error even with AE_ENGINE=SOFT. But with the configuration changes above, the video plays at normal speed, the sound appears unafffected, and I get DD and DTS passthrough to the receiver. 
  • Ralphman21Ralphman21 Posts: 19Members, Plex Pass Plex Pass
    edited February 2015

    Anyone coming across this thread, I was able to get my DTS audio working by following Plexeej2's advice. Simply enter sudo nano /usr/bin/plexhometheater.sh into terminal and hit enter. The code listed in his post will appear. Remove the "#" from in front of the "#export AE_ENGINE=SOFT", then press control and x. It will ask you save changes by pressing Y. Then enter

    After this I went into the audio settings in my Plex Home Theater and changed the Output Device. I had to try a few different ones because one worked but I lost the Plex system sounds (the click when scrolling), but the one I settled on gave me DTS and system sounds.


  • samuelwnsamuelwn Posts: 3Members, Plex Pass Plex Pass
    edited February 2016

    Plexeej2: Thank you.

  • scottsiscoscottsisco Posts: 1Members, Plex Pass Plex Pass

    Plexeej2, Thank you so much!

Sign In or Register to comment.