Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[REL] Google Music Channel

1101113151619

Comments

  • thezoofthezoof Members Posts: 8 ✭✭

    Hey all. I finally have my basement setup and plex is working well.

    I have been trying to get this app to work the past few days and unfortunately struggling with logging in. Is there something I should be doing different?

    Steps:

    Downloaded plug in, unzipped to plugins folder, removed -master, started plex, click gear icon, type u/p, and click on channel. I get 'This channel is not responding'.

    I tried removing the plug in, clearing cache from C:\Users\Media\AppData\Local\Plex Media Server\Plug-in Support\Caches but same issue occurs.

    I have confirmed the username and password is correct(same as what I log into google music with in browser) but I am getting the following error when I click on the channel:

    "type": "ajax",
    "url": "https://192-168-0-10.498a3784570c4dd1998fffcac005945c.plex.direct:32400/music/googlemusic",
    "status": 500,
    "headers": {
    "X-Plex-Product": "Plex Web",
    "X-Plex-Version": "2.4.23",
    "X-Plex-Client-Identifier": "qid2v2d051w6ogvi",
    "X-Plex-Platform": "Chrome",
    "X-Plex-Platform-Version": "46.0",
    "X-Plex-Device": "Windows",
    "X-Plex-Device-Name": "Plex Web (Chrome)",
    "X-Plex-Username": "thezoof",
    "X-Plex-Token": "TOKEN",
    "Accept-Language": "en"
    },
    "statusText": "Internal Server Error",
    "response": "<?xml version='1.0' encoding='utf-8'?>\n\n Traceback (most recent call last):\n File \"bundles-release/Framework.bundle-dist/Contents/Resources/Versions/2/Python/Framework/components/runtime.py\", line 843, in handle_request\n File \"bundles-release/Framework.bundle-dist/Contents/Resources/Versions/2/Python/Framework/handlers/base.py\", line 111, in call\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Code\__init__.py\", line 47, in MainMenu\n API.authenticate(Prefs['email'], Prefs['password'])\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusic.py\", line 66, in authenticate\n self._set_all_access()\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusic.py\", line 38, in _set_all_access\n settings = self._webclient._make_call(webclient.GetSettings, '')\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\clients\shared.py\", line 80, in _make_call\n return protocol.perform(self.session, self.validate, *args, **kwargs)\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\protocol\shared.py\", line 208, in perform\n response = session.send(req_kwargs, cls.required_auth)\n File \"C:\Users\Media\AppData\Local\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\session.py\", line 81, in send\n raise NotLoggedIn\nNotLoggedIn\n\n\n",
    "time": "2015-10-27T15:05:41.822Z"

  • thezoofthezoof Members Posts: 8 ✭✭

    I also want to add that if i change u/p then it doesn't make a difference. It seems like I am missing a step to actually log in or something.

    Google Music is working fine in browser and on android device, just not in channel.

  • SlinkynoseSlinkynose Members, Plex Pass Posts: 44 Plex Pass

    thezoof,

    Firstly I want to thank you very much for your write up. It helped me resolve my boneheaded error of leaving the "-master" on the bundle filename.

    I can see the channel now, but have the same issue that you do - it just says "Channel not responding". I thought it might be because I have to use the App Password from Google (https://security.google.com/settings/security/apppasswords) due to 2-Step authentication. But I'm not sure.

    I see this entry in the googlemusic plug-in log

    "2015-10-27 13:15:16,953 (15d0) : CRITICAL (core:572) - Exception (most recent call last):
    File "bundles-release/Framework.bundle-dist/Contents/Resources/Versions/2/Python/Framework/components/runtime.py", line 843, in handle_request
    File "bundles-release/Framework.bundle-dist/Contents/Resources/Versions/2/Python/Framework/handlers/base.py", line 111, in call
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Code__init__.py", line 47, in MainMenu
    API.authenticate(Prefs['email'], Prefs['password'])
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusic.py", line 66, in authenticate
    self._set_all_access()
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusic.py", line 38, in _set_all_access
    settings = self._webclient._make_call(webclient.GetSettings, '')
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\clients\shared.py", line 80, in _make_call
    return protocol.perform(self.session, self.validate, *args, **kwargs)
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\protocol\shared.py", line 208, in perform
    response = session.send(req_kwargs, cls.required_auth)
    File "D:\PlexData\Plex Media Server\Plug-ins\GoogleMusic.bundle\Contents\Libraries\Shared\gmusicapi\session.py", line 81, in send
    raise NotLoggedIn
    NotLoggedIn"

  • thezoofthezoof Members Posts: 8 ✭✭

    You're welcome.

    I turned off two step authentication and still have issue. If you have two step authentication then I think you should get an email to clear things up and select password/uid. I believe that someone else mentioned that earlier in the thread.

  • thezoofthezoof Members Posts: 8 ✭✭

    interesting. If I remove u/pwd then it looks like it loads without issues. I am able to click 'refresh library' at that point. See what happens... I will let you know.

  • thezoofthezoof Members Posts: 8 ✭✭

    Unfortunately it allows the channel to work but it doesn't link to my google account. There must be something silly I am doing wrong. Thanks all for any help.

  • GuffieGuffie Members, Plex Pass Posts: 3 Plex Pass
  • thezoofthezoof Members Posts: 8 ✭✭

    Thanks. That works. Sorry I missed it.

  • SlinkynoseSlinkynose Members, Plex Pass Posts: 44 Plex Pass

    Yep, worked for me too. Been so long I forgot about that post. Thanks to all of you, Guffie and thezoof, and most of all to Pablorusso, really glad to have this working again!

  • errkalerrkal Members Posts: 14 ✭✭
    edited October 2015

    MIne doesn't work, it doesn't load my library at all. I jjust get what I posted a few days ago.

    Attached the logs

  • domplex12345domplex12345 Members Posts: 3 ✭✭

    Hi

    I have plex media server installed on two computers at home. Both are windows 10 systems.
    On first computer google music channel is working but with problems. Radio stations and Genres are not working. I click on first song and it constantly loads. Onlly once it managed to start. My library starts instantly but it does not continue on next song. I have google music subscription.
    On second computer when i start google channel it says directory is empy or something like that.

    I have installed this plugin yesterday and tried it just a little bit so maybe i am missing some basic setup stuff to get it working. I would appreciate some help.

  • laplace11laplace11 Members Posts: 1

    Note: If you're using multi-factor authentication with your Google account you won't be able to use your regular account password with this plugin. Visit https://security.google.com/settings/security/apppasswords and generate a password, then use that. This solved my issues

  • huvanilehuvanile Members, Plex Pass Posts: 3 Plex Pass

    Got it working.

    Note that if you've changed your "The path where local application data is stored" server preference, you'll need to save the channel's files at a different location (i.e., not C:\users[username]\AppData\Local\Plex Media Server\Plug-ins). For example, mine was G:\Plex Media Server\Plex Media Server\Plug-ins.

  • raevengelraevengel Members, Plex Pass Posts: 106 Plex Pass

    Thanks everyone for posting your trials and difficulties. I had the same issues with everything going blank when I added my username and password. I followed every link given that was supposed to help with the resolution and yet couldn't understand what I needed to do. In the end, I reinstalled from what I thought I had initially but it seems that it was either the new version with the mobileapi or my initial install was bad. I think I just didn't have the latest version. Anyway, to make it simple, if anyone else has this issue, reinstall the newest version that says it has the login fix. It should then work. Here's a link directly to the files:
    https://github.com/pablorusso/GoogleMusic.bundle/tree/update_gmusicapi_fix_login

  • ethanhunt202ethanhunt202 Members, Plex Pass Posts: 43 Plex Pass

    Am I being a total plank, or does this not work for Linux yet? I have a NetGear ReadyNAS and when I add the original channel, it appears straight away on Mac and PC, but when I add the login fixed version, it doesn't.

    Am I being thick or missing a step somewhere?

  • tristanteutristanteu Members, Plex Pass Posts: 1 Plex Pass

    i was facing the same issue!

    you need to compile https://pypi.python.org/pypi/pycrypto for linux.
    in this version: https://github.com/pablorusso/GoogleMusic.bundle/tree/update_gmusicapi_fix_login
    there is only pycrypto for windows.

    I have compiled it on debian:
    https://dl.dropboxusercontent.com/u/13344648/Crypto.zip

    just replace the crypto folder and it should be working on linux.

    regards
    tristan

  • ethanhunt202ethanhunt202 Members, Plex Pass Posts: 43 Plex Pass

    Thanks Tristan, but that hasn't worked. Doesn't show up in the channel list.

    Thanks anyway.

  • unLiebunLieb Members, Plex Pass Posts: 83 Plex Pass

    Access denied!

    The server denies access . Please make sure that you are logged on as a user with access rights for this server .

    Any ideas?

  • edifiededified Members, Plex Pass Posts: 59 Plex Pass

    Does this plugin work for anyone right now? I can't get it to work (when loading the app, it throws an error message... It never lets me even put in username/password anymore.)

    Is there a way to clear the stored username/password?

  • edifiededified Members, Plex Pass Posts: 59 Plex Pass

    OK, works for me now. I installed the plugin obtained by going to
    https://github.com/pablorusso/GoogleMusic.bundle/tree/update_gmusicapi_fix_login
    and then clicking "Download ZIP". No git access needed. I just wish google search results would put that link at the top of the search results for "google music plex" instead of jwdempsey's broken version.

Sign In or Register to comment.