Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

My Music/TV Shows/Movies Aren't Showing Up

elanelan Sheriff of PlexvilleMauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
edited September 2010 in OS X (Mac)
Help us help you
I'd like to use this topic to gather valuable information from you to help us improve the scanners so as to get your media into the library. This topic is NOT for you if you have your media in the library, but aren't getting any metadata (e.g. posters, art) for it.

Background information:

Plex Media Scanner log: ~/Library/Logs/Plex Media Scanner.log
Plex Media Server log: ~/Library/Logs/Plex Media Server.log
Location for crash reports: ~/Library/Logs/CrashReporter/

If your media is not showing up, there are two basic possibilities:

  1. The way your files are named doesn't agree with the scanner.
  2. The scanner is exiting/crashing on a particular item.
  3. The missing item got merged with another item.


A few notes on how your media has to be set up (and more details here):

  • Movies are the most liberal of all, most every video file should be scanned in.
  • TV shows need *at least* a top-level show folder.
  • Plex must be able to identify the season/episode from (a) the name or (B) MP4 atoms.
  • Music must have either ID3 tags or M4A tags (at the moment).


Let's address the first one because it's the primary issue, especially for TV Shows. If most of your media shows up except a few shows or episodes, you can look at the Plex Media Scanner log (referenced above): [I've left in only the interesting lines]

Sep 05, 2010 10:25:33 [0xa043f500] DEBUG -     * Scanning directory /Volumes/Drobo2/TV Shows/Arrested Development/Season 1
Sep 05, 2010 10:25:33 [0xa043f500] DEBUG -       * Scanning Arrested Development Season 1 Episode 1
Sep 05, 2010 10:25:33 [0xa043f500] DEBUG -       * Scanning Arrested Development Season 1 Episode 2


That snippet from the log shows what you'll see for two episodes that are scanned in correctly. If you do NOT see those "Scanning" lines for episodes, they are not being scanned. If this is the case, I would like you to do the following:

Please post a reply to this thread with the full names of the folders and episodes not being match (e.g. "/Volumes/Backups/Downloads/24 - 8x12 - Day 8_ 3_00A.M. - 4_00A.M/24.s08e12.720p.hdtv.x264-immerse.mkv") That should be all the data we need for TV shows and movies.

Same thing if you're missing a movie or an album. Note though, for music, that the most likely culprit is not having ID3 tags. We'd love to work with developers to build better scanners, and since they are "pluggable" it would be perfectly possible to have one that scanned simply based on directory structure, e.g.

Now if you're seeing only the *first* X shows or movies scanned in, for example, and you seem to be missing the last half, then it's likely the scanner crashing or stopping for some weird reason. In this case, please note this in your post, and try to figure out which piece of media is causing the issue by looking at the end of the scanner log. You can temporarily move out a piece of media to try to identify the culprit.
«13456739

Comments

  • playstation87playstation87 Posts: 99Members, Plex Pass Plex Pass
    edited September 2010
    1 TV Show episodes are giving me trouble. Using the new github tvdb scanner with a symlink. plex media scanner.log does not have entries for this episode.

    /Volumes/Media Drive/TV Shows/Chuck/Season 3/Chuck - S03E06 - Chuck vs. the Nacho Sampler.avi - I've also tried renaming to Chuck - S03E06.avi but it didn't work
  • dzerovibedzerovibe Posts: 77Members, Plex Pass
    playstation87 wrote on 06 September 2010 - 05:09 AM:

    1 TV Show episodes are giving me trouble. Using the new github tvdb scanner with a symlink. plex media scanner.log does not have entries for this episode.

    /Volumes/Media Drive/TV Shows/Chuck/Season 3/Chuck - S03E06 - Chuck vs. the Nacho Sampler.avi - I've also tried renaming to Chuck - S03E06.avi but it didn't work

    That's interesting... I hadn't noticed, but after seeing this post I had a look, and sure enough, the same episode is missing from my library. The full path is:

    /Volumes/1tb_Seagate/TV/Chuck/Chuck - 03x06 - Chuck vs. the Nacho Sampler.avi
    


    Here are the relevant snippets from the scanner log:

    Sep 06, 2010 06:04:39 [0xa0b92500] DEBUG -     * Scanning directory /Volumes/1tb_Seagate/TV/Chuck
    
    ...
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG -       * Scanning Chuck Season 3 Episode 5
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG - Looking for path match for [/Volumes/1tb_Seagate/TV/Chuck/Chuck - 03x05 - Chuck vs. First Class.avi]
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG - Path matched, we're reusing media item 584
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG -       * Scanning Chuck Season 3 Episode 7
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG - Looking for path match for [/Volumes/1tb_Seagate/TV/Chuck/Chuck - 03x07 - Chuck Versus the Mask.avi]
    Sep 06, 2010 06:04:41 [0xa0b92500] DEBUG - Path matched, we're reusing media item 585
    
  • cmackenzcmackenz Posts: 1Members
    First of all - brilliant software, appreciate the hard work.

    None of the shows in this directory will scan, and it stops scanning all subsequent directories alphabetically after this one:

    /Volumes/Data/TV/Monty Pythons Flying Circus/Monty.Python.S01E01.m4v

    Plex Media Scanner.log has the following:

    Sep 05, 2010 18:02:36 [0xa036f500] DEBUG - * Scanning directory /Volumes/Data/TV/Monty Pythons Flying Circus
    Sep 05, 2010 18:02:36 [0xa036f500] DEBUG - * Taking directory 'Monty Pythons Flying Circus' (528) out of the map (0 left)
    Sep 05, 2010 18:02:37 [0xa036f500] ERROR - Error scanning location: /Volumes/Data/TV

    The episodes were encoded some time ago with VisualHub, newer shows in other directories which are fine were all done with HandBrake (not sure if the encoding format matters, but mentioning it as I saw some previous threads tied to M4V issues).

    Thanks for any suggestions...
  • playstation87playstation87 Posts: 99Members, Plex Pass Plex Pass
    dzerovibe wrote on 05 September 2010 - 04:15 PM:

    That's interesting... I hadn't noticed, but after seeing this post I had a look, and sure enough, the same episode is missing from my library. The full path is:

    /Volumes/1tb_Seagate/TV/Chuck/Chuck - 03x06 - Chuck vs. the Nacho Sampler.avi
    


    Found a work around. Apparently "sample" is a keyword causing that to episode to fail. I removed the name and just called it Chuck - S03E06.avi then in TV shows in the media manager I hit shift and the referesh button in the lower right and it scanned in. Then later I went back and renamed the episode.




  • elanelan Sheriff of Plexville MauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Oh, man, I should have noticed that "SAMPLEr" issue :-) Good catch!
  • danny_michaeldanny_michael Posts: 46Members ✭✭
    edited September 2010
    Sorry, wrong topic...
  • bjlewis2bjlewis2 Posts: 1Members
    edited September 2010
    I FINALLY figured out what was giving me issues. Here's what happened:

    I have 17 TV shows in my Folder: 30 Rock, Alias, Chuck...Smallville, etc.
    The only show that was showing up in my media manager was 30 Rock... I was upset.
    I decided to remove the next show (Alias) and see if plex was running into an error with one of its episodes.

    I then had 11 shows in my media manager!! Yay! progress!
    I noticed all of my shows after and including Smallville were not showing up, just the first 11.
    So, I removed the Smallville folder, and voila! the rest of my shows popped up after I rescanned!

    I then started adding each individual episode of Alias (rescanning after each new episode) and I found my problem:

    alias - s03e15 - Façade.m4v

    Then I checked Smallville, guess what I found:

    smallville - s04e03 - Façade.m4v

    Every other episode works fine, I guess it is the accent on the 'c' that is causing the problem. What I found interesting was that as soon as Plex came across one of these episodes, it would prevent any episode from that show from showing up, and prevent Plex from looking for additional shows. The accent seems to break the scan.

    Also a note: I tried renaming the files with a regular 'c' but Plex would act like the accent was still there and stop the scan.
    So, my advice is to check for accents in your file names...Hope that helps!


    -Brian Lewis-
  • elanelan Sheriff of Plexville MauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Great input, we're turning it right into bugfixes...thanks so much!
  • elanelan Sheriff of Plexville MauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Danny Michael wrote on 05 September 2010 - 01:22 PM:

    After adding the new .bundle, my TV Shows still do not have any information.

    Sep 06, 2010 01:11:54 [0xb116a000] WARN - Request for plug-in [com.plexapp.agents.thetvdb] but it doesn't exist.
    



    This thread is for people not able to get shows into the Media Manager, not for people lacking posters. However, it looks from your log that something went wrong with your bundle tweaking, because the agent isn't running.
  • tredingtreding Posts: 29Members, Plex Pass Plex Pass
    edited September 2010
    Twitter: treding

    I'm having issues with Music scrapping. I have no problem with the music that Plex finds (as far as artwork goes, although I have one weird instance of track lists, but I think it's an issue on my ID3 tags), but it isn't finding everything, mainly folders where I only have 1 or 2 songs and not an entire album.

    Here are the log files... I can't see anything wrong in them, but I have no clue what I'm looking for. Every file has ID3 tags and I can't think of anything that would be different between the full album files and the singles as far as ID3 tags go... unless iTunes is writing them wrong for some reason...

    http://www.tomreding.com/plex_logs/Plex_Media_Scanner.log
    http://www.tomreding.com/plex_logs/Plex_Media_Server.log

    an example directory path of one that's not working:

    /Beyonce/I Am Sasha Fierce/sweet_dreams.mp3


    ISSUE FIXED WITH LATEST UPDATE, thanks
  • tardontardon Posts: 8Members, Plex Pass
    edited September 2010
    I don't know if this is any help but here goes:
    I posted in another thread that some of my movies weren't being scanned. One of them was "Transformers", even though "Revenge of the fallen" was scanned properly.
    The only difference with the two was that the Transformers movie from 2007 was rar-files and revenge of the fallen was an unrared mkv (Since plex plays rar-files it just didn't cross my mind before).
    When I expanded the rar-files Plex media manager automaticly scanned Transformers for me.

    I haven't tried this on any other movies yet but I hope this helps.

    Edit: This also worked on "I love you Phillip Morris"
  • ccjensenccjensen Posts: 438Members ✭✭
    edited September 2010
    I noticed that plex was having trouble scanning lost, so I put it into a seperate folder (called "TV2"), and tried creating a new section for just it (called "tvtest"). The log linked to below is what happens when I add the top folder "/Volumes/Drobo/TV2" as the root of the section.

    To give context, this is the entire scanning of Lost:
    http://pastebin.com/3H548AJ5


    By use of trial and error, I have determined that it is season 3 episodes 14 that makes the scanning of season 3 fail (and it then fails and skips the rest of the seasons 4-6). This is the filename and path of the culprit:
    /Volumes/Drobo/TV2/Lost/Lost - Season 3/Lost - S03E14 - Exposé.m4v
    /Volumes/Drobo/TV2/Lost/Lost - Season 3/Lost - S03E14 - Exposé.sha256
    

    The .sha256 files are hashes of the original files to check for any corruption of the video files.

    I have determined that this is the episode by having plex successfully scan the Lost folder by removing this one episode. My guess it is the é at the end of exposé causing problems.

    Not sure if this will be of help, but perhaps this will save you having to dig through the entire log file linked to above. This was made by removing seasons 0-2 (ie only 3-6 are left in the lost folder that is scanned):
    Sep 05, 2010 18:45:23 [0xa02f8500] DEBUG - Opening database session to library, SQLite 3.6.23.1, threadsafe=1
    Sep 05, 2010 18:45:23 [0xa02f8500] DEBUG - Scanning tvtest with 0 current items in the database...
    Sep 05, 2010 18:45:23 [0xa02f8500] DEBUG -   * Scanning /Volumes/Drobo/TV2
    Sep 05, 2010 18:45:23 [0xa02f8500] DEBUG - 	* Scanning directory /Volumes/Drobo/TV2
    Sep 05, 2010 18:45:23 [0xa02f8500] DEBUG - 	* Taking directory '' (3729) out of the map (0 left)
    Sep 05, 2010 18:45:24 [0xa02f8500] DEBUG - 	* Scanning directory /Volumes/Drobo/TV2/Lost
    Sep 05, 2010 18:45:24 [0xa02f8500] DEBUG - 	* Taking directory 'Lost' (3730) out of the map (0 left)
    Sep 05, 2010 18:45:24 [0xa02f8500] DEBUG - 	* Scanning directory /Volumes/Drobo/TV2/Lost/Lost - Season 3
    Sep 05, 2010 18:45:24 [0xa02f8500] DEBUG - 	* Taking directory 'Lost/Lost - Season 3' (3731) out of the map (0 left)
    Sep 05, 2010 18:45:24 [0xa02f8500] ERROR - Error scanning location: /Volumes/Drobo/TV2
    Sep 05, 2010 18:45:24 [0xa02f8500] DEBUG - Refreshing section 15 of type: 2
    

    And that is the entire log, it fails almost immediately.

    Please let me know if there is any additional testing I can do or logs to provide

    twitter username is ccjensen
  • elanelan Sheriff of Plexville MauiPosts: 8,848Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    bjlewis2 wrote on 05 September 2010 - 01:30 PM:

    I FINALLY figured out what was giving me issues. Here's what happened:

    alias - s03e15 - Façade.m4v


    Thanks for the investigation. This issue *should* have been fixed already with a scanner update with the following changes:

    FIX: Handle exceptions parsing mp4 file
    FIX: .AppleDouble issue
    FIX: Scanning date-based episodes inside season files.
    


    Please check in Plex Online > More... > View History and see if you see this log for a "Scanners" update. If not, restart Plex Media Server and check for updates. If you see that update and you still see the issue, please make that file available for me to download and test with. Thanks!
  • perrinperrin Posts: 23Members, Plex Pass Plex Pass
    Just went to grab logs for error I posted in a different topic for "discovery channel: ancient rome" and this time it came up properly.

    Thanks
  • yum9meyum9me Posts: 3Members, Plex Pass
    Having an issue with CSI. Currently it gets merged with CSI: New York.

    Directory structures are as follows:

    /Volumes/My Book/Television/CSI/Season 8/CSI s08e01 - Dead Doll.avi
    /Volumes/My Book/Television/CSI New York/Season 4/CSI New York s04e01 - Can You Hear Me Now.avi
  • playstation87playstation87 Posts: 99Members, Plex Pass Plex Pass
    yum9me wrote on 05 September 2010 - 11:04 PM:

    Having an issue with CSI. Currently it gets merged with CSI: New York.

    Directory structures are as follows:

    /Volumes/My Book/Television/CSI/Season 8/CSI s08e01 - Dead Doll.avi
    /Volumes/My Book/Television/CSI New York/Season 4/CSI New York s04e01 - Can You Hear Me Now.avi


    It may be due to the TVDB having different entities try renaming these 2 episodes based on there tvdb entries and see if they'll scan


    /Volumes/My Book/Television/CSI: Crime Scene Investigation/Season 8/CSI: Crime Scene Investigation S08E01 - Dead Doll.avi
    /Volumes/My Book/Television/CSI: NY/Season 4/CSI: NY S04E01 - Can You Hear Me Now.avi

    then hit shift + refresh on lower right of the plex media server.



  • yum9meyum9me Posts: 3Members, Plex Pass
    playstation87 wrote on 06 September 2010 - 05:37 PM:

    It may be due to the TVDB having different entities try renaming these 2 episodes based on there tvdb entries and see if they'll scan


    /Volumes/My Book/Television/CSI: Crime Scene Investigation/Season 8/CSI: Crime Scene Investigation S08E01 - Dead Doll.avi
    /Volumes/My Book/Television/CSI: NY/Season 4/CSI: NY S04E01 - Can You Hear Me Now.avi

    then hit shift + refresh on lower right of the plex media server.


    Renaming the CSI directory so the structure is as shown below gets the scanner to pick the show up and separate it from CSI: NY. It would be nice if the scanner could identify that they are different shows since they are in different parent directories.

    /Volumes/My Book/Television/CSI Crime Scene Investigation/Season 8/CSI s08e01 - Dead Doll.avi

    Thanks for your help, playstation87. Appreciate it.
  • ilikeimacilikeimac Posts: 6Members
    Most of my Deep Space 9 episodes didn't scan. The "9" in "DS9" combined with the use of "#x##" notation seems to have confused the scanner. Examples:

    ds9-2x01 - The Homecoming.avi                             <-- interpreted as Season 9 Episode 2, rest of season 2 ignored
    Star Trek - DS9 - 3x01 - The Search - Part 1.avi  <-- interpreted as Season 9 Episode 3, rest of season 3 ignored
    


    I'd attach logs but any mention of these files seems long gone and I'm just going to rename the files. The first season was named with "S##E##" notation and that worked fine.
  • icornicorn Posts: 11Members
    bjlewis2 wrote on 06 September 2010 - 01:30 AM:

    I FINALLY figured out what was giving me issues. Here's what happened:

    I have 17 TV shows in my Folder: 30 Rock, Alias, Chuck...Smallville, etc.
    The only show that was showing up in my media manager was 30 Rock... I was upset.
    I decided to remove the next show (Alias) and see if plex was running into an error with one of its episodes.

    I then had 11 shows in my media manager!! Yay! progress!
    I noticed all of my shows after and including Smallville were not showing up, just the first 11.
    So, I removed the Smallville folder, and voila! the rest of my shows popped up after I rescanned!

    I then started adding each individual episode of Alias (rescanning after each new episode) and I found my problem:

    alias - s03e15 - Façade.m4v

    Then I checked Smallville, guess what I found:

    smallville - s04e03 - Façade.m4v

    Every other episode works fine, I guess it is the accent on the 'c' that is causing the problem. What I found interesting was that as soon as Plex came across one of these episodes, it would prevent any episode from that show from showing up, and prevent Plex from looking for additional shows. The accent seems to break the scan.

    Also a note: I tried renaming the files with a regular 'c' but Plex would act like the accent was still there and stop the scan.
    So, my advice is to check for accents in your file names...Hope that helps!


    -Brian Lewis-


    Yeah, that's it! That is also true for all german umlauts (ä, ö, ü, Ä, Ö, Ü, ß). After removing those shows, everything works for me.

    @elan: Please add this to the same bug-report.
  • hippojayhippojay Posts: 958Members, Plex Pass Plex Pass
    edited September 2010
    Numbers in filenames appear to stop movies being scanned (if they appears early in name, or are not delimited from chars). Here some stuff I put together a few days ago:

    http://forums.plexapp.com/index.php?/topic/16371-over-1000-movies-but-only-394-scanned/page__view__findpost__p__98128
    http://forums.plexapp.com/index.php?/topic/16371-over-1000-movies-but-only-394-scanned/page__view__findpost__p__98232

    I believe that they are skipped because the scanner believes it's a TV show (some references in log files).

    It only affected around 3-4 of my Movies, so the impact may not be big..

    @hippojay if you want me on twitter...
«13456739
Sign In or Register to comment.