Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

My Music/TV Shows/Movies Aren't Showing Up

1235740

Comments

  • FrankMartinFrankMartin Posts: 4Members
    Craig Wilson wrote on 11 September 2010 - 01:55 AM:

    I'm also seeing this, although the episodes do show up in Plex, just without any metadata or artwork (off-topic for this thread, I know, sorry). My logs also report successful path matches as well.


    Also only with Chuck, or other shows as well?
    Couldn't find a solution till now, I already tried renaming the each episode with the proper TVDB title ("Chuck vs. the..."), but that also didn't work.
  • aernouddekkeraernouddekker Posts: 2Members
    Martin wrote on 10 September 2010 - 08:50 PM:

    iMDB scanner is still disabled, I think?

    "Down for maintenance" - twitter said that they hoped it would be online again "sometime tomorrow".



    Ah. Thanks! I didn't know they where down.. Today it worked fine!
  • mgworekmgworek Posts: 196Members, Plex Pass Plex Pass
    9 Movies with numbers in the title not getting picked up. Other movies with numbers in the titles are working. Plex .9 saw these movies originally but now after starting over again, they are not seen. I know about the IMDB issues. I look in the logs and these movies are not even getting looked at. I moved the files, did a scan, moved them back in and did a scan. No luck. Like I said, the scanner isn't even looking at them.

    Some of the movies are

    /Volumes/Media/Movies/

    /Volumes/Media/Movies/300 (2006).mp4
    /Volumes/Media/Movies/101 Dalmatians (1996).m4v
    /Volumes/Media/Movies/2012 (2009).mkv

    Here are my logs
  • sdjmesdjme Posts: 665Members, Plex Pass Plex Pass
    I had a few movies that were not showing up in my library at all. Per Elan's helpful post, I examined the media scanner logs and found that Plex thought those movies looked like TV shows, so they were being skipped. Apparently it was due to the filename (not sure why, it didn't have season or episode information in it, and the directories were appropriately named). Once I renamed the files, all was well.

    My question is, what would make Plex think a movie is a TV show, simply based on the filename??
  • lalubinalalubina Posts: 8Members
    Great that Plex 9 is working again!!! Super good job folks!!

    Just one question! Since the new imdb update (now it appears as "Plex" in the scanners), all the movie titles are english only. If I add "El secreto de sus ojos", the poster and info doesn't appear unless I fix incorrect match and then the media manager changes the title for "The secret in their eyes", which is odd for me as an Spaniard. Last week it kept the Spanish title.

    Thanks in advance and all the best
  • DarkOxygenDarkOxygen Posts: 7Members
    FrankMartin wrote on 11 September 2010 - 02:34 AM:

    Also only with Chuck, or other shows as well?
    Couldn't find a solution till now, I already tried renaming the each episode with the proper TVDB title ("Chuck vs. the..."), but that also didn't work.


    Only with Chuck. And I currently have my episodes named as Chuck - S01EXX.mkv, "XX" being the episode number, obviously.
  • bitgodbitgod Posts: 23Members ✭✭
    Issue: I have an Anime section that points to an Anime folder with a sub-folder Paranoia Agent. Inside the folder are 13 episodes, named Paranoia Agent 1.mkv to Paranoia Agent 13.mkv.

    When I go into my Anime section, it shows there's only 4 episodes of Paranoia Agent. Two other anime series are showing up completely. The 4 episodes that were showing up were 10-13.

    Solution: I couldn't find mention of Paranoia Agent in the log I looked, and looking at the file names the only difference I could see was that the 4 episodes that show up have double digit numbers in their title. So I went back and renamed the files Paranoia Agent 01.mkv, 02, etc... Updated the library, now all 13 episodes show up and are tagged correctly.
  • elanelan CTO and Co-founder MauiPosts: 6,981Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Chuck should be fixed, it was corrupt XML coming from TheTVDB.

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • hippojayhippojay Posts: 959Members, Plex Pass Plex Pass
    kaiguy wrote on 11 September 2010 - 03:55 PM:
    My question is, what would make Plex think a movie is a TV show, simply based on the filename??


    The scanner runs through a could of regular expressions which are used to identify TV shows, but which are also applied to filename in movies (I guess to eliminate any strays - belt and braces and all that). It is matches, it doesn;t get scanned. What were the file names? I found I had problem with names like:

    xxxxxs1080xxxxx
    xxxxxs720xxxxxx
    Turn KODI into a Plex Client with PleXBMC

  • caracoscaracos Posts: 19Members ✭✭
    Yesterday after the IMDB Plugin update everything seems to be working fine. But just now I'm having problem adding one new movie on Plex .9.
    The movie title is Sling Blade. I already forced the Media Manager to update by clicking Shift + Refresh but it doesn't work either.
    Below is my Plex .9 Info.

    Plugin Version:
    IMDB: 196.1033
    System: 191.1031
    Framework: 190.1030

    I've looked at the "Plex Media Server.log" and it kept giving this error:
    Sep 13, 2010 03:08:38 [0xb134d000] ERROR - Library updater: select() failed with errno=9

    I've attached my "Plex Media Server.log" for Plex Developer to view and troubleshoot.

    After a few day using Plex .9, below is my findings:
    1. iTunes Plugin kept missing. Had to relaunch Plex everytime in order to make it work for a while. After a while it will definitely gone missing again.
    2. "Mark as Watched" is not working for stack movies (for example: Robin Hood Pt1.avi and Robin Hood Pt2.avi)
    3. Missing delete function in browser mode

    Anyway, keep up the good work! Plex .9 is awesome!
  • elanelan CTO and Co-founder MauiPosts: 6,981Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Noted, thanks hippojay!

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • elanelan CTO and Co-founder MauiPosts: 6,981Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    caracos wrote on 12 September 2010 - 09:38 AM:

    I've looked at the "Plex Media Server.log" and it kept giving this error:
    Sep 13, 2010 03:08:38 [0xb134d000] ERROR - Library updater: select() failed with errno=9


    This part:

    Exec of /Users/Azmir/Library/Application Support/Plex/Plex Media Server.app/Contents/MacOS/Plex Media Scanner failed
    


    Implies that something went wrong, maybe you tried to install a hotfix and it went wrong, or maybe the permissions on this file is incorrect? If nothing else, you can quit PMS, delete /Users/Azmir/Library/Application Support/Plex/Plex Media Server.app, and then run Plex, which will restore PMS from its pristine state.

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • caracoscaracos Posts: 19Members ✭✭
    Hi Elan, thanks for your help. I did install a hotfix and somehow it got screwed up. Did exactly as your instruction and everything back to normal.
  • sandman4suresandman4sure Posts: 792Members, Plex Pass, Plex Ninja Plex Ninja
    jonny2002 wrote on 08 September 2010 - 11:58 PM:

    Found an issue with the movie "Extraordinary Measures".
    It doesn't show up in the Media Manager, no traces of it in the log.

    Directory structure is as follows:

    /Volumes/Movies/2010/Extraordinary Measures/Extraordinary Measures.avi

    Renaming the folder to "_Extraordinary Measures" or "Extr_aordinary Measures"
    and, voila, it shows up. Renaming it to "Extra_ordinary Measures", it will not.

    Seems like it fails when the directory begins with the word "Extra"...


    Yes, the movie Extract (2009) is also not showing up
  • Jez27Jez27 Posts: 3Members, Plex Pass Plex Pass
    AshTemple wrote on 10 September 2010 - 06:16 PM:

    for the life of me i cant get the uk version of the office to appear, they used to work perfectly before, ive tried removing them from the system, scanning then re scanning holding shift. ive made the amercian office The Office The Amercian Workplace and ive added (uk) and .uk in all the file names, so it now looks like:
    television/The Office (uk)/season 1/The Office.uk.01x01.avi

    and it still wont show. ive attached the log files and hoping someone can show me the error of my ways

    thanks

    [attachment=4045:plex_log.zip]

    I have exactly the same problem as above, albeit my files are named differently;

    The Office (UK)/Season X/S0XE0X.avi
    The Office (US)/Season X/S0XE0X.avi

    Etc.

    The American office shows up fine, with some of the Office (UK) extras categorised as "Season 0" episodes for the US version, but that's it. There's no way to change it in the Media Manager either, is there?

    Other than that, my TV shows, movies & music have all scanned in perfectly!
  • maaniacmaaniac Posts: 190Members, Plex Pass Plex Pass
    elan wrote on 11 September 2010 - 08:53 PM:

    Chuck should be fixed, it was corrupt XML coming from TheTVDB.


    Elan, still can't get chuck season 3 episode 6 scanned. Its the only file from that entire season which doesn't show up. All files are named identically so it can't be a naming issue.
  • mgworekmgworek Posts: 196Members, Plex Pass Plex Pass
    Along with my movies that don't get scanned if they have numbers in this, mentioned above, G.I. Resolute won't scan. If I try to manually fix it, all the other G.I. cartoons are listed but not Resolute. Worked when .9 first got released.

    Thanks
  • MartinAylaMartinAyla Posts: 859Members, Plex Pass Plex Pass
    Jez27 wrote on 13 September 2010 - 07:42 PM:

    I have exactly the same problem as above, albeit my files are named differently;

    The Office (UK)/Season X/S0XE0X.avi
    The Office (US)/Season X/S0XE0X.avi

    Etc.

    The American office shows up fine, with some of the Office (UK) extras categorised as "Season 0" episodes for the US version, but that's it. There's no way to change it in the Media Manager either, is there?

    Other than that, my TV shows, movies & music have all scanned in perfectly!


    Regarding "The Office",

    I had problems scanning "The Office (UK)" after "The Office (US)".

    The UK episodes didn't show up, but I figured out that they were added under the US entry (even though there's no way to check individual episodes in the Media Manager yet.. that would have helped).

    What I had to do was:

    In Finder, move the US version away from the scan folder.

    Let it scan so it removes the US version from Media Manager.

    Move the UK version to the scan folder.

    Scan.

    It was picked up as the US version.

    Fix match, select UK version.

    Move US version back.

    It was scanned as the US version.

    And they both lived happily ever after...

    /Martin

  • SplendidSplendid Posts: 4Members
    edited September 2010
    Same problems here, almost all tv series are showing up fine, except the Big bang theory.

    File and map names are even better that other series that are showing up so I'm lost here.

    Dir name: The Big Bang Theory
    File names: The Big Bang Theory S02E01.avi - The Big Bang Theory S02E23.avi WITH .srt files with the exact same name.

    Log file:
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG - Scanning The Big Bang Theory with 0 current items in the database...
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG -   * Scanning /Volumes/Media/Series/The Big Bang Theory
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG -     * Scanning directory /Volumes/Media/Series/The Big Bang Theory
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG -     * Taking directory '' (330) out of the map (0 left)
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG - Whacking 0 media items that were left.
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG - Whacking 0 directories that were left.
    Sep 13, 2010 20:56:19 [0xa01cf500] DEBUG - Refreshing section 5 of type: 1
    


    * OMG, thats fast, it works now :P
  • Jez27Jez27 Posts: 3Members, Plex Pass Plex Pass
    Martin wrote on 13 September 2010 - 06:24 PM:

    Regarding "The Office",

    I had problems scanning "The Office (UK)" after "The Office (US)".

    The UK episodes didn't show up, but I figured out that they were added under the US entry (even though there's no way to check individual episodes in the Media Manager yet.. that would have helped).

    What I had to do was:

    In Finder, move the US version away from the scan folder.

    Let it scan so it removes the US version from Media Manager.

    Move the UK version to the scan folder.

    Scan.

    It was picked up as the US version.

    Fix match, select UK version.

    Move US version back.

    It was scanned as the US version.

    And they both lived happily ever after...


    Thanks, that worked a treat! :D

    My media library is officially complete!
Sign In or Register to comment.