Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Hackintosh + Plex

Confuzed OneConfuzed One Posts: 11Members
Gray Screen
Hi everyone,

I'll try to keep it simple, and hope some of you can help me out.

I have a Hackintosh (a PC converted to Mac OS X) running Snow Leopard, all updates done.

The machine runs great, and i use it as a "media box", holding all my movies, and streaming to all my devices (Apple TV, iPhone 4, PlayStation, Xbox)...

The Plex Media Server works great! I have no complaints. It works on all devices (even the new Apple TV with the jailbroken Plex client works fantastic!).

Plex Client, on the other hand, opens up as a Gray screen. This is probably due to "smart" display detection or something like that i read somewhere, but didn't give any "fix".

Does anyone offer any suggestion? On my Hackintosh, it's not the full video drivers, but i would like to "force" Plex Client to load in the lowest resolution possible.. maybe this will resolve my gray box issue.

Thanks in advance!

Confuzed One

Comments

  • adriandbadriandb Posts: 946Members, Plex Pass Plex Pass
    I just started experiencing the same issue on my Hackintosh Dell mini 10v. Previously I've run Plex 0.8 and 0.9 on this machine, but it no longer will display video. Oddly enough I do hear the menu clicks as I scroll around through the options, but the screen stays grey. It's as if the OS thinks there isn't a display connected. Anyone else?
  • Confuzed OneConfuzed One Posts: 11Members
    adriandb wrote:

    I just started experiencing the same issue on my Hackintosh Dell mini 10v. Previously I've run Plex 0.8 and 0.9 on this machine, but it no longer will display video. Oddly enough I do hear the menu clicks as I scroll around through the options, but the screen stays grey. It's as if the OS thinks there isn't a display connected. Anyone else?


    Isn't there a way to "force" a certain resolution or screen size?
  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    adriandb wrote:

    I just started experiencing the same issue on my Hackintosh Dell mini 10v. Previously I've run Plex 0.8 and 0.9 on this machine, but it no longer will display video. Oddly enough I do hear the menu clicks as I scroll around through the options, but the screen stays grey. It's as if the OS thinks there isn't a display connected. Anyone else?

    Sounds like it... if Mac OS X doesn't 'see' a display connected it can't pass the display context to applications. People were seeing a grey screen with the UI sounds working when Screen Sharing to a headless Mac. I'd say that's the cause of the issue... how to fix it is another thing! You might need to check for drivers etc...

    James
  • jamjam Plex Dev Team Posts: 4,296Members, Plex Employee, Plex Pass Plex Employee
    The "grey screen" will also be caused by a graphics card or driver that isn't fully supported by OS X, i.e. one that doesn't support Quartz Extreme and Core Image.
  • Confuzed OneConfuzed One Posts: 11Members
    So, there is no way to get Plex working on VESA?
  • jamjam Plex Dev Team Posts: 4,296Members, Plex Employee, Plex Pass Plex Employee
    No. Plex requires OpenGL-capable hardware and drivers.
  • adriandbadriandb Posts: 946Members, Plex Pass Plex Pass
    I know I had both Plex 0.8 and 0.9 running on my Hackintosh previously, I wonder what changed...
Sign In or Register to comment.