If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Your connection to the server is not fast enough to stream this video. Check your Network."



  • canioncanion Posts: 22Members, Plex Pass Plex Pass

    I tried disabling Direct Play on my setup that also has this problem, but it didn't help. Issue still arose. Other Plex clients (Amazon Fire Stick, iPads) work just fine.

  • ValdhorValdhor Posts: 501Members, Plex Pass Plex Pass

    @joekw said:
    Been getting this issue with 1080p content recently. Videos take ages to start playing and then a few minutes in this pop up will appear. Tried playing the same video in the Samsung Smart TV app on my KS8000 and it'll play flawlessly. Since i pretty much just use the apple TV for plex since i (usually) love the app, makes me wonder why i even have it.

    If the video takes ages to start then this is almost certainly your server having to transcode the file. Is your server up to the task? This message can also pop up if your server can't supply the video fast enough (ie. can't transcode fast enough).

    Your Samsung TV may not need to have the video transcoded. Same with clients on other platforms. The server can easily handle the lower resolution on an iPad but has trouble transcoding a full 1080p file for the ATV4.

  • tsheleytsheley Posts: 127Members, Plex Pass Plex Pass

    So this will probably jinx my good fortune but I have not had this problem in almost 2 months. In that time 2 things on my setup have changed.

    1. I am running the Plex DVR Beta 4 for my Media Server on my iMac.
    2. Replaced my Airport Extreme with a Neater Nighthawk R7800

    Don't know if either of those 2 make a difference but I have been running with Direct Play turned on for almost 2 months now on the Apple TV app with no problems. Even played movies that consistently gave me the problem prior and they played great.

    Just thought I would share.

  • alefkaalefka Posts: 12Members, Plex Pass Plex Pass

    Well, I'm glad I'm not alone as I was loosing my mind already.

    I've started having this issue about 2 months ago, usually tv-shows (720p) play fine but 720p or 1080p movies get that your networks isn't fast enough crap, I've tried changing the quality from 2mbps to Original with no difference. I have an i7-4790K, it barely shows any usage when this happens, I have a 50mbps upload with only 5mbps used when that happens. I've reinstalled, I've messed with every possible setting, messed with my routers (AC-3200), I know my hardware and my network is not an issue.

    Reading the comments, I'll try using the build in Samsung TV Plex app.

    Plex, please fix this.

  • simoncroppsimoncropp Posts: 1Members, Plex Pass Plex Pass

    any update for this?

  • DudaaiDudaai Posts: 66Members, Plex Pass Plex Pass

    Problem still for me with Plex on ATV. PMS running on Mac Mini connected to router by Cat 6. ATV connected to same router also by Cat 6. CONSTANT problems. Keeps pausing by itself, then buffers and then the 'Your connection is too slow' etc. Seriously I've had it with Plex, just too unreliable and too high maintenance. Barely a few weeks go by without another problem develops. Stop running out the gimmicks and focus on fixing the stuff that's already out there. Plex Pass? Pay for this? No way!!! Like others. I've moved to Infuse. Despite the fact is does things differently. It DOES work. I'll put up with the less well designed UI for an app that actually WORKS!!!

  • DudaaiDudaai Posts: 66Members, Plex Pass Plex Pass

    Oh. And in my case. All the files are M4V already. Lord knows what it'd be like if Plex actually had to DO anything like transcode, it can't even play files that are already in the correct format for Apple TV. Deleted.

  • kreegeekreegee Posts: 16Members, Plex Pass Plex Pass
    edited March 2017
  • ladrosladros Posts: 36Members, Plex Pass Plex Pass

    @kreegee likely, the lack of buffering is one possible cause of this error message. Though it is possible to get this error if the network between the ATV and the plex server is too slow such as on wifi in a crowded / noisy environment, bad cable, or using a remote plex server with limited upload bandwidth and running too high a bit rate... I verified my network using the "Wi-Fi Speed Test" tool from the app store running on a mac that was hard wired next to my plex server and on the AppleTV (would be nice if someone would just add a port of iperf3 to the appleTV store). Ran a number of iterations to try detect any transient performance issues and didn't find any.

    Would be super awesome if Plex clients had a built in network micro benchmark perf test that you could run for an extended period of time (1 to 20 min) to see if there are perf issues on the network. Seems like it might make triaging whether a customer is experiencing network issues or something with plex itself much easier for their support team..

  • ValdhorValdhor Posts: 501Members, Plex Pass Plex Pass

    This is not only an ATV4 issue (Your connection is not fast enough...).

    I sometimes get it on my iMac i7 when playing in Chrome browser. My server is a dual Xeon with 72GB ECC RAM. My iMac and Plex server are hardwired via gigabit ethernet using an HP managed switch with CAT-6 cables.

    The videos are generally 720p TV shows with an mkv container and mp4/aac audio/video tracks.

  • canioncanion Posts: 22Members, Plex Pass Plex Pass

    Early days yet, but I seem to have had some improvement to this problem by removing my Airport Time Capsule from my network topology. It had been set in Bridge mode to extend my wifi network. Now, with that gone, the whole house is running through a combination of wifi and Ethernet out of my Airport Extreme (with a couple of Gigabit switches along the way). I currently have my Apple TV running on the wifi, and as of yet I haven't had any network speed issues.

    Earlier tonight, before removing the Airport Time Capsule, I was getting buffering problems.

    I will continue to monitor.

  • canioncanion Posts: 22Members, Plex Pass Plex Pass

    @canion said:

    I will continue to monitor.

    Well, that was shortlived. Got the network too slow message once again.

  • aragnophyaragnophy Posts: 1Members

    I also having a "slow network" issue on ATV4 since Plex app version 1.7. Tried wireless\wired connection, tried reinstall app, reboot router, the result is the same. With Samsung Plex for SmartTV app and in a web app I have no issues, with the same video files on the same network and same quality settings (original audio and video, Direct Streaming).

    I don't know what else to do, Plex became unusable since the last update for me.

  • mnemonic0nemnemonic0ne Posts: 7Members, Plex Pass Plex Pass
    edited March 2017

    Not to pile on, but count me in the group of having issues. Any iOS device, wired (multiple ATVs) or wireless (iPad or iPhone) have issues with even native M4V / MP4 playback via Plex Server/App.

    Any other device with Plex (XBOX One S) or client app (iOS VLC app) I use has ZERO problems with streaming exactly the same content. With iOS VLC app on my iPad I can even stream Native 1:1 BluRay rips of MKVs either via my Synology DNLA or via my i7 Plex Server with zero issues.

    Here is what I am running on my system, this is NOT a hardware issue. It is unequivocally an iOS issue. I have spent years trying to build my bullet proof dream system and just when I have EVER hardware piece in place this freaking message is driving me crazy

    Content housed on Synology 1512+ with bonded dual 1 Gb NICs
    Entire network is Ubiquity Unifi Platform - 48 and 24 port Gb switches, Unifi AC Pro APs
    Plex Media Server i7 4770 with 32GB RAM bonded dual Intel 1 Gb NICs
    All CAT6 runs, most wired clients in same rack as Server/NAS with HDBASE-T runs to displays in room

    All Clients and Plex Media Server software is CURRENT.

    ATV 4s (Qty x 4) all wired Ethernet (have tested on AC as well, no change) - Network too slow warning all the time - M4V/MP4 or MKVs
    XBOX One S and XBOX One all wired Ethernet - no hiccups regardless of content frame rate or resolution - M4V/MP4 or MKVs
    Desktop PCs all wired Ethernet - no hiccups regardless of content frame rate or resolution - M4V/MP4 or MKVs
    Various iPads and iPhones all AC - Network too slow warning all the time - M4V/MP4 or MKVs

    All of my tests are over local LAN, outside of LAN shows similar issues even though I'm on ATT Fiber.

    I have done the tricks and flips and tweaks and turns and each result in the same results... Your connection to the server is not fast enough to stream this video. Check your Network

  • rrdharanrrdharan Posts: 1Members, Plex Pass Plex Pass

    I'm having the same problems as described by the last two commenters, and it does seem to be a very recent phenomenon so like @aragnophy above I suspect it's related to the 1.7 update? No recent changes to my network topology but I'm getting the "connection to the server is not fast enough" all of a sudden with my ATV4 when playing things that used to stream fine.

  • DanneFrankDanneFrank Posts: 60Members, Plex Pass Plex Pass

    This issue is the same as the other thread about buffering - or lack of. Being able to buffer would solve this issue for so many people! Don't see why this hasn't been fixed already. Pretty shocking especially since I'm paying for this service :/ Been waiting for so long for a fix to this obvious problem.

  • BastardSheepBastardSheep Posts: 287Members, Plex Pass Plex Pass

    @DanneFrank said:
    Don't see why this hasn't been fixed already.

    Because a solution hasn't been found yet. They're using Apple's built-in media player and thus are limited by the API calls apple provides.

  • DanneFrankDanneFrank Posts: 60Members, Plex Pass Plex Pass

    @BastardSheep I understand that but I have seen plenty of people suggest posting in the Apple developers forums to help with this and no one from Plex has replied. Also they keep releasing pointless features when they haven't even got the app to work properly. Seems their resources are being used in various other ways instead of getting the apps functionality right. The conflict in interest has been a problem I've seen all throughout this forum. To using the built in player, the same player buffers when home sharing etc so I don't see how that is a valid reason to be honest. Also no word as usual from anyone at Plex. It's Poor service which ever way you look at it.

  • ValdhorValdhor Posts: 501Members, Plex Pass Plex Pass

    @DanneFrank said:
    This issue is the same as the other thread about buffering - or lack of.

    Um, no it isn't. I get this "Network not fast enough" issue in my web browser so it's not limited to ATV4. Fixing the buffering issue on the ATV4 is not going to fix this issue in my browser.

  • DanneFrankDanneFrank Posts: 60Members, Plex Pass Plex Pass

    @Valdhor well I've seen many comments that have linked the two, and a lot of people are experiencing both problems. This is an Apple TV thread.. so fixing the buffering issue would solve the issue for many people including myself. I don't work for Plex and can't speak for every single user, I was just referring to the Apple TV issue that has been an issue since it was released. That is all.

Sign In or Register to comment.