If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Problem connecting to server

mwittmwitt Posts: 68Members, Plex Pass Plex Pass
Problem connection from iphone, ipod and ipad to server
I have an annoying problem that turns up now and again. It seems that I sometimes cant connect to the plex media server from iphone, ipod or ipad. I have not yet seen any patterns when this occurs, but did a few basic tests to see if I could work out why this happens.
- Suddenly none of the devices can contact the server (a 2010 mac mini running plex, OSX 10.6.6), but the server has been up all day and I have looked at a number of movies during the day, both on devices and on the TV its connected to.
- The plex media server is running as well as the plex app and everything works on the TV.
- The mini is listening on port 32400 and I can connect to it using telnet from my iphone, but nothing shows up in the plex server log when connection is established...?
- Restarting plex server multiple times changes nothing and I can see no clue in the log-files (though I´m not an expert)
- The only way I have been able to resolve this so far is rebooting the mini

My amateur deduction tells me that something goes wrong with the internal communication from connections to port 32400 and plex media server, that the process is not restarted when the media server is restarted, but it is restarted when I reboot the machine...?

Please advice if there are any log-files that could help out with troubleshooting.


  • mwittmwitt Posts: 68Members, Plex Pass Plex Pass
    Ohh , and one more thing...

    - After putting the mini to sleep from the plaex app UI, the machine wakes up when I try to connect from my iphone, but iphone app reports that the server can not be found
  • mr_magicfingersmr_magicfingers Posts: 18Members, Plex Pass Plex Pass
    edited January 2011
    Yes, I've been seeing the same thing for the past couple of weeks. Very annoying indeed. Rebooting the ipad makes no difference.
  • mr_magicfingersmr_magicfingers Posts: 18Members, Plex Pass Plex Pass
    Seems the only way to fix it is to reboot the mac mini that plex is running on, the the ipad sees the library.
  • MetropolisMetropolis Posts: 62Members
    I have this same issue with a 2010 mini running os x 10.6.6 server. I boot it and launch plex, ios devices and other plex clients can see the server for about 5 minutes, after that I get errors when trying to connect via ios. At this point plex clients can no longer see the server and eventually it doesn't show in the server list on the ios devices. The local system (everything on the mini) always continues to work. I have full network access to the mini while all of this is going on, the only way to fix it is to reboot and start the whole procedure over.

    I have completely re-installed Plex to no avail. My only hope now is that it is because i'm running OS X Server on the mini instead of Standard OS X, maybe it's trying to block something or push something out that is interfering with the media server.
  • jgrasjojgrasjo Posts: 25Members
    Check if you in your router have the RIP settings set to Direction: Both and RIP version :2B
    This solved my problem with connection to Plex Media server
  • super_kevsuper_kev Posts: 16Members, Plex Pass Plex Pass
    Mine is scattered... I cannot step-by-step replicate the inability for my iOS device to see the PMS, but I do notice that it is after I use the iOS as a remote to watch something, then after I quit Plex (or sometimes even when the TV interface is running) I cannot see the PMS on iOS after a few hours. Only a reboot fixes the issue with me as well.

    jgrasjo wrote:

    Check if you in your router have the RIP settings set to Direction: Both and RIP version :2B
    This solved my problem with connection to Plex Media server

    Some of us cannot use Dynamic Routing (RIP) with the way our network is setup (mine included), others don't even have this option on our routers, so another solution needs to be found.
  • Pilot andyPilot andy Posts: 2Members
    Hi All,

    Has anybody been able to solve this? I have a Macbook that I have been happily run Plex on for a few months now, I have linked the Iphone and have had no issues. A few days ago I got myself a Mac Mini and have had no success at connecting my Iphone to Plex on the mini. Both devices are working on the same wifi as is the macbook that proved no problems in the past.

    Anybody able to help?
  • jurgenvejurgenve Posts: 59Members
    I can confirm the issue of loosing sometimes the ability to approach the mini (late 2010 model, OS X 10.6.6) through any iPad application. I use Plex, EyeTV and Remote Buddy and when this happens, none of the apps work. IR control and keyboard control of the mini still operates fine however, and so does e.g. Safari on the iPad.

    Looking at this as a layman, it looks like this particular issue is a communication handshake issue between a command sent from the iPad and a return communication from the mini. Closing applications on the mini or the iPad does not help, as it is the mini which is supposed to close the handshake cycle, which it fails to do.
    As other users found, the only way to get it going again is reboot the mini. Unlike some users here however, this problem occurs rarely for me. The users that have consistent problems, will probably suffer from another problem then me.

    In any case, if what I think is true about the problem I observed, I fear there is not much the Plex developers can do but it is a bug in the mini software. The structural issues may be caused by Plex however.
    HTPC: 2.4 GHz Intel C2D Unibody Mac Mini, 4 GB RAM, OS X 10.6.8 • USB devices: EyeTV Hybrid USB tuner & Hauppauge WinTV CI • Application software: Plex, EyeTV 3.5.3, Remote Buddy 1.18.1 • Network Storage: QNAP Turbo 419P+ 6TB Raid5 - Gigabit LAN • HDTV: LG 42LE8500 Infinia LED TV • Audio: Panasonic Home Theater with 5.1 / DTS • Control: iPad - Plex/EyeTV apps and AJAX Remote Buddy universal control. Backup: Logitech Harmony 555
  • from a buick 8from a buick 8 Posts: 5Members, Plex Pass Plex Pass
    edited February 2011
    I ran into this (iPad with plex server running on an iMac), I was able to just quit an restart the plex server on my iMac and it came back.
Sign In or Register to comment.