If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

DLNA no longer transcodes

azjoeazjoe Posts: 3Members, Plex Pass Plex Pass
edited October 2016 in DLNA

After the last update Plex will no longer transcode for my DLNA clients. Application and web interfaces are fine, they transcode without issue. But DLNA, namely Hopper, will not transcode. Anything but directplay come back with "This file cannot be played"
My Hopper.xml client profile was working great. Something changed on the Plex side. Any help? BTW, below is my Hopper DLNA Client profile.

<?xml version="1.0" encoding="utf-8"?>
<Client name="Hopper">
  <Identification>
    <Header name="User-Agent" substring="xip" />
    <Header name="User-Agent" substring="Lavf" />
    <Header name="User-Agent" substring="ZiP" />
  </Identification>
  <Settings>
    <Setting name="OnlyPlainVideoItems" value="true" />
    <Setting name="OnlyStorageFolders" value="true" />
  </Settings>
  <TranscodeTargets>
    <VideoProfile protocol="dash" container="mp4" codec="h264,mpeg2ts" audioCodec="aac,mp3,ac3" context="streaming" />
    <VideoProfile protocol="hls" container="mpegts" codec="h264,mpeg2ts" audioCodec="aac,mp3,ac3" context="streaming" />
    <VideoProfile protocol="http" container="mkv" codec="h264,mpeg2ts" audioCodec="aac,mp3,ac3" context="streaming" />
<!--    <VideoProfile container="mp4" codec="h264,mpeg2video,mpeg4" audioCodec="ac3,aac,mp3" />
    <VideoProfile container="mpegts" codec="h264,mpeg2video,mpeg4" audioCodec="ac3,aac,mp3" />
    <VideoProfile container="mkv" codec="h264,mpeg2video,mpeg4" audioCodec="ac3,aac,mp3" /> -->
    <MusicProfile container="mp3" codec="mp3" />
    <PhotoProfile container="jpeg" />
  </TranscodeTargets>
  <DirectPlayProfiles>
<!--    <VideoProfile container="mov" codec="h264,mpeg4" audioCodec="aac,ac3" /> -->
    <VideoProfile container="mp4" codec="h264,mpeg2ts,mpeg4" audioCodec="aac,ac3,mp3" />
<!--    <VideoProfile container="mpeg" codec="h264" audioCodec="aac" /> -->
    <VideoProfile container="mkv" codec="h264,mpeg2ts,mpeg4" audioCodec="aac,ac3,mp3" subtitleFormat="srt" />
<!--    <VideoProfile container="avi" codec="h264,mpeg2ts,mpeg4" audioCodec="aac,ac3,mp3" /> -->
    <MusicProfile container="mp3" codec="mp3" />
    <MusicProfile container="mp4" codec="aac" />
    <MusicProfile container="aac" codec="aac" />
    <PhotoProfile container="jpeg" />
  </DirectPlayProfiles> -->
  <CodecProfiles>
    <VideoCodec name="*">
      <Limitations>
        <UpperBound name="video.width" value="1920" isRequired="true" />
        <UpperBound name="video.height" value="1080" isRequired="true" />
        <UpperBound name="video.bitrate" value="12000" />
<!--        <Setting name="MaxFps" value="30" /> -->
      </Limitations>
    </VideoCodec>
    <VideoAudioCodec name="*">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    <MusicCodec name="mp3">
      <Limitations>
        <UpperBound name="audio.bitrate" value="320" />
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </MusicCodec>
  </CodecProfiles>
  <ContainerProfiles>
    <PhotoContainer name="*">
      <Limitations>
        <UpperBound name="media.width" value="1920" isRequired="true" />
        <UpperBound name="media.height" value="1080" isRequired="true" />
      </Limitations>
    </PhotoContainer>
  </ContainerProfiles>
  <DlnaMediaProfiles>
    <DlnaVideoProfile container="avi,mkv,mp4,mpegts,mpeg4" mimeType="video/mpeg" />
    <DlnaMusicProfile container="mp4" mimeType="audio/mpeg" />
  </DlnaMediaProfiles>
</Client>
Tagged:

Answers

  • azjoeazjoe Posts: 3Members, Plex Pass Plex Pass

    A little update. I downgraded from 1.2.2.2857-d34b464 to 1.1.4.2757-24ffd60 and I can transcode again. It would appear that 1.2.2.2857 has an issue.

  • jsterlingjsterling Posts: 1Members, Plex Pass Plex Pass
    edited October 2016

    I had to make a small change to my profile by adding mp4 to my directplay container after having this same problem. This profile works.

    Edit: My change got MP4 working again but AVI is still not able to be played. I'm on 1.2.2 as well and anything that requires DLNA transcoding (The Hopper requires AVI transcode) seems to be failing.

    <?xml version="1.0" encoding="utf-8"?>
    <Client name="Dish Hopper-Joey">
      <!-- Author: Plex Inc. -->
      <Identification>
        <Header name="User-Agent" substring="XiP"/>
        <Header name="User-Agent" substring="ZiP"/>
        <Header name="User-Agent" substring="Lavf"/>
        <DeviceDescription>
          <Manufacturer substring="Echostar Technologies LLC" />
        </DeviceDescription>
      </Identification>
      <Settings>
        <Setting name="OnlyPlainVideoItems" value="false" />
        <Setting name="OnlyStorageFolders" value="false" />
        <Setting name="IgnoreTranscodeByteRangeRequests" value="false" />
        <Setting name="TimelineBufferOffset" value="0" />
        <Setting name="IconResolution" value="48x48" />
        <Setting name="AlbumArtResolution" value="480x480" />
        <Setting name="AlbumArtPN" value="JPEG_SM" />
      </Settings>
      <TranscodeTargets>
        <VideoProfile protocol="http" container="mkv" codec="h264" audioCodec="aac" context="streaming">
          <Setting name="VideoEncodeFlags" value="-x264opts bframes=3:cabac=1" />
        </VideoProfile>
        <MusicProfile container="mp3" codec="mp3" />
        <PhotoProfile container="jpeg" />
      </TranscodeTargets>
      <TranscodeTargetProfiles>
        <VideoTranscodeTarget protocol="http" context="streaming">
          <VideoCodec name="*">
            <Limitations>
              <UpperBound name="video.width" value="1920" />
              <UpperBound name="video.height" value="1080" />
              <UpperBound name="video.bitDepth" value="8" isRequired="false" />
            </Limitations>
          </VideoCodec>
        </VideoTranscodeTarget>
      </TranscodeTargetProfiles>
      <DirectPlayProfiles>
        <VideoProfile container="mkv,mp4" codec="h264,mpeg2video" audioCodec="mp3,ac3,aac,he-aac,pcm" />
        <MusicProfile container="mp3" codec="mp3" />
        <PhotoProfile container="jpeg" />
      </DirectPlayProfiles>
      <ContainerProfiles>
        <VideoContainer name="mp4">
          <Limitations>
            <Match name="part.optimizedForStreaming" value="1" />
          </Limitations>
        </VideoContainer>
      </ContainerProfiles>
      <CodecProfiles>
        <VideoCodec name="*">
          <Limitations>
            <UpperBound name="video.width" value="1920" />
            <UpperBound name="video.height" value="1080" />
            <UpperBound name="video.bitDepth" value="8" isRequired="false" />
            <UpperBound name="video.level" value="42" isRequired="false" />
          </Limitations>
        </VideoCodec>
        <VideoAudioCodec name="aac">
          <Limitations>
            <UpperBound name="audio.channels" value="6" />
          </Limitations>
        </VideoAudioCodec>
      </CodecProfiles>
    </Client>
    
  • reottoreotto Posts: 1Members, Plex Pass Plex Pass

    Any updates to this as 90% of my video files are in AVI format

Sign In or Register to comment.