Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Folders view not Saving

theatreplex008theatreplex008 Posts: 244Members ✭✭
Plex won't save the folders view selection
Plex will not save the List view on Movies folder anymore> Select View mode...exit and re-enter...going back to regular list view.

* I'm trying to keep it saved in Coverflow view in movies.

*This just happened after adding 500 artists in my Music Library.
«1

Comments

  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    I've heard a few people have had issues with the ~/Library/Application Support/Plex/guisettings.xml file getting corrupted or otherwise "messed up" before. Close the Plex client, nuke that file (or, better yet, back it up and remove), and see if things work after that.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    Removed Plex XML gui file> and placed it on the desktop.

    * It still will not save any of the View settings for any Home folders.

    Any other suggestions?
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    edited March 2011
    Ok

    So anyone else know why Plex doesn't save movie folders views?

    None of the folders will save the view anymore> removed the GUI.xml file and another one showed up in it's place?

    Does this mean I should just trash plex and restart again?

    It's shouldn't be that difficult to resolve this?
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    As far as I know, the "view" setting info is stored in that guisettings.xml file. My install works fine and changes I make to the view are saved for me.

    Are you using the default skin (MediaStream)? That one works fine for me, as do Blur and PlexAeon on my install. Did you close the client as well as stop/quit the PMS before you removed the guisettings.xml file previously? If not, try doing that.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    edited March 2011
    Chris C wrote:

    As far as I know, the "view" setting info is stored in that guisettings.xml file. My install works fine and changes I make to the view are saved for me.

    Are you using the default skin (MediaStream)? That one works fine for me, as do Blur and PlexAeon on my install. Did you close the client as well as stop/quit the PMS before you removed the guisettings.xml file previously? If not, try doing that.


    I quite Plex> I run it full screen mode, I assume it's stops, when you enter back to the desktop> Default skin is enabled.

    What do you mean by close the client? Is that media manager?> I close plex when I removed the file> but it re-appeared after logging back into plex? Doing this resets my resolutions settings, and that is all it does.

    Please quantify on client?
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    By "client", I meant the app you use to browse through and watch your content.

    It appears I was at least partially incorrect before regarding the "view" options all being in the guisettings.xml file. I found out this evening that there are at least some view settings stored in the database, too. If you're feeling brave, you can try running the following command in a Terminal window, which should clear out stored view settings on the PMS:

    sqlite3 ~/Library/Application\ Support/Plex\ Media\ Server/Plug-in\ Support/Databases/com.plexapp.plugins.library.db "delete from view_settings"
    
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    So I'll just cut and paste the above command.
  • atrusatrus Posts: 11,165Members, Plex Pass, Plex Ninja Plex Ninja
    Yes, run it in your Terminal.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    Ok, I ran the command in Terminal> First issue was " database was locked?"

    I stopped running Plex Media manager> Re-prompted the command> this time nothing came up ( I assume it ran the command)

    * Checked in Plex to see if folders where being saved> No-Go.

    * What else?
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    I'm thinking of just nuking plex altogether, and re-scaning all my files with a new install of it> hopefully without the view display bug.

    * Any more suggestions?
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    I'm afraid we seem to be out of ideas on this one. Apparently, there is a bug regarding the "view" settings for sections in the current version (that should be fixed in the next one) and you might have somehow hit it. However, Elan mentioned that typically running the database command mentioned before should clear it up.

    Anyway, if you're up for it, then completely clearing out your current Plex install and starting over ought to get things working again. In addition to the regular Plex.app file, you'll also want to remove these two directories if you choose to go this route:

    ~/Library/Application Support/Plex/
    ~/Library/Application Support/Plex Media Server/
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    Chris C wrote:

    I'm afraid we seem to be out of ideas on this one. Apparently, there is a bug regarding the "view" settings for sections in the current version (that should be fixed in the next one) and you might have somehow hit it. However, Elan mentioned that typically running the database command mentioned before should clear it up.

    Anyway, if you're up for it, then completely clearing out your current Plex install and starting over ought to get things working again. In addition to the regular Plex.app file, you'll also want to remove these two directories if you choose to go this route:

    ~/Library/Application Support/Plex/
    ~/Library/Application Support/Plex Media Server/


    Hmm, I'll give the command another try> I don't know what it does if it works though? Does it state the command was enabled or something?, sorry I don't know how command prompts are dictated.

    * I just ran the command, and it went to the next prompt (computer name etc) Are spaces critical as well?

    * What should it say if the command was succesfully executed?
  • Chris CChris C Posts: 11,672Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    I haven't really messed with command-line SQL queries, I'm afraid. I'd not be surprised if there's no feedback returned after running the command (unless there's a problem). If it's successful then it probably just returns you to the command prompt like you're seeing. Spaces would be important in it so that you get the correct path and such.

    Have you updated to 0.9.2.3 yet? That one should (to my knowledge) have the fixes in for the view state saving, so it might all be fixed for you.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    Chris C wrote:

    I haven't really messed with command-line SQL queries, I'm afraid. I'd not be surprised if there's no feedback returned after running the command (unless there's a problem). If it's successful then it probably just returns you to the command prompt like you're seeing. Spaces would be important in it so that you get the correct path and such.

    Have you updated to 0.9.2.3 yet? That one should (to my knowledge) have the fixes in for the view state saving, so it might all be fixed for you.


    I assumed I had the latest Plex 9 version since I only downloaded it 4 weeks ago etc.
  • nerpissadnerpissad Plex Ninja Posts: 1,502Members, Plex Pass, Plex Ninja Plex Ninja
    if you execute the command in terminal it doesn't return anything after you press enter. it'll just show you the prompt like it did for you before:
    [attachment=6168:Screen shot 2011-03-17 at 22.39.11.png]


    don't trash your folders just yet. I'd try the latest release from here and see if that fixes your issue.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    nerpissad wrote:

    if you execute the command in terminal it doesn't return anything after you press enter. it'll just show you the prompt like it did for you before:
    [attachment=6168:Screen shot 2011-03-17 at 22.39.11.png]


    don't trash your folders just yet. I'd try the latest release from here and see if that fixes your issue.



    The glitch happened> * after scanning a few hundred music files or adding 20 music and video-apps including netflix etc. Or I could have been in media manager and something was changed while in there as well.
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    Ok, I tried the command again with exact spacing, and it didn't work.

    * I just got an update message from Plex today (that was fast) installed the latest update> and it didn't fix the issue of saving the view in folder view settings etc. :angry:
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    If Plex is constantly updating the media server> then I might just wait to erase it for now.


    But I hope it's fixed before I get my new set.
  • farpumpefarpumpe Posts: 2Members
    I'm having the same problem using v.0.9.2.5.

    I change the view option under 'Movies', go one step back to the filter page, and upon entering again, it will go back to the info list view option.

    Tried to run the command, but it didn't help. :unsure:

    Also, I'm having a problem with posters not showing up -> http://forums.plexapp.com/index.php/topic/24865-posters-not-showing-after-latest-upgrades/page__view__findpost__p__157139
    Don't know if it has anything to do with this problem?
  • theatreplex008theatreplex008 Posts: 244Members ✭✭
    From what I've heard, certain add-on apps can corrupt xml files.

    * But I'm still hoping for a fix, since the above hasn't worked at all :huh:
«1
Sign In or Register to comment.