Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to remove movies in the Media Manager?

htpc_dudehtpc_dude Posts: 14Members
edited April 2011 in Plex Media Center - Mac
The Plex Media Manager has put in several movies that I don't want in my media library. What it is picking up is not really complete movies but every .mkv file in a folder.

For example, I have a movie folder that contains several .mkv files, say movie001.mkv thru movie009.mkv, so Plex adds nine movie items in the media manager. All I need is movie001.mkv, when Plex plays that file it knows to continue playing the rest of the .mkv files in that folder.

The previous version of Plex allowed me to removed the unwanted movie items (posters) from the Media Manager, however, I don't see where this release will let me remove items.

Comments

  • pooploserpooploser Plex Ninja Posts: 958Members, Plex Pass, Plex Ninja Plex Ninja
    you have to rename them to either CD1, CD2, or part1, part2 etc.
    however, max. 6 items can be stacked at the moment.
    and to answer the question in the header, you can't remove films from the media manager, unless you remove them from your Movie folder.
  • htpc_dudehtpc_dude Posts: 14Members
    So you are saying that I either have to combine all the .mkv files into no more than six files and rename them part1-part6 or physically remove the files from the movie folder? Pardon my disappointment, but that's pretty stupid. Not allowing the user to control what items are shown (or scraped) is, in my opinion, a fatal flaw in the software.
  • htpc_dudehtpc_dude Posts: 14Members
    Any other advice guys?
  • Chris CChris C Plex Employee Posts: 11,644Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Plex is designed to try and make available all the media within the content location (and subdirectories within) you specify. So, if you don't want something picked up by Plex then it shouldn't be placed within that content location. That's the intended behavior for Plex.

    The CD1, Part 1, etc. that pooploser mentioned is the "Stacking" feature available within Plex. It's intended for situations where, say, a single movie is split between 2 or 3 separate videos (for instance, the Lord of the Rings movies being split on 2 DVDs, and the video being ripped from each one). When such files are "stacked", Plex will play them one after the other to make them appear/behave as if they were one file. See the Naming Guide for some info.
  • hwilke01hwilke01 Posts: 4Members
    I had a directory in my 'Movies' folder that had some 'bonus material' from the DVD- i.e. deleted scenes and whatnot. Because there was no accurate metadata for these clips, Media Manager (or freebase or whatever service it used) made a guess and assigned them names. Well, I really don't care about these files and have removed them from my 'Movies' folder... (actually they were in a subfolder of the the Movies folder). However, they are still showing up in the Media Manager and subsequently in the Plex Client with a yellow '!' triangle. Is there a file I can edit to remove them? Or an easy way to remove them so they no longer show up in my Plex Client?

    Right clicking and selecting 'unmatch' doesn't seem to do the trick, nor any of the other options on a right click within Media Manager.

    Many thanks in advance for any assistance.

    Hal
  • jamerson9jamerson9 Posts: 772Members ✭✭
    hwilke01 wrote:

    I had a directory in my 'Movies' folder that had some 'bonus material' from the DVD- i.e. deleted scenes and whatnot. Because there was no accurate metadata for these clips, Media Manager (or freebase or whatever service it used) made a guess and assigned them names. Well, I really don't care about these files and have removed them from my 'Movies' folder... (actually they were in a subfolder of the the Movies folder). However, they are still showing up in the Media Manager and subsequently in the Plex Client with a yellow '!' triangle. Is there a file I can edit to remove them? Or an easy way to remove them so they no longer show up in my Plex Client?

    Right clicking and selecting 'unmatch' doesn't seem to do the trick, nor any of the other options on a right click within Media Manager.

    Many thanks in advance for any assistance.

    Hal

    Hi, its the soft deletion feature (see the wiki for more information), to clear it empty the trash bin in the Media Manager.
Sign In or Register to comment.