Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

LGwebOSTV Profile for direct play HEVC

albi84albi84 Posts: 6Validating, Plex Pass Plex Pass
edited February 15 in DLNA

I want to direct Play HEVC MKV Files because the Server is to slow to transcode them. The TV is able to Play HEVC (I played Hevc from USB drive)

I Can't get the Profile to work. and im not sure ist it the Identifier or the Code itself.

Am I corect to try to get direct Play for HEVC to work with a Profile for the TV.

<Client name="LGwebOSTV">
        <!-- http://www.lge.com -->
    <Identification>
             <!--<Header name="User-Agent" substring="LGE_DLNA_SDK" />--> <!-- Full header is "LGE WebOS TV LGE_DLNA_SDK" -->
        <Header name="User-Agent" substring="Web0S" /> <!--note the zero instead of the leter O -->
        <Header name="DLNADeviceName.lge.com" regex=".*webOS.*" />
        <DeviceDescription>
            <FriendlyName substring="LLGwebOSTV" />
            <!-- Option for NetCast devices -->
            <!-- <FriendlyName substring="LG TV" />  -->
            <ModelNumber substring="1.0" />
            <ModelUrl substring="http://www.lge.com/" />
            <Manufacturer substring="LG Electronics." />
            <Manufacturer substring="http://www.lge.com" />
        </DeviceDescription>
    </Identification>
    <Settings>
                <!--<Setting name="OnlyPlainVideoItems" value ="true" />
        <Setting name="OnlyStorageFolders" value="true" />
        <Setting name="IgnoreTranscodeByteRangeRequests" value="true" />
        <Setting name="EmitAlbumArtResources" value="false" /> -->
        <Setting name="TimelineBufferOffset" value="0" /> <!--original=10 -->
        <Setting name="AlbumArtPN" value="JPEG_SM" />
        <Setting name="IgnoreTranscodeByteRangeRequests" value="false" />
    </Settings>
        <DirectPlayProfiles>
                <VideoProfile container="mpegts" codec="HEVC,hevc,h265,h264,vc1,mpeg2video" audioCodec="ac3,mp3" />
                <VideoProfile container="mkv" codec="HEVC,hevc,h265,h264,mpeg1video,mpeg2video,mpeg4,wmv3,vc1" audioCodec="aac,ac3,mp3,dca,mp2,pcm" />
                <VideoProfile container="mp4" codec="HEVC,hevc,h265,h264,mpeg4,avc" audioCodec="ac3,mp3" />
                <VideoProfile container="avi" codec="HEVC,hevc,h265,h264,mpeg4.mjpeg" audioCodec="ac3,mp3,dca" />
                <VideoProfile container="mpeg,mpg" codec="mpeg1video,mpeg2video" audioCodec="ac3,mp3" />
                <MusicProfile container="mp3" codec="mp3" />
                <MusicProfile container="mp4" codec="aac" />
                <MusicProfile container="wav" codec="pcm,dca" />
                <PhotoProfile container="jpeg" codec="jpeg" />
        </DirectPlayProfiles>
    <CodecProfiles>
        <VideoCodec name="*">
            <Limitations>
                <UpperBound name="video.width" value="1920" />
                <UpperBound name="video.height" value="1080" />
                <UpperBound name="video.videoFrameRate" value="30" isRequired="false" />
            </Limitations>
        </VideoCodec>
        <VideoCodec name="h265">
            <Limitations>
                <UpperBound name="video.width" value="1920" />
                <UpperBound name="video.height" value="1080" />
                <UpperBound name="video.videoFrameRate" value="30" isRequired="false" />
                <UpperBound name="video.level" value="51" isRequired="false" />
            </Limitations>
        </VideoCodec>
        <VideoCodec name="h264">
            <Limitations>
                <UpperBound name="video.width" value="1920" />
                <UpperBound name="video.height" value="1080" />
                <UpperBound name="video.videoFrameRate" value="30" isRequired="false" />
                <UpperBound name="video.level" value="51" isRequired="false" />
            </Limitations>
        </VideoCodec>
        <VideoAudioCodec name="ac3,aac">
            <Limitations>
                <UpperBound name="audio.channels" value="6" isRequired="false" />
            </Limitations>
        </VideoAudioCodec>
        <VideoAudioCodec name="mp3">
            <Limitations>
                <UpperBound name="audio.channels" value="2" isRequired="false" />
            </Limitations>
        </VideoAudioCodec>
        <VideoAudioCodec name="dca">
            <Limitations>
                <UpperBound name="audio.channels" value="8" isRequired="false" />
            </Limitations>
        </VideoAudioCodec>
    </CodecProfiles>
    <DlnaMediaProfiles>
        <DlnaVideoProfile container="mpeg" mimeType="video/mpeg" pn="MPEG_PS_NTSC,MPEG_PS_PAL"/>
        <DlnaVideoProfile container="avi" mimeType="video/x-msvideo" />
    </DlnaMediaProfiles>
</Client>

Location of the File is:

C:\Users\MEDIASERVER\AppData\Local\Plex Media Server\Profiles\LGwebOSTV.xml

Plex is running as a Service.

--jmckee edited to put xml in code tags

Best Answer

Answers

  • jmckeejmckee Posts: 4,599Members, Plex Pass, Plex Ninja Plex Ninja

    What does your DLNA log show when you try and playback a file?

    Everything looks like it is where it should be. The main observation I have is that your profile has no transcodetargets section. This means that everything that matches to that profile should be trying to directplay no matter what.

  • albi84albi84 Posts: 6Validating, Plex Pass Plex Pass

    The DLNA Log dont Show anything:

    Feb 15, 2017 20:37:28.048 [8324] INFO - Plex DLNA Server v1.4.1.3362-77c6a4f80 - Microsoft PC x64 - build: windows-i386 - GMT 01:00
    Feb 15, 2017 20:37:28.048 [8324] INFO - Windows version: 6.2 (Build 9200), language de-DE
    Feb 15, 2017 20:37:28.048 [8324] INFO - 4 2152 MHz processor(s): Architecture=0, Level=22, Revision=1 Processor Identifier=AMD64 Family 22 Model 0 Stepping 1, AuthenticAMD

    Im still not sure if the profiles file is recongnized. because nearly no file is direct played

  • jmckeejmckee Posts: 4,599Members, Plex Pass, Plex Ninja Plex Ninja

    If that's the case are you using a DLNA client on the TV or the actual Plex App?

    If it's a DLNA client you should be seeing a lot of activity there once your start playing a file. There should be some MDE lines, some requests being sent to the actual server, etc.

  • albi84albi84 Posts: 6Validating, Plex Pass Plex Pass

    I use the actual plex app.

Sign In or Register to comment.