Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to play any video

David SnyderDavid Snyder Posts: 1,485Members, Plex Pass Plex Pass
edited May 2011 in Plex Classic for Roku
video playback doesn't work on any file
Was excited to see the Roku channel stream - and finally have a reason to plug-in my old dusty Roku box =) I've installed the channel, and am able to browse my library. It pulls in all the meta data etc. and all looks fine. But, when I try to play any video file, it simply says 'retrieving' and then goes back to the previous screen. Have tried a couple dozen videos of all sizes, codecs and quality - no joy. Any one else experiencing similar issue?

EDIT
If it first you don't succeed, reboot. I forgot the first basic rule of troubleshooting =) Restarted the box and now all is well.
«1

Comments

  • jwrayjwray Posts: 1,269Members, Plex Pass Plex Pass
    Never saw that issue in 3 months of development, but glad you got it working. Let me know what you think once you've used it more.

    Jonny
  • friedflixfriedflix Posts: 1,963Members, Plex Pass Plex Pass
    Just want to thank you for this...you increased how Plexified our home is by a factor of two with one fell swoop. Awesome.
  • David SnyderDavid Snyder Posts: 1,485Members, Plex Pass Plex Pass
    Jonny Wray wrote:

    Never saw that issue in 3 months of development, but glad you got it working. Let me know what you think once you've used it more.

    Jonny


    I haven't done exhaustive testing yet, just played a few videos - but I can replicated that issue. Changing the quality setting requires a reboot of the box, otherwise nothing will play; certainly not a big deal tho. Also no 1080p content will play, it doesn't even try. I have the original Roku box, first gen - that may have something to do with it. Other than that, seems to be working great. I'm really impressed with what you've done; it's given new life to a box that was otherwise destined to sit in my closet unused indefinitely. =)

    I thought I read in the blog post that it was to support direct streaming? In the tests I've done, nothing has however, everything is being transcoding on my server.
  • seahorsejlseahorsejl Posts: 181Members, Plex Pass Plex Pass
    The original Roku boxes only support up to 720p. Only the XD and XDS support 1080p.
  • friedflixfriedflix Posts: 1,963Members, Plex Pass Plex Pass
    edited May 2011
    nn
    DavidNC wrote:

    I haven't done exhaustive testing yet, just played a few videos - but I can replicated that issue. Changing the quality setting requires a reboot of the box, otherwise nothing will play; certainly not a big deal tho. Also no 1080p content will play, it doesn't even try. I have the original Roku box, first gen - that may have something to do with it. Other than that, seems to be working great. I'm really impressed with what you've done; it's given new life to a box that was otherwise destined to sit in my closet unused indefinitely. =)

    I thought I read in the blog post that it was to support direct streaming? In the tests I've done, nothing has however, everything is being transcoding on my server.


    don't forget what Jonny just wrote...Roku only supports h.264 video codec so everything else will be transcoded.

    http://forums.plexapp.com/index.php/topic/26305-considering-buying-a-roku-nowfeedback/page__view__findpost__p__167508
  • jwrayjwray Posts: 1,269Members, Plex Pass Plex Pass
    Thanks man, appreciate the kind words.

    Curious about the reboot, I certainly never had that issue changing quality settings. Could be an issue with the box. I'll certainly look into it though, that's not good.

    What's your network set up? I did experience the Roku silently failing to play some streams over wireless - basically high bit rate ones - but I never could get it to replicate consistently. Wired, I never saw such an issue. But, with a low enough quality setting (which basically maps to max bit rate) it should play the 1080 content via transcoding.

    Whether direct streaming can be used or not is determined by a number of parameters. If it can be used it will be. The biggest two parameters that stop it being used are i) Roku only supports h.264 over streaming and ii) only supports up to level 4.0 of the h.264 codec, anything above that will be transcoded. Other video parameters will also affect it but these are the big two based on my testing. If you have examples of things you think should be direct streamed but aren't, again, I'd love to hear about them.

    Jonny

    DavidNC wrote:

    I haven't done exhaustive testing yet, just played a few videos - but I can replicated that issue. Changing the quality setting requires a reboot of the box, otherwise nothing will play; certainly not a big deal tho. Also no 1080p content will play, it doesn't even try. I have the original Roku box, first gen - that may have something to do with it. Other than that, seems to be working great. I'm really impressed with what you've done; it's given new life to a box that was otherwise destined to sit in my closet unused indefinitely. =)

    I thought I read in the blog post that it was to support direct streaming? In the tests I've done, nothing has however, everything is being transcoding on my server.
  • David SnyderDavid Snyder Posts: 1,485Members, Plex Pass Plex Pass
    Jonny Wray wrote:

    What's your network set up? I did experience the Roku silently failing to play some streams over wireless - basically high bit rate ones - but I never could get it to replicate consistently. Wired, I never saw such an issue. But, with a low enough quality setting (which basically maps to max bit rate) it should play the 1080 content via transcoding.



    I'm on WiFi, via an Airport Base Station. Everything in my house is wireless - from My Mac Mini server to my storage array, and two ATV's. Everything else works great playing the highest quality video - though this Roku is ancient, and I believe is only supporting G; so that could be the issue right there come to think of it.

    Jonny Wray wrote:

    Whether direct streaming can be used or not is determined by a number of parameters. If it can be used it will be. The biggest two parameters that stop it being used are i) Roku only supports h.264 over streaming and ii) only supports up to level 4.0 of the h.264 codec, anything above that will be transcoded. Other video parameters will also affect it but these are the big two based on my testing. If you have examples of things you think should be direct streamed but aren't, again, I'd love to hear about them.



    Thanks for the clarification on the streaming. I already run a dedicated Plex server that does nothing but transcoding for my ATV clients - so it's not an issue to me at all, was just curious.

    Again, I'm really impressed with this. Thanks so much for your work on it.
  • jwrayjwray Posts: 1,269Members, Plex Pass Plex Pass
    Wireless issue sounds about right based on my empirical testing. We also did some testing with faking the stream bit rate reported to the Roku and in fact it was able to handle it just fine. Looks like they err on the side of caution with respect to what the device can handle. Makes sense for that point of view.

    Yeah, I was hoping direct streaming could be used more. Again, I did some empirical testing and the device can handle a lot of content way above reported specs, but not 100%, and I couldn't find a pattern so we're stuck at respecting their specs.

    Thanks again for the kind words, they are appreciated.
    Jonny

    DavidNC wrote:

    I'm on WiFi, via an Airport Base Station. Everything in my house is wireless - from My Mac Mini server to my storage array, and two ATV's. Everything else works great playing the highest quality video - though this Roku is ancient, and I believe is only supporting G; so that could be the issue right there come to think of it.



    Thanks for the clarification on the streaming. I already run a dedicated Plex server that does nothing but transcoding for my ATV clients - so it's not an issue to me at all, was just curious.

    Again, I'm really impressed with this. Thanks so much for your work on it.
  • brent112brent112 Posts: 775Members, Plex Pass Plex Pass
    What if we trick the device to thinking it is a different profile level, like Change 4.1 to 4.0 for example, H264LevelEditor does this.. http://www.softpedia.com/get/Multimedia/Video/Other-VIDEO-Tools/H264-Level-Editor.shtml
  • David SnyderDavid Snyder Posts: 1,485Members, Plex Pass Plex Pass
    edited May 2011
    seahorsejl wrote:

    The original Roku boxes only support up to 720p. Only the XD and XDS support 1080p.



    Right - but it's transcoding so it just isn't outputting 1080p via the box. Same with the ATV etc. It will still play 1080p source.
  • jwrayjwray Posts: 1,269Members, Plex Pass Plex Pass
    I did some testing along those lines, although from the other direction - telling PMS that the client can handle level 5.1. Bottom line was about 75% of my test movies with level > 4.0 played fine. Most of the others played audio and no video.

    So, try and see I guess is the answer :)

    brent112 wrote:

    What if we trick the device to thinking it is a different profile level, like Change 4.1 to 4.0 for example, H264LevelEditor does this.. http://www.softpedia.com/get/Multimedia/Video/Other-VIDEO-Tools/H264-Level-Editor.shtml
  • drumerboy1988drumerboy1988 Posts: 3Members
    I'm experiencing the same issue... My media shows up, but when I go to play a movie it goes to the retrieving screen for a second and goes back to the movie info screen.

    I have the newer Roku XDS model and I'm streaming over wifi...

    specs of movie file I'm trying to stream:
    Codec: H.264, AAC, AC3
    Total Bit Rate: 2,605

    Thanks again for making this app! The UI blows away the Roku USB channel...
  • biggyvbiggyv Posts: 1Members
    edited May 2011
    I've had the same problem; metadata loads, connects to the server, etc. and when I try to access a video, I get the "retrieving" message, and then it quickly kicks back out, just as the OP experienced. I tried rebooting the Roku as he did, but no dice, I'm getting the same problem. Could it be a filetype/codec issue? I'm at a loss here...

    EDIT: Ahhh, changed the quality setting down to 2.0 mbps. That'll do it!
  • drumerboy1988drumerboy1988 Posts: 3Members
    biggyv wrote:

    I've had the same problem; metadata loads, connects to the server, etc. and when I try to access a video, I get the "retrieving" message, and then it quickly kicks back out, just as the OP experienced. I tried rebooting the Roku as he did, but no dice, I'm getting the same problem. Could it be a filetype/codec issue? I'm at a loss here...

    EDIT: Ahhh, changed the quality setting down to 2.0 mbps. That'll do it!



    Just adjusted the settings to 2.0 mbps and IT WORKS!

    Thanks!
  • jwrayjwray Posts: 1,269Members, Plex Pass Plex Pass
    The best solution here, if you can do it, is to plugin the Roku box into your wired network.

    That said, glad you're both up and running.

    Jonny
  • lhodgkinslhodgkins Posts: 109Members, Plex Pass Plex Pass
    Hi Guys,
    Where are we adjusting the quality setting to 2 mbps??

    Thanks,
    Lennie
  • seahorsejlseahorsejl Posts: 181Members, Plex Pass Plex Pass
    lhodgkins wrote:

    Hi Guys,
    Where are we adjusting the quality setting to 2 mbps??

    Thanks,
    Lennie


    In the main Plex Roku channel screen, scroll right to the very end and your will see a Settings/Preferences (can't remember what is is actually called). Select this, and you will be present with a pick list of different quality settings to choose from.
  • lhodgkinslhodgkins Posts: 109Members, Plex Pass Plex Pass
    Yup, Just figured that out....

    Thanks!!
  • jdavis83jdavis83 Posts: 59Members, Plex Pass Plex Pass
    Same issue. Had to set to 2.0mbps stream, reboot and is working. Testing 720p and 1080p h264 now. Will test other streams and plugins later and let you know what I find.
  • jdavis83jdavis83 Posts: 59Members, Plex Pass Plex Pass
    Plugin channels aren't showing up for me. Any settings I need to change server side or client side?
«1
Sign In or Register to comment.