Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Problem with Play music

PolypetePolypete Members, Plex Pass Posts: 29 Plex Pass

Hi,

I have a problem with my sonos for play music from PLEX when use the sonos plugin beta.

No problem with PLEX, all work in all configuration (Windows, Android, iOS, etc..) in internal network (LAN) and from internet (WAN), only from PLEX sonos plugin have a problem when try to play the music, I receive a message : impossible tu play this file, not find this file.

Very Strange because in Sonos I see all album, artist, etc.. Only when I add the file into list, when sonos try to read the file, not possible.

It's necessary to open (NAT) a specific port into PLEX server ?

Answers

  • SkywizardSkywizard Members Posts: 4 ✭✭

    I do not know why there is an option to select PLEX on the Sonos when you can map your music library direct to the source....

  • virgiliomivirgiliomi Members, Plex Pass Posts: 51 Plex Pass

    @Skywizard said:
    I do not know why there is an option to select PLEX on the Sonos when you can map your music library direct to the source....

    Because some people have a music library that is larger than Sonos' 65,000 track limit (or they have music with longer metadata tags that reduce that track limit some). Also, you could use Plex on Sonos to play music stored on a remote Plex server... like one at a family member's house that they've given you access to, or through Plex Cloud.

    As to the OP... if you can browse your Plex music library from Sonos, then you have things set up right. The catch is that to play music, some routers can't handle the kind of request that Plex is making Sonos use to play the song. Some have had to enable a certain NAT setting on their router in order for things to work properly. Others have found that simply manually creating the port forward, rather than letting Plex do it automatically, has worked for them. And some just aren't able to use Plex through Sonos because of this issue.

    If Plex ever comes back to working on this, they might figure out a way to handle those connections internally on the network... but that seems to be a distant possibility at the moment.

  • wwwizzarrdrywwwizzarrdry Members, Plex Pass Posts: 186 Plex Pass
    edited May 5

    It will be faster to plant some magic beans and wait for Jack and the Beanstalk to come than to wait for Plex to respond, much less actually fix, their Sonos plugin issues.

    They're​ more than happy boasting about this amazing service on their product page. But they dont announce that its broken and they dont plan to fix it... Classic bait and switch.

  • paganomt@gmail.compaganomt@gmail.com Members, Plex Pass Posts: 3 Plex Pass

    I have this same issue. Why doesn't Plex support answer in the forums? I thought that was their method of communication?
    Plex and sonos need to work together on this.

  • PolypetePolypete Members, Plex Pass Posts: 29 Plex Pass
    edited June 18

    Now for me work fine.
    I add a UniFI Security Gateway 3P in my home for redirect Sonos Plex Lab request only in my LAN.

    Now when Sonos send a request to Plex, the file is only PLAY into my LAN (now not send network request LAN->WAN->LAN).

    Only need a rules Firewall :

    Under WAN IN:
                                            "3006": {
                                                    "action": "accept",
                                                    "description": "PortForward [Plex]",
                                                    "destination": {
                                                            "address": "XXX.XXX.XXX.XXX",
                                                            "port": "32400"
                                                    },
                                                    "log": "enable",
                                                    "protocol": "tcp_udp"
                                            },
    Under Port Forwarding:
                            "3004": {
                                    "description": "Plex",
                                    "forward-to": {
                                            "address": "XXX.XXX.XXX.XXX"
                                    },
                                    "original-port": "32400",
                                    "protocol": "tcp_udp"
                            },

Sign In or Register to comment.