If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to Play Watch Later YouTube videos on Plex Web

shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja

There is an issue with Plex Web for Chrome playing YouTube Watch Later videos. They just sit there loading forever.

There was an issue with PMS for Windows v1.5.2 being unable to transcode YouTube videos, but that issue has been resolved in PMS for Windows v1.5.6 and later. I know this issues is resolved because the Plex app for Roku must trancode some YouTube Watch Later videos and they play and transcode fine on the Plex app for Roku using PMS for Windows v1.5.6 or later.

The same YouTube Watch Later videos will direct play on the iOS app and transcode on the Roku app. But I have tried playing these YouTube videos in Plex Web v3.2.1, v3.4.1, and v3.6 in Chrome and they just sit there loading forever.

I even tried disabling Direct Play under Settings > Plex Web > Player, but they still will not play.

Many issues and questions can be resolved by reviewing the Plex Support Documentation
Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
See Log Files
Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
FAQ for Channel Plugin FAQ

«1

Comments

  • shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja
    edited May 18

    I have also tried the latest version of the Plex Web app (v3.6) on Firefox and Safari from another device (including disabling direct play) and YouTube Watch Later video playback fails on those browsers as well.

    EDIT:

    I have also tried the latest version of the Plex Web app (v3.6) on browsers from Ipad (Safari and Firefox) and YouTube Watch Later video playback fails as well. But Firefox on Windows 10 can play YouTube Watch Later videos.

    Many issues and questions can be resolved by reviewing the Plex Support Documentation
    Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
    See Log Files
    Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
    READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
    FAQ for Channel Plugin FAQ

  • shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja

    It appears there is an issue with the Plex Web app sending the POST request necessary to get the video stream. This same request works fine on the Plex app for Roku and iOS.

    Many issues and questions can be resolved by reviewing the Plex Support Documentation
    Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
    See Log Files
    Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
    READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
    FAQ for Channel Plugin FAQ

  • harrogukharroguk Posts: 168Members, Plex Pass Plex Pass

    Just as a side note, it is working in Microsoft Edge on Windows 10

    all-thin-banner.jpg

  • shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja

    This does appear to be an issue affecting the Chrome and Safari browsers. Firefox works as well (except on Ipad).

    Many issues and questions can be resolved by reviewing the Plex Support Documentation
    Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
    See Log Files
    Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
    READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
    FAQ for Channel Plugin FAQ

  • donyzzdonyzz Posts: 153Members ✭✭

    Still not working in chrome or edge(for me). This has been a problem for about 2 months. :'(

  • harrogukharroguk Posts: 168Members, Plex Pass Plex Pass

    Still not working in Chrome (Works fine in M$ Edge)

    PlexWeb: Version 3.6.0
    Plex Media Server: Version 1.7.0.3840
    Chrome: Version 58.0.3029.110 (64-bit)

    all-thin-banner.jpg

  • LiLSaInT0925LiLSaInT0925 Posts: 4Members, Plex Pass Plex Pass

    @shopgirl284 said:
    There is an issue with Plex Web for Chrome playing YouTube Watch Later videos. They just sit there loading forever.

    There was an issue with PMS for Windows v1.5.2 being unable to transcode YouTube videos, but that issue has been resolved in PMS for Windows v1.5.6 and later. I know this issues is resolved because the Plex app for Roku must trancode some YouTube Watch Later videos and they play and transcode fine on the Plex app for Roku using PMS for Windows v1.5.6 or later.

    The same YouTube Watch Later videos will direct play on the iOS app and transcode on the Roku app. But I have tried playing these YouTube videos in Plex Web v3.2.1, v3.4.1, and v3.6 in Chrome and they just sit there loading forever.

    I even tried disabling Direct Play under Settings > Plex Web > Player, but they still will not play.

    I am getting the same issue with Watch later not working in Chrome. I have tried IE and that works but not Chrome. So far I have tested the following:

    • Chrome (Doesn't work)
    • Internet Explorer (Works)
    • Plex Windows App (Works)
    • Android (Works)
    • iOS (Works)

    Not sure where the issue is with Chrome but it is for sure the browser that won't play the videos in the Watch Later playlist.

    Question

    Does anyone know if there is a way to send an email to Plex and have their development team take a look at the issue? I know it is a small thing but it would be nice to have this working.

  • chrishoagechrishoage Posts: 134Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

    As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.

  • LiLSaInT0925LiLSaInT0925 Posts: 4Members, Plex Pass Plex Pass

    @chrishoage said:
    We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

    As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.

    Thank you!

  • harrogukharroguk Posts: 168Members, Plex Pass Plex Pass

    As per https://forums.plex.tv/discussion/comment/1448504#Comment_1448504

    Upgraded to
    PMS Version 1.7.2.3878
    Still not working

    all-thin-banner.jpg

  • jhoward15jhoward15 Posts: 23Members, Plex Pass Plex Pass

    Same here with the latest version of Chrome on a Chromebook - playing videos from Youtube via Watch Later just sit with a spinning circle like it's trying to buffer them.

  • gboudreaugboudreau Posts: 90Members, Plex Pass Plex Pass
    edited July 25

    I posted a thorough investigation the issue here:
    https://forums.plex.tv/discussion/280030/cant-play-youtube-videos-from-watch-later-in-plex-web-app-in-google-chrome

    The problem is the Accept-Encoding HTTP header that Chrome sends to PMS, when it requests the HTML required to play a YouTube video.
    The fix should be simple from there, for a Plex developer.

    For end-users who can't wait for Plex to fix this issue, you can install a Chrome extension that allows you to modify the HTTP headers sent to servers, and force the Accept-Encoding header to always send the value gzip, deflate

    I tested with the Requestly extension, and the following settings:

    You can import this rule in Requestly by visiting this URL after installing Requestly. Use the Import List button in the top-right corner.

    And I (and you!) can now play YouTube videos without problems in Chrome. Yay!

  • gboudreaugboudreau Posts: 90Members, Plex Pass Plex Pass

    @chrishoage said:
    We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

    As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.

    @chrishoage Would you mind updating the ticket you opened in the PMS repo with the information I posted in the above thread?

  • chrishoagechrishoage Posts: 134Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @gboudreau I have attached that thread to the internal issue. Thanks!

  • harrogukharroguk Posts: 168Members, Plex Pass Plex Pass

    Thanks very much @gboudreau you are the greatest.

    all-thin-banner.jpg

  • fookharfookhar Posts: 1Members Plex Pass
    edited July 27

    @gboudreau, thank you so much for the Chrome fix!

  • donyzzdonyzz Posts: 153Members ✭✭

    Thanks @gboudreau for fixing a deal breaker. I wonder why plex employees couldn't address this sooner? There were tons of complaints on it. Hopefully the update with the fix doesn't take till Christmas as I'm sure there many out there who don't know about the chrome extension workaround.

  • rckmnrrckmnr Posts: 12Members ✭✭

    It still doesn't work in firefox.

  • sander1sander1 Channel Developer/Admin Posts: 3,695Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 27

    @rckmnr said:
    It still doesn't work in firefox.

    The Brotli encoding, where the problem lies, is implemented in Firefox version 44+ (and Chrome version 49+). You can turn it off in Firefox and YouTube videos in the Watch Later queue will start working again.

    Turn off Brotli encoding in Accept-Encoding header in Firefox

    1. Type about:config into the location bar of Firefox and press enter.
    2. Read the warning and click "I accept the risk!" if you feel comfortable.
    3. Type encoding in the search bar and look for the entry named network.http.accept-encoding.secure.
    4. Change the value of network.http.accept-encoding.secure to gzip, deflate (the default value is gzip, deflate, br).

    Turn off Brotli encoding in Accept-Encoding header in Chrome

    1. Type chrome://flags into the location bar of Chrome and press enter.
    2. A long page with options will open. Look for Brotli Content-Encoding.
    3. Select Disabled from the dropdown menu.
    4. Press the "Relaunch Now "button at the bottom of the screen for the change to take effect.

    .
    Don't forget to change the values back once PMS has been fixed.

  • breathe67breathe67 Posts: 1Members

    I'm having the same problem, video will play in MS Explorer browser or Plex desktop client, but stalls at loading in Chrome.

«1
Sign In or Register to comment.