If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Some photos showing "Unable to Load Photo" when viewed in Plex on Roku

Crag_MonkeyCrag_Monkey Posts: 6Members, Plex Pass Plex Pass

Certain photos do not display on the Roku's Plex App (gray screen with "Unable to Load Photo" error message), while others display fine. Seems to be all photos taken with regular point-and-shoot cameras fail, while pictures taken on a smart phone display properly. The same photos do not display a thumbnail, instead showing a gray square.

All photos display properly in Plex web app viewed from browser, and all photos happen to be jpegs.

«1

Answers

  • J&JSmithJ&JSmith Posts: 2Members, Plex Pass Plex Pass

    I have the same problems on a Roku 3. It usually starts happening after several photos have displayed in slide show mode. If I reset the Roku, the photos will display once more. I have ordered a new Roku Premier+. It'll be interesting to see if it has the same problem with the Plex app.

  • kwyjibo317kwyjibo317 Posts: 1Members, Plex Pass Plex Pass

    Same as J&J, rebooted Roku, thumbnail/display issues resolved across all apps (Plex/Photos, Hulu, Netflix, etc.)

  • J&JSmithJ&JSmith Posts: 2Members, Plex Pass Plex Pass

    Update: Bought Roku Premier+. Problem seems to be gone now.

  • dgmelvindgmelvin Posts: 49Members, Plex Pass Plex Pass

    This is a big problem on the Roku 3. I don't have other Roku devices to test on, but on the Roku 3 after a number of photos show the not able to load message shows up and then all Roku apps that show images are messed up. You have to reboot.

    Is this being fixed?

  • Crag_MonkeyCrag_Monkey Posts: 6Members, Plex Pass Plex Pass

    Rebooting Roku does not rectify the issue.

  • jonvaughtjonvaught Posts: 12Members, Plex Pass Plex Pass

    Just bought a Roku Premier+ and I still have the same issue

  • jonvaughtjonvaught Posts: 12Members, Plex Pass Plex Pass

    guys please help, I have an important family event coming up next week and need some photo slideshows to work. It just hands on "loading" and it is never the same pictures and sometimes it will go 2 minutes without a problem and other times it will go 10 minutes without an issue. My setup is a ReadyNAS running Plex and a Roku Premier +

  • MovieFan.PlexMovieFan.Plex Posts: 17,434Members, Plex Pass, Plex Ninja Plex Employee

    Those having this issue, please PM me 1 photo that is causing this issue.

  • sa2000sa2000 Posts: 31,286Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    There was a big issue on Roku 3's with photos - failing after a number of photos - this problem came with Roku firmware 7.6 build 4125

    The problem appears to have got resolved in Firmware update 7.7.0 build 4094-04 which I got 9 days ago

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • isaacschwarz3@gmail.comisaacschwarz3@gmail.com Posts: 1Members

    I have a Roku 3, updating the firmware to 7.7.0 build 4094-04 did not fix the issue for me.

    However, my issue may be (somewhat) different, I am also "unable to load photo". I can see all the photos as thumbnails, but displays the message when I try to view them. This issue isn't restricted to the Roku and also presents itself on the Windows Plex App and also on the web client.

  • sa2000sa2000 Posts: 31,286Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited July 2017

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • escape2escape2 Posts: 9Members ✭✭

    @sa2000 said:
    There was a big issue on Roku 3's with photos - failing after a number of photos - this problem came with Roku firmware 7.6 build 4125

    The problem appears to have got resolved in Firmware update 7.7.0 build 4094-04 which I got 9 days ago

    Thank you very much! Upgrading to 7.7.0 fixed this issue for me. For some reason, my Roku 3 would not automatically pull this latest firmware. I had to manually ask it to update.

  • thorntonskthorntonsk Posts: 7Members, Plex Pass Plex Pass

    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

  • CortopassiCortopassi Posts: 35Members, Plex Pass Plex Pass

    Same there are no playable items problem here.

  • CortopassiCortopassi Posts: 35Members, Plex Pass Plex Pass
    edited May 16

    I see in release 5.3.1(?) on May 9, there is this note: Verified my Roku preview channel is 5.3.2, with the issue still

    (Photo) Fix playback from Recently Added hub.

    Is this supposed to solve this thread's issue, because it does not seem to have, for me at least. I still get the there are no playable items when trying photos.

  • sa2000sa2000 Posts: 31,286Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @thorntonsk said:
    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

    I can see the error

    May 06, 2018 16:26:37.402 [32360] ERROR - LPE: exception generating query for invalid path 'library://5fa5384f-b9aa-4e2c-9948-8af9d7017535/directory/%2Flibrary%2Fsections%2F6%2Fall%3FsourceType%3D13%2C12%26sort%3DaddedAt%3Adesc': bad lexical cast: source type value could not be interpreted as target
    

    This is fixed in release 5.3.0 which has been submitted to Roku and should be out soon.

    See release note https://forums.plex.tv/discussion/comment/1666730/#Comment_1666730

    • (Photo) Fix playback from Recently Added hub.

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • CortopassiCortopassi Posts: 35Members, Plex Pass Plex Pass

    @sa2000 said:

    @thorntonsk said:
    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

    I can see the error

    May 06, 2018 16:26:37.402 [32360] ERROR - LPE: exception generating query for invalid path 'library://5fa5384f-b9aa-4e2c-9948-8af9d7017535/directory/%2Flibrary%2Fsections%2F6%2Fall%3FsourceType%3D13%2C12%26sort%3DaddedAt%3Adesc': bad lexical cast: source type value could not be interpreted as target
    

    This is fixed in release 5.3.0 which has been submitted to Roku and should be out soon.

    See release note https://forums.plex.tv/discussion/comment/1666730/#Comment_1666730

    • (Photo) Fix playback from Recently Added hub.

    I noted in my previous comment that my Roku channel is 5.3.2, and I still have this issue? Am I missing something here?

  • sa2000sa2000 Posts: 31,286Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @Cortopassi said:

    @sa2000 said:

    @thorntonsk said:
    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

    I can see the error

    May 06, 2018 16:26:37.402 [32360] ERROR - LPE: exception generating query for invalid path 'library://5fa5384f-b9aa-4e2c-9948-8af9d7017535/directory/%2Flibrary%2Fsections%2F6%2Fall%3FsourceType%3D13%2C12%26sort%3DaddedAt%3Adesc': bad lexical cast: source type value could not be interpreted as target
    

    This is fixed in release 5.3.0 which has been submitted to Roku and should be out soon.

    See release note https://forums.plex.tv/discussion/comment/1666730/#Comment_1666730

    • (Photo) Fix playback from Recently Added hub.

    I noted in my previous comment that my Roku channel is 5.3.2, and I still have this issue? Am I missing something here?

    I don't believe I have looked at any logs from you. My feedback about the fix was to @thorntonsk

    If you have a problem, please enable debug logging on the server and the roku plex app and provide logs from both when the problem arises

    See
    https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    https://support.plex.tv/articles/201377603-roku-logs/

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • CortopassiCortopassi Posts: 35Members, Plex Pass Plex Pass

    @sa2000 said:

    @Cortopassi said:

    @sa2000 said:

    @thorntonsk said:
    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

    I can see the error

    May 06, 2018 16:26:37.402 [32360] ERROR - LPE: exception generating query for invalid path 'library://5fa5384f-b9aa-4e2c-9948-8af9d7017535/directory/%2Flibrary%2Fsections%2F6%2Fall%3FsourceType%3D13%2C12%26sort%3DaddedAt%3Adesc': bad lexical cast: source type value could not be interpreted as target
    

    This is fixed in release 5.3.0 which has been submitted to Roku and should be out soon.

    See release note https://forums.plex.tv/discussion/comment/1666730/#Comment_1666730

    • (Photo) Fix playback from Recently Added hub.

    I noted in my previous comment that my Roku channel is 5.3.2, and I still have this issue? Am I missing something here?

    I don't believe I have looked at any logs from you. My feedback about the fix was to @thorntonsk

    If you have a problem, please enable debug logging on the server and the roku plex app and provide logs from both when the problem arises

    See
    https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    https://support.plex.tv/articles/201377603-roku-logs/

    I will try to get logs, but:

    --Roku regular release app (not sure what the current version is) does not have this problem.
    --Only the preview channel does

  • sa2000sa2000 Posts: 31,286Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @Cortopassi said:

    @sa2000 said:

    @Cortopassi said:

    @sa2000 said:

    @thorntonsk said:
    I've gotten similar failures worded "There are no playable items" when I try to display a JPEG photo or MOV video from iphone. logs enclosed.

    I can see the error

    May 06, 2018 16:26:37.402 [32360] ERROR - LPE: exception generating query for invalid path 'library://5fa5384f-b9aa-4e2c-9948-8af9d7017535/directory/%2Flibrary%2Fsections%2F6%2Fall%3FsourceType%3D13%2C12%26sort%3DaddedAt%3Adesc': bad lexical cast: source type value could not be interpreted as target
    

    This is fixed in release 5.3.0 which has been submitted to Roku and should be out soon.

    See release note https://forums.plex.tv/discussion/comment/1666730/#Comment_1666730

    • (Photo) Fix playback from Recently Added hub.

    I noted in my previous comment that my Roku channel is 5.3.2, and I still have this issue? Am I missing something here?

    I don't believe I have looked at any logs from you. My feedback about the fix was to @thorntonsk

    If you have a problem, please enable debug logging on the server and the roku plex app and provide logs from both when the problem arises

    See
    https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    https://support.plex.tv/articles/201377603-roku-logs/

    I will try to get logs, but:

    --Roku regular release app (not sure what the current version is) does not have this problem.
    --Only the preview channel does

    which version has the problem?

    The official public release is now 5.3.4 and that includes the fix that went into preview app version 5.3.2

    Will need logs if the version with the problem is 5.3.2 or later

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
«1
Sign In or Register to comment.