Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Camera upload not uploading in the background

RTMcGRTMcG Posts: 21Members, Plex Pass Plex Pass
in iOS

The way I understand it the camera upload feature is supposed to continue to upload the photos in the background. As soon as my phone goes dark or the app is minimized the upload seems to stop.

«1

Answers

  • lobbyistlobbyist Posts: 2Members, Plex Pass Plex Pass

    Same problem here.

  • GregFaulknerGregFaulkner Posts: 2Members, Plex Pass Plex Pass

    I have the same problem, its not uploading in the background. On 2 iPhones. Why is this question marked as answered, theres no answer here ?

  • RTMcGRTMcG Posts: 21Members, Plex Pass Plex Pass

    Still no answer.... Hello? Beuller?

  • LamariosLamarios Posts: 13Members, Plex Pass Plex Pass
    edited June 19

    The camera upload stopped working at all for the past 10 days for me. It seems like it doesn't pick up new pictures, I tried to reset the camera upload but no luck. Logs don't show anything wrong. Same goes for my wife's phone.

  • El_CidEl_Cid Posts: 2Members, Plex Pass Plex Pass

    I have the same issue - it doesn't seem to upload anything if the app is not opened.
    I have a huge library of 7000 items because I just enabled the feature...

  • RTMcGRTMcG Posts: 21Members, Plex Pass Plex Pass

    The app has to be running for it to work, but the problem is it's supposed to be uploading while the app is running in the background, i.e., the phone is "dark" or another app is on the screen but Plex is running. That's the part that doesn't work. You have to actually keep the app running on an active screen for it to upload.

  • thedavixthedavix Posts: 4Members, Plex Pass Plex Pass

    Just installed for the first time the Plex app, and did activate the camera upload in the background.
    I did manage to do the first upload of all my ~2k pictures by leaving the app opened, but now it will not sync my pictures automatically in the background.

  • RTMcGRTMcG Posts: 21Members, Plex Pass Plex Pass

    Yours has worked better than mine so far then. Mine would only upload while the app was open, phone on (screen lit up) with plex being the primary app (not in the background). Once the app goes to the background or the phone goes dark it all stops.

  • shooter71shooter71 Posts: 30Members, Plex Pass Plex Pass

    Same issue on my iPhone and iPads; you need to continue opening the app to continue having it load pictures. Not sure if it auto uploads new pictures, as usually I get a server disconnect error before i can test that feature and then it thinks I am connected to a new server and have to start the process all over again.

  • calvo.familycalvo.family Posts: 24Members, Plex Pass Plex Pass

    Seeing the same problem, after uploading 10k pictures by forcing foreground in the app, now it wont do anything in background.

  • stevenhastevenha Posts: 150Members, Plex Pass Plex Pass

    Same here, I have to baby sit the upload every time which is very frustrating. That and the iCloud download issue makes this even slower than it should be for some unknown reason, even though I have no iCloud data for the device.

  • SteveaggieSteveaggie Posts: 1Members, Plex Pass Plex Pass

    Any update on this? I have the same problem. Upload works in the foreground but the app has to be active in the foreground.

  • sa2000sa2000 Posts: 28,600Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Would like some logs to refer to refer to the development team

    See https://support.plex.tv/hc/en-us/articles/201636593-iOS-Logs
    Settings / Help & Support / Debugging / Share Debugging Data / Select Mail and send to your mailbox and then attach the zip here

    Please indicate if upload is allowed only for wifi

    Background upload is supposed to happen - but slowly. Need to establish if there is an issue

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • stevenhastevenha Posts: 150Members, Plex Pass Plex Pass

    I believe it may well happen in the background but it is SO slow its pointless.

    To be clear, what I personally mean by background is not running a different app in the foreground but when the device locks to turn the screen off. This should allow full speed sync to make the feature usable.

  • clinderwclinderw Posts: 2Members, Plex Pass Plex Pass

    I am also experiencing this issue - @sa2000 & plex folks - have you been able to replicate yet?

  • sa2000sa2000 Posts: 28,600Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @clinderw said:
    I am also experiencing this issue - @sa2000 & plex folks - have you been able to replicate yet?

    I am aware it is slow process if you have thousands to be uploaded and may need to help it along by keeping the app in the foreground for periods of time

    I have no diagnostic logs to indicate that it does not run in the background - provided the server is available and wifi (if upload restricted to wifi)

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • jk0jk0 Channel Developer Posts: 107Members, Plex Pass Plex Pass

    I can also confirm this behavior on 3 separate iPhones. Upload is only allowed over WiFi. It will only upload photos when the Plex iOS app is running in the foreground and the screen is unlocked.

    Will work on getting logs.

  • jk0jk0 Channel Developer Posts: 107Members, Plex Pass Plex Pass

    Does Background App Refresh need to be enabled for the iOS app for this to work?

  • mm98mm98 Posts: 391Members, Plex Pass Plex Pass
    edited September 13

    @sa2000 said:

    I just did some testing regarding Camera upload. It only uploads to PMS if the app is running (background refresh allowed). I tried different things, but noticed this line - when i took a picture on the iPhone (without the app running) .. Nothing else in the Logs regarding any problems.

    Specific these two lines from PMS: (5 seconds before the image filename time-stamp)

        Sep 13, 2017 17:03:45.346 [0x7f1648d11700] DEBUG - handleStreamWrite code 32: Broken pipe
        Sep 13, 2017 17:03:45.346 [0x7f1648d11700] DEBUG - NotificationStream: Removing because of error
    

    PMS Logs:

    Sep 13, 2017 17:03:30.946 [0x7f1642111700] DEBUG - Sync: downloaded 1 sync lists, analyzing now...
    Sep 13, 2017 17:03:30.946 [0x7f1642111700] DEBUG - Sync: sync list 18777244: user 1 (mm98), device iPhone 6, profile iOS, id ABA0363E-D9D5-4B83-8717-B3712884CBBD, sync item(s): 21651668
    Sep 13, 2017 17:03:30.946 [0x7f1642111700] DEBUG - Sync: synchronizing 1 sync lists to generators
    Sep 13, 2017 17:03:30.949 [0x7f1642111700] DEBUG - Sync: synchronized 1 sync list(s) to 1 generators
    Sep 13, 2017 17:03:30.950 [0x7f1642111700] INFO - Sync: downloaded 1 sync list(s) with 1 sync items(s): 0 new, 0 updated, 0 deleted
    Sep 13, 2017 17:03:30.950 [0x7f163ffff700] DEBUG - BPQ: garbageCollect - sync - forced - 8
    Sep 13, 2017 17:03:30.950 [0x7f163ffff700] DEBUG - Sync: starting Sync garbage collection: 8, forced
    Sep 13, 2017 17:03:30.950 [0x7f163ffff700] DEBUG - Sync: scanning for items to reprocess in sync list 18777244
    Sep 13, 2017 17:03:30.951 [0x7f163ffff700] DEBUG - Sync: scanned for items to reprocess in sync list 18777244
    Sep 13, 2017 17:03:30.951 [0x7f163ffff700] DEBUG - Sync: finished Sync garbage collection: 8
    Sep 13, 2017 17:03:30.951 [0x7f1648d11700] DEBUG - Completed: [10.0.0.164:56352] 200 PUT /sync/refreshContent (13 live) TLS GZIP 234ms 195 bytes (pipelined: 25)
    Sep 13, 2017 17:03:45.346 [0x7f1648d11700] DEBUG - handleStreamWrite code 32: Broken pipe
    Sep 13, 2017 17:03:45.346 [0x7f1648d11700] DEBUG - NotificationStream: Removing because of error
    Sep 13, 2017 17:04:01.984 [0x7f16497ff700] DEBUG - EPG[xmltv]: Next thing to start/end is at 2017-09-13 15:05:00 (in 60 seconds)
    

    Plex for iOS logs - logfile matching the PMS logs:

    Sep 13, 2017 17:03:12 [0x16e75f000] INFO - Plex Media Server v0.9.12.9.1-d80948a -    - build: ios-arm64 macosx
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Opening 6 database sessions to library, SQLite 3.8.9, threadsafe=1
    Sep 13, 2017 17:03:12 [0x16e75f000] ERROR - Error setting multithreaded mode for SQLite3 (21)
    Sep 13, 2017 17:03:12 [0x16e75f000] ERROR - Error disabling memory status mode for SQLite3 (21)
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Running migrations.
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Listening on port 32400 with queue of 128 connections.
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Listening on port 32400 with queue of 128 connections.
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Started HTTP server successfully.
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Image transcode cache directory: /private/var/mobile/Containers/Data/Application/906A6EBB-9529-4164-A954-0789EA6352C4/Library/Caches/PlexMediaServer/PhotoTranscoder
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Starting HTTP server.
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Running server...
    Sep 13, 2017 17:03:12 [0x16e75f000] DEBUG - Waiting for server condition to be signaled.
    Sep 13, 2017 17:03:12 [0x16edef000] DEBUG - Set up a thread pool for HTTP server with 2 threads.
    Sep 13, 2017 17:03:12 [0x16ecd7000] ERROR - Couldn't accept new TLS connection: Operation canceled
    Sep 13, 2017 17:03:12 [0x16edef000] DEBUG - Running database fix-ups.
    Sep 13, 2017 17:03:12 [0x16edef000] DEBUG - Database Fixups: Destroyed 0 transient items.
    Sep 13, 2017 17:03:12 [0x16edef000] DEBUG - Running database fix-ups completed in 0.0 seconds.
    Sep 13, 2017 17:03:13 [0x16ee7b000] DEBUG - Request: [127.0.0.1:56356] GET /?X-Plex-Device-Name=iPhone%206 (1 live) GZIP
    Sep 13, 2017 17:03:13 [0x16ee7b000] ERROR - Translator: unable to enumerate message files.
    Sep 13, 2017 17:03:13 [0x16ee7b000] DEBUG - It took 0.0 sec to serialize a list with 5 elements.
    Sep 13, 2017 17:03:13 [0x16ed63000] DEBUG - Completed: [127.0.0.1:56356] GET / (1 live) GZIP 9ms 571 bytes 200
    

    Plex Media Server: QNAP TS-453 Pro (CPU Mark: 1864, Intel Celeron @ 1.99GHz Quad-Core, 8GB RAM, SSD, 2 x WD)
    Plex Media Clients: PlexWeb (app.plex.tv), Plex for LG, ChromeCast Ultra, iPhone 6, iPad Pro, Apple TV 4 and Sonos
    DVR Hardware: HDHomeRun EXPAND (HDHR3-4DC)
    Smart TV: LG UHD UH7500 (US) / UH750V (EU) (WebOS 3.0)

  • mm98mm98 Posts: 391Members, Plex Pass Plex Pass
    edited September 13

    Extra info (from com.plexapp.plex 2017-09-13 14-47.log):

    Picture was taken at 17:03:50 (filename: 2017-09-13 17.03.50.JPG)

    Plex for iOS was closed:
    2017/09/13 17:03:32.291 (58 MB) (5074797) I PMKAppDelegate.m:218 | Application will terminate

    no log lines between these two ....

    Plex for iOS was started again:
    2017/09/13 17:11:08.097 (31 MB) (5076510) I PMKRemoteConfigurationManager.m:97 | Starting asyncronous update of remote configuration…
    2017/09/13 17:11:08.266 (33 MB) (5076510) I PMKAppDelegate.m:91 | Application did finish launching with options: (null)

    Image was uploaded from the Plex for iOS app here:
    2017/09/13 17:11:19.100 (61 MB) (5076571) I PMKCameraUploadEngine.m:1779 | Created data transfer task to check for 2017-09-13 17.03.50.JPG

    I have the PMS and iOS debug logs if you need them?

    Plex Media Server: QNAP TS-453 Pro (CPU Mark: 1864, Intel Celeron @ 1.99GHz Quad-Core, 8GB RAM, SSD, 2 x WD)
    Plex Media Clients: PlexWeb (app.plex.tv), Plex for LG, ChromeCast Ultra, iPhone 6, iPad Pro, Apple TV 4 and Sonos
    DVR Hardware: HDHomeRun EXPAND (HDHR3-4DC)
    Smart TV: LG UHD UH7500 (US) / UH750V (EU) (WebOS 3.0)

«1
Sign In or Register to comment.