If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public ..

Xen0sysXen0sys Posts: 609Members, Plex Pass Plex Pass
edited June 2017 in Linux

plexmediaplayer.list contains: deb https://downloads.plex.tv/repo/deb/ public main but I get the below message every update.

Full message when running sudo apt-get update:

W: Conflicting distribution: https://downloads.plex.tv/repo/deb public InRelease (expected public but got )

I'm not sure if it's not working or not as my currently installed version matches the latest public release however this notice only recently cropped up for me.

Best Answer


  • Xen0sysXen0sys Posts: 609Members, Plex Pass Plex Pass

    @ziggimon said:
    Can you try and change the line to be: deb https://downloads.plex.tv/repo/deb ./public main and run sudo apt-get clean all and re-run sudo apt-get update

    That does the trick.

  • ziggimonziggimon AarhusPosts: 2,443Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks. I'll go address it in our support docs.

    Get you Plex guides here: Naming Guide, NAS Guide, NTFS on Linux Guide, Linux Permissions Guide, Logs & Library Maintenance Help, Plex Help Page.

    My Plex world:
    Primary PMS: NAS - 24 bay Inter-Tech 4324L, Xeon E3-1230v2, SuperMicro X9SCM-F, 800GB SSD, Enough Spinning Storage
    HTPC/EyeTV: Mid 2011 Mac Mini 4GB RAM 60GB Vertex SSD, 50" Kuro
    Clients: Hackintosh - i7 3770K, 27" CinemaDisplay, 15" rMBP, ATV4, Roku3, iPhone 6 64GB, iPhone 5 64GB, iPad 3 16GB, riPad mini 32GB, Intel NUC DN2820FYKH, Asus Chromebox, RPI2, RPi3
  • Bengt7jqbBengt7jqb Posts: 101Members ✭✭

    http://downloads.plex.tv/repo/deb/ worka better ! not https:

  • nekton1nekton1 Posts: 235Members, Plex Pass Plex Pass

    I am getting this with get-apt update

    Failed to fetch https://downloads.plex.tv/repo/deb/dists/./public/InRelease Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

    Can you give an explanation for dummies about how to fix it please.

  • nekton1nekton1 Posts: 235Members, Plex Pass Plex Pass

    Don't worry — got it fixed in the end after some reading. But still cannot get 1.7.x.x to update to It's as though the update package is not in the repo.

  • nekton1nekton1 Posts: 235Members, Plex Pass Plex Pass

    Waiting for uglymagoo to update the packages in his respository

  • evanrichevanrich Posts: 69Members, Plex Pass Plex Pass

    Just came across this after salting my box.

    root@plexmediaserver:/etc/apt/sources.list.d# apt-get update
    Hit:1 http://downloads.plex.tv/repo/deb public InRelease
    Hit:2 http://linux.dell.com/repo/community/openmanage/910/xenial xenial InRelease
    Hit:3 http://us.archive.ubuntu.com/ubuntu bionic InRelease
    Hit:4 https://repos.influxdata.com/ubuntu bionic InRelease
    Hit:5 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
    Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
    Hit:7 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
    Reading package lists... Done
    W: Conflicting distribution: http://downloads.plex.tv/repo/deb public InRelease (expected public but got )
    root@plexmediaserver:/etc/apt/sources.list.d# cat plexmediaserver.list
    deb http://downloads.plex.tv/repo/deb/ public main

    I've tried http, https, with a trailing / or not, always get that message. I have been installing packages by hand, but after starting to automate things with Salt, I'd like to figure this out.

    I'm on 18.04 LTS:
    root@plexmediaserver:/etc/apt/sources.list.d# lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 18.04 LTS
    Release: 18.04
    Codename: bionic

    • HTPC: Nvidia Shield TV
    • Firewall/Router: Ubiquiti USG-3p
    • Core Switches: US-48-500W POE & US-24
    • AP: Ubiquiti AP-AC-PRO + IW-AP-AC
    • NAS: Supermicro X10SDV-2C-7TP4F / 48GB DDR4 / SC846 24-bay Chassis/12x 8TB WD Red RAID-Z2 / Avago 9207-8i HBA / Intel X520 10GbE / FreeNAS 11.1
    • Media Aggregation: Dell Poweredge R230 with docker containers.
    • Plex Media Server: Dell Poweredge R230 w/ E3-1225v5
  • ChuckPAChuckPA Posts: 22,285Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited May 17

    Please create a new thread. This thread was marked as closed (the green at top)

    The correct codename is public (repo corrected)
    Branch main

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips


    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

This discussion has been closed.