If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Chromecast playback is stuttering and buffering all the time for 5mbps and above

olliepopsicleolliepopsicle Posts: 5Validating, Plex Pass Plex Pass
edited July 23 in Google Chromecast

Chromecast seems to be stuttering while trying to watch a movie at 5mbps. I tested out on my Roku TV and it's fine, so it seems to be isolated to Chromecast. Playing a video on Chromecast whose bit rate is about 3mbps was fine as well.

It is playing via Direct play with issues, and when I try to set the quality to 720p, 2mbps it still has similar issues.

Server: Plex Cloud
App Version: Chromecast 2.0, not sure how to find the app version...

I am still trying to evaluate if Plex Cloud is worth the price. Any help or direction is appreciated. Thanks!

Answers

  • richarddc79richarddc79 Posts: 194Members, Plex Pass Plex Pass

    @olliepopsicle said:
    Chromecast seems to be stuttering while trying to watch a movie at 5mbps. I tested out on my Roku TV and it's fine, so it seems to be isolated to Chromecast. Playing a video on Chromecast whose bit rate is about 3mbps was fine as well.

    It is playing via Direct play with issues, and when I try to set the quality to 720p, 2mbps it still has similar issues.

    Server: Plex Cloud
    App Version: Chromecast 2.0, not sure how to find the app version...

    I am still trying to evaluate if Plex Cloud is worth the price. Any help or direction is appreciated. Thanks!

    I am getting really bad performance (stuttering and stopping from my Chromecasts, noticed last night that playing several 4-5mbps files which are all direct playabled on my gen 1 CC, it seems to take an age for all video to get started, and today I tried my gen 2 CC which I have connected to ethernet, same files cant even stutter and , even though I have in the last few months been able to get a 30mbps file to direct play.

    One thing I have noticed is that after a period of time both Chromecasts would reboot.

    HP Laptop core i5 (Plex Server hardware transcoding)
    Lenovo M58p Core 2 Duo Windows 10 (secondary Plex Server + NAS - 4TB Movies + TV shows)
    Xbox One S
    Fire TV stick gen 2
    Fire TV stick gen 1
    Chromecast gen 2 wired ethernet x 1
    Chromecast gen 1 x 2
    iPhone 6
    iPhone 7
    iPad Mini
    iPod touch
    Fire kids tablet

  • lucidnonsenselucidnonsense Posts: 6Members, Plex Pass Plex Pass
    edited July 25

    I too am experiencing stuttering, flashes, and dropped frames. The logs show nothing. It is only on some files (Not sure what distinguishes them) but DirectPlay seems affected.
    This is only on chromecast

    Plex server (windows 10 - 1.7.6.4058)
    chromecast 2

  • Jefferson CavessanaJefferson Cavessana Posts: 8Members ✭✭

    Some movies I'm playing on chromecast 2.0 are having flashes on the screen, and the movie cover appears all the time. This does not happen with just a few movies. I tested on the LG smartv app and the problem does not happen. I would like help

  • DemoV3DemoV3 Posts: 13Members, Plex Pass Plex Pass

    I to am having this issue. Started in the last few weeks and only affects chromecast. Android app is great, windows chrome tab is fine, xbox one and 360 are fine.
    And as said above it is hit or miss on when it does it but I have a few movies that will do it, not sure what in them causes it. Different file types(mp4 and mkv), diferent resolutions(720 to 4k), different raw size(1.5 to 4gb so far).
    plex version 1.7.5.4035
    Chromecast version 1.25.90308
    Server is local on network
    Wireless AP less than 10 foot from chromecast

    All other streaming to chromecast works prefect, youtube anyway...

  • tmalinentmalinen Posts: 12Members, Plex Pass Plex Pass
    edited July 30

    It's a bug in Chromecast firmware. It'll be fixed in the next Chromecast update. Nobody knows when it's going to be released.

  • olliepopsicleolliepopsicle Posts: 5Validating, Plex Pass Plex Pass

    @Jefferson Cavessana said:
    Some movies I'm playing on chromecast 2.0 are having flashes on the screen, and the movie cover appears all the time. This does not happen with just a few movies. I tested on the LG smartv app and the problem does not happen. I would like help

    Exact same thing is happening to me.

    On a related note, I am seeing a similar issue with the same videos on the web app version. Mac OSX Yosemite 10.10.5 and Chrome version 59.0.3071.115

  • asjmcguireplexasjmcguireplex Posts: 24Members, Plex Pass Plex Pass

    @olliepopsicle said:

    @Jefferson Cavessana said:
    Some movies I'm playing on chromecast 2.0 are having flashes on the screen, and the movie cover appears all the time. This does not happen with just a few movies. I tested on the LG smartv app and the problem does not happen. I would like help

    Exact same thing is happening to me.

    On a related note, I am seeing a similar issue with the same videos on the web app version. Mac OSX Yosemite 10.10.5 and Chrome version 59.0.3071.115

    The bug is actually in Chromium, which means it affects everything that uses the Chromium source - which includes Chrome and Chromecast. The movies affected - are any movie with more than one soundtrack - with an AAC track as the first track - and changing to any other track stops the bug from happening.

  • SacalmMSacalmM Posts: 6Members Plex Pass
    edited August 8

    Any solution? Same problems here :(

    I find a "solution". Edit your .mkv files and delete the second AC3 audio. Works fine now :)

    PD: sorry for my bad english

  • g4ngst3rg4ngst3r Posts: 1Members, Plex Pass

    I have the same problem, playing with direct play the videos i'm playing on chromecast 2.0 are having flashes on the screen, and the movie cover appears all the time.

    I have ChromeCast 2 fw version: 1.26.92486
    Plex Server Windows: 1.8.0.4109

    The fails are only with Direct play or stream. If the movies make transcoding no show problems.

    Anyone knows anythink to fix it?

  • CpNCpN Posts: 31Members, Plex Pass Plex Pass

    PMS: v.1.8.0.4109> @g4ngst3r said:

    I have the same problem, playing with direct play the videos i'm playing on chromecast 2.0 are having flashes on the screen, and the movie cover appears all the time.

    I have ChromeCast 2 fw version: 1.26.92486
    Plex Server Windows: 1.8.0.4109

    The fails are only with Direct play or stream. If the movies make transcoding no show problems.

    Anyone knows anythink to fix it?

    Exact same problem as @g4ngst3r
    Also, I only have issues if the streams are over 12mbps, then they lag and stutter.

    Chromecast 2. v.1.25.90308
    PMS: 1.8.0.4109

  • _sSs__sSs_ Posts: 7Members ✭✭

    Found this thread, since I was having problem just recently.
    Thought it had to do with my connection to the CCv2, bought Ethernet adapter still got problems.
    Converted the sound to A3c instead of AAC,still got problems.
    So your saying its a problem with CCv2?

    Since my Plex Media Server is running on a preatty good computer:
    OS: Arch Linux x86_64
    Kernel: 4.11.9-1-ARCH
    RAM: 1032M / 7959M (12%)
    SWAP: 4M / 10239M (0%)
    CPU: AMD Phenom(tm) II X6 1055T Processor

    I thought that the server would be able to handle the conversation of the sound. I haven't checked the logs to verify but I hope so.
    Looks like I have the PMS 1.7.5.4035 and CCv2 1.25.90308.

    The best leader is the one that do not want to be leader!

Sign In or Register to comment.