Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Hulu

wombatiwombati Posts: 5Members
I just did a clean Plex 9.2.7 install. Everything except the Hulu plug-in is working. But Hulu does not work at all; I can not search, or look at any listings. Whenever I click on one of the menus nothing happens.
I looked into the logs and it seems the media server makes a request, but still nothing shows up in Plex:

Any ideas?

Thanks in advance,

Tom

Plex.log:
23:11:10 T:2691679552 M:798048256 ERROR: CGUIMediaWindow::GetDirectory(http://127.0.0.1:32400/video/hulu/:/function/feeds?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoyCnM1NgpodHRwOi8vcnNzLmh1bHUuY29tL0h1bHVQb3B1bGFyVmlkZW9zVGhpc1dlZWs@Zm9ybWF0PXhtbHM3CmZlZWRVcmxyMgpzNgpzZW5kZXI1CnMyNApQb3B1bGFyIFZpZGVvcyBUaGlzIFdlZWtzOQppdGVtVGl0bGVzNApIdWx1czYKdGl0bGUxczQKTm9uZXM2CnRpdGxlMnMzOQovdmlkZW8vaHVsdS86L3Jlc291cmNlcy9hcnQtZGVmYXVsdC5qcGdzMwphcnRzNDAKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvaWNvbi1kZWZhdWx0LnBuZ3M1CnRodW1icjEKcjAK/) failed
23:11:10 T:2691679552 M:798048256 DEBUG: CGUIMediaWindow::GetDirectory (http://127.0.0.1:32400/video/hulu/:/function/menupopular?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoxCnIyCnM2CnNlbmRlcjUKczE0ClBvcHVsYXIgVmlkZW9zczkKaXRlbVRpdGxlczQKSHVsdXM2CnRpdGxlMXM0Ck5vbmVzNgp0aXRsZTJzMzkKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvYXJ0LWRlZmF1bHQuanBnczMKYXJ0czQwCi92aWRlby9odWx1LzovcmVzb3VyY2VzL2ljb24tZGVmYXVsdC5wbmdzNQp0aHVtYnIxCnIwCg__/)
23:11:10 T:2691679552 M:798048256 DEBUG: ParentPath = [http://127.0.0.1:32400/video/hulu/]

Plex Media Server Log:
Jul 10, 2011 23:11:10 [0xb0c3a000] DEBUG - Plug-in com.plexapp.plugins.hulu has been used 22 times.
Jul 10, 2011 23:11:10 [0xb0c3a000] DEBUG - [com.plexapp.plugins.hulu] Sending command over HTTP (GET): /video/hulu/:/function/feeds?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoyCnM1NgpodHRwOi8vcnNzLmh1bHUuY29tL0h1bHVQb3B1bGFyVmlkZW9zVGhpc1dlZWs%40Zm9ybWF0PXhtbHM3CmZlZWRVcmxyMgpzNgpzZW5kZXI1CnMyNApQb3B1bGFyIFZpZGVvcyBUaGlzIFdlZWtzOQppdGVtVGl0bGVzNApIdWx1czYKdGl0bGUxczQKTm9uZXM2CnRpdGxlMnMzOQovdmlkZW8vaHVsdS86L3Jlc291cmNlcy9hcnQtZGVmYXVsdC5qcGdzMwphcnRzNDAKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvaWNvbi1kZWZhdWx0LnBuZ3M1CnRodW1icjEKcjAK
Jul 10, 2011 23:11:10 [0xb0c3a000] WARN - Error issuing request to: http://127.0.0.1:50987/video/hulu/:/function/feeds?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoyCnM1NgpodHRwOi8vcnNzLmh1bHUuY29tL0h1bHVQb3B1bGFyVmlkZW9zVGhpc1dlZWs@Zm9ybWF0PXhtbHM3CmZlZWRVcmxyMgpzNgpzZW5kZXI1CnMyNApQb3B1bGFyIFZpZGVvcyBUaGlzIFdlZWtzOQppdGVtVGl0bGVzNApIdWx1czYKdGl0bGUxczQKTm9uZXM2CnRpdGxlMnMzOQovdmlkZW8vaHVsdS86L3Jlc291cmNlcy9hcnQtZGVmYXVsdC5qcGdzMwphcnRzNDAKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvaWNvbi1kZWZhdWx0LnBuZ3M1CnRodW1icjEKcjAK (22)
Jul 10, 2011 23:11:10 [0xb0c3a000] DEBUG - [com.plexapp.plugins.hulu] HTTP reply status 404, with 0 bytes of content.
Jul 10, 2011 23:11:10 [0xb0c3a000] DEBUG - [com.plexapp.plugins.hulu] Completed command GET /video/hulu/:/function/feeds?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoyCnM1NgpodHRwOi8vcnNzLmh1bHUuY29tL0h1bHVQb3B1bGFyVmlkZW9zVGhpc1dlZWs%40Zm9ybWF0PXhtbHM3CmZlZWRVcmxyMgpzNgpzZW5kZXI1CnMyNApQb3B1bGFyIFZpZGVvcyBUaGlzIFdlZWtzOQppdGVtVGl0bGVzNApIdWx1czYKdGl0bGUxczQKTm9uZXM2CnRpdGxlMnMzOQovdmlkZW8vaHVsdS86L3Jlc291cmNlcy9hcnQtZGVmYXVsdC5qcGdzMwphcnRzNDAKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvaWNvbi1kZWZhdWx0LnBuZ3M1CnRodW1icjEKcjAK in 0.000814 seconds.
«13

Comments

  • rreims1rreims1 Posts: 20Members, Plex Pass Plex Pass
    Having the same problem...started a few days ago. Other plug-ins work just fine.
  • zgresszgress Posts: 1Members
    +1 ! :huh:
  • pierre1313pierre1313 Posts: 580Members
    Something seems to have changed on the Hulu.com side. I will take a look and correct the plugin as soon as possible.
  • pierre1313pierre1313 Posts: 580Members
    I have found a fix and pushed the updated plugin for approval before it gets rolled out to the Plex Online. Should be available shortly. thanks for the report
  • wombatiwombati Posts: 5Members
    Thanks a lot!

    Tom
  • BrettBBrettB Posts: 24Members
    Any update on this?

    I just moved back to Plex after a long Boxee hiatus, and would love to quit using Boxee and Hulu Desktop. :)
  • pierre1313pierre1313 Posts: 580Members
    it should be all up to date in Plex online. If something still does not work, please let me know
  • justmeeejustmeee Posts: 149Members
    Pierre wrote:

    it should be all up to date in Plex online. If something still does not work, please let me know


    Pierre, one thing I've noticed about the Hulu plugin is that is doesn't seem to want to play any Hulu + content. I'm a Hulu + subscriber and I've tried everything .... logging into Hulu from safari first and double checking everything. It plays normal content just fine, but if I try to play something say from the Criterion Collection (which is only + material), it just bounces right back to the menu and doesn't even try to stream. It's like it doesn't recognize it at all.

    Am I missing something or is there anything that can be done about this??
  • BrettBBrettB Posts: 24Members
    Pierre wrote:

    it should be all up to date in Plex online. If something still does not work, please let me know

    Looks like I am having problems with the My Hulu section. I checked and double check my Hulu username and password with Hulu.com, and I verfied I put it in correct.

    Any recommendations on how to resolve this? Thanks a bunch Pierre!
  • BrettBBrettB Posts: 24Members
    BrettB wrote:

    Looks like I am having problems with the My Hulu section. I checked and double check my Hulu username and password with Hulu.com, and I verfied I put it in correct.

    Any recommendations on how to resolve this? Thanks a bunch Pierre!


    I take that back. I am also not getting any video, just audio

    I select an episode, and get the "Starting Stream" pop-up, the audio starts, but I never have a transition to a video window.

    Thanks,
    Brett
  • shavenyakshavenyak Posts: 121Members
    I get "This section contains no video" for everything I try to watch.
  • stineystiney Posts: 21Members
    I also am getting Audio, but no video. The audio starts but the screen still has Plex's plug-in screen up. This is only happening on my Mac Mini which has plex 9.2.7 on OS 10.6.8 with the latest flash. My MacBook pro plays hulu fine with Mac OS 10.6.8, Plex 9.2.7 and flash 10.1.102. I have tried to put flash 10.1.102 on my mac mini, but I have the same issue. I am really confused as to whats going wrong on the mini.

    Thanks,
    Stiney
  • gvegastigergvegastiger Posts: 14Members
    I have the same problem with my iMac running 9.3.4 and OS 10.6.8. I get the initial audio and then nothing. No video. I was really excited that there was a Hulu plugin but now I'm not.
  • racecarrracecarr Posts: 4Members, Plex Pass
    I had the exact same problem with 9.3.4 and 10.6.8 - audio but no video. My HD crashed so I had to reinstall everything from scratch - OS X, iTunes, Plex, Flash, Perian, and VLC.
    Now the HULU plug-in just stalls at beginning to play the video and doesn't even play any audio. Gets stuck at window, watch the episode now.
    Hulu must have it out for Plex!

    Aug 04, 2011 21:13:24 [0xb0ad1000] DEBUG - [com.plexapp.plugins.hulu] HTTP reply status 200, with 852 bytes of content.
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - Request: GET /video/:/webkit?url=http%3A%2F%2Fwww.hulu.com%2Fwatch%2F255140%2Fburn-notice-bloodlines&prefix=/video/hulu [127.0.0.1] (1 live)
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - * url => http://www.hulu.com/watch/255140/burn-notice-bloodlines
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - * prefix => /video/hulu
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - WebKit: [http://www.hulu.com/watch/255140/burn-notice-bloodlines]
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - Found corresponding plug-in: /Users/server/Library/Application Support/Plex Media Server/Plug-in Support/Data/com.plexapp.plugins.hulu
    Aug 04, 2011 21:13:30 [0xb0ad1000] DEBUG - Using /Users/server/Library/Application Support/Plex Media Server/Plug-ins/Hulu.bundle/Contents/Site Configurations/hulu.xml with score of 19.
    Aug 04, 2011 21:13:30 [0xa0bd8540] DEBUG - Received title [Hulu - Burn Notice: Bloodlines - Watch the full episode now.].
    Aug 04, 2011 21:13:35 [0xa0bd8540] DEBUG - 0x319c550 Plugin loaded [http://www.hulu.com/site-player/109073/player102wrapper.swf] (0 214 1009 405 player)
    Aug 04, 2011 21:13:35 [0xa0bd8540] DEBUG - 0x33728d0 Plugin loaded [http://www.hulu.com/copyembedcode.swf] (151 938 120 20 copyembedcode)
    Aug 04, 2011 21:13:35 [0xa0bd8540] DEBUG - 0xe333230 Plugin loaded [http://www.hulu.com/vc.swf] (-1000 -1000 1 1 vcs)
    Aug 04, 2011 21:13:35 [0xa0bd8540] DEBUG - 0xe3c0870 Plugin loaded [http://www.hulu.com/guid.swf?v2] (504 4329 1 1 pguid)
    Aug 04, 2011 21:13:37 [0xa0bd8540] DEBUG - 0x1181efc0 Plugin loaded [http://www.hulu.com/cram.swf] (-100 -100 1 1 _cram_swf)
    Aug 04, 2011 21:13:43 [0xa0bd8540] DEBUG - 0x16e1b8d0 Plugin loaded [http://www.hulu.com/site-player/109073/banner.swf] (661 99 300 100 banner_c)
    Aug 04, 2011 21:14:00 [0xa0bd8540] DEBUG - 0x16e1b8d0 Plugin loaded [http://www.hulu.com/site-player/109073/banner.swf] (661 99 300 100 banner_c)
  • Brandon JonesBrandon Jones Posts: 40Members, Plex Pass Plex Pass
    I either get stuck on "Opening" (which cannot be canceled) or Plex outright crashes. This is on a brand-new mini running Lion, latest Flash, no other apps, with Hulu working fine in Safari. Not going through My Queue, just one of the shows in Most Popular.

    Plugin Log (the block below then goes on to repeat, indicating that it is requesting other shows that I haven't clicked on):

    2011-08-09 22:41:06,602 (-4f557000) :  DEBUG (networking:96) - Requesting http://www.hulu.com/api/oembed.json?url=http://www.hulu.com/watch/266520/the-colbert-report-mon-aug-8-2011
    2011-08-09 22:41:06,615 (-4f453000) :  CRITICAL (runtime:237) - Exception in task thread (most recent call last):
      File "/Users/bunny/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/Framework/components/runtime.py", line 235, in _start
        obj._exec()
      File "/Users/bunny/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/Framework/components/runtime.py", line 186, in _exec
        self._result = self._f(*self._args, **self._kwargs)
      File "/Users/bunny/Library/Application Support/Plex Media Server/Plug-ins/Hulu.bundle/Contents/Code/__init__.py", line 380, in Metadata
        titleFromFeed = titleFromFeed[0] + '-' + titleFromFeed[2]
      File "/Users/bunny/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resources/Versions/2/Python/Framework/bases.py", line 162, in <lambda>
        _getitem_ = lambda x, y: x.__getitem__(y),
    IndexError: list index out of range
    


    Server:

    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG - Request: GET /video/:/webkit?url=http%3A%2F%2Fwww.hulu.com%2Fwatch%2F266520%2Fthe-colbert-report-mon-aug-8-2011&prefix=/video/hulu [127.0.0.1] (1 live)
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG -  * url => http://www.hulu.com/watch/266520/the-colbert-report-mon-aug-8-2011
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG -  * prefix => /video/hulu
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG - WebKit: [http://www.hulu.com/watch/266520/the-colbert-report-mon-aug-8-2011]
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG - Found corresponding plug-in: /Users/bunny/Library/Application Support/Plex Media Server/Plug-in Support/Data/com.plexapp.plugins.hulu
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG - Resetting to state wait-for-frame-load
    Aug 09, 2011 22:41:13 [0xb0c2f000] DEBUG - Using /Users/bunny/Library/Application Support/Plex Media Server/Plug-ins/Hulu.bundle/Contents/Site Configurations/hulu.xml with score of 19.
    Aug 09, 2011 22:41:13 [0xb079d000] DEBUG - LINE: HELLO
    Aug 09, 2011 22:41:13 [0xac0db2c0] DEBUG - Received title [Hulu - The Colbert Report: Mon, Aug 8, 2011 - Watch the full episode now.].
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Executing Pausing 30ms
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Stopping execution, waiting for 2
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Got frame loaded, was waiting for something else.
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Timer Expired.
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Executing Moving to state check-for-auth
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Executing Performing plug-in lock
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Executing Moving to state playing
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Sending 4 plug-ins.
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - 0x9187db0 Plugin loaded [http://www.hulu.com/vc.swf] (-1000 -1000 1 1 vcs)
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - 0x9263ba0 Plugin loaded [http://www.hulu.com/copyembedcode.swf] (159 896 120 20 copyembedcode)
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - 0x93896f0 Plugin loaded [http://www.hulu.com/site-player/109410/player102wrapper.swf] (0 214 1024 405 player)
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - 0x939b690 Plugin loaded [http://www.hulu.com/guid.swf?v2] (511 3737 1 1 pguid)
    Aug 09, 2011 22:41:14 [0xac0db2c0] DEBUG - Initializing shared memory 700 x 400
    Aug 09, 2011 22:41:17 [0xac0db2c0] DEBUG - 0x35e7bb0 Plugin loaded [http://www.hulu.com/cram.swf] (-100 -100 1 1 _cram_swf)
    Aug 09, 2011 22:41:17 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Received title [Like].
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Received title [XD Proxy].
    Aug 09, 2011 22:41:18 [0xac0db2c0] DEBUG - Frame was loaded.
    Aug 09, 2011 22:41:19 [0xb0c2f000] DEBUG - Stream closed.
    Aug 09, 2011 22:41:20 [0xb13cd000] DEBUG - Server disconnected: bunny
    Aug 09, 2011 22:41:20 [0xb13cd000] DEBUG - Updating TXT record (success=Yes)
    


    Client:

    22:41:04 T:2886578880 M:2480840704  NOTICE: PlexDirectory::GetDirectory(http://127.0.0.1:32400/video/hulu/:/function/menupopular?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoxCnIyCnM2CnNlbmRlcjUKczE0ClBvcHVsYXIgVmlkZW9zczkKaXRlbVRpdGxlczQKSHVsdXM2CnRpdGxlMXM0Ck5vbmVzNgp0aXRsZTJzMzkKL3ZpZGVvL2h1bHUvOi9yZXNvdXJjZXMvYXJ0LWRlZmF1bHQuanBnczMKYXJ0czQwCi92aWRlby9odWx1LzovcmVzb3VyY2VzL2ljb24tZGVmYXVsdC5wbmdzNQp0aHVtYnIxCnIwCg__)
    22:41:05 T:2886578880 M:2479833088  NOTICE: PlexDirectory::GetDirectory(http://127.0.0.1:32400/video/hulu/:/function/feeds?function_args=Y2VyZWFsMQozCmRpY3QKZGljdApGcmFtZXdvcmsub2JqZWN0cy5JdGVtSW5mb1JlY29yZAoyCnM1MwpodHRwOi8vcnNzLmh1bHUuY29tL0h1bHVQb3B1bGFyVmlkZW9zVG9kYXk@Zm9ybWF0PXhtbHM3CmZlZWRVcmxyMgpzNgpzZW5kZXI1CnMyMApQb3B1bGFyIFZpZGVvcyBUb2RheXM5Cml0ZW1UaXRsZXM0Ckh1bHVzNgp0aXRsZTFzNApOb25lczYKdGl0bGUyczM5Ci92aWRlby9odWx1LzovcmVzb3VyY2VzL2FydC1kZWZhdWx0LmpwZ3MzCmFydHM0MAovdmlkZW8vaHVsdS86L3Jlc291cmNlcy9pY29uLWRlZmF1bHQucG5nczUKdGh1bWJyMQpyMAo_)
    


    Pierre, is this helpful at all? I am happy to help in any way possible. Thanks for all your hard work!
  • unblowupable5unblowupable5 Posts: 378Members, Plex Pass Plex Pass
    I am having the same issue with getting the opening stream dialog box, and I hear audio but the video never starts.

    Thanks
  • soetartsoetart Posts: 59Members ✭✭
    Add me to the list of those having problems with Hulu. Seeing the same symptoms as unblowupable, audio plays but no video. The episode menu and opening stream window are displayed while the audio is playing.

    Bill
  • hrcolb0hrcolb0 Posts: 1,239Members ✭✭
    +1 for audio and no video
  • RastrilloRastrillo Posts: 42Members, Plex Pass Plex Pass
    Same problem here. Audio with no video. Latest Lion, Plex and Flash installed.
  • HarryO53HarryO53 Posts: 318Members ✭✭
    I am getting a total lock up with the Hulu plugin at this point. I've tried several different things, but in 10.7, I have no luck.
«13
Sign In or Register to comment.