Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Metadata Agents on a ReadyNAS

ExplosiveExplosive Posts: 27Members, Plex Pass Plex Pass
I was wondering if someone could help me with the following question.

Last week I bought a ReadyNAS Ultra 4 and over the weekend I migrated my Plex library from my Mac mini to the NAS (running the Plex Server).
On my Mac mini I had some nice (Dutch) agents installed, like 'Moviemeter' and 'Bierdopje'.

Now my question:

Is it possible to install these agents on my new server, running on the ReadyNAS?
If so, how can it be done?

Comments

  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    edited July 2011
    You can grab the .bundle files from here https://github.com/plexinc-agents then drop them into the Plug-ins folder on the ReadyNAS. Here's a post that tells you how to access the .plex directory on the ReadyNAS...

    Be aware that there are some limitations around LinuxPMS plug-ins. Flash based plug-ins don't work - there may be other issues I'm unaware of too.

    James
  • ExplosiveExplosive Posts: 27Members, Plex Pass Plex Pass
    Thanks for your quick reply James.

    I will try it as soon as I get home tonight!
  • kebarvidkebarvid Posts: 11Members
    Tried to add a metadata agent this way but it doesn't work. no sign in the logs about the agent.

    works good on my Mac, why is it not working on the readynas?
  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 2011
    Arvid S wrote:

    Tried to add a metadata agent this way but it doesn't work. no sign in the logs about the agent.

    works good on my Mac, why is it not working on the readynas?

    Which plug-in did you add? Did you re-start the PMS service from Frontview > Addons?

    Realise that Plug-ins need to be installed locally on a Plex for Mac client. Add them to the PMS if you're using iOS/Android.

    James
  • kebarvidkebarvid Posts: 11Members
    boots2x wrote:

    Which plug-in did you add? Did you re-start the PMS service from Frontview > Addons?

    Realise that Plug-ins need to be installed locally on a Plex for Mac client. Add them to the PMS if you're using iOS/Android.

    James


    It was a metadata agent i've created myself.

    yes i did restart the server from frontview -> addons
  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 2011
    Arvid S wrote:

    It was a metadata agent i've created myself.

    yes i did restart the server from frontview -> addons

    Have you confirmed it's operation with a MacOS/Windows PMS? If you can, do that. If it's confirmed working, could I get access to the Agent to check it out?

    James
  • kebarvidkebarvid Posts: 11Members
    boots2x wrote:

    Have you confirmed it's operation with a MacOS/Windows PMS? If you can, do that. If it's confirmed working, could I get access to the Agent to check it out?

    James


    Yes, i've tried it on two different MacOS PMS servers, working great on both.

    you can download the bundle on http://www.arvid.nu/Filmtipset.bundle.zip

    I've also tried installing the Moviepilot bundle on the readynas but didn't get it to work either. No mention of it in the log files.
  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 2011
    Hmm... worked for me without any special stuff... I didn't have time to set it scanning though. Did you get this far? If you did, can you please give me a sample show filename to test with?

    James
  • kebarvidkebarvid Posts: 11Members
    Nope didn't get that far.

    I can't get the bundle to get picked up by the system. i put it in /c/.plex/Resources/Plug-Ins/ where the other plugins are located. Restart plex from frontview but i get no mention of it in the log files and i can't see it on the web interface.


    boots2x wrote:

    Hmm... worked for me without any special stuff... I didn't have time to set it scanning though. Did you get this far? If you did, can you please give me a sample show filename to test with?

    James
  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 2011
    Ah! The correct location is:

    /.plex/Library/Application Support/Plex Media Server/Plug-ins

    I think that'll have you going!

    James
  • kebarvidkebarvid Posts: 11Members
    boots2x wrote:

    Ah! The correct location is:

    /.plex/Library/Application Support/Plex Media Server/Plug-ins

    I think that'll have you going!

    James



    I knew there was something easy i missed. now it's working =)
Sign In or Register to comment.