Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Server gives a 404 error

dbordondbordon Posts: 3Members
edited July 2011 in Windows
Plex Server gives a 404 error
Hello all,

I have a strange issue with Plex running on my Windows 7 desktop (64-bit).
It was running fine for a week or two, but all of a sudden I can no longer access my media shares.
I was able to connect to it just fine using my LG TV or my laptop with XBMC on it.
Now the LG TV just pops up with "Not Found". If I hit the green button to rescan it sees the Server "Daggett", but when I select it, "Not Found" comes up again.
When I try through XBMC it connects to "Daggett", but then returns a 404 error.
I've tried restarting Plex, restarting the machine, and even uninstalling Plex and Bonjour and all those bits and re-installing.
After re-installing I noticed that it still knew my libraries and media, so I'm guessing there were files left behind. I thought re-installing would have filled in the gaps and got me going again.
I haven't done anything unusual with it in the last few days. I haven't added any plugins, or new media at all. I just wanted to watch some TV shows last night and now I can't!
I've also got my media drives shared through the SMB share, so I can still watch them on the laptop with VLC, but the LG TV can't see SMB shares.

Does anyone have any ideas on what could have happened and how I can fix this?




  • hippojayhippojay Posts: 958Members, Plex Pass Plex Pass
    Can't comment on the lg tv stuff, but there was an issue with the XBMC plugin that meant it didn't work correctly with windows PLex media server.

    Depending on how you installed the XBMC plugin, it *can* auto update, which might explain why it suddenly stopped working.

    However, Plex fixes this and should stop the 404 errors with the XBMC plugin. I recommend you upgrade to the latest version.
  • dbordondbordon Posts: 3Members
    I've had a look on the Plex site and the version that I am running ( seems to be the newest.
    I only installed XBMC and the Plex plug in for that about a week ago, so they aren't too old.

    The thing is, that the whole set up worked great for a week or so, then suddenly died, and I have no idea why. No set up changes, not even new content in the libraries.

    I've noticed another issue when I thought my libraries may be corrupt or something. If I try to add a new library for TV Shows or Movies I notice that there are no agents in the drop lists.
    I think I saw something about this in another thread and the recommendation was to delete all the libraries and plugins and stuff and let Plex rebuild them.
    Where does Plex store the library information? I'll just blow that away and rebuild it all and see if that helps.

    If this all works, I'll update this post so others can learn from this.
  • dbordondbordon Posts: 3Members
    There we go. All fixed.

    I just followed the instructions in this thread:

    I just renamed the Plugins and Cache folder to have the word Backup on the end and Plex fixed itself.

    Crisis averted. Thanks everyone!
Sign In or Register to comment.