Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Media Server Movie Scan skips every 16th folder?

dographydography Posts: 10Members, Plex Pass Plex Pass
I have the strangest problem when adding a lot of movie files at once through the Media Server scan.

My movies are all tagged in the following format (and I mean all, I'm pretty anal with this stuff)...

Adventures of Power (2009)
Adventures of Power (2009).avi
Adventures of Power (2009).jpg

...but when I run the scan on the new folder it skips every 16th film (so only adds the first 15 alphabetically, then misses one, then adds 17 to 31 and misses 32 etc).

As an example, I just added a folder with 95 movies and the movie count at the bottom of the media server was 5 less than expected. A Shift+Scan didn't work to find the additional films so, having located the films in question (bizarrely the 16th, 32nd, 48th, 64th and 80th alphabetically), I removed them from the folder before re-scanning. The Trash icon then turned black to indicate films were missing so I clicked it to get rid of them. The movie count didn't go down, implying that although the films hadn't registered in the movie window or the count, they were somehow recognised.

Adding these 5 films back to the folder and re-scanning worked fine, updating the count and displaying the films in the window, but it has me completely perPLEXed (sorry).

I'm using Lion and Plex but had the same issue using Snow Leopard and the version of Plex prior to so it's definitely not that. I expect you're going to ask me for some kind of log but it's taken me so long to get the library reflecting my entire collection, I'm reluctant to remove any films to try again.

Has anyone else had the same problem, seems pretty specific, just thought I'd highlight it in case it was a simple fix.

Anyway...love Plex, no idea how you guys keep this project going for free but I'm taking full advantage and appreciate all the effort that's gone into crafting such a beautiful piece of software.


  • elanelan Sheriff of Plexville MauiPosts: 9,176Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited July 2011
    Wow, that is very odd, but I think I know what is going on, based on this code:

    #define MAX_BATCH_SIZE 15

    I think that the movies are all being added, but it's not displaying them on the first scan. I believe that if you switch away to another section and then back, all the movies will be displayed.

    Feel free to prove me wrong :)

    (And thanks for the kind words!)
  • dographydography Posts: 10Members, Plex Pass Plex Pass
    Thanks for the quick response!

    That must be it, but isn't that a strange piece of code to include given that most people (when scanning for the first time at least, maybe even several times if they split their movies in categories like myself) will more than likely be adding folders with over 15 movies at a time? It took me a while to figure out what was happening but until I did I was sure I must be doing something wrong, I just couldn't work out what.

    Before I managed to figure it out and solve by following the process outlined in my previous post, I'd tried everything I could to get the movies to show up with no luck...Switching to my TV section and back, running a refresh, a deep scan, a full scan, quitting Media Server and relaunching, restarting my Mac etc but to no avail.

    I'm not too fussed since now I've added my full library I wouldn't have thought I'll be adding more than a few at a time in future, even if I do I can keep a look out for this anomaly. It does, however, discourage me from having the auto update feature enabled as I'm worried a film won't be captured and will be lost forever so instead I refresh manually each time I add a film to check it's picked up.

    For a first time user I imagine it would be very frustrating, possibly encouraging them (like it did initially for me, but not for very long at all) to try XBMC or similar, I just don't want people to be put off in the first time they try it. In fact, I'm surprised no-one else has encountered the same problem.

    Thanks again anyway.
  • elanelan Sheriff of Plexville MauiPosts: 9,176Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    It'll be fixed in the next version for sure; I should have explained more what the fragment of code meant. When the scanner runs, it finds new media and "batches" it (collects it) to notify the media server about in one fell swoop. Due to this silly bug, the 16th item caused the batch to be sent with only 15.

    I'm nearly 100% sure that the "missing" media would show up if you switched back and forth to the new section, but you're indicating that you tried that, so I will verify this morning as I fix the actual bug.

    Thanks again, and welcome to the forums :)
  • dographydography Posts: 10Members, Plex Pass Plex Pass
    Good to hear.

    The fact that I've been using Plex for almost a year and this is the first issue I've had is testament to it's brilliance. Together with the ATV2 port, it makes my pants wet.

    I thank you sir!
  • bytesailrbytesailr Posts: 14Members
    Too funny. I saw this today too. Thanks for posting this and thanks for the clear replies Elan! I was dropping batches of movies in to be scanned in batches of 32 at a time. Every time I noticed that 2 movies out of 32 (or 1 in 16) were missing. It was driving me a little nuts as I saw them getting scanned at the bottom of the PMS just fine.

    I just tried what you suggested Elan, switching out to another section and then back again, and now I see them.

    Thanks again, and looking forward to the fix.

  • Chris CChris C Posts: 11,700Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    FYI, I'm virtually positive this has also been fixed in the current 0.9.5 preview release for the Plex Media Server.
Sign In or Register to comment.