If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 77k

Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass
edited August 28 in Linux

I have been getting errors with channel streams on clients not on the local network. It is an IPTV channel.

For example, I could have my android phone with latest Plex app on my local wifi network and stream a live channel feed just fine. Then I could shut off the wifi so it goes to mobile data aka remote client viewing and I keep getting this error. But it is only on channel live streaming, watching movies and shows work fine. I have tried changing the "Internet upload speed" to 0 or clearing the field on the "Server > Remote Access" page, I have tried checking and unchecking "Direct Play/Direct Stream" and other boxes on the "Web > Player" page. No dice. I have tried changing the remote stream qualities both on the "Server" and the actual clients to "Original" and still didn't fix it.

Any help is appreciated.

Plex Media Server log attached.

Few lines from log:

Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: analyzing media item -1
Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: Box Nation: Direct Play is disabled
Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: Box Nation: no direct play video profile exists for hls/mpegts/h264
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: no direct play video profile exists for hls/mpegts/h264/aac
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: Direct Streaming is disabled, so video stream will be transcoded
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: no remuxable profile found, so video stream will be transcoded
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Clipped max bitrate to 0Kbps based on client-requested limit
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: Audio Direct Streaming is disabled, so video's audio stream will be transcoded
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: selected media 0 / -1
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Streaming Resource: Could not fit playback within bandwidth limit of 200000kbps
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] ERROR - get - invalid ratingKey value: http://my-iptv-provider.site:8000/box-nation/index.m3u8
Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Streaming Resource: Reached Decision id=-1 codes=(MDE=3001,Cannot direct play this item. Required bandwidth is not known and only kbps is available. General=2000,Neither direct play nor conversion is available. Direct Play=3000,App cannot direct play this item. No direct play video profile exists for protocol hls, with container mpegts, and video codec h264. Transcode=4004,Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 77kbps.)

Best Answer

«13

Answers

  • kjetilhansenkjetilhansen Posts: 6Members, Plex Pass Plex Pass

    I have the same problem! I have two different providers, sometime it works, but most of the times it don't work.. I have done what most people said, to set the internet streaming to original (I've also tried to set it to the lowest setting)

    This must be a bug in plex?

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @Kryptonit3 said:
    I have been getting errors with channel streams on clients not on the local network. It is an IPTV channel.

    For example, I could have my android phone with latest Plex app on my local wifi network and stream a live channel feed just fine. Then I could shut off the wifi so it goes to mobile data aka remote client viewing and I keep getting this error. But it is only on channel live streaming, watching movies and shows work fine. I have tried changing the "Internet upload speed" to 0 or clearing the field on the "Server > Remote Access" page, I have tried checking and unchecking "Direct Play/Direct Stream" and other boxes on the "Web > Player" page. No dice. I have tried changing the remote stream qualities both on the "Server" and the actual clients to "Original" and still didn't fix it.

    Any help is appreciated.

    Plex Media Server log attached.

    Few lines from log:

    Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: analyzing media item -1
    Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: Box Nation: Direct Play is disabled
    Aug 27, 2017 21:08:12.048 [0x7f75657ff700] DEBUG - MDE: Box Nation: no direct play video profile exists for hls/mpegts/h264
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: no direct play video profile exists for hls/mpegts/h264/aac
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: Direct Streaming is disabled, so video stream will be transcoded
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: no remuxable profile found, so video stream will be transcoded
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Clipped max bitrate to 0Kbps based on client-requested limit
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: Audio Direct Streaming is disabled, so video's audio stream will be transcoded
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - MDE: Box Nation: selected media 0 / -1
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Streaming Resource: Could not fit playback within bandwidth limit of 200000kbps
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] ERROR - get - invalid ratingKey value: http://my-iptv-provider.site:8000/box-nation/index.m3u8
    Aug 27, 2017 21:08:12.049 [0x7f75657ff700] DEBUG - Streaming Resource: Reached Decision id=-1 codes=(MDE=3001,Cannot direct play this item. Required bandwidth is not known and only kbps is available. General=2000,Neither direct play nor conversion is available. Direct Play=3000,App cannot direct play this item. No direct play video profile exists for protocol hls, with container mpegts, and video codec h264. Transcode=4004,Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 77kbps.)

    The attached log file is a continuation of an earlier log file and does not actually show the request coming in and what headers / options

    Could you include all the logs please. Also would like to see zip of the plugin logs - the standard zipped logs do not include logs from added 3rd party plugins/channels

    What was the plex client / version? If it was Plex Web, does the issue arise in both : hosted Plex Web (plex.tv/web) and bundled plex web (http://localhost:32400/web)

    Does the problem arise when using other plex clients ? eg Plex for iOS / Plex for Android

    And was the maximum upload bandwidth set to unlimited (zero value) at the time of this error?

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass
    edited September 1

    @sa2000 I attached two log groups. I tried streaming multiple items.

    Is posting these log zips a security risk?

    Server Version 1.8.1.4139

    The problem only happens when a client who is not on the local network tries to stream a live channel aka "remote client". The same clients that work inside my network without issue, fail when moved outside the network when they become "remote clients".

    I have set maximum upload to 0, null (delete field) and currently 2000 Mbps (I have gigabit connection at home) same issue.

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @Kryptonit3 said:
    Is posting these log zips a security risk?

    Only if you have enabled logging of security tokens

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited September 1

    @Kryptonit3 said:
    @sa2000 I attached two log groups. I tried streaming multiple items.

    Is posting these log zips a security risk?

    Server Version 1.8.1.4139

    The problem only happens when a client who is not on the local network tries to stream a live channel aka "remote client". The same clients that work inside my network without issue, fail when moved outside the network when they become "remote clients".

    I have set maximum upload to 0, null (delete field) and currently 2000 Mbps (I have gigabit connection at home) same issue.

    Will be looking at the logs tomorrow - late now.
    Could you tell me what this torula agent is and if it is an add-on ? and does it have its own logs in PMS Plugin Logs?

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    I have passed it to the development team. I am not sure at this point if it is a specific issue when using the android client app for this or a general server issue.

    Please could you let me have the steps to reproduce te problem and what plugins if any used

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass

    @sa2000 the torula plugin is an iptv live streaming client app (attached) . It is not an issue with the plex mobile app, it is an issue with multiple clients (plex android, firestick, roku 3) ONLY when they are remote clients (not on my physical network).

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Thank you. The problem has been raised with the development team. It is understood but solution yet to be worked out

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    On the server settings, on Remote Access settings page
    Did you try having
    No Upload Speed Set
    and also
    Limit remote stream bitrate set to Original (No Limit)

    See if deleting WanTotalMaxUploadRate in Preferences.xml makes a difference

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass
    edited September 5

    @sa2000 I tried all that. same issue. I invited you to my plex server. Should only be channels available for you. Check out the torula app, any sub stream. If sa2000 isn't your plex username let me know. Thanks!

    Just upgraded server to Version 1.8.3.4235 and issue persists.

  • Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass

    @sa2000 look at attachments

    Local Playback (LAN)

    Remote Playback (Separate network over WAN)

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Thanks - the problem is now understood. The fix is still to be worked out and I understand it is not going to be straightforward

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • kanabrewskikanabrewski Posts: 59Members, Plex Pass Plex Pass

    @sa2000 any update on this?

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Nothing at the moment. Sorry

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • woodsdogwoodsdog Posts: 5Validating, Plex Pass Plex Pass
    edited September 11

    I'm having this EXACT same issue. I'm using Torula plugin as well. It is even giving me the same 77kbs message. I have tried all the suggestions in this thread and others, but nothing fixes it outside of my local lan.

    Not adding much to this thread other than bumping it! Thanks for looking into this issue

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @woodsdog said:
    I'm having this EXACT same issue. I'm using Torula plugin as well. It is even giving me the same 77kbs message. I have tried all the suggestions in this thread and others, but nothing fixes it outside of my local lan.

    Not adding much to this thread other than bumping it! Thanks for looking into this issue

    Understood and i have added your post to the issue.
    There is no easy fix and it stems from lack of video resolution information

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • fordyxyzfordyxyz Posts: 1Members

    I have the same with IPTV streams. Works fine in web browsers over Lan, but get "Not enough bandwidth for any playback of this item. Cannot convert to below minimum bandwidth of 77k" on Roku 3 app.

  • Kryptonit3Kryptonit3 Posts: 18Members, Plex Pass Plex Pass

    @sa2000 is there any setting that we can add to the bundle app code to circumvent this issue or to tell the server it is 720p or 1080?

  • sa2000sa2000 Posts: 29,383Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @Kryptonit3 said:
    @sa2000 is there any setting that we can add to the bundle app code to circumvent this issue or to tell the server it is 720p or 1080?

    I don;t think it is that simple. I believe it is to do multi-quality HLS source which needs to be transcoded to DASH

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • woodsdogwoodsdog Posts: 5Validating, Plex Pass Plex Pass

    I'm adding another data point. This isn't a fix for clients, but I noticed that I was able to get the plugin to play through the web interface.

    In a web browser on a non-lan computer, I go into plex:

    Setting -> Web -> Quality.

    Under "Internet Streaming" the quality was at 2 mbps/720p. I moved this to "Maximum". I then refreshed my plex web browser, and the channels were able start playing without the 77kbs error. I went ahead and set it back to 2mbps, refreshed the browser, the error was back.

    This helps for web browser, but not for the app on my phone or other apps. I believe this is a "This web browser setting", not a overall server setting, so it's specific to that browser. I don't know if clients, like android, can be tweaked like this.

«13
Sign In or Register to comment.