If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Support for Win2008 R2

Ray RayRay Ray Posts: 1Members
Hi guys,
I have a server in my home network running Windows 2008 R2 180 day evaluation version. My hardware is fairly contemporary and exceeds greatly the recommended system requirements. The box functions as a backup, print and file server. I allow automatic updating and my browser is chrome. I have tried repeatedly to make the Plex media server work, but, so far, I have not succeeded (It runs fine on my Win 7 box). I tried installing in compatibility mode (XP), running as administrator, but I still have not been successful. No matter what I try I get the following error message: "The application was unable to start correctly (0xc0150002). Click OK to close the application"

To be fair, Win2008 is not listed among the supported OSs. Offloading the Plex server to this machine would be nice, but it is certainly not an emergency. Is support for Windows 2008 in the works? Is there something else I can try? TIA for your help.


  • noddy43noddy43 Posts: 8Members
    i too would be very interested in support for windows 2008 R2, it running on my server atm so would be keen to have official support for this OS.
  • es95ples95pl Posts: 12Members, Plex Pass Plex Pass
    Actually I'm running PMS on my 2008 R2 without any problems.
    English version, UAC turned off. No other special config.
  • rabbixrabbix Posts: 15Members
    edited August 2011
    I've run PMS on Windows 2008 Server R2 since the Plex Server for Windows has been available. I've had none of the problems you have described with any of the builds. In my experience, if a program will run on Windows 7, then it will run on Server.

    There must be another problem here. Check your Application and System logs in Event Viewer to see if they give anymore info.

    If I was to venture a guess, it might be either an issue with Python or possibly a Visual C++ Distribution. Might look into updating the latter.

    You could also try downloading: http://www.dependencywalker.com/ and run it against the PMS executable. It might be able to point you in the right direction if you are missing a dependency.

    I've also seen a couple reports with that particular error that stated the problem was resolved by installing QuickTime. Personally, I don't have QuickTime installed so I doubt there is any need for it. Maybe it just included a needed dependency. At least worth a try I guess if you run into a brick wall and can't find the real issue.

    You should not need to run compatibility mode or anything special like that.

    Good Luck tracking it down.
  • wdrsnwdrsn Posts: 1Members
    I had the same problem and I solved it with installing Microsoft Visual C++ 2008 SP1 (I'm using Windows 2008 R2 64bit).
  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    Rabbix's suggestions are right on the money.

    From the perspective of PMS, Windows 2008 R2 is the same as Windows 7.

    I'd be curious to know whether installing VS 2008 CRT SP1 redist helps people. The odd thing is that PMS installs VS 2008 CRT SP1 merge modules, so there shouldn't be a need to install the redist at all.

    Real money here, though, would be figuring out which DLL's dependencies are causing the initialization error. A process dump of PMS when the error dialog is up would be great. Any chance someone could get me that?
  • noddy43noddy43 Posts: 8Members

    I get the same error (0xc0150002). Click OK to close the application. When i try to start PMS.
    I reinstalled the latest version and checked the events log and got what seems to be an error during the installation process.
    Attached is the error log which points to a source of "sidebyside" as the error. Not sure if i have attached the right information.
    I'm a bit of a noob with this server thing.
  • rabbixrabbix Posts: 15Members
    edited August 2011
    Concerning SidebySide Event 33 error you reported, here is an answer from Microsoft:


    This appears to be related to: Microsoft Visual C++ Redistributable Package.

    I would recommend installing the latest version and seeing if that helps resolve this.

    (from the link above)

    The post below mine from "mfeingol" mentioned: Microsoft Visual C++ Redistributable Package 2008 SP1. Many times programs need specific versions of the C++ package to function correctly, which is why alot of times you will have multiple versions of this installed. Probably wouldn't hurt to look for this specific version as well and reinstall it.

    The Plex team may have further input based on the Event Log report.

    I still have never had any issues like this. I have setup up multiple 2008 R2 Servers, since I always seem to be changing something. I am pretty sure Plex is one of the early programs I install after an initial setup.

    I always do Windows update first to make sure everything is up to date before installing programs and of course have SP1 installed. After that, the main things I install on which ever server I am going to use for the PMS:

    -SABNZBD - Usenet Downloader (www.sabnzbd.org)
    -SICKBEARD - For automatically quering USENET indexes and sending download request for TV shows to SABNZBD (sickbeard.com)
    -Google Chrome

    That's about it. It's possible one of the above programs had something else in there that Plex used.

    Currently all my servers are 2008 Enterprise Edition, but I have run it successfully with Standard as well. It honestly shouldn't matter, that is unless you are actually running a ServerCore installation. I have tested that with Plex and it will NOT work with ServerCore. If I remember that one test I did a while back I think it was due to the Visual C++ packages being incompatible.

    I do IT support for a living and have a TECHNET subscription that helps with easily using the different versions, which may not be an option for you, but like I said with expection to ServerCore it should't matter.

    I finished up the last Microsoft MCITP certifications I wanted a earlier this year so the number of VM servers I was running was always fluctuating up and down. I think I am down to only 4 servers running right now :) I only mention this because I have probably installed plex from scratch a minimum of 5 times on a fresh server and have not seen this issue.

    Good luck. Try the Visual C++ Package reinstall/install and let us know how it goes.
  • noddy43noddy43 Posts: 8Members
    edited August 2011

    Thanks for the recommendation and the fact you have installed it on 2008 many times gives me confidence in your suggestion. I will give the C++ redist a go and let you know. Located in Australia here so let you know in 12 hours or so!
  • noddy43noddy43 Posts: 8Members
    It worked. C++ dist was the soution for me thanks for the help rabbix
  • rabbixrabbix Posts: 15Members
    edited August 2011
    Great! I'm glad you got it working. Plex has managed to become so integrated into my household it's become hard to imagine life without it now. I hope you get as much enjoyment out of it as I have. Take care.

    BTW - If you got a minute, post the steps you ended up having to perform to solve the issue. It may help others in the future.
  • noddy43noddy43 Posts: 8Members
    Yeah no worries.
    Uninstalled everything, plex, bonjour, c++. Then rebooted and installed rabbix's linked version of C++ (latest). Then plex (open as administrator) and rebooted and got it working.

    Thanks again
  • mfeingolmfeingol Posts: 5,091Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
Sign In or Register to comment.