Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Synology package thread

NudgenudgeNudgenudge Master Synology EngineerPosts: 293Members
edited August 2011 in Linux
Bugs, issues...
IMPORTANT: here is the list of supported, Intel Synology NAS:
DS710+
DS1010+
RS810+
DS411+
DS411+ II
DS1511+
RS2211+
For other models, check below the "what about ARM/PPC builds" chapter.

Since the official Synology package is now released, I decided to do a new thread in order to better keep track of things related to it.

What does the package do?
It:
- installs the Plex Media Server (duh),
- creates a "plex" user, which will run the PMS,
- creates a "Plex" folder in your main volume, containing the library,
- configures everything automatically: Avahi, rsync, etc.
- creates a "Plex Media Server" icon in the DSM, to access the Media Manager:
DSM.png

I installed the previous version of the package. How do I upgrade?
The best way to do that is to upgrade the package in the DSM, as if you tried to install it.
I strongly recommand NOT to uninstall/re-install. The main reason behind this is that the Library is huge.

I still want to do a full clean install!
Okay, in this case, here are the steps:
1) uninstall the package.
2) remove the Plex shared folder. This is very, VERY long (as in "hours"). Better do it via SSH.
3) re-install everything.
If you want to keep the Library, you'll have to do a "chown -R plex:users /volume1/Plex" after re-install (the user was deleted/created, so the rights are not set correctly).

What about ARM/PPC builds?
This is a more general issue; I recommend that users who want ARM/PPC build post in this thread, created by thorsten: http://forums.plexapp.com/index.php/topic/29208-on-which-synology-diskstation-would-you-like-to-run-pms/
I'm just the guy that does the package, not the binary inside it. :P

Bugs are still okay here?
Well, to be honest, since the binary is the same source code between environments (ReadyNAS especially), you'd be better to create threads/post in already-existing threads for those issues.
Again, this is to get the devs' attention.

So, what goes here?
Install, uninstall, upgrade, crashes or "it's not running at all" issues.
Also, issues like the Resource Manager not running (by the way, Elan contacted Synology about that, and they're preparing a DSM release with a fix for that. My gut instinct was right. :D ).
«13456725

Comments

  • papalozaroupapalozarou Posts: 94Members, Plex Pass Plex Pass
    A (probably stupid) question: I've just upgraded my install, but it still says the version number is 0.9.2.8. Is that right?
  • NudgenudgeNudgenudge Master Synology Engineer Posts: 293Members

    A (probably stupid) question: I've just upgraded my install, but it still says the version number is 0.9.2.8. Is that right?

    Yes, it's just a variable in the text file that wasn't updated. Nothing important.
  • LenslarqueLenslarque Posts: 10Members
    Nudgenudge wrote:

    Yes, it's just a variable in the text file that wasn't updated. Nothing important.


    Can you tell us what the release notes are?
  • NudgenudgeNudgenudge Master Synology Engineer Posts: 293Members
    Lenslarque wrote:

    Can you tell us what the release notes are?

    This is the Linux 0.9.3.5, so I'll send you back to the blog posts Elan made.

    Mostly bug fixes, performance improvements, deletion from the client (couldn't test it), better music matching, timed/automatic library refreshes... so, a good release.
  • BasajaunBasajaun Posts: 4Members
    Hi

    First thanks to @ Nudgenudge and Elan, this is really great job!

    I have just downloaded and installed. TVshows scan was quite well but in Films scan it dosen't find anything. I have install Filmaffinity plugin manually (download and put in the plugins folder as in macosx version) I have try with other agents and even changing the scanner. I stop and run the service (from the web panel) of plex several times but allways get the same: No files found.

    Actually I'm running in DS1511+ model with DSM 3.2 build 1869 BETA (this firmware is BETA and I can not go back for testing in 3.1)

    Hope you can find the issue and help me (and hope the rest of users if someone get the same problem like me) :)

    Thanks
  • NudgenudgeNudgenudge Master Synology Engineer Posts: 293Members
    edited August 2011
    Basajaun wrote:

    Hi

    First thanks to @ Nudgenudge and Elan, this is really great job!

    I have just downloaded and installed. TVshows scan was quite well but in Films scan it dosen't find anything. I have install Filmaffinity plugin manually (download and put in the plugins folder as in macosx version) I have try with other agents and even changing the scanner. I stop and run the service (from the web panel) of plex several times but allways get the same: No files found.

    Actually I'm running in DS1511+ model with DSM 3.2 build 1869 BETA (this firmware is BETA and I can not go back for testing in 3.1)

    Hope you can find the issue and help me (and hope the rest of users if someone get the same problem like me) :)

    Thanks

    The only thing I can think of is: does the Plex user have the rights to read the Films folder?
  • BasajaunBasajaun Posts: 4Members
    edited August 2011
    Nudgenudge wrote:

    The only thing I can think of is: does the Plex user have the rights to read the Films folder?


    Yes, sorry I didn't mention this in my reply. I have review the rights and by default it have access to movies folder with read and write rights... :S

    edit: I have try to put some films in tvshows folder.... now they are scanned and they appear... hummm maybe is an issue with the beta versión of synology I have also some issues with rights but only when I transfer it to my computer. I will try fix this rights via ssh.
  • NudgenudgeNudgenudge Master Synology Engineer Posts: 293Members
    Basajaun wrote:

    Yes, sorry I didn't mention this in my reply. I have review the rights and by default it have access to movies folder with read and write rights... :S

    edit: I have try to put some films in tvshows folder.... now they are scanned and they appear... hummm maybe is an issue with the beta versión of synology I have also some issues with rights but only when I transfer it to my computer. I will try fix this rights via ssh.

    That may be it.

    Another issue which I think isn't fixed is that files with accents in them are crashing the PMS.
    This is a "global" Linux issue: Ubuntu, ReadyNAS, etc... have it too.
  • BasajaunBasajaun Posts: 4Members
    Nudgenudge wrote:

    That may be it.

    Another issue which I think isn't fixed is that files with accents in them are crashing the PMS.
    This is a "global" Linux issue: Ubuntu, ReadyNAS, etc... have it too.



    woooooo I was near to do chmod 777 when I see your reply!!! xD I was getting crazy xD my folder name was: "Películas" As I'm spanish it was accent!!! thanks for the tip!!! I have change the name and now is happyly scanning!! :)

    thanks!
  • papalozaroupapalozarou Posts: 94Members, Plex Pass Plex Pass
    Basajaun wrote:

    Yes, sorry I didn't mention this in my reply. I have review the rights and by default it have access to movies folder with read and write rights... :S

    edit: I have try to put some films in tvshows folder.... now they are scanned and they appear... hummm maybe is an issue with the beta versión of synology I have also some issues with rights but only when I transfer it to my computer. I will try fix this rights via ssh.


    I've had issues with scanning, but for TV shows, where I've added say a large amount of files (i.e. all of The Sopranos or something). It will scan the first folder then skip a folder, then scan another folder then skip two folders. Moving the folders, rescanning, and then moving them back into place seems to sort it out. The log sheds no light on the problem though - just says that as nothing has updated in the folder it's not going to scan it (even though it's not displaying in media manager).
  • underlircsunderlircs Posts: 7Members, Plex Pass
    edited August 2011
    Thanks for the great package!

    I too am having the movies not found issue. PMS searched the TV shows directory without a hitch; but nothing is showing for the movies directory. Both the TV shows and movies directories are inside their parent 'Video' directory. The 'plex' user has read/write privileges for the 'Plex' and 'Video' directories.

    Any ideas? :huh: I don't have any accents in my file names.
  • papalozaroupapalozarou Posts: 94Members, Plex Pass Plex Pass
    edited August 2011
    underlircs wrote:

    Thanks for the great package!

    I too am having the movies not found issue. PMS searched the TV shows directory without a hitch; but nothing is showing for the movies directory. Both the TV shows and movies directories are inside their parent 'Video' directory. The 'plex' user has read/write privileges for the 'Plex' and 'Video' directories.

    Any ideas? :huh: I don't have any accents in my file names.


    Have a look at the log file within the plex folder (cant remember exact location as on iPad now).

    I thought I had got all the files that had special characters in them, then realised from the log file that all six of my Star Wars rips had a colon in them which choked the scanner. In the log file the unrecognised characters should come up as a box with a cross in them - sort of like this: [x]
  • mitahmitah Posts: 99Members, Plex Pass Plex Pass
    has anyone tried migrating the database from a mac to a disksation? I've copied my 10 GB library Folder from my mac to the diskstation (into the generated Plex folder) ... but that took a complete day... no I guess it's another few hours changing ownership of the folder to the plex user

    is there a way to keep the customizations (Artwork, Cover Art, viewed count) without having to copy all the other data from the mac?
  • VerdiVerdi Posts: 3Members
    Hi, I just tried to install the spk-package on my Synology 211+ but it keeps saying the package is not supported. Yes, I am a first time user (n00b if you will). Do I need to install other packages first. I read something about SabNZB, athough i'm not sure if it's connected. After several hours of googling, ging through this and other forums, I just can't find a manual. Somebody please help me.
  • NudgenudgeNudgenudge Master Synology Engineer Posts: 293Members
    edited August 2011
    Verdi wrote:

    Hi, I just tried to install the spk-package on my Synology 211+ but it keeps saying the package is not supported. Yes, I am a first time user (n00b if you will). Do I need to install other packages first. I read something about SabNZB, athough i'm not sure if it's connected. After several hours of googling, ging through this and other forums, I just can't find a manual. Somebody please help me.

    It's an ARM processor in this NAS. Right now, the Plex Media Server is Intel-only, which only concers a few models.
    To discuss/request it, here is the thread: http://forums.plexapp.com/index.php/topic/29208-on-which-synology-diskstation-would-you-like-to-run-pms/

    And I'll add a short list of supported NAS in the top post.
  • lazantlazant Posts: 25Members, Plex Pass Plex Pass
    Amazing! Great work Nudgenudge!

    One question, is there a way in the browser-based media manager to "Reveal in Finder" as you can in the Mac OS X version? I need to fix some incorrect matches but cannot see what files they refer to as the file paths are so long that it becomes abbreviated in the "Fix incorrect match" drop-down and the endings are often very generic. Of course I can figure it out by playing it, but that is pretty time consuming.

    I also noticed that the "Add to collection" submenu is no longer present when right-clicking items. Is that intentional or a bug?

    Again, excellent work and thank you!
  • bloodshinebloodshine Posts: 1Members, Plex Pass Plex Pass
    edited August 2011
    same bug as before
  • VerdiVerdi Posts: 3Members
    Nudgenudge wrote:

    It's an ARM processor in this NAS. Right now, the Plex Media Server is Intel-only, which only concers a few models.
    To discuss/request it, here is the thread: http://forums.plexapp.com/index.php/topic/29208-on-which-synology-diskstation-would-you-like-to-run-pms/

    And I'll add a short list of supported NAS in the top post.


    Thank you for clearing that up and saving me a lot of wasted time trying to fix what can not be fixed.
  • underlircsunderlircs Posts: 7Members, Plex Pass

    Have a look at the log file within the plex folder (cant remember exact location as on iPad now).

    I thought I had got all the files that had special characters in them, then realised from the log file that all six of my Star Wars rips had a colon in them which choked the scanner. In the log file the unrecognised characters should come up as a box with a cross in them - sort of like this: [x]


    Thank you! It was exactly that, a symbol. An apostrophe that was causing the issue; all working now. :)
  • jeromem75jeromem75 Posts: 15Members
    I am about to purchase the DS3611xs which use Bromolow .
    Will it be supported as it is an intel cpu ?
«13456725
Sign In or Register to comment.