If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Add custom script link for multiboot

erikendswithakerikendswithak Posts: 24Members, Plex Pass Plex Pass

I have a multi boot raspberry pi and would like to add a custom link to reboot with retropie, raspbian, kodi, etc. I have never edited a plex skin. I have the black edition skin installed and have been editing the LeftSideMenu.xml. It currently doesn't show up, so I'm missing something. The code for these three links were copied from the previous skin that had it working.

Thanks,

I have added this code:

            <control type="button" id="109">
                <texturefocus>b-pp-unwatched-s.png</texturefocus>
                <texturenofocus>b-pp-unwatched.png</texturenofocus>
                <onright>XBMC.NextItem</onright>
                <onright condition="!IsEmpty(ListItem.Property(PlexExtras))">SetFocus(30)</onright>
                <onleft>XBMC.PrevItem</onleft>
                <onclick>markaswatched</onclick>
                <include>leftMenuBarButton</include>
            </control>      
            <control type=“button” id=“800">
                <description>Launch KODI</description>
                <label>Launch KODI</label>
                <onclick>Dialog.Close(4998)</onclick>
                <onclick>RunAddon(script.kodi)</onclick>
                <visible>System.isSystem(openelec) + !System.UserIsRestricted</visible>
            </control>
            <control type=“button” id=“801">
                <description>Launch Raspbian</description>
                <label>Launch Raspbian</label>
                <onclick>Dialog.Close(4998)</onclick>
                <onclick>RunAddon(script.raspbian)</onclick>
                <visible>System.isSystem(openelec) + !System.UserIsRestricted</visible>
            </control>
            <control type=“button” id=“802">
                <description>Launch RetroPie</description>
                <label>Launch RetroPie</label>
                <onclick>Dialog.Close(4998)</onclick>
                <onclick>RunAddon(script.retropie)</onclick>
                <visible>System.isSystem(openelec) + !System.UserIsRestricted</visible>
            </control>

Answers

  • DeadEyeFlintDeadEyeFlint Posts: 308Members, Plex Pass Plex Pass

    IncludesHomeMenu.xml

    Submenu line 149, Homemenu line 238:
    Use Items instead of Buttons:

        <item id="800">
            <description>Launch KODI</description>
                <label>Launch KODI</label>
                <onclick>Dialog.Close(4998)</onclick>
                <onclick>RunAddon(script.kodi)</onclick>
        </item>
    
Sign In or Register to comment.