If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to connect to

Johan76Johan76 Posts: 245Members, Plex Pass Plex Pass

I get "Unable to connect to" error on most of my movies. Some work and some don't.
Doesn't matter if it's movies, 3D movie or TV series.

What could be wrong?

Comments

  • millerjemillerje Posts: 2Members, Plex Pass Plex Pass

    I get the same error. I have yet to find a movie or tv show that will play. They all get the same error "Unable to connect to".

  • ManuelPGManuelPG Plex Dev Team Posts: 387Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Sorry you guys are having trouble with this.

    We'll hopefully be adding the ability so share devices logs to the app soon, but until that happens I'm not sure what to suggest. Just to see if we can identify a pattern, can you guys share information about your setup (device model, Android version, PMS version, PMS platform...)

    Some additional bits of information that might help:

    • Does the same error occur when playing local videos stored on the device?
    • Do the PMS videos you guys are trying to play require transcoding or do they direct play? (As a rule of thumb, anything that's not h264 over mp4/mkv, or that has audio other than mp3/aac, or that have a selected subtitle stream will require transcoding).
    • Does the problem go way if you force a transcode by lowering the quality in the playback settings to SD or HD?

    Thanks in advance.

  • millerjemillerje Posts: 2Members, Plex Pass Plex Pass

    I got mine to work by uninstalling the Plex VR app on my Google Pixel XL, removing the device from the device list on my server, and then reinstalling Plex VR on my phone. I then allowed the app permission to the 2 "required" requests. I believe it was Audio and Video permissions. I then launched it from the daydream app and it worked perfectly. Those are the steps I did last night to get it to work for me. I was able to start a sd, hd and 3d moving with no issues. Transcode and direct play as well.

    To answer your question though, as this may help others.

    Device: Google Pixel XL
    Android Version: 8.1.0
    PMS Version: 1.11.0.4666
    PMS Platform: Windows Server 2016
    *I also have SSL set to required

    I didn't have the option for local video files. I believe this is because I denied access when I first launched the app.

    I tried all types of files. Those that require transcoding and those that will play via direct play. All failed with same error.

    I changed every setting available in the app to see if I could get it to play.

    Only the uninstall - reinstall process from above got the app to work for me.

  • geo255geo255 Posts: 4Members, Plex Pass Plex Pass

    Getting the same error with a few movies, although most work OK. I've not managed to see if there's a pattern with codec/resolution/etc yet, but I do know that it isn't the file type. I've not tried many TV programs, but the ones that I have tried have worked ok.

    The videos that don't work with Plex VR do work OK with the normal Android App.

    Device: Samsung Galaxy s8+
    Android version: 7.0
    PMS version: 1.11.1.4753
    PMS Platform: FreeBSD 9.3-RELEASE-p26 (FreeNAS-9.3-STABLE-201509282017)

    I tried the suggested uninstall the Android APP and reinstall, but that didn't make any difference.

  • geo255geo255 Posts: 4Members, Plex Pass Plex Pass

    Additional information:
    I had Cmoar VR Cinema installed along with the Plex plugin. I uninstalled Cmoar and now (at least one of) the videos which produced the error play correctly.

  • ManuelPGManuelPG Plex Dev Team Posts: 387Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Only the uninstall - reinstall process from above got the app to work for me.

    @millerje That suggests to me that maybe you had set the quality to SD or HD, and all your videos were being transcoding (and failing at doing so for some reason). Can you try changing the quality to SD or HD and seeing if it breaks things again? Sorry I don't have anything more useful than that to offer, we're working on adding the ability for users to share the application logs which will help a lot with this kind of situation

  • ManuelPGManuelPG Plex Dev Team Posts: 387Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I had Cmoar VR Cinema installed along with the Plex plugin. I uninstalled Cmoar and now (at least one of) the videos which produced the error play correctly

    @geo255 Weird, I don't have a rational explanation as to why that would be the case...

    Anyway, until we add the ability to share the application logs, can you share your PMS logs after trying to play one of the videos that fail? There might be something in there that hints at what's causing the problem.

    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    Thanks a lot for your help.

  • geo255geo255 Posts: 4Members, Plex Pass Plex Pass
    edited February 9

    It does seem to be related to using Cmoar - works fine with that uninstalled, doesn't work with it (after reinstalling). I've got the PMS log files, how should I send them to you?

  • ManuelPGManuelPG Plex Dev Team Posts: 387Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    How weird! Will be interesting to take a look at those logs.

    how should I send them to you?

    Just zip the file and post it here? Or DM it to me if you prefer?

  • Technomancer01Technomancer01 Posts: 13Members, Plex Pass Plex Pass
    edited May 7

    UPDATE: A new version of the plex client on the Oculus Go came out, and now things seem to be working OK. Thanks, Plex Coders for staying on top on things. It's much more comfortable to watch 3D movies this way than with flickery glasses on the TV.

    I upgraded to 1.13.0.5003-8fcb5b6e5 (on linux; CentOS 6), and now no video works in Plex VR on the Oculus Go; I get this error "Unable to connect to" floating in front of the screen (which in and of it self is not very helpful, or even a seemingly complete error message) whenever I try to play any video (including those that were working before the upgrade). I have rebooted the Go, and restarted the server. Still the same problem.

    And of course, even when it was working (server plexmediaserver-1.12.3.4973-215c28d86), Plex VR on the Go would crash the whole device (not just the app) VERY frequently when navigating through movies/shows, leaving a blue wall as the only thing on the screen. The remote was locked out, and I had to use the power button to force reset it.

  • n9ytyn9yty Posts: 58Members, Plex Pass Plex Pass
    edited May 3

    Just got an Oculus Go today. I'm not at home, but I was on an older version of Plex Server, 1.12.something, and I also was getting nothing but "Unable to connect to", or sometimes "400" floating. I upgraded to Version 1.13.0.5003 and one video started, but nothing else, mostly "400" messages or just a black screen. {sigh} This was really the reason I bought it in the first place. The Plex Server status screen shows that it thought it was playing the videos, but it wasn't working.

  • n9ytyn9yty Posts: 58Members, Plex Pass Plex Pass

    I just noticed on the page for this, it says "This means that managed user accounts cannot sign into the app currently." Does that mean that if you have that turned on, they won't work at all, or that it only works as the primary user? I have it enabled, but was browsing the library so I thought there would be no problems playing. Just asking in case this is related.

  • CaptainBistoCaptainBisto Posts: 7Members ✭✭

    I get the "Cannot connect to server" error with some movie files (but not all) when using the Samsung Smart TV app. I have no idea what causes it and can't see any connection between the files that have problems, but I did find that switching to Direct Streaming solves it every time. Not sure if that option is available in other versions of the app though.

  • PassivirPassivir Posts: 2Members, Plex Pass Plex Pass

    Ok, I'm using Plex VR with the Gear VR. It seems to work fine with Netflix, and other apps, but when I load up Plex VR from the Oculus store I get signed in (my avatar shows up so I know I'm logged in successfully) but a message says that there is no Plex media server available. Just to be clear, I am on local wifi and my server is available to the regular Plex app. The version of the server is Version 1.13.0.5023. The notes indicate version 1.8 is required which is confusing as I can not find such a version. I'm assuming it's something obvious, but can't see what's the issue.

  • SctyScty Posts: 1Members, Plex Pass Plex Pass

    Having the “could not connect to” error appear on any content I try to play while using Oculus Go. Thumbnails and titles for everything load fine, but nothing will play. Server version 1.13.1.5063-b4605f76e , using wi-if, Apple TV and iOS devices all work perfectly.

  • Randy_OneRandy_One Posts: 11Members, Plex Pass Plex Pass

    Just bought the Oculus Go this morning because I saw that it supports plex and thought I can finally watch 3D movies, but like others here I only get the "Unable To Connect" message when I try to play them. Just updated my server to version 1.13.2.5102-4898d7d96 and the issue remains. Looking forward to this being fixed. As a side note I have been able to view these movies using DLNA from my NAS using Pigasus but it is failing to play the audio tracks, maybe there is a connection there.

  • ondra.osondra.os Posts: 4Members, Plex Pass Plex Pass

    Same issue here, I start Plex on Oculus Go, see thumbnails and all content, try to play a file, the virtual room gets ready, black screen in front of me, nothing happens, no loading, no controls, just the error message "Unable to connect to" and I'm back in the Plex library.
    I have Plex Media Server Beta at Nvidia Shield (1.13.2.5102-4898d7d96)
    Plex app at Oculus: 1.3.0.36

Sign In or Register to comment.