If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server on Pi 3

Jase BleazardJase Bleazard Posts: 7Members, Plex Pass Plex Pass

I am having trouble getting to the web interface of my Plex Media Server on a Raspberry Pi 3. I have followed several tutorials for a PMS on RasPi3 with no problems... until the end of course. Here is the status of the process

pi@raspberrypi:~ $ sudo service plexmediaserver status
● plexmediaserver.service - Plex Media Server for Linux
   Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-03-02 20:26:21 MST; 24min ago
  Process: 8168 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS)
 Main PID: 8172 (sh)
   CGroup: /system.slice/plexmediaserver.service
           ├─8172 /bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server"
           └─8174 /usr/lib/plexmediaserver/Plex Media Server

Mar 02 20:26:21 raspberrypi systemd[1]: Starting Plex Media Server for Linux...
Mar 02 20:26:21 raspberrypi systemd[1]: Started Plex Media Server for Linux.

It looks like everything is going fine. The only strange thing about the set up is that when I tried installing it with the installer it made a file at /etc/default/plexmediaserver.prev but all (or at least most) of the tutorials said it should be /etc/default/plexmediaserver and it was not. So I created a copy of the first the named the latter still no affect.

I have changed permissions on several files. Does anyone have anything i can try to get this going? I have installed the latest everything on the pi running Raspian.

Best Answer


  • Jase BleazardJase Bleazard Posts: 7Members, Plex Pass Plex Pass

    Thank you very much! I did read your posts and tried to fix all of my changing of permissions and what not but based on what you told me to do that fixed it I was changing the wrong files. Thank you for your help!

Sign In or Register to comment.