If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PVR recording video freezing on DS918+ with Direct Play

jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

On my DS918+, when I try to watch back a video that was recorded via Plex DVR the audio plays fine, but the video locks up every few seconds. If I force it to transcode (even at 20Mbps 1080p) it plays fine.

I have a HDHomeRun CONNECT Duo and the recordings are from Channel 4 HD (UK).

Exactly the same issue occurs on iOS (WifI), Apple TV (Ethernet) and Mac Plex Web (Ethernet). (Interestingly, on Apple TV if I turn Off Allow Direct Play in Settings, it still Direct Streams, and I need to set the individual video to "Convert..." instead of "Play Original Quality").

Here is a sample file that reproduces the issue: http://pswd.biz/plex/sample-f1-DS916-freezing.ts (52 MB)

Remove commercials: Enabled
Convert video while recording: Disabled

Anyone else seeing this issue?

Answers

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja
    edited April 15

    From watching your sample, I see what I term 'digital freeze', which means that the signal was lost or corrupted during transmission or recording.

    Make sure Plex is not performing maintenance or adding media and any other apps on the system should be disabled when recording any program.

    You should also check all of your physical connections and make sure they are clean and free of oxidants etc... Isopropyl Alcohol and a cotton bud (Q-Tip) or a soft white pencil eraser are best for cleaning the physical connections.

    If you have any other systems running on your network besides the NAS, make sure they are not up/downloading during recording, that could interfere with the signal as it is being recorded.

    If using an external antenna, make sure you are recieving the strongest signal possible and it's connections are also clean and free of oxidants etc...

    Make sure the HD Homerun has adequate ventilation and is not overheating during recording.

    If the digital freeze is occuring at the broadcast end of the equation, then there is nothing you can do about that at all.

    HTH

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks for your message.

    First of all, if you can hear audio that indicates that the file is actually playing, correct?

    And if the file is playing then the issue must be within the content itself, correct?

    And if the issue is in the content and it is playing then it is unlikely to be an issue with Plex, correct?

    If transcoding corrects the problem, that would indicate that the problem is with the actual file and it's formatting and not necessarily the actual content.

    As I have already pointed out, that could be influenced by a number of things and not necessarily be an issue with Plex.

    But, I would like you to play the file and after it has 'frozen' and does not display the video, wait one minute, then grab your Plex logs by going to Plex settings > server > help and click on the Download Logs button. Attach the .zip file to your post, thanks. If you could also provide logs for the same time period from your Plex client that would also help.

    https://support.plex.tv/articles/201869908-log-files/

    It would help if you let me know the actual filename and the time/date that it was played, thanks.

    For some reason the forums were glitching last night. I don't know exactly what the issue was, but that probably explains why you were unable to post. It was nothing anyone did deliberately.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass
    edited April 16

    Here are the logs.

    File output.ts was played at 16:38:30 and froze immediately.

    Note that this issue appears to occur for any recording made by the Plex DVR, it's not just this specific file.

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja
    edited April 16

    From your logs:

    Apr 16, 2018 16:38:33.730 [0x7fc7e1d11700] ERROR - [Transcoder] [h264 @ 0x1c787c0] mmco: unref short failure
    Apr 16, 2018 16:38:33.923 [0x7fc7e55a1700] ERROR - [Transcoder] [h264 @ 0x1c787c0] number of reference frames (0+5) exceeds max (4; probably corrupt input), discarding one
    

    To be honest, I have no idea what that error means. I will ask our resident guru for his thoughts, but I do suspect the issue is file related, just not entirely sure how. The RefFrames is definitely an issue though and is related to the file format.

    Will let you know when I have something for you.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    The guru has asked if we could possibly see the actual file. Could you upload it somewhere and provide a link to it so we can examine it further, thanks.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    The guru wishes to know how many splitters you have between the entry point to your home and the actual HD Homerun and if any, are they 2, 3 or 4 way splitters.

    He also advises that you downgrade to Plex version 1.12.2.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass
    edited April 16

    The output.ts file is just the same one that I linked to in my first post (before I renamed it for uploading): http://pswd.biz/plex/sample-f1-DS916-freezing.ts

  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    @trumpy81 said:
    The guru wishes to know how many splitters you have between the entry point to your home and the actual HD Homerun and if any, are they 2, 3 or 4 way splitters.

    1x 2-way splitter. The HDHomeRun Config shows very good signal stats:

    He also advises that you downgrade to Plex version 1.12.2.

    I was on 1.12.2, then upgraded to 1.12.3 to see if it resolved the issue, but no change.

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks, but we wanted the full unadulterated file if that's possible, please.

    I will pass that information on, thanks. :)

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • ChuckPAChuckPA Posts: 21,646Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    do you have dBmv values, similar to:

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    Speak of the devil ..... lol

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    @trumpy81 said:
    Thanks, but we wanted the full unadulterated file if that's possible, please.

    Just uploading the full orig file (it's 1TB), in the meantime here is a quick recording I did just now that has the same issue: http://pswd.biz/plex/Pointless%20(2009)%20-%20S19E11%20-%20Episode%2011.ts I've not made any changes to this file, it's the full length of the recording by Plex.

    @ChuckPA said:
    do you have dBmv values

    It's not a cable box, it's an over the air antenna:

  • ChuckPAChuckPA Posts: 21,646Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Please clarify? 1 Terabyte? (as in 1000 Gigabytes) ?

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    @ChuckPA said:
    Please clarify? 1 Terabyte? (as in 1000 Gigabytes) ?

    Ha, apologies! I meant to say 1 GB. It'll be up in 10 mins.

  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    Here is the orig full file: pswd.biz/plex/Live%20Formula%201%20Motor%20Racing%20(2011)%20-%202018-04-08%2018%2020%2000%20-%20Bahrain%20Grand%20Prix%20Live%20Reaction.ts

    I just removed the splitter and did another recording test, but the issue remains.

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    After reviewing the file it is fairly clear that the problem is your reception. The file shows momentary freezing of the image which is caused by missing frame data.

    As indicated here:

    Apr 16, 2018 16:38:33.730 [0x7fc7e1d11700] ERROR - [Transcoder] [h264 @ 0x1c787c0] mmco: unref short failure
    

    When the file is transcoded, the missing frame data is corrected or the frame is dropped and that will show as smooth playback, which is what I see when I watch it in VLC. Watching in Plex/Web shows the freezing etc.

    I would suggest you invest in a signal booster for your antenna. That should not effect the stronger channels, but will help with the weaker ones.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    Interesting. Thanks for investigating. I will look into that, would have thought that HDHomeRun reporting 100% Signal Quality and 100% Symbol Quality would have been enough (getting that on BBC1 which still has the same Plex recording issues).

    Also curious why Plex is susceptible to freezing on supposed missing frame data, when other apps like VLC, Quicktime etc seem to be able to deal with it fine.

    I'll look into my signal strength and report back.

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    The missing data is saved in the file itself and when Direct Played, Plex does nothing to the file at all, it sends the raw data from the file.

    When the file is transcoded, then Plex is able to correct the issue since it is changing the format etc...

    VLC and similar 'players' correct the file as it is being played because they use their own built-in codecs and error correction routines etc.

    Unfortunately, OTA connections can flucuate wildly in signal strength at any given point in time and what you see in your program does not necessarily reflect what is happening at the signal level, there is some smoothing of the signal displayed.

    You can re-encode the file yourself using HandBrake and you will find that it will Direct Play without issue, other than what was broadcast, and seen in the many Youtube recordings.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
  • jcwackyjcwacky Posts: 44Members, Plex Pass Plex Pass

    Thanks for explaining how transcoding can effectively "fix" the file.

    However, I've since discovered that the Channels iOS & Apple TV apps and the Channels DVR work flawlessly with no change to my setup, so I think I'll use them for now, until Plex's Live features are more polished and robust.

  • trumpy81trumpy81 Posts: 10,676Members, Plex Pass, Plex Ninja Plex Ninja

    Yes, I have heard that said of the Channels apps. If they work for you then by all means use them.

    Regards,
    Andy M.

    My Equipment: Synology DS1813+ | Panasonic TH-L42ET60A & TH-55DX600U | Windows 10 Professional 64Bit PC's | Raspberry Pi 2's & Odroid C2 with OpenPHT


    Device Profiles | File Naming in Plex | NAS - Plex Compatibility Guide | What CPU does my NAS have | Synology FAQ's page | Tips & Tricks
Sign In or Register to comment.