If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Audio issues on Pioneer AVR

Data_DanData_Dan Posts: 4Members ✭✭

I am running PMP2 v2.80 on an Asustor AS7004T NAS connected via HDMI to a Pioneer VSX-1128 receiver. The server v1.12.2.4929 is also running on the NAS. I only get downmixed stereo playback when playing AC3 and DTS titles. I am also running Kodi v17.6 with no issues, in fact it will also playback h265 encodes. I also have a Roku3 player connected which plays back flawlessly but I prefer the GUI of PMP2. Can someone please have a look at my logs to see where the problem lies?
Note: I had to add .txt file extension to allow uploading to the forum.

Thanks

Answers

  • Data_DanData_Dan Posts: 4Members ✭✭
    edited April 18

    I finally got it working! I can playback h264 and h265 encodes in surround sound using PCM. Since card0 shows my edid info in eld#0.1, I chose HDMI #1 instead of alsa and disabled normalize downmixing and all the passthrough settings. If ANY of them are on there is no audio period. I had tried different settings earlier but I hadn't exited and restarted the player...that's the key when playing around with the audio settings! The confusing thing is that the configuration file shows "false" for allowing AC3 etc but they playback in PCM
    },
    "audio": {
    "allowAC3": false,
    "allowDCA": false,
    "allowEAC3": false,
    "allowTrueHD": false,
    "audioBoost": 100,
    "channels": "7.1,5.1,2.0",
    "device": "alsa/hdmi:CARD=HDMI,DEV=1",
    "devicetype": "hdmi",
    "exclusive": false,
    "normalize": false,
    "passthrough.ac3": false,
    "passthrough.dts": false,
    "passthrough.dts-hd": false,
    "passthrough.eac3": false,
    "passthrough.truehd": false

    Unfortunately I get no sound with mp3 files with a sample rate of 44100 hz . Only files with 48khz work which is not the norm!

  • Data_DanData_Dan Posts: 4Members ✭✭

    In version 2.90 passthrough is now working for all multichannel titles in this configuration,
    },
    "audio": {
    "allowAC3": false,
    "allowDCA": false,
    "allowEAC3": false,
    "allowTrueHD": false,
    "audioBoost": 100,
    "channels": "7.1,5.1,2.0",
    "device": "alsa/hdmi:CARD=HDMI,DEV=1",
    "devicetype": "hdmi",
    "exclusive": false,
    "normalize": true,
    "passthrough.ac3": true,
    "passthrough.dts": true,
    "passthrough.dts-hd": true,
    "passthrough.eac3": true,
    "passthrough.truehd": true

    But mp3 files with a sample rate of 44100hz still don't work.

  • maerlinmaerlin Posts: 1Members, Plex Pass Plex Pass

    Hi there,

    Same issue here. Same PMP version. Asustor AS5002T.

    All stereo audio content I tried refused to play. Pressing "I" -> Audio output = "null".
    Whatever sample rate (44100 or 48000Hz). I haven't tried mp3 files, but videos woth stereo tracks: movie trailers provided by PMP, homemade videos, etc.

    Passthrough for AC3, DTS, etc. is OK.
    My NAS HDMI output is connected to a Philips Fidelio E5 receiver.

    Works fine on Kodi or OpenPHT.

    My conf:
    },
    "audio": {
    "allowAC3": false,
    "allowDCA": false,
    "allowEAC3": false,
    "allowTrueHD": false,
    "audioBoost": 100,
    "channels": "5.1,2.0",
    "device": "alsa",
    "devicetype": "hdmi",
    "exclusive": false,
    "normalize": false,
    "passthrough.ac3": true,
    "passthrough.dts": true,
    "passthrough.dts-hd": false,
    "passthrough.eac3": true,
    "passthrough.truehd": false
    },

Sign In or Register to comment.