If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

CCTV - IPCAM/Analog Home Security with R PI3

Folks,

I am building a home security system using Rasberry PI, Can an you please help me fix the following situations

Problem Case 1:

I was trying to process the IP CCTV CAM(HIK VISION) video live stream inside R PI 3(Ubuntu Mate 16.04 & OpenCV 2.4) using Ethernet cable, I am able to get the video stream, but its very very slow(at least a five minute lag). Can you please enlighten me to understand the reason?

Problem Case 2:

I was trying to process analog CCTV Camera(HIK VISION) video live stream video live stream inside R PI 3(Ubuntu Mate 16.04 & OpenCV 2.4), but here, since I was told both DVR and R PI needed to be in the same network(Meaning: Similar IP Address), I had connected the DVR feed to wifi modem and I took the output feed from wifi modem to R PI 3, Please correct me, If this approach is wrong, as its very slow but working

Please also suggest me, If I need to change my approach in both the cases

Thanks

Guru

Tagged:

Answers

  • uglymagoouglymagoo Posts: 977Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja
    edited May 4

    (1) Do you even use Plex? There is nothing in your description indicating Plex is used somewhere in the chain :)
    (2) Are you able to use some hardware acceleration (e.g. via OpenGL) on your Pi in OpenCV 2.4? The CPU in the Pi is much too slow to perform live video processing / conversion --> huge delay.

    Edit: Moved to RPi category.

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • ChuckPAChuckPA Posts: 22,283Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited May 4

    Reviewing the OP does not assert or imply any connection to Plex.

    The author is requested to create a new thread explaining how this is related to his Plex server.

    This thread is now closed.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • OttoKernerOttoKerner Posts: 30,287Members, Plex Pass, Plex Ninja Plex Ninja
    edited May 4

    Judging by the email address, this is just another spammer trying to prime his forum account...
    We'll be seeing some Guru-related spam from him soon. Which will then get his a** banned.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
This discussion has been closed.