Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Server not strong enough to transcode

wheelshotwheelshot Members, Plex Pass Posts: 5 Plex Pass

Hi,

I just finished setup my Pi 3b+ with PMS on it. All works fine except when the client on my android tablet want to check a movie and its encoding I got the server not strong enough message.

I read some other posts in here about it but I couldnt understand how I could specificaly fix it. Im not really good with Linux and Raspbian but from what I understand its not related to my setup but more on the PMS config or my file format. I usually encode my media files in MP4.

Thanks for helping and be patient with my slow understanding haha !

Best Answer

  • eckartheckarth Members, Plex Pass Posts: 502 Plex Pass
    Accepted Answer

    These are way too many files and it is hard to locate anything as I do not know at which time your problems arose.

    Anyhow, I found

    May 19, 2018 07:41:26.992 [0x6a1ff400] DEBUG - Request: [192.168.10.11:57687 (Subnet)] GET /video/:/transcode/universal/decision?audioBoost=100&autoAdjustQuality=0&directPlay=0&directStream=1&directStreamAudio=1&fastSeek=1&hasMDE=1&location=lan&maxVideoBitrate=20000&mediaBufferSize=209664&mediaIndex=0&partIndex=0&path=%2Flibrary%2Fmetadata%2F6411&protocol=*&session=eedf205abe01e3e9-com-plexapp-android&subtitleSize=100&videoBitrate=20000&videoQuality=100&videoResolution=1920x1080 (4 live) TLS GZIP Signed-in Token (wheelshot)
    May 19, 2018 07:41:26.993 [0x6a1ff400] DEBUG - Found session GUID of eedf205abe01e3e9-com-plexapp-android in session start.
    May 19, 2018 07:41:26.997 [0x6a1ff400] DEBUG - TranscodeUniversalRequest: using augmented profile Android
    May 19, 2018 07:41:27.002 [0x6a1ff400] DEBUG - Downloading document http://127.0.0.1:32400/library/metadata/6411?includeBandwidths=1&offset=-1&X-Plex-Session-Identifier=eedf205abe01e3e9-com-plexapp-android
    May 19, 2018 07:41:27.004 [0x6a1ff400] DEBUG - Auth: authenticated user 1 as wheelshot
    May 19, 2018 07:41:27.037 [0x6a1ff400] DEBUG - We're going to try to auto-select an audio stream for account 1.
    May 19, 2018 07:41:27.038 [0x6a1ff400] DEBUG - Selecting best audio stream for part ID 18073 (autoselect: 1 language: fr)
    May 19, 2018 07:41:27.038 [0x6a1ff400] DEBUG - Audio Stream: 42013, Subtitle Stream: -1
    May 19, 2018 07:41:27.047 [0x6a1ff400] DEBUG - Scaled up video bitrate to 4029Kbps based on 1.500000x fudge factor.
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: Selected protocol hls; container: mpegts
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: analyzing media item 18071
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): Direct Play is disabled
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): media must be transcoded in order to use the hls protocol
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no direct play video profile exists for http/mkv/h264
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no direct play video profile exists for http/mkv/h264/ac3
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no remuxable profile found, so video stream will be transcoded
    May 19, 2018 07:41:27.050 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.050 [0x6a1ff400] DEBUG - MDE: Cannot direct stream video stream due to profile or setting limitations

    That says 192.168.10.11 aka "wheelshot" wanted to play "The Good Dinosaur." The video stream is encoded in h.264 level 4.1. PMS thinks your device will only accept up to level 4.0. Hence, the video stream needs to be transcoded.

    From the xml file I read

    "bitrate="3326" width="1280" height="536"".

    Any arm device, including all the Pis, will not be able to do that in on-the-fly.

    I feel you only way out is to create optimized versions before hand.

    And, you better stay away from level 4.1 and keep it to level 4.0 while encoding video. Level 4.1 does not gain you that much, but can cause problems with older devices as you are just experiencing.

Answers

  • uglymagoouglymagoo Members, Plex Pass, Plex Ninja, TunerTester Posts: 1,083 Plex Ninja

    @wheelshot said:
    I just finished setup my Pi 3b+ with PMS on it. All works fine except when the client on my android tablet want to check a movie and its encoding I got the server not strong enough message.

    That's normal. Avoid video transcoding at all costs. Only Direct Play or Direct Stream is an option if you use a RPi server.

    https://support.plex.tv/articles/200250387-streaming-media-direct-play-and-direct-stream/

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • wheelshotwheelshot Members, Plex Pass Posts: 5 Plex Pass

    @uglymagoo said:

    @wheelshot said:
    I just finished setup my Pi 3b+ with PMS on it. All works fine except when the client on my android tablet want to check a movie and its encoding I got the server not strong enough message.

    That's normal. Avoid video transcoding at all costs. Only Direct Play or Direct Stream is an option if you use a RPi server.

    https://support.plex.tv/articles/200250387-streaming-media-direct-play-and-direct-stream/

    Thanks for the link but how can this be done technically? All my files are already in MP4 and im using the plex App on my Android tablet.

    When playing a movie Im trying to select the "Original quality" but the app keeps putting it back to "1080P". I check all the server side menu I could think of and didnt find a related option about forcing it to Direct Play.

    Can you pinpoint me where is that option? Is is in the client side app or on the server and where is it exactly? Thanks for your time!

  • uglymagoouglymagoo Members, Plex Pass, Plex Ninja, TunerTester Posts: 1,083 Plex Ninja

    @wheelshot said:
    Is is in the client side app or on the server and where is it exactly? Thanks for your time!

    It's a bit of both. The server has a base knowledge about the capabilities of the client (e.g. general codec support), the client augments this server located profile and also requests transcoding if lower qualities are selected by you or set in the app settings (e.g. remote quality) or your server's "Remote Access" is broken.

    Furthermore, MP4 is not a codec, it's a container, and says nothing about the video codec (e.g. h264, h265, mpeg4) or audio codec.

    To help you understand why your RPi is transcoding we need at least the following information:

    (1) Android phone model
    (2) Video Info xml (click in the web client on the "..." menu of the problematic movie, click on "Get Info" and then on "View XML"
    (3) "Remote Access" status in the web client server settings
    (4) Server logs AFTER you had attempted playback in the client

    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • wheelshotwheelshot Members, Plex Pass Posts: 5 Plex Pass

    Hi,

    Here's what I got:
    1) Its a Samsung Galaxy Tab (SM-T350)
    2) Here's 2 examples xml attached. I know theres mkv but ive read that mkv should be able to be directplayed as well as MP4 (right?)
    3) Remote access is disabled. The limit is set to Original (no limit)
    4) Server logs are attached

    Thanks a lot for your time!

  • uglymagoouglymagoo Members, Plex Pass, Plex Ninja, TunerTester Posts: 1,083 Plex Ninja

    Please post the logs I had asked for (take a look at the link) :) Where is your logs.txt from? :D

    However, your device has a very low resolution (below 720p) and I believe Plex could restrict the resolution to the maximum of your display. The logs will tell us exactly what is going on.

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • wheelshotwheelshot Members, Plex Pass Posts: 5 Plex Pass

    First, sorry for the delay and second, sorry for the wrong logs haha! I took them in the Web > Debug menu. This one should be better.

    Thanks again for your help Mr. Magoo

  • eckartheckarth Members, Plex Pass Posts: 502 Plex Pass
    Accepted Answer

    These are way too many files and it is hard to locate anything as I do not know at which time your problems arose.

    Anyhow, I found

    May 19, 2018 07:41:26.992 [0x6a1ff400] DEBUG - Request: [192.168.10.11:57687 (Subnet)] GET /video/:/transcode/universal/decision?audioBoost=100&autoAdjustQuality=0&directPlay=0&directStream=1&directStreamAudio=1&fastSeek=1&hasMDE=1&location=lan&maxVideoBitrate=20000&mediaBufferSize=209664&mediaIndex=0&partIndex=0&path=%2Flibrary%2Fmetadata%2F6411&protocol=*&session=eedf205abe01e3e9-com-plexapp-android&subtitleSize=100&videoBitrate=20000&videoQuality=100&videoResolution=1920x1080 (4 live) TLS GZIP Signed-in Token (wheelshot)
    May 19, 2018 07:41:26.993 [0x6a1ff400] DEBUG - Found session GUID of eedf205abe01e3e9-com-plexapp-android in session start.
    May 19, 2018 07:41:26.997 [0x6a1ff400] DEBUG - TranscodeUniversalRequest: using augmented profile Android
    May 19, 2018 07:41:27.002 [0x6a1ff400] DEBUG - Downloading document http://127.0.0.1:32400/library/metadata/6411?includeBandwidths=1&offset=-1&X-Plex-Session-Identifier=eedf205abe01e3e9-com-plexapp-android
    May 19, 2018 07:41:27.004 [0x6a1ff400] DEBUG - Auth: authenticated user 1 as wheelshot
    May 19, 2018 07:41:27.037 [0x6a1ff400] DEBUG - We're going to try to auto-select an audio stream for account 1.
    May 19, 2018 07:41:27.038 [0x6a1ff400] DEBUG - Selecting best audio stream for part ID 18073 (autoselect: 1 language: fr)
    May 19, 2018 07:41:27.038 [0x6a1ff400] DEBUG - Audio Stream: 42013, Subtitle Stream: -1
    May 19, 2018 07:41:27.047 [0x6a1ff400] DEBUG - Scaled up video bitrate to 4029Kbps based on 1.500000x fudge factor.
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: Selected protocol hls; container: mpegts
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: analyzing media item 18071
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): Direct Play is disabled
    May 19, 2018 07:41:27.048 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): media must be transcoded in order to use the hls protocol
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no direct play video profile exists for http/mkv/h264
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no direct play video profile exists for http/mkv/h264/ac3
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.049 [0x6a1ff400] DEBUG - MDE: The Good Dinosaur (2015): no remuxable profile found, so video stream will be transcoded
    May 19, 2018 07:41:27.050 [0x6a1ff400] DEBUG - The Good Dinosaur - video.level limitation applies: 41 > 40
    May 19, 2018 07:41:27.050 [0x6a1ff400] DEBUG - MDE: Cannot direct stream video stream due to profile or setting limitations

    That says 192.168.10.11 aka "wheelshot" wanted to play "The Good Dinosaur." The video stream is encoded in h.264 level 4.1. PMS thinks your device will only accept up to level 4.0. Hence, the video stream needs to be transcoded.

    From the xml file I read

    "bitrate="3326" width="1280" height="536"".

    Any arm device, including all the Pis, will not be able to do that in on-the-fly.

    I feel you only way out is to create optimized versions before hand.

    And, you better stay away from level 4.1 and keep it to level 4.0 while encoding video. Level 4.1 does not gain you that much, but can cause problems with older devices as you are just experiencing.

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,875 Plex Ninja
    edited May 24

    @eckarth said:
    And, you better stay away from level 4.1 and keep it to level 4.0 while encoding video. Level 4.1 does not gain you that much, but can cause problems with older devices as you are just experiencing.

    On many Android devices, you can safely override the accepted level from 4.0 to 4.1
    The only difference between these two is the maximum allowed bitrate. In many many cases files which are marked as 4.1 will play fine on a device which nominally only supports 4.0

    You will find it in the Settings of the Android app, under Advanced, Device, Maximum H.264 Level
    Resist the urge to move it higher up than 4.1 though. It won't work.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • eckartheckarth Members, Plex Pass Posts: 502 Plex Pass

    @OttoKerner: what you are suggesting is a pragmatic hack. However, the server will then direct stream files of bitrates higher than the limit the level 4.0 specs, which is expected to fail. I think it would be proper if the server direct streamed level 4.1 files, anyhow, provided their bitrate is lower then the limit speced in 4.0.

  • wheelshotwheelshot Members, Plex Pass Posts: 5 Plex Pass

    @eckarth said:

    I feel you only way out is to create optimized versions before hand.

    And, you better stay away from level 4.1 and keep it to level 4.0 while encoding video. Level 4.1 does not gain you that much, but can cause problems with older devices as you are just experiencing.

    Ok so, what would be the correct settings to use for say in Handbrake to fit that? Im really green with video enconding and such.

    I followed that PDF attached and I really thought the Pi would be able to just send it as it is to the devices like cell phones and my tablet. Maybe I missed a config somewhere along the lines.

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,875 Plex Ninja

    @wheelshot said:
    Ok so, what would be the correct settings to use for say in Handbrake to fit that? Im really green with video enconding and such.

    That screen shot shows only a part of the relevant parameters.
    Please paste the content of the Plex XML info of this file.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • eckartheckarth Members, Plex Pass Posts: 502 Plex Pass

    That all looks fine. See, it says "encoder level 4.0." However, the file for "The Good Dinosaur" comes with the level set to the value 4.1, which then causes the problem you are experiencing.

    Hence, I think you used settings different from what your screen shot shows when you encoded the Good Dinosaur file.

Sign In or Register to comment.