Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

LG webOS direct play without transcoding

Are you going to fix it?

«1345

Answers

  • edy.bro@gmail.comedy.bro@gmail.com Members Posts: 33 ✭✭

    It works only without subtitles.
    When choosing subs stops working,
    Please not that the third party xplay app works just fine with subs !!!

  • SteveFPSteveFP Members, Plex Pass Posts: 157 Plex Pass

    Could you please clarify. Are you saying that it works when subtitles are turned off or if subtitles do not exist in the content. My gut is telling me you mean that the subtitles do not exist in the content but would be helpful for you to clarify.

  • Cafe DiemCafe Diem Members, Plex Pass Posts: 158 Plex Pass

    They mean when Subtitles are enabled. They can exist in the content without affecting the ability to Direct Play.

    Plex on WebOS can definitely direct play. Almost all models should handle h264. Recent models can direct play h265. A current model with the Early Access beta can even direct play MPEG2. What kind of file is failing to direct play? Check out the section on the right about logs, and you might consider pasting a "Get Info" on the video file in question so we can see what codecs it uses.

  • SteveFPSteveFP Members, Plex Pass Posts: 157 Plex Pass

    Hmmm that is not what I saw. I have a 4K file, with subtitles in the content. I had to strip out all the extra audio and subtitles before it would direct play on my TV. I still had a buffering issue bc the content needs about 70 megs of bandwidth and the ethernet port on the TV is only 100 meg.

    I would be happy to make available the movie on my cloud storage, if you would like to test on your side. It is 52 gig in size.

  • LSL1337LSL1337 Members, Plex Pass Posts: 48 Plex Pass

    did you turn off the subtitles? you don't need to strip it, just turn it off.
    it should direct play than

  • SteveFPSteveFP Members, Plex Pass Posts: 157 Plex Pass

    It did not...only when I removed them did it finally direct play.

  • KrazehKrazeh Members, Plex Pass Posts: 15 Plex Pass

    You said you stripped out extra audio? Are you sure it wasn't an issue with the audio, rather than subtitles?

  • khaztr@gmail.comkhaztr@gmail.com Validating, Plex Pass Posts: 9 Plex Pass

    How can you tell if it's playing direct or not?

    I'm having an issue with video not maintaining a constant speed and therefore going out of sync with the audio, and I think knowing whether it's playing directly will be a helpful first step in solving this.

  • SE56SE56 Members, Plex Pass Posts: 2,290 Plex Pass
    edited May 25

    @khaztr@gmail.com said:
    How can you tell if it's playing direct or not?

    I'm having an issue with video not maintaining a constant speed and therefore going out of sync with the audio, and I think knowing whether it's playing directly will be a helpful first step in solving this.

    You need to go to Plex Media server/ Status/Now playing. Hover the cursor over the Title to gain the information.

    TV:(1). LG 65UB950T UHD Smart TV WebOS 1.4, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • khaztr@gmail.comkhaztr@gmail.com Validating, Plex Pass Posts: 9 Plex Pass

    Thanks! Looks like direct play is working for me only in the sense that the server isn't transcoding. However, as I mentioned above, the video doesn't run at a constant speed and gets way out of sync with the audio. In a sense, direct play isn't working for me either, but in a different way than the OP is mentioning, so I'll be leaving now...

  • edy.bro@gmail.comedy.bro@gmail.com Members Posts: 33 ✭✭
    edited May 26

    I have Synology NAS with LG WebOS TV.
    When I playing any content without subtitles (or disabled) it works fine(no transcoding), but when I enabling subs it doesn't stream, getting errors message that my "server is not powerful enough to convert video", which means that it tries to preform transcoding.
    For me it looks like a bug.
    With Xplay client on same TV works fine with same subs and without transcoding

  • SteveFPSteveFP Members, Plex Pass Posts: 157 Plex Pass

    I am hoping its a bug.

  • edy.bro@gmail.comedy.bro@gmail.com Members Posts: 33 ✭✭

    is there someone from PLEX support in this forum?

  • jmelz28jmelz28 Members Posts: 46 ✭✭
    edited May 26

    @edy.bro@gmail.com said:
    I have Synology NAS with LG WebOS TV.
    When I playing any content without subtitles (or disabled) it works fine(no transcoding), but when I enabling subs it doesn't stream, getting errors message that my "server is not powerful enough to convert video", which means that it tries to preform transcoding.
    For me it looks like a bug.
    With Xplay client on same TV works fine with same subs and without transcoding

    Same exact situation here with a netgear readynas 102 running latest firmware and plex from it. Really furstrating that I have to resort to paying for a russian app to do what I bought the tv for :(

    Everything I've read points to the profile that plex uses on the tv. Xplay uses a better profile that actually mirrors what the tv is capable of, rather than this garbage profile used by plex.

    EDIT: I have found, just now, an inconvenient workaround that may help the developers fix the issue. If you use the web browser on the LG webos tv, you can go to plex.tv and use the web interface. Videos play fine, just like xplay. It's obvious the problem lies with the plex app profile.

  • edy.bro@gmail.comedy.bro@gmail.com Members Posts: 33 ✭✭

    you are right... just verified it.
    now we just need the fix for the webos app.

  • jmelz28jmelz28 Members Posts: 46 ✭✭

    I suggest everyone send messages to this plex employee with logs:

    https://forums.plex.tv/discussion/comment/1624110/#Comment_1624110

  • ChuckPAChuckPA Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 22,850 Plex Team Member

    To all reading.

    There appear to be a few issues floating around.

    Before sending off logs, kindly verify the subtitle settings in the app itself. Some apps were found to be set as "ALWAYS BURN" Subtitles.
    This isn't a bug. It's working as instructed by the user setting.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • ChuckPAChuckPA Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 22,850 Plex Team Member
    edited May 27

    Plex/Web and the Plex.tv settings provide control of this. It is independent of the app itself.
    The TV app itself does not yet have integrated control. They are working on this.

    Control the settings here.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • ChuckPAChuckPA Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 22,850 Plex Team Member

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • edy.bro@gmail.comedy.bro@gmail.com Members Posts: 33 ✭✭

    so what should i configure to get subs working without transcoding? I tried every settings but still doesnt work...
    LG web browser and Xplay app works fine with same plex server settings and video, working with subs without transcoding

«1345
Sign In or Register to comment.