Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

S4U - undertexter

kire012kire012 Posts: 72Members, Plex Pass Plex Pass
Hej


Jag har installerat S4U på min ReadyNas (Linux) och får följande meddelande i PlexMediaServer.Log :

Nov 28, 2011 06:51:37 [0xf098bb90] DEBUG - Starting plug-in /root/Library/Application Support/Plex Media Server/Plug-ins/s4u.se Metadata Agent (Svenska undertexter).bundle.
Nov 28, 2011 06:51:37 [0xf098bb90] DEBUG - Perfect cache hit, we don't need to start [com.plexapp.agents.s4u] yet.


Någon som vet vad det betyder?

Mvh

Erik
«1

Comments

  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    kire012 wrote:

    Hej


    Jag har installerat S4U på min ReadyNas (Linux) och får följande meddelande i PlexMediaServer.Log :

    Nov 28, 2011 06:51:37 [0xf098bb90] DEBUG - Starting plug-in /root/Library/Application Support/Plex Media Server/Plug-ins/s4u.se Metadata Agent (Svenska undertexter).bundle.
    Nov 28, 2011 06:51:37 [0xf098bb90] DEBUG - Perfect cache hit, we don't need to start [com.plexapp.agents.s4u] yet.


    Någon som vet vad det betyder?

    Mvh

    Erik

    Det är ett helt normalt meddelande som du kan bortse ifrån. Har du problem med pluggen?
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    atrus wrote:

    Det är ett helt normalt meddelande som du kan bortse ifrån. Har du problem med pluggen?


    Jag tycker inte jag kan upptäcka någon skillnad efter jag kört ett par uppdateringar. Jag kan inte heller hitta något i loggen om eventuell download av texter som skett. Var exakt skall S4Us aktivitet framgå. Är det i PlexMediaServer.Log eller möjligen någon annan logfil?


    Mvh

    Erik
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    kire012 wrote:

    Jag tycker inte jag kan upptäcka någon skillnad efter jag kört ett par uppdateringar. Jag kan inte heller hitta något i loggen om eventuell download av texter som skett. Var exakt skall S4Us aktivitet framgå. Är det i PlexMediaServer.Log eller möjligen någon annan logfil?


    Mvh

    Erik

    ~/Library/Logs/PMS Plugin Logs/com.plexapp.agents.s4u.log om du kör Mac. Den loggen du sa tidigare att du hittat. Lägg upp den här så ska jag ta mig en titt.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    Hej


    Jag försöker ladda upp filen men jag får meddelandet "Error You aren't permitted to upload this kind of file" hela tiden. Vad beror det på?

    Mvh

    Erik
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    kire012 wrote:

    Hej


    Jag försöker ladda upp filen men jag får meddelandet "Error You aren't permitted to upload this kind of file" hela tiden. Vad beror det på?

    Mvh

    Erik

    Byt suffix till txt eller zippa den.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    atrus wrote:

    Byt suffix till txt eller zippa den.



    Hej


    Jag provade att byta till .txt innan men det gick inte heller. Men Zip gick bra så här kommer den. Kan du se något märkligt?

    Mvh

    Erik
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    kire012 wrote:

    Hej


    Jag provade att byta till .txt innan men det gick inte heller. Men Zip gick bra så här kommer den. Kan du se något märkligt?

    Mvh

    Erik

    Om jag inte minns fel så är det där exakt samma fel som det var i den gamla versionen. Ingen aning dock vad du gör för fel (om det nu är du som gör fel, det vet vi inte ännu). Har du läst igenom hela denna tråden: http://forums.plexapp.com/index.php/topic/30069-s4use-svenska-undertexter-agent/
    ?
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    Ah, och dubbelkolla så du inte har två s4u bundles i plug-ins-mappen. Ser att du döpt denna till "s4u.se Metadata Agent (Svenska undertexter).bundle". Kollar om du har någon annan som heter något med s4u.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    atrus wrote:

    Ah, och dubbelkolla så du inte har två s4u bundles i plug-ins-mappen. Ser att du döpt denna till "s4u.se Metadata Agent (Svenska undertexter).bundle". Kollar om du har någon annan som heter något med s4u.



    Hej igen


    Nu har jag kollat enligt dina instruktioner och jag har bara 1 s4u i aktuellt bibliotek. Jag har även läst din tråden som du hänvisade mig till och bytt ut "__init__.py" filen till den nya och scannat igen. Ingen skillnad! Jag har dessutom installerat Podnapisi och den verkar scanna och ladda ner några konstigt benämnda undertextfiler men de dyker inte upp i själva filmen när jag "bläddrar" med S-knappen.

    Jag bifogar de senaste loggarna från S4u och Podnapisi.

    Tacksam för all hjälp.

    Mvh

    Erik
  • CoilCoil Posts: 280Members ✭✭
    Hej. Podnapisiloggen ser helt korrekt ut.
    Slår du på enable subtitles när du kollar på filmen så skall du sen kunna välja vilken du vill använda av de som laddats ner.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    Coil wrote:

    Hej. Podnapisiloggen ser helt korrekt ut.
    Slår du på enable subtitles när du kollar på filmen så skall du sen kunna välja vilken du vill använda av de som laddats ner.



    Hej

    Det är det som är problemet. När jag leker med "S" så får jag aldrig upp några Svenska texter på de filmer som inte hade det från början. Normalt borde det ju läggas en srt fil med samma namn som filmen i samma bibliotek men det händer inte. Det som händer med Podnapisi är på sin höjd att en fil med något långt okänt namn läggs i ett helt annat bibliotek som uppenbarligen inte känns igen av Plex. Jag har ingen aning hur jag skall gå vidare.

    Mvh

    Erik
  • CoilCoil Posts: 280Members ✭✭
    kire012 wrote:

    Hej

    Det är det som är problemet. När jag leker med "S" så får jag aldrig upp några Svenska texter på de filmer som inte hade det från början. Normalt borde det ju läggas en srt fil med samma namn som filmen i samma bibliotek men det händer inte. Det som händer med Podnapisi är på sin höjd att en fil med något långt okänt namn läggs i ett helt annat bibliotek som uppenbarligen inte känns igen av Plex. Jag har ingen aning hur jag skall gå vidare.

    Mvh

    Erik


    Podnapisi har inte sökt på några svenska subtitles i din logg, bara engelska. Det är nog en del av problemet :) Har du ställt in den rätt med svenska som andra språk? Testa att sätta svenska som första språk kanske.

    Podnapisi gör inte som s4u och manuellt sparar en .srt-fil i samma katalog som filen. Podnapisi lägger till den via Plex metadata funktion så du behöver aldrig väla "Browse for subtitles". Filen sparas istället i Plex egna hierarki med metadata.
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2011
    Plus att S-knappen inte bläddrar mellan flera undertexter. S slår bara av eller på dom. L-knappen däremot bläddrar bland dina undertexter ifall undertexterna är påslagna.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    Coil wrote:

    Podnapisi har inte sökt på några svenska subtitles i din logg, bara engelska. Det är nog en del av problemet :) Har du ställt in den rätt med svenska som andra språk? Testa att sätta svenska som första språk kanske.

    Podnapisi gör inte som s4u och manuellt sparar en .srt-fil i samma katalog som filen. Podnapisi lägger till den via Plex metadata funktion så du behöver aldrig väla "Browse for subtitles". Filen sparas istället i Plex egna hierarki med metadata.



    Hej

    Tack för svaret men om det är språket i PMM så står där i tur och ordning: Svenska, Alltid på, Svenska. Vad menade du med andra språk? Jag kör PMM på ett ReadyNas och hittar inte någonstans jag kan välja första och andra språk.

    Mvh

    Erik
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    Det där är den generella undertexthanteringen för PMS. Det Coil säger är att du måste ställa in i agenten att du vill ladda hem engelska och svenska. Gå in i din sektion i PMS, klicka på kugghjulet, markera theTVdb till vänster (för tv-serier) eller Freebase (för filmer) och markera podnapisi-agenten och klicka på inställningsknappen som syns där.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    edited December 2011
    atrus wrote:

    Det där är den generella undertexthanteringen för PMS. Det Coil säger är att du måste ställa in i agenten att du vill ladda hem engelska och svenska. Gå in i din sektion i PMS, klicka på kugghjulet, markera theTVdb till vänster (för tv-serier) eller Freebase (för filmer) och markera podnapisi-agenten och klicka på inställningsknappen som syns där.



    Tack för svaret. Jag kör dock PMS på ett ReadyNas och det ser inte ut riktigt som du beskriver. Dock framgår det av bifogad bild att svenska är valt. Dock kan jag inte göra något enskilt val för podnapisi utan får göra ett övergripande för Freebase.

    Kan det vara något annat kanske?

    Mvh

    Erik
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    kire012 wrote:

    Tack för svaret. Jag kör dock PMS på ett ReadyNas och det ser inte ut riktigt som du beskriver. Dock framgår det av bifogad bild att svenska är valt. Dock kan jag inte göra något enskilt val för podnapisi utan får göra ett övergripande för Freebase.

    Kan det vara något annat kanske?

    Mvh

    Erik

    Bah, nu förstår jag vad du menar. Nej, det där valet har inget med undertexterna att göra.
    Det man ska göra är att man ska klicka på Preferences-knappen och gå till "Agents". Där hittar man det jag beskrev. Men jag ser nu att webbgränssnittet inte visar inställningsknappen för en Agent, vilket dock fungerar bra i OSX-interfacet. Ska fråga Elan och se vad han har att säga om detta. Återkommer.
  • atrusatrus Posts: 11,166Members, Plex Pass, Plex Ninja Plex Ninja
    Hittade en lösning. Tror jag. Funkar iaf på Macen, och jag gissar att det går göra ungefär samma sak i ditt ReadyNAS.
    I din Plex Media Server-mapp (som i OSX ligger här:
    ~/Library/Application Support/Plex Media Server/
    
    ) så har du en mapp som heter "Plug-in Support". I den mappen så finns en mapp som heter "Preferences". I den mappen så ska det finnas en fil som heter "com.plexapp.agents.podnapisi.xml". Om det inte gör det, skapa den och öppna den filen och klistra in följande:
    <?xml version='1.0' encoding='utf-8'?>
    <PluginPreferences>
      <langPref1>37</langPref1>
      <langPref2>11</langPref2>
    </PluginPreferences>
    


    Ovanstående betyder att Podnapisi laddar hem svenska och engelska undertexter ifall den hittar några.
    Det där fungerar i OSX iaf. Ska bli spännande att höra ifall det funkar i Linux också.
  • kire012kire012 Posts: 72Members, Plex Pass Plex Pass
    atrus wrote:

    Hittade en lösning. Tror jag. Funkar iaf på Macen, och jag gissar att det går göra ungefär samma sak i ditt ReadyNAS.
    I din Plex Media Server-mapp (som i OSX ligger här:
    ~/Library/Application Support/Plex Media Server/
    
    ) så har du en mapp som heter "Plug-in Support". I den mappen så finns en mapp som heter "Preferences". I den mappen så ska det finnas en fil som heter "com.plexapp.agents.podnapisi.xml". Om det inte gör det, skapa den och öppna den filen och klistra in följande:
    <?xml version='1.0' encoding='utf-8'?>
    <PluginPreferences>
      <langPref1>37</langPref1>
      <langPref2>11</langPref2>
    </PluginPreferences>
    


    Ovanstående betyder att Podnapisi laddar hem svenska och engelska undertexter ifall den hittar några.
    Det där fungerar i OSX iaf. Ska bli spännande att höra ifall det funkar i Linux också.




    Hej

    Tack för din hjälp. Det verkar fungera med att den försöker ladda ner texter nu. Dock verkar den inte hitta några texter, framförallt inga svenska texter.

    Skall jag ladda upp nya loggar ?

    Mvh

    Erik
  • CoilCoil Posts: 280Members ✭✭
    kire012 wrote:

    Hej

    Tack för din hjälp. Det verkar fungera med att den försöker ladda ner texter nu. Dock verkar den inte hitta några texter, framförallt inga svenska texter.

    Skall jag ladda upp nya loggar ?

    Mvh

    Erik


    Är du säker på att det finns svenska subs för det du söker på? Dubbelkolla gärna med manuella sökningar på podnapisi först. I loggarna finns det en print typ:
    2011-12-03 10:32:46,305 (-b135470) : INFO (__init__:41) - searchUrl: http://www.podnapisi.net/en/ppodnapisi/search?tbsl=3&sK=Transformers:+Dark+of+the+Moon&sR=1080&sJ=2

    Som är en direktlänk till själva sökningen. Testa att manuellt köra dessa i din browser och se om du får resultat på svenska.
    I slutet på urlen så ser du "sJ=2" det indikerar att det är engelska subs den söker efter..
    Om du vill hitta dem som söker efter svenska subs så skall där istället stå "sJ=25".
«1
Sign In or Register to comment.