Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Most of my video files will not play.

I recently installed plex server on my pc, The UI and coverart layout is amazing. I have plex installed on my laptop, all videos play perfectly. On my google tv most videos do not play. I get an error that says "There was a problem with media playback". It doesnt seem to matter what the file type is, some avi will play, some will not. Some mkv will play, some will not. I would love to be able to use plex but it needs to play more than 30% of my videos. Is there anything i can do to get the rest of the vid's playing properly??

Thanks

Comments

  • Fuzzman88Fuzzman88 Posts: 18Members, Plex Pass Plex Pass
    The problem is that the .mkv is just a "container" for video and audio streams. Download a program called MediaInfo and use it to check your files. You will likely see that the files that won't play have unsupported codecs inside the .mkv container.

    Here's a link: http://mediainfo.sourceforge.net/en
  • night_shadenight_shade Posts: 42Members

    I recently installed plex server on my pc, The UI and coverart layout is amazing. I have plex installed on my laptop, all videos play perfectly. On my google tv most videos do not play. I get an error that says "There was a problem with media playback". It doesnt seem to matter what the file type is, some avi will play, some will not. Some mkv will play, some will not. I would love to be able to use plex but it needs to play more than 30% of my videos. Is there anything i can do to get the rest of the vid's playing properly??

    Thanks


    I am new to plex and a newbie but I just wanted to say that I had some trouble getting my avi files to play then, as suggested by someone in the chat,i re-named my files in a way that makes plex happy using this: http://wiki.plexapp.com/index.php/PlexNine_PMS_Naming_Guide and now all my files play correctly. I have a folder movies > the movie files inside. And for TV it's folder with series name> folder with season # > s01e01 (for example)

    don't know if that's gonna help but just wanted to put it out there
  • Plumbing108Plumbing108 Posts: 1Members
    edited December 2011
    Your post is highly informative. I appreciate your efforts.
  • night_shadenight_shade Posts: 42Members

    I am new to plex and a newbie but I just wanted to say that I had some trouble getting my avi files to play then, as suggested by someone in the chat,i re-named my files in a way that makes plex happy using this: http://wiki.plexapp.com/index.php/PlexNine_PMS_Naming_Guide and now all my files play correctly. I have a folder movies > the movie files inside. And for TV it's folder with series name> folder with season # > s01e01 (for example)

    don't know if that's gonna help but just wanted to put it out there


    Correction, I have come across a couple of files that won't play, I get the "we're sorry but there was a problem attempting to play. (then the name of the file)
    There was a problem with media playback. "

    So I guess there is still something wrong with some files.
  • computercodes@hotmail.comcomputercodes@hotmail.com Posts: 1Members, Plex Pass
    edited December 2011

    Correction, I have come across a couple of files that won't play, I get the "we're sorry but there was a problem attempting to play. (then the name of the file)
    There was a problem with media playback. "

    So I guess there is still something wrong with some files.



    I can't get any of my files to play. I'm attempting to use myPlex from one home to another. I get the same error time and time again regardless of file type or naming convention. Is anyone else having problems like this? Home 1 (server) to Home 2 (Google TV Logitech Revue). I am able to play these files using my plex phone app. So I find it weird that I can't watch it on my Revue, but it works fine on both my tablet (TF101) and my Galaxy Nexus LTE.
Sign In or Register to comment.