Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Jailbreaking and Installing Plex on your ATV2

135678

Comments

  • tobiashietatobiashieta Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 5,524 Plex Employee
    SvenJ wrote:

    Thanks for rapid response.
    I missed to logon to my account under myPles Settings, after that I have Queue as a menu a option.
    The server is shared and I can see it under servers at my.plexapp.com.
    I can access it from my iPhone, but not from the ATV.
    Where should it show up? Under server list? If so does it take long time?

    // Sven


    If it's accessible, it should show up pretty quickly. If not, please use NSLogger to extract logs and post them to a ticket in LightHouse and I will look at it when I have time.
  • SvenJSvenJ Members Posts: 3

    If it's accessible, it should show up pretty quickly. If not, please use NSLogger to extract logs and post them to a ticket in LightHouse and I will look at it when I have time.


    Thanks again!
    I logged out and restarted the ATV then logged in again and now it works.
    Thanks for all the help!

    // Sven
  • XtoastXtoast Members Posts: 3
    edited February 2012
    so which version runs best on 4.4.4 ? the latest?
    I ran the terminal commands and it looks like it took but I have no plex


    Apple-TV:~ root# echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
    Apple-TV:~ root# wget http://nightlies.plexapp.com/plex-atv-plugin/repo/com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    wget: Syntax error in /usr/etc/wgetrc at line 1.
    --2012-02-08 13:40:16-- http://nightlies.plexapp.com/plex-atv-plugin/repo/com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    Resolving nightlies.plexapp.com... 217.211.254.45
    Connecting to nightlies.plexapp.com|217.211.254.45|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 784 [application/octet-stream]
    Saving to: `com.plexapp.repo.beta_1.0_iphoneos-arm.deb'

    100%[=======================================>] 784 --.-K/s in 0.001s

    2012-02-08 13:40:32 (992 KB/s) - `com.plexapp.repo.beta_1.0_iphoneos-arm.deb' saved [784/784]

    Apple-TV:~ root# dpkg -i com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    Selecting previously deselected package com.plexapp.repo.beta.
    (Reading database ... 1277 files and directories currently installed.)
    Unpacking com.plexapp.repo.beta (from com.plexapp.repo.beta_1.0_iphoneos-arm.deb) ...
    Setting up com.plexapp.repo.beta (1.0) ...
    Apple-TV:~ root# apt-get update
    Ign http://nightlies.plexapp.com beta Release.gpg
    Get:1 http://apt.thebigboss.org stable Release.gpg [197B]
    Hit http://apt.saurik.com tangelo-3.7 Release.gpg
    Get:2 http://apt.modmyi.com stable Release.gpg [189B]
    Hit http://nitosoft.com Release.gpg
    Ign http://mirrors.xbmc.org ./ Release.gpg
    Ign http://www.ambertation.de ./downloads/PLEX/ Release.gpg
    Get:3 http://nightlies.plexapp.com beta Release [968B]
    Get:4 http://apt.thebigboss.org stable Release [1007B]
    Hit http://apt.saurik.com tangelo-3.7 Release
    Get:5 http://apt.modmyi.com stable Release [1331B]
    Hit http://nitosoft.com Release
    Ign http://www.ambertation.de ./downloads/PLEX/ Release
    Ign http://mirrors.xbmc.org ./ Release
    Get:6 http://apt.thebigboss.org stable/main Packages/DiffIndex [588B]
    Get:7 http://apt.modmyi.com stable/main Packages/DiffIndex [3777B]
    Ign http://nitosoft.com Packages/DiffIndex
    Ign http://nightlies.plexapp.com beta/main Packages
    Ign http://apt.saurik.com tangelo-3.7/main Packages/DiffIndex
    Ign http://www.ambertation.de ./downloads/PLEX/ Packages/DiffIndex
    Hit http://apt.saurik.com tangelo-3.7/main Packages
    Hit http://nitosoft.com Packages
    Ign http://nightlies.plexapp.com beta/main Packages
    Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
    Hit http://www.ambertation.de ./downloads/PLEX/ Packages
    Get:8 http://apt.modmyi.com stable/main Packages [1909kB]
    Get:9 http://nightlies.plexapp.com beta/main Packages [621B]
    Hit http://mirrors.xbmc.org ./ Packages
    Get:10 http://apt.thebigboss.org stable/main Packages [869kB]
    Hit http://apt.awkwardtv.org stable Release.gpg
    Get:11 http://cydia.zodttd.com stable Release.gpg [189B]
    Hit http://apt.awkwardtv.org stable Release
    Get:12 http://cydia.zodttd.com stable Release [1616B]
    Get:13 http://apt.awkwardtv.org stable/main Packages/DiffIndex [4449B]
    Get:14 http://cydia.zodttd.com stable/main Packages/DiffIndex [3756B]
    Get:15 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Get:16 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Get:17 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Fetched 2799kB in 4min 8s (11.2kB/s)
    Reading package lists... Done

    then ran:

    Apple-TV:~ root# killall AppleTV

    but no plex even after reboot

    thanks for any help
  • XtoastXtoast Members Posts: 3
    Xtoast wrote:

    so which version runs best on 4.4.4 ? the latest?
    I ran the terminal commands and it looks like it took but I have no plex


    Apple-TV:~ root# echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
    Apple-TV:~ root# wget http://nightlies.plexapp.com/plex-atv-plugin/repo/com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    wget: Syntax error in /usr/etc/wgetrc at line 1.
    --2012-02-08 13:40:16-- http://nightlies.plexapp.com/plex-atv-plugin/repo/com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    Resolving nightlies.plexapp.com... 217.211.254.45
    Connecting to nightlies.plexapp.com|217.211.254.45|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 784 [application/octet-stream]
    Saving to: `com.plexapp.repo.beta_1.0_iphoneos-arm.deb'

    100%[=======================================>] 784 --.-K/s in 0.001s

    2012-02-08 13:40:32 (992 KB/s) - `com.plexapp.repo.beta_1.0_iphoneos-arm.deb' saved [784/784]

    Apple-TV:~ root# dpkg -i com.plexapp.repo.beta_1.0_iphoneos-arm.deb
    Selecting previously deselected package com.plexapp.repo.beta.
    (Reading database ... 1277 files and directories currently installed.)
    Unpacking com.plexapp.repo.beta (from com.plexapp.repo.beta_1.0_iphoneos-arm.deb) ...
    Setting up com.plexapp.repo.beta (1.0) ...
    Apple-TV:~ root# apt-get update
    Ign http://nightlies.plexapp.com beta Release.gpg
    Get:1 http://apt.thebigboss.org stable Release.gpg [197B]
    Hit http://apt.saurik.com tangelo-3.7 Release.gpg
    Get:2 http://apt.modmyi.com stable Release.gpg [189B]
    Hit http://nitosoft.com Release.gpg
    Ign http://mirrors.xbmc.org ./ Release.gpg
    Ign http://www.ambertation.de ./downloads/PLEX/ Release.gpg
    Get:3 http://nightlies.plexapp.com beta Release [968B]
    Get:4 http://apt.thebigboss.org stable Release [1007B]
    Hit http://apt.saurik.com tangelo-3.7 Release
    Get:5 http://apt.modmyi.com stable Release [1331B]
    Hit http://nitosoft.com Release
    Ign http://www.ambertation.de ./downloads/PLEX/ Release
    Ign http://mirrors.xbmc.org ./ Release
    Get:6 http://apt.thebigboss.org stable/main Packages/DiffIndex [588B]
    Get:7 http://apt.modmyi.com stable/main Packages/DiffIndex [3777B]
    Ign http://nitosoft.com Packages/DiffIndex
    Ign http://nightlies.plexapp.com beta/main Packages
    Ign http://apt.saurik.com tangelo-3.7/main Packages/DiffIndex
    Ign http://www.ambertation.de ./downloads/PLEX/ Packages/DiffIndex
    Hit http://apt.saurik.com tangelo-3.7/main Packages
    Hit http://nitosoft.com Packages
    Ign http://nightlies.plexapp.com beta/main Packages
    Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
    Hit http://www.ambertation.de ./downloads/PLEX/ Packages
    Get:8 http://apt.modmyi.com stable/main Packages [1909kB]
    Get:9 http://nightlies.plexapp.com beta/main Packages [621B]
    Hit http://mirrors.xbmc.org ./ Packages
    Get:10 http://apt.thebigboss.org stable/main Packages [869kB]
    Hit http://apt.awkwardtv.org stable Release.gpg
    Get:11 http://cydia.zodttd.com stable Release.gpg [189B]
    Hit http://apt.awkwardtv.org stable Release
    Get:12 http://cydia.zodttd.com stable Release [1616B]
    Get:13 http://apt.awkwardtv.org stable/main Packages/DiffIndex [4449B]
    Get:14 http://cydia.zodttd.com stable/main Packages/DiffIndex [3756B]
    Get:15 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Get:16 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Get:17 http://cydia.zodttd.com stable/main 2012-02-08-1900.04+2012-02-08-2100.08.pdiff [2265B]
    Fetched 2799kB in 4min 8s (11.2kB/s)
    Reading package lists... Done

    then ran:

    Apple-TV:~ root# killall AppleTV

    but no plex even after reboot

    thanks for any help
  • XtoastXtoast Members Posts: 3
    ok another try and a reboot from the remote and it worked. I didn't get the killall appleTV to work but reboot from remote did yay!
  • israrisrar Members, Plex Pass Posts: 25 Plex Pass
    awesome. i just jailbroke and installed plex on my atv for the first time. I am quite a noob at this. But this was quite easy. Thanks a lot. Off to trying plex now on atv
  • MethanoidMethanoid Members Posts: 18 ✭✭
    I had Plex 0.8.3 on my ATV2 for several months and used this to "install" 0.10 but it still says 0.8.3 - SHOULD IT? Or does it actually say 0.10 in the about screen?
  • baabaa Members, Plex Pass, Forum Moderator Posts: 3,954 Forum Mod
    Methanoid wrote:

    I had Plex 0.8.3 on my ATV2 for several months and used this to "install" 0.10 but it still says 0.8.3 - SHOULD IT? Or does it actually say 0.10 in the about screen?

    Yes... should say 0.10...
    Which iOS version are you running? I think 0.10 does not support the older ones any more. Did you also update your aTV to 4.4.4?
  • MethanoidMethanoid Members Posts: 18 ✭✭
    baa wrote:

    Yes... should say 0.10...
    Which iOS version are you running? I think 0.10 does not support the older ones any more. Did you also update your aTV to 4.4.4?


    4.3 iOS... I read on XBMC.org that they recommend NOT updating to 4.4.4 and I also run XBMC (or try to!).
  • tobiashietatobiashieta Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 5,524 Plex Employee
    4.3 should work. File a bug with logs.
  • MethanoidMethanoid Members Posts: 18 ✭✭

    4.3 should work. File a bug with logs.


    Thanks, sorted it by uninstalling BOTH parts of Plex

    dpkg -l to list what was there
    dpkg -r to uninstall BOTH com.plex**** bits (there were two!)

    Unfortunately Plex 0.10 is still not finding Subtitle files, which my son thought was hilarious. "All that effort to watch Borgen, Dad, and the subs still not there!!". Nice boy! :angry:
  • tobiashietatobiashieta Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 5,524 Plex Employee
    Methanoid wrote:

    Thanks, sorted it by uninstalling BOTH parts of Plex

    dpkg -l to list what was there
    dpkg -r to uninstall BOTH com.plex**** bits (there were two!)

    Unfortunately Plex 0.10 is still not finding Subtitle files, which my son thought was hilarious. "All that effort to watch Borgen, Dad, and the subs still not there!!". Nice boy! :angry:


    Subtitles are handled by PMS, not Plex for ATV. Check the logs.
  • lee.eldred@me.comlee.eldred@me.com Members Posts: 1
    Hi, Could any one shed some light on a few problems i am having. i am a total novice and this is all new to me so please be patient with me. i am trying to install plex onto my new apple tv 2. so far i think i have jail broken it with season pass (as the fc logo appears on my apple tv) the main problem i am having is installing the plex app into my atv2 i have got to the part in the terminal (I'm using a mac) where it says apple tv root but can't seem to install past this point? when i drag the installer into the terminal it says no such file or directory. i have typed cd then a space but that is all it says. if i restart the terminal and drag the installer into terminal it it will go through an install but I'm guessing this is not in the atv?

    I apologies again for my lack of knowledge but we all have to start somewhere i guess!!

    Lee
  • whodeanwhodean Members, Plex Pass Posts: 80 Plex Pass
    Has anyone else lost nbatv capability on the AppleTV after the latest jailbreak?
  • phaseshiftphaseshift Members Posts: 68 Plex Pass
    I have a question, I'm thinking of possibly buying an apple tv in the future once it supports 1080p or maybe just buy apple tv2 now but anyway my question is I currently run the Plex Media Server on my mac mini, will I be able to set the apple tv to connect to my PMS?
  • tobiashietatobiashieta Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 5,524 Plex Employee
    phaseshift wrote:

    I have a question, I'm thinking of possibly buying an apple tv in the future once it supports 1080p or maybe just buy apple tv2 now but anyway my question is I currently run the Plex Media Server on my mac mini, will I be able to set the apple tv to connect to my PMS?


    Yes
  • cthorp7@gmail.comcthorp7@gmail.com Members Posts: 2
    Hi,

    Help !! In trying to set up Plex on my new AppleTV I've managed to stuff something up and now it won't even boot up.

    I managed to jb it ok and then followed the following commands via putty to get Plex installed:
    1. echo "deb http://awkwardtv.dyndns.tv ./" > /etc/apt/sources.list.d/awkwardtv.list
    2. echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
    3. apt-get update
    4. apt-get install com.plex.client-plugin
    5. killall AppleTV

    I got these from some youtube video .. i notice they aren't quite the same as the posting here.

    Anyway ... my AppleTV won't even start now. When I cut the juice and power up again i see the apple logo, then the screen gloes black, flickers a bit, and stays black.

    Any suggestions are most welcome. I dare not plug my Apple TV directly into my PC and try to restore via iTunes as that will brick-it, I suspect.

    Cheers,
    CT.
  • cthorp7@gmail.comcthorp7@gmail.com Members Posts: 2
    ct777 wrote:

    Hi,

    Help !! In trying to set up Plex on my new AppleTV I've managed to stuff something up and now it won't even boot up.

    I managed to jb it ok and then followed the following commands via putty to get Plex installed:
    1. echo "deb http://awkwardtv.dyndns.tv ./" > /etc/apt/sources.list.d/awkwardtv.list
    2. echo "deb http://www.ambertation.de ./downloads/PLEX/" > /etc/apt/sources.list.d/plex.list
    3. apt-get update
    4. apt-get install com.plex.client-plugin
    5. killall AppleTV

    I got these from some youtube video .. i notice they aren't quite the same as the posting here.

    Anyway ... my AppleTV won't even start now. When I cut the juice and power up again i see the apple logo, then the screen gloes black, flickers a bit, and stays black.

    Any suggestions are most welcome. I dare not plug my Apple TV directly into my PC and try to restore via iTunes as that will brick-it, I suspect.

    Cheers,
    CT.



    Got it working ! I did the master reset with the AppleTV remote (hold down-arrow and menu for 7 secs) and then Putty'd into it again to repeat the whole process (jailbreak and load PLEX) following the instructions on this forum .... and it all works !
  • Ronin_NgRonin_Ng Members, Plex Pass Posts: 29 Plex Pass
    ct777 wrote:

    Got it working ! I did the master reset with the AppleTV remote (hold down-arrow and menu for 7 secs) and then Putty'd into it again to repeat the whole process (jailbreak and load PLEX) following the instructions on this forum .... and it all works !


    Thanks, that's great to know. I got caught also when I tried to install PLEX the first time. Before I found this post! Good to know about the master reset!
  • djmayhemdjmayhem Members, Plex Pass Posts: 70 Plex Pass
    Accidentally updated to 5.1. There are guides out there for rolling it back to 4.4.4... can't get it to go into dfu mode with redsnow to save my life.

    Sigh.
Sign In or Register to comment.