If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Jailbreaking and Installing Plex on your ATV2

124678

Comments

  • boots2xboots2x IP Challenged Ninja Posts: 1,184Members, Plex Pass, Plex Ninja Plex Ninja
    Sigh indeed... I don't think there's currently a reliable way to get back down to 4.4.4. Check the Firecore forums out... http://forum.firecore.com/137

    James

    These resources are your friends! The Plex Help Center | The Plex Forums | Forum Search is DEFINITELY your friend!

    Check the Plex Media Preparation Guide! | Learn how to collect Log filesGet MediaInfo to analyse video files

    Plex Media Server: Mac OS X and ReadyNAS Pro 6 | Plex Clients: Mac Mini 2010 2.66Ghz, 2Gb RAM, AppleTV Gen 2, iPhone 3GS | LG 56" DLP-TV | Sherwood AV Amp | Storage: ReadyNAS Pro 6 with 6 x 2Gb Hitachi HDD for 8Tb storage | Network: Cat 6 cabled, 1000BaseT

  • milindnmilindn Posts: 5Members
    Folks Please need your help. Had this working and now its not. Don't know what really changed. Sonnection and browsing works fine will just not play any video. It just says 'An Error Occured...'. Have tried both versions of the PMS server (this is on a Mac), Only one client working which is a Win 7 HTPC. All others iPad, iphone, android (touchpad) and atv 2 same issue - shows the lisings (browse) but will not play any video!
  • tobiashietatobiashieta Plex Dev Team Posts: 5,524Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    milindn wrote:

    Folks Please need your help. Had this working and now its not. Don't know what really changed. Sonnection and browsing works fine will just not play any video. It just says 'An Error Occured...'. Have tried both versions of the PMS server (this is on a Mac), Only one client working which is a Win 7 HTPC. All others iPad, iphone, android (touchpad) and atv 2 same issue - shows the lisings (browse) but will not play any video!


    Can you post logs?

    Follow me on twitter @tobiashieta or G+

  • milindnmilindn Posts: 5Members
    edited March 2012

    Can you post logs?

    Thank You so much!! Appreciate your help!
    Sure thing. How do I get them?

    NVM: found them and sent both ATV and Plex Media Server logs to you in pm.
  • platinumplatinum Posts: 12Members
    am i still asleep? where is the link to 0.9 Beta? for apple TV2
  • Trial_MasterTrial_Master Posts: 15Members
    Hello

    I'm a little confused if I can jailbreak or not. I am looking to purchase a secondhand atv2 with 4.4 installed. Can this be jailbreaked without blobs?

    Sorry for dumb question I've read a fair bit on forums before asking question.
  • FrozenTroutFrozenTrout Posts: 37Members, Plex Pass Plex Pass
    edited March 2012
    As long as you still have 4.4.4 (and probably earlier) installed on your Apple TV, and access to Windows, it's still possible to jailbreak. http://forum.firecore.com/topic/7279 has some directions.

    When my Apple TV arrived, it had 4.4.4, but 5.0 was already out and Apple stopped signing earlier 4.x firmware, so I couldn't get the blobs from Tiny Umbrella. I did get the blobs from iFaith, and tried following some directions to get it to work, but iTunes kept giving errors, and by the end it wouldn't even boot; I had to then update to 5.0. I had pretty much resigned myself to using my iPad to send Plex via airplay to the ATV. Then I found these directions, and decided to give it one last shot last night; it actually worked! I managed to install jailbroken 4.4.4 over 5.0, and now have Plex on my ATV :D

    I hope this is helpful to anyone still on clean 4.4.4, or on 5.0 with iFaith blobs for 4.4.4!
  • Trial_MasterTrial_Master Posts: 15Members

    As long as you still have 4.4.4 (and probably earlier) installed on your Apple TV, and access to Windows, it's still possible to jailbreak. http://forum.firecore.com/topic/7279 has some directions.

    When my Apple TV arrived, it had 4.4.4, but 5.0 was already out and Apple stopped signing earlier 4.x firmware, so I couldn't get the blobs from Tiny Umbrella. I did get the blobs from iFaith, and tried following some directions to get it to work, but iTunes kept giving errors, and by the end it wouldn't even boot; I had to then update to 5.0. I had pretty much resigned myself to using my iPad to send Plex via airplay to the ATV. Then I found these directions, and decided to give it one last shot last night; it actually worked! I managed to install jailbroken 4.4.4 over 5.0, and now have Plex on my ATV :D

    I hope this is helpful to anyone still on clean 4.4.4, or on 5.0 with iFaith blobs for 4.4.4!


    Thanks heaps for all the info. I'll definitely give that a go then get Plex installed. Cheers....,,
  • aartilesaartiles Posts: 1Members
    Hello,

    I have an Apple TV with firmware 4.2.1 (2010). Are there any way to upgrade to 4.3 or 4.4 and not 5.x ??
  • rimpy69rimpy69 Posts: 72Members, Plex Pass Plex Pass
    Maybe this will help
    AppleTV 5.0 Update now available, support for latest iOS 5.1
    http://blog.firecore.com/7437
  • benbraerbenbraer Posts: 2Members, Plex Pass
    How long shall it take untill PLEX us available for this version?
  • AlexmacAlexmac Posts: 81Members
    it takes as long as it takes. Just give Tobias some time, he's getting seasonpass when its published, so its been 2 days or something
    ?
    Just give him some time =)
  • benbraerbenbraer Posts: 2Members, Plex Pass
    Go Tobias! God Speed to you! :)
  • djmayhemdjmayhem Posts: 70Members, Plex Pass Plex Pass
    Word is plex does work, with a few bugs. Yaaaa! Happy sunday!
  • paljoluntapaljolunta Posts: 3Members, Plex Pass Plex Pass
    edited April 2012
    Plex is indeed working! Just got my first atv and plex works just fine on 5.0. The automatic appinstaller didnt work but method 2 still works. Plex even finds servers shared to me! Only seen plex running on 4.4.4 before and i think it runs smoothly now except for a few ui bugs which I dont mind.

    Great job tobias! Keep up the great work on plex!
  • plexberryplexberry Posts: 211Members ✭✭
    hi there

    this is all great!

    However when I try to run the installer - following your clear instructions (cd then space then drag file in terminal) I hit enter and terminal tells me there is no such directoy.

    What should I do?

    thanks
    Thank you to all who have built Plex up to what it is... it has changed my movie viewing experience!
  • paljoluntapaljolunta Posts: 3Members, Plex Pass Plex Pass
    plexberry wrote:

    hi there

    this is all great!

    However when I try to run the installer - following your clear instructions (cd then space then drag file in terminal) I hit enter and terminal tells me there is no such directoy.

    What should I do?

    thanks


    Use method #2 in the beginning of this topic
  • I keep getting hung up on awkwardtv.dyndns.tv not resolving. Is there a way I can download the packages to my own internal webserver and tell it to get it from there instead of this obscure host that is unresolvable in DNS?

    Thanks!
  • I think I am going to revert my AppleTV to the original non jailbroken status. I tried both method #1 and method #2 and now when I power up my Apple TV its now showing the connect to a USB errror. What a waste of time to just get this crappy program to work.
  • buggerbugger Posts: 176Members
    How do I install Plex on my atv 2gen, wich I already use atv flash?
    please :/
Sign In or Register to comment.