Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Jailbreaking and Installing Plex on your ATV2

123578

Comments

  • betocamarabetocamara Members Posts: 2
    edited May 2012
    Anyone knows how to solve the icon problem? Also everything seem to be very slow...
  • maxcracksmaxcracks Members Posts: 1
    Hi new to this

    Have just started to follow instructions

    as per youtube video: image

    I cant get my ATV2 to go to "DFU" mode? (as described @3.10 in video)

    Have tried several times

    White light flashes as I hold down remote keys, but as I release nothing, with no response on iMac screen (SeasOnPass window as described in video)

    I hope I'm being clear enough to get some help!
  • mahjongnewsmahjongnews Members Posts: 35
    edited May 2012
    maxcracks wrote:

    I cant get my ATV2 to go to "DFU" mode? (as described @3.10 in video)
    I hope I'm being clear enough to get some help!


    You might want to try with with the power cord connected to the ATV.
  • loldevloldev Members Posts: 2
    I have a ATV2 jailbroken on Firmware 4.2.2(2203) how can I upgrade it to 4.3 or 4.4 without using the apple software update?
  • danielddanield Members Posts: 3
    I just picked up an AppleTV 2 with the purpose to use it with plex on the bedroom TV.

    Please be patient as I am an absolute Apple noob with this being my first ever iDevice.


    So im having a little trouble starting of the whole jailbreaking thing. My ATV appears to be running 4.4.3, I thought this inituially a good thing however I can't seem to fully understand if I should be keeping it on 4.4.3 or going to 4.4.4.

    Question#1 - If I was to upgrade the firmware at all, how is it done? Im assuming itunes, but Ive never seen the ATV appear in itunes as a device (although Ive only installed itunes today and not familiar with it, so might be doing something wrong)

    I'm also very worried about accidently updating as Ive spent all day trying to put it into DFU mode.

    Question#2 - I have managed grabbed the Blobs with both TinyUmbrella and iFaith however can someone clarify if this still helps to put my device back to 4.4.3 now with Apple not signing older versions, does this effect this step?




    Question#3 - At the first step of the SeasOnPass process it downloads the ipsw, it appears to be version 5.0, is there anyway i can accidently update the firmware with this process? And is it suppose to take hours to download? It is downloading Apple TV2.1_5.0_9B206f_Restore.ipsw and is currently at about 30% after 7 hours. Is there a quicker way to do this or should I just let it go and get back to it in the morning?
  • JSBhopalJSBhopal Members Posts: 3 ✭✭
    I just want to second that Plex is working only ATV2 running 5.1. Even though it says 'unsupported' on the firecore site. Just jailbreak as usual then install plea using the 2nd method. Also for those having problems putting it in DFU mode, Make sure the POWER cord is in! Enjoy!!
  • damac3damac3 Members, Plex Pass Posts: 7 Plex Pass
    edited May 2012
    I am running 5.0 and have Plex installed on two ATV2's. Both will play TV shows, but neither will play any movies. Plex won't even open either of my movie shares but will open and play files in both of my TV Show shares (I have separate shares for Movies & TV shows for kids, but everything is shared on my Drobo).

    I have XBMC & the Firecore movie player also installed, and they will both play my movies. But I much prefer Plex.

    Anybody else having this problem?
  • yvvvvvyvvvvv Members Posts: 33
    edited May 2012
    I run Plex on my Apple TV 2 with iOS 5.0.1. Jailbroken with FireCore, then installed Plex through SSH (Plex wiki on Apple TV). The icon will be missing from the menu, so check out this thread to install one: http://forums.plexapp.com/index.php/topic/40411-fire-core-15/page__st__20

    damac3, you say that Plex in Apple TV won't even open your movie shares (folders) in your Plex Media Server. Have you tried removing these shares from PMS and resetting them and/or removing your server from the Server List and resetting it? I have 2 shares in my PMS, Movies and TV Shows and they both show up fine on Plex Apple TV. Are the file types much different between your shares? Most of my TV shows are in avi and my Movies in mp4.
  • damac3damac3 Members, Plex Pass Posts: 7 Plex Pass
    Yes, I have removed the shares and added them again. Most of my movies are H264, but so are a lot of my TV Shows. It would be one thing to not play most of them, but Plex won't open any share designated as movies. I have 3 movie shares - Movies, Kids Movies, and SK Movies (Stephen King movies, wanted them separate because I am a fan of his and have about 30 movies based on his books). None of them will even open, and almost all the Kids Movies are AVI.

    In my home I have Plex on two iPads, one iPhone, and another Mac, and the problem only exists on the ATV2's. With all these devices running Plex, it is so much handier to use it. Plus, I prefer Plex greatly over the alternatives.


    Yves B. wrote:

    I run Plex on my Apple TV 2 with iOS 5.0.1. Jailbroken with FireCore, then installed Plex through SSH (Plex wiki on Apple TV). The icon will be missing from the menu, so check out this thread to install one: http://forums.plexapp.com/index.php/topic/40411-fire-core-15/page__st__20

    damac3, you say that Plex in Apple TV won't even open your movie shares (folders) in your Plex Media Server. Have you tried removing these shares from PMS and resetting them and/or removing your server from the Server List and resetting it? I have 2 shares in my PMS, Movies and TV Shows and they both show up fine on Plex Apple TV. Are the file types much different between your shares? Most of my TV shows are in avi and my Movies in mp4.
  • The_LonzThe_Lonz Members Posts: 4
    edited May 2012
    Hi Guys, I'm having some major difficulties.

    I have Plex 0.9 running on my ATV2 (4.4.4) and it was running fine till the other day. Now it won't connect to my PMS. So I tried removing and reconnecting my server. No joy however.

    As version .10 is now available I thought I'd update that, but when I go to ssh into my ATV2, after I enter the IP address, it just times out and doesn't even give me to option to enter the password.

    So, I thought fine I'll just start from the very beginning, restore my ATV to factory settings and go from there. But no, it won't even let me do that, "Apple TV can't download the latest update right now. Try again later". AAAAAAAAARRRRRRRRRRRRRRGGGGGGGHHHH!

    Any help would be great,
    Lonz

    EDIT: Well I've managed to restore my ATV and updated it to 5.0.1. Haven't jailbroken it yet. Is it worth trying to run .10 or should I wait for the update?
  • HealeydaveHealeydave Members, Plex Pass Posts: 279 Plex Pass
    edited May 2012
    Warning:
    If you follow the links in the first post to download Seas0nPass, you will end up with a version that thinks its clever to update your ATV2 to the latest 5.1.1 Tethered iOS without any warning, as I have just found out to my dismay!!!

    I had a ATV2 on 4.2 which was perfectly jailbreakable to an untethered iOS, as I hadn't done one for a while, I just came to this thread for a refresher and followed the links to Seas0sPass.

    I can't believe the writers of Seas0nPass don't just push the latest untethered version of iOS by default and only go newer if the users specifically overrides it to do so!!!!!

    I've jailbroken a few ATV's over the years, I'm no novice, but I didn't expect Seas0nPass to go all out and push a tethered update to a unit that's perfectly suitable to go incremental keeping an untethered jailbreak!!
    I was f***ing furious initially as having only just acquired this ATV2, I don't have any older SHSH blobs as Apple are no longer signing, so I am unable to repair the damage done by Seas0nPass :-(

    The only saving grace is Absinthe 2.0 should be out this week according the the blogs which promises and untethered JB for ATV2, phew, can't wait.
  • MarisArbidansMarisArbidans Members, Plex Pass Posts: 22 Plex Pass
    Hi

    I have one problem. Today i discover that in my Apple TV 2gn aTV flash black (version 1.5) in maintaince extra settings available install Plex client. I cant do it. Every time its stop/crash instaling. Where is problem?
  • Trial_MasterTrial_Master Members Posts: 15
    edited May 2012
    Hello

    I have a tethered jailbreak on ATV2 5.0 (4099). Apart from the GUI issues Plex runs fine. Has anyone upgraded to 5.1.1 and can confirm Plex still works? I would like to upgrade to the soon to be released un-tethered JB but only if Plex won't be affected.

    Thanks in advance
  • mikethewxguymikethewxguy Members Posts: 11
    Going through the UNTETHERED jailbreak on ATV2 5.1 that was just released. Using METHOD 2; I can only get to 37%:

    Last login: Fri May 25 17:49:46 on ttys001
    mikes-imac-office:~ iMacMike2011$ cd '/Users/iMacMike2011/Downloads/PlexATV-plex-atv-installer-6794404/' && '/usr/bin/pythonw' '/Users/iMacMike2011/Downloads/PlexATV-plex-atv-installer-6794404/plex-atv-installer.py' && echo Exit status: $? && exit 1
    Usage: plex-atv-installer.py [options] command

    plex-atv-installer.py is a easy way to install plex-atv on your
    Apple TV (Gen 2). If you want to install just
    run ./plex-atv-installer.py install.

    Commands:
    install - install plex-atv
    upgrade - attempt to upgrade plex-atv
    remove - remove plex-atv
    status - print status and version of plex-atv
    removesettings - remove settings for plex-atv

    mikes-imac-office:PlexATV-plex-atv-installer-6794404 iMacMike2011$ ./plex-atv-installer.py install
    !Logging in (root:alpine@apple-tv.local)
    !connected
    !install repo
    !updating sources (might take a while)
    !looking for updates
    !new version is 0.10.0.101-49431c03
    !restarting AppleTV process
    !done - no errors
    mikes-imac-office:PlexATV-plex-atv-installer-6794404 iMacMike2011$ ./plex-atv-installer.py -b beta install
    !Logging in (root:alpine@apple-tv.local)
    !connected
    !updating sources (might take a while)
    !looking for updates
    !!failed to install: apt-get update
    Ign http://nightlies.plexapp.com beta Release.gpg
    Ign http://www.ambertation.de ./downloads/PLEX/ Release.gpg
    Ign http://mirrors.xbmc.org ./ Release.gpg
    Hit http://nightlies.plexapp.com beta Release
    Ign http://www.ambertation.de ./downloads/PLEX/ Release
    Ign http://mirrors.xbmc.org ./ Release
    Ign http://nightlies.plexapp.com beta/main Packages/DiffIndex
    Hit http://apt.saurik.com tangelo-3.7 Release.gpg
    Get:1 http://www.ambertation.de ./downloads/PLEX/ Packages [2239B]
    Hit http://nitosoft.com Release.gpg
    Hit http://apt.thebigboss.org stable Release.gpg
    Hit http://apt.modmyi.com stable Release.gpg
    Hit http://apt.awkwardtv.org stable Release.gpg
    Ign http://nightlies.plexapp.com beta/main Packages
    Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
    Hit http://apt.saurik.com tangelo-3.7 Release
    Ign http://nightlies.plexapp.com beta/main Packages
    Hit http://apt.thebigboss.org stable Release
    Hit http://nitosoft.com Release
    Hit http://mirrors.xbmc.org ./ Packages
    Hit http://nightlies.plexapp.com beta/main Packages
    Ign http://apt.saurik.com tangelo-3.7/main Packages/DiffIndex
    Get:2 http://apt.modmyi.com stable Release [1341B]
    Ign http://nitosoft.com Packages/DiffIndex
    Hit http://apt.saurik.com tangelo-3.7/main Packages
    Get:3 http://apt.thebigboss.org stable/main Packages [925kB]
    Hit http://nitosoft.com Packages
    Get:4 http://apt.modmyi.com stable/main Packages/DiffIndex [42.0kB]
    Hit http://cydia.zodttd.com stable Release.gpg
    Hit http://apt.awkwardtv.org stable Release
    Hit http://cydia.zodttd.com stable Release
    Hit http://apt.awkwardtv.org stable/main Packages/DiffIndex
    Get:5 http://cydia.zodttd.com stable/main Packages [1419kB]
    Ign http://cydia.zodttd.com stable/main Packages
    Ign http://cydia.zodttd.com stable/main Packages
    Get:6 http://cydia.zodttd.com stable/main Packages [1765kB]
    35% [6 Packages 485kB/1765kB 27%] 1350B/s 33min 19sapt-get install --yes --force-yes com.plex.client-plugin
    36% [6 Packages 553kB/1765kB 31%] 2255B/s 19min 26sdpkg -s com.plex.client-plugin
    37% [6 Packages 570kB/1765kB 32%] 2475B/s 17min 36s!!
    mikes-imac-office:PlexATV-plex-atv-installer-6794404 iMacMike2011$


    What should I do? Just keep trying? Or am I doing something wrong?

    Thanks
  • HealeydaveHealeydave Members, Plex Pass Posts: 279 Plex Pass
    edited May 2012
    @mikethewxguy

    Using method 2 , I got to "get 23" but it stalled so I aborted and tried again, now I'm struggling to get past "get 4".

    You'll notice it gathers updates from various sources and probably because of all the jailbreaking going on today with the new absinthe release, some of the sources are probably struggling under the load!

    Whats annoying is this procedure seems really in-efficient in that whatever stage it gets to, it starts all over again when you have to abort it. That's not helping the servers or the end users trying to get updates!!

    By the way, you can always skip the Package Updater in step 4 and proceed to install the Plex Client to have a play around.

    It may not run too well if its dependent on some Package updates but you can always run the "apt-get update" on its own later when the servers have cooled down!
  • mlazarinmlazarin Members Posts: 8
    Just jailbreaked to 5.0.1 (5.1.1) untethered, installation through Firecore worked well, and manually as well (I tried to update to the last version). Tried few films, no issues until now on playing them. The only point I observed is that if I choose GRID in the view options, it simply does nothing. If I choose LIST, works like a charm.
    Browsing the forum to see if I find something about this.
    Good luck!!
  • MrPhilMrPhil Members Posts: 111 ✭✭
    Trying method one, the drag and drop of the folder to terminal with the CD command, just produces - "no such file or folder"

    So trying method two, I get to...

    Get:4 http://apt.thebigboss.org stable/main Packages [925kB]
    Get:5 http://apt.awkwardtv.org stable/main Packages [21.7kB]
    Get:6 http://apt.modmyi.com stable/main 2012-05-26-1448.29.pdiff [242B]
    Get:7 http://apt.modmyi.com stable/main 2012-05-26-1448.29.pdiff [242B]
    Get:8 http://apt.modmyi.com stable/main 2012-05-26-1448.29.pdiff [242B]
    Get:9 http://cydia.zodttd.com stable/main Packages/DiffIndex [53.0kB]
    99% [4 Packages bzip2 0B]

    and it then just sits there forever

    Am I doing something wrong or can some one tell me how to use the CD command in method 1 ?

    Thanks

    Phil
  • azmodemanazmodeman Members Posts: 12 ✭✭
    When I try to get into the ssh root thru the terminal I keep getting this error message.




    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    d1:d9:ec:d9:07:f8:ea:c8:fb:24:53:14:da:74:82:71.
    Please contact your system administrator.
    Add correct host key in /Users/TimsMacBook/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/TimsMacBook/.ssh/known_hosts:2
    RSA host key for 10.0.1.8 has changed and you have requested strict checking.
    Host key verification failed.

    I have not seen this before and lost on what to do.
  • jmcgeejrjmcgeejr Members, Plex Pass, Plex Ninja Posts: 2,997 Plex Ninja
    azmodeman wrote:

    When I try to get into the ssh root thru the terminal I keep getting this error message.




    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    d1:d9:ec:d9:07:f8:ea:c8:fb:24:53:14:da:74:82:71.
    Please contact your system administrator.
    Add correct host key in /Users/TimsMacBook/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/TimsMacBook/.ssh/known_hosts:2
    RSA host key for 10.0.1.8 has changed and you have requested strict checking.
    Host key verification failed.

    I have not seen this before and lost on what to do.


    It's because you updated the firmware on the atv, quickest and easiest is to just delete the known_hosts file and reconnect, the dirty way is to go in and remove the d1:d9:ec:d9:07:f8:ea:c8:fb:24:53:14:da:74:82:71 key from the file.

    JR
  • azmodemanazmodeman Members Posts: 12 ✭✭

    It's because you updated the firmware on the atv, quickest and easiest is to just delete the known_hosts file and reconnect, the dirty way is to go in and remove the d1:d9:ec:d9:07:f8:ea:c8:fb:24:53:14:da:74:82:71 key from the file.

    JR



    Thanks.
Sign In or Register to comment.