Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Jailbreaking and Installing Plex on your ATV2

123468

Comments

  • BamboozleBamboozle Members, Plex Pass Posts: 69 Plex Pass
    Hi,

    new to jailbreaking therefor maybe a stupid question.

    Just updated my ATV2 to the latest untethered jailbreak. Worked fine. I was just a little surprised that all my previous settings (in plex and MLB and the ATV2 itself) were gone after the update.

    Is this normal and is there a way to preserve all the settings?
  • MarisArbidansMarisArbidans Members, Plex Pass Posts: 22 Plex Pass

    Hi

    I have one problem. Today i discover that in my Apple TV 2gn aTV flash black (version 1.5) in maintaince extra settings available install Plex client. I cant do it. Every time its stop/crash instaling. Where is problem?



    I secesfully install Plex cleint via FireCore Maintance setting, but Plex wont open corently. Some times it shows my added server list but sometimes not. Sometimes i can open some movie folders, sometimes not!!!??
  • salisdsalisd Members, Plex Pass Posts: 5
    New to all this. Trying to get PLEX up and running on ATV2
    Followed marklight instructions at beginning of this post.
    Jailbreak OK -- but inadvertently upgraded to 5.1 in the process of jailbreaking w/ Seasonpass.
    Had trouble SSH'ing w/ puTTY and WinSCP on my Windows 7 PC. Would not accept "alpine" password. Downloaded SSH Terminal on iPad and seemed to work.
    Followed marklight Method 2 instructions -- no major error messages in SSH terminal -- but after "killall" command my ATV2 doesn't boot (just get apple logo screen and nothing else happens).
    Tried this to reinstall:
    apt-get remove com.plex.client-plugin
    apt-get update
    apt-get install com.plex.client-plugin=0.0.9.0.0-312c11b0

    and also tried:

    apt-get install com.plex.client-plugin=0.10.0.101-49431c03

    Nothing seems to happen after the install command -- just immediately goes back to "root#" command.
    Apple TV still not booting up.
    What did I do wrong? Any help/direction for newbie would be appreciated. Thx.
  • marklightmarklight Members, Plex Pass Posts: 1,006 Plex Pass
    I'd caution everyone on installing plex with iOS 5 - it does work with the manual install method (2) but it's unreliable. Once the app is updated I'll adjust the guide. Also, the code to remove certain sections no longer is applicable .
  • PCKidPCKid Members, Plex Pass Posts: 106 Plex Pass
    marklight wrote:

    I'd caution everyone on installing plex with iOS 5 - it does work with the manual install method (2) but it's unreliable. Once the app is updated I'll adjust the guide. Also, the code to remove certain sections no longer is applicable .


    Even with the Manual install after a few good runs all of a sudden it decides not to work and you have to manually remove it and re install it. I've done this five times and given up for now.
  • archduk3archduk3 Members, Plex Pass Posts: 28 Plex Pass
    5.0.2 has several issues I guess.

    Firecore just recently updated and Plex seems to be vanished. I was running 4.4.4 before so I was due for an update. But now nothing appears except "Computers" and "Settings"

    Is there a way to force FireCore to update to 5.0.1 instead? or just 5.0?

    I do still have the 4.4.4. update but it has been acting up real strange lately....

    //C
  • dherktdherkt Members, Plex Pass Posts: 9 Plex Pass
    maxcracks wrote:

    Hi new to this

    Have just started to follow instructions

    as per youtube video: image

    I cant get my ATV2 to go to "DFU" mode? (as described @3.10 in video)

    Have tried several times

    White light flashes as I hold down remote keys, but as I release nothing, with no response on iMac screen (SeasOnPass window as described in video)

    I hope I'm being clear enough to get some help!



    Mate, after spending DAYS on this, download ireb v5, plug it in (usb), wait for itunes to recognise the ATV, then run ireb. You are stuck in a recovery loop like i was. the single most painful period of my life.
  • Redw28Redw28 Members Posts: 9
    salisd wrote:

    New to all this. Trying to get PLEX up and running on ATV2
    Followed marklight instructions at beginning of this post.
    Jailbreak OK -- but inadvertently upgraded to 5.1 in the process of jailbreaking w/ Seasonpass.
    Had trouble SSH'ing w/ puTTY and WinSCP on my Windows 7 PC. Would not accept "alpine" password. Downloaded SSH Terminal on iPad and seemed to work.
    Followed marklight Method 2 instructions -- no major error messages in SSH terminal -- but after "killall" command my ATV2 doesn't boot (just get apple logo screen and nothing else happens).
    Tried this to reinstall:
    apt-get remove com.plex.client-plugin
    apt-get update
    apt-get install com.plex.client-plugin=0.0.9.0.0-312c11b0

    and also tried:

    apt-get install com.plex.client-plugin=0.10.0.101-49431c03

    Nothing seems to happen after the install command -- just immediately goes back to "root#" command.
    Apple TV still not booting up.
    What did I do wrong? Any help/direction for newbie would be appreciated. Thx.


    Hi,

    I'm pretty sure I did the same thing yesterday. I had to JB mine again and after the killall command I had the 'Plug into iTunes' logo. So I clicked on tethered boot and it ran through a few automated steps and then it was done.

    As is documented here though, there seem to be problems with this version on IOS 5.1.1.. I had to manually add the server which was ok but whilst I can now see the server and select the programs, they won't actually play. I guess we are waiting for the updated version marklight is referring to.
  • dcmicdcmic Members, Plex Pass Posts: 5 Plex Pass
    I have a few questions having just discovered Plex today. I recently bought an ATV2 v5.0.2. It had been jailbroken with Sn0breeze, no idea what version.(how can I find this info). I had been trying to use XBMC to stream the media on my HD, but couldn't get it to access the HD without a user/password. Some kind of bug I couldn't find a solution for. So in my search I found Plex. I was somehow able to install it on my ATV using Nitro (it is called a PLEX client for Lowtide (beta)). Installed the client on my PC fine and found my media.

    Using Plex I was able to find my server and my media folders. Here is where I have my problem. When I click on one of my media folders, the little circle starts spinning as if it is searching and after about a minute it kicks me back to the ATV main interface. It doesn't matter what folder I choose it always kicks me back.

    Any suggestions/solutions would be appreciated.

    Thanks
  • josh@jab.fmjosh@jab.fm Members, Plex Pass Posts: 133 Plex Pass
    ThomasHW has already covered that in Build: 0.10.0-b0b2ed28

    First Post on the page:

    http://forums.plexapp.com/index.php/topic/46519-plex-update-01000-b0b2ed28/

    dcmic wrote:

    I have a few questions having just discovered Plex today. I recently bought an ATV2 v5.0.2. It had been jailbroken with Sn0breeze, no idea what version.(how can I find this info). I had been trying to use XBMC to stream the media on my HD, but couldn't get it to access the HD without a user/password. Some kind of bug I couldn't find a solution for. So in my search I found Plex. I was somehow able to install it on my ATV using Nitro (it is called a PLEX client for Lowtide (beta)). Installed the client on my PC fine and found my media.

    Using Plex I was able to find my server and my media folders. Here is where I have my problem. When I click on one of my media folders, the little circle starts spinning as if it is searching and after about a minute it kicks me back to the ATV main interface. It doesn't matter what folder I choose it always kicks me back.

    Any suggestions/solutions would be appreciated.

    Thanks
  • bananacatbananacat Members Posts: 3
    my install get stuck here


    Err http://awkwardtv.dyndns.tv ./ Release.gpg
    POSIX: Operation timed out
    Ign http://awkwardtv.dyndns.tv ./ Release
    99% [Connecting to awkwardtv.dyndns.tv]


    Can anyone help me?
  • josh@jab.fmjosh@jab.fm Members, Plex Pass Posts: 133 Plex Pass
    Have you tried with the latest revision 0.10.107?

    http://forums.plexapp.com/index.php/topic/47779-plex-010107/

    bananacat wrote:

    my install get stuck here


    Err http://awkwardtv.dyndns.tv ./ Release.gpg
    POSIX: Operation timed out
    Ign http://awkwardtv.dyndns.tv ./ Release
    99% [Connecting to awkwardtv.dyndns.tv]


    Can anyone help me?
  • MicarlMicarl Members Posts: 10 ✭✭
    edited October 2012
    Freshly Jailbroken my ATV2 to 5.0.2_9B830 and after installing Plex 10.107 it just won't display ATV menu.

    If I run apt-get remove com.plex.client-plugin I get my ATV menu back without Plex.

    Any solutions without doing another fresh Jailbreak?

    Thanks

    *Edit - Another attempt at doing a fresh jailbreak has solved the issue.
  • crlieutenantcrlieutenant Members Posts: 15 ✭✭
    edited October 2012
    Micarl wrote:

    Freshly Jailbroken my ATV2 to 5.0.2_9B830 and after installing Plex 10.107 it just won't display ATV menu.

    If I run apt-get remove com.plex.client-plugin I get my ATV menu back without Plex.

    Any solutions without doing another fresh Jailbreak?

    Thanks

    *Edit - Another attempt at doing a fresh jailbreak has solved the issue.

    I had a similar experience yesterday. I used seas0n pass to jailbreak and install 5.0.2 and confirmed that the apple tv2 was working without plex. Then I insrtalled plex using instructions for 0.10.107. I confirmed that the correct version of ios and plex were installed, however after the appletv went to sleep, I was unable to get back to the apple tv menu. The device seemed to go into an endless series of reboots. Occasionally the apple tv starting logo would appear then the screen would turn to total blackness.

    I could see the LED cycling on and off as if trying to reboot. I tried everything I could think of. I tried unplugging the apple tv and that didn't work. I tried removing the plex plugin via ssh but no luck. I jailbroke and reinstalled plex v0.10.107, five different times with the same results. Finally, I decided to jailbreak and install plex 0.10.106 and what do you know!!! No more reboot into blackness. Everything seemed to work as it should using plex 0.10.106.

    I see lots of reports that people are enjoying appletv 5.0.2 with plex 0.10.107 but for me there was no joy.

    Hope this may save someone else the headache I went through.
  • MicarlMicarl Members Posts: 10 ✭✭
    On my freshly Jailbroken ATV I installed 0.10.107 without a hitch, but when I tried yesterday I was getting the same issues as you were with the ATV rebooting itself on start up.
    It could have something to do with the instructions I had used from the previous beta thread where you had to run 'apt-get update', 'apt-get -f install' before installing the beta on a freshly Jailbroken device - now this isn't necessary but I tried it using that first. All seems to be ok following the instructions for 0.10.107 after a fresh Jailbreak.
  • crturboguycrturboguy Members, Plex Pass Posts: 6 Plex Pass
    I tried to JB my ATV2 using the instructions found in this post: http://forums.plexapp.com/index.php/topic/47777-how-to-upgrade-ios-plex/ and I had no luck getting it to install, I kept getting errors about my device not being eligible for that version of software. I have my SHSH blobs saved with TinyUmbrella and even tried running the SHSH server, but it wouldn't update. Anyone else running into this?

    --JOsh
  • MicarlMicarl Members Posts: 10 ✭✭
    Jailbreak with Seas0nPass then install 0.10.107 using the instructions in the pinned 0.10.107 thread.
  • ristakisristakis Members Posts: 1
    Hagbard88 wrote:

    Hi, i just bought an ATV2 and it came with Software 4.4.3 (3323). Then i just downloaded and installed itunes (haven´t any account nor apple id. does this matter?) and got seas0npass and an orginal firmware file with version 4.3 (i want to try this for plex).
    I startet seas0npass and did a shift-Click on Create-IPSW and gave him the AppleTV2,1_4.3_8F455_Restore.ipsw file .... he does as been told and created the custom firmware and after i got the ATV in DFU mode, itunes tried to install the CF. But i always get the error 3194.
    Yes, my hosts file is fine. No entry facing an apple server.
    I tried to reboot and tried another windows client. No success.

    Is there an error with apple signing this CF?
    Can anyone help?

    Hi Hagbar88.
    All step to Jailbreak your Apple Tv goo hire to this link Jailbreak the Apple TV 2G SeasOnPasshopes streams helped you.:)
  • HomieXHomieX Members Posts: 8
    edited October 2012
    For me .107 is the most unstable version so far...
    I cant even start PLEX on my ATv b4 it rebots :(
    after that it goes in to endless bootloop and i have to pull powercord to make it stop...

    I have tried to do a fresh install through iTunes after that jailbreak with latest seasonpass then install PLEX again ---> Fails still the same.
    Tried install fresh jailbreak with seasonpass directly after what i mentiond above, still no go !


    Looks like i have to wait for a more stable jailbreak version b4 PLEX will work properly again.

    Or another update for the PLEX client...


    /Homie
  • crlieutenantcrlieutenant Members Posts: 15 ✭✭
    edited October 2012
    HomieX wrote:

    For me .107 is the most unstable version so far...
    I cant even start PLEX on my ATv b4 it rebots :(
    after that it goes in to endless bootloop and i have to pull powercord to make it stop...

    I have tried to do a fresh install through iTunes after that jailbreak with latest seasonpass then install PLEX again ---> Fails still the same.
    Tried install fresh jailbreak with seasonpass directly after what i mentiond above, still no go !


    Looks like i have to wait for a more stable jailbreak version b4 PLEX will work properly again.

    Or another update for the PLEX client...


    /Homie

    I was having same problem as you after installing .107. I did a fresh jailbreak and installed .106. Now I am able to use plex until the next version comes out.

    I hope you didn't install the latest firmware from itunes. If you did, then it may be to late for you since there is no jailbreak yet for Apple TV firmware 5.1
Sign In or Register to comment.