If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Stuttering Video to LG / Samsung TV's

stottmstottm Posts: 32Members, Plex Pass Plex Pass
Some video formats stutter
I think there is a possible transcode problem for Samsung & LG TV's. Judging from what I saw in the forums and my own experience with a Samsung TV. Either the video is not being transcoded (very possible) and the third party Plex client takes what is given but the TV itself chokes on the video or it is transcoded but some video / audio codecs are not taken into account. Newer TV / BD Players have fewer problems because of more powerful CPU's or improved codec support. Most of the problematic files are bluray rips either 720 or 1080. DTS Sound and usually x264.

I bought a Samsung UN55D6000 TV and managed to get the Plex Laika SmartTV App installed. However, some files skip, pause, stutter and sometimes hang and crash/reboot the TV. Basically unwatchable. The same files play fine on iPad and Mac Plex clients. I found that the Open Source Serviio DLNA app for OS X seems to have no trouble with any of the files. Then I dug deeper and found that Serviio has transcoding and even provided an XML file with many profile settings for various TV sets. This might help transcode video files in a format that will work with Samsung / LG TV's that have trouble with certain video files.

For example, the attached XML file explains in detail how a particular video / audio formatted file gets transcoded for a particular TV set's DLNA feature. Now, I know we are not using DLNA but if it works for DLNA than it should work for the third party Plex App on Samsung and even LG. So what I am proposing is adding some options to the PMS to transcode for specific TV's. Such as Samsung C/D and BD players. I don't recommend doing more than what the client supports. I can only assume that the PMS can see which clients are connecting and adjust it's stream for each appropriately. The XML file just shows the video / audio input and output settings for a given TV. Profile ID's are inherited to the child levels so Profile ID 4 inherits from ID2 which inherits from ID1, etc. profiles.xml

I am not sure exactly what's going on inside the PMS but it is transcoding for the iPad / Android clients and perhaps it is trying to just transmit with no transcoding to other devices. May need to add more transcoding profiles for the LG / Samsung Plex clients, specifically audio and perhaps some video settings.

The PMS already includes a checkbox to Enable DTS mix-down for Media Link (LG) clients. So hopefully, you can add some default behavior for the Samsung Smart TV Plex Client as well as the LG Plex Client. The problem appears to be a transcode issue more than anything else. The forums are full of discussions about WiFi and networks, etc. If DNLA works flawlessly but Plex stutters, than something else is going on, the network is not at fault. Some users with very new TVs/BD Players have fewer issues but it is suspected they have more powerful CPU's in their TVs /BD Players and the newer devices might even support the video/audio codecs that cause earlier models to choke and sputter.

If you have some need for me to collect advanced data let me know, I will be willing to assist. Just let me know how to obtain what you need. I will be trying to convert some of these files that are causing trouble and seeing what happens afterwards. i.e. running Shaun of the Dead through Handbrake and seeing if it plays better. This one had extreme stuttering. I will start collecting details on each of the video files that have trouble.

Others following this new thread... I defer all to the Plex developers, they know best. I am just trying to collect data and assist in a quest for a solution. If you have an LG or Samsung TV. You can post your experience but include useful information like Make/Model of TV, what runs your PMS (Windows, Mac, Linux) and the file specs of the files that choke and stutter. I.e. technical details like Bitrate, Resolution, Video / Audio Codecs, etc.


  • stottmstottm Posts: 32Members, Plex Pass Plex Pass
    After using Handbrake to convert Shaun of the Dead to AppleTV2 & MKV container, it's working fine with Plex. The Shaun of the Dead original was 720p DTS x264 file and it stuttered very badly with Samsung Plex. A Tron Legacy 1080p Bluray pauses and caches with a loading prompt under DLNA as well as Plex. So this one appears to be too big to stream quickly. Currently running it through Handbrake as the AppleTV2 setting and changed to custom by making it MKV instead of M4V container. This should downscale it to 720dpi. Seems this particular TV might not be able to handle 1080p streamed video even over DLNA. I suspect the CPU in the TV is not powerful enough to handle the file on the fly and still grab more data from the stream quickly enough. Reports of others buying high end Samsung BD Players which are also SmartTV ready and having much better experience with 1080p files. However, Shaun of the Dead was not 1080p so it might be a codec problem still.

    I'll continue to dig and post findings as I go. I'll need to load up my handbrake queue and let it go on 10-15 videos overnight and see what I have for results.

    Not too worried about BluRay 1080p files with Plex. They are so large I typically go with 720p instead. Too much storage per file and too much bandwidth. Those with large 1080p libraries might have to opt for a more powerful TV / BD Player and perhaps an actual ethernet cable connection vs. WiFi. This was the reason Apple didn't go 1080p with their AppleTV2. The file storage, bandwidth, etc. is just a bit too much for most people. 720p is a nice HD alternative that is almost as good and has significantly smaller files.

    Perhaps there could be a PMS option to transcode 1080p -> 720p and some of the audio codecs like you already have for DTS issues under LG Media Link TV's. Obviously, you are transcoding the iPad and the iPad is certainly not 1080p capable. There should be a compromise for those with a stuttering problem on Samsung / LG TVs so they don't have to convert terabytes of video files.
  • stottmstottm Posts: 32Members, Plex Pass Plex Pass
    Ok further testing results:

    1) found my WiFi signal to be less than perfect and it fluctuated so I decided to switch to a NetGear Powerline converter (XAV1004 / XAV1002). i.e. convert 100MB to run over the power outlet. Initial setup out of the box worked great. Then it flaked out a bit so I dug deeper. Upgraded firmware on both Powerline boxes and setup security (encryption) then tried a different outlet. Now getting 80+ Mbps xfer rate and NetGear monitoring tool says HD Video as the quality.

    2) Was working fine for most of a day. This morning it's still stuttering even on 720p TV episodes. It will stutter, restart, freeze and the TV reboots. Signal quality is still very good with the Powerline to be truthful there is a visible improvement in launching Plex and changing screens. Loading time is many times faster. Yet it still stutters. Adjusting buffers in Plex seems to make little to no difference.

    3. Monitoring of the network connection shows it's stable and not losing bandwidth intermittently.

    Possible solution. Shutdown the PMS and purged the disk cache/etc. Using OS X w/Developer Tools installed - Purge command.

    purge(8) BSD System Manager's Manual purge(8)

    purge -- force disk cache to be purged (flushed and emptied)


    Purge can be used to approximate initial boot conditions with a cold disk
    buffer cache for performance analysis. It does not affect anonymous mem-
    ory that has been allocated through malloc, vm_allocate, etc.

    sync(8), malloc(3)

    Current status, working better than ever. Even 1080p is not stuttering!

    Possible PMS memory leak, etc? This may explain why it's working and stops working but after restarting PMS after a purge works or even a full reboot...

    I will continue to try to duplicate the resolution after it occurs a few more times. Trying not to do too many things at once until I narrow down what's working for me.
  • stewbaccastewbacca Posts: 1Members
    edited January 2012
    I'm having the same issues on 2 different Samsung TVs (models - UA46D7000 and UA55D7000) using the Plex Laika app where most mkv files will play fine but basic avi movie/tv show files (don't have specs sorry) will stutter and eventually crash not only either tv but my entire wifi network for about 2 mins. The files will play fine on the plex apps on an ipad, an iphone, and a macbook pro. My media server is running on an iMac. I have no other issues with my wifi network other than when I use the Plex Laika app.

    I haven't done much in regards to troubleshooting other than factory reset router, reinstall Plex Laika on both tv's and play with buffering settings on the app - none of which alleviates the issue.

    Hope this helps.
  • stottmstottm Posts: 32Members, Plex Pass Plex Pass
    Ok, final result after switching from WiFi to an Ethernet Powerline: Working better than ever! Even full on 1080p streams with zero stutter. So the entire stutter issue was a bandwidth problem for me. 100Mbps works fine, Gigabit Ethernet would be overkill. Older Samsung models have slower CPU's and may have more trouble with a WiFi network where signal strength varies.

    I have had some issues with certain AVI files, but that was a problem even prior to my Samsung TV purchase. I am on a Mac Plex Media Server and some AVI files just won't play.

    Those who state that it works on iPad and even a Plex PC/Mac client need to understand that the PMS downscales the video on the fly (transcode) for the specific client. Most are not even HD capable (iPad). Streaming the same video to a 1080p TV results in a more complete picture in full quality. I would say it is 4-10 times the number of pixels. The difference is clear.

    You need at least 60-100 megabits per second transfer speed for full HD video. Using the Powerline Netgear system there is a monitor app that lets you turn on security and QoS (Quality of Service) and monitor your bandwith. You may have to try other electrical outlets. Also make sure you have well grounded power outlets. Do not use a power strip with the Powerline Netgear. Be sure to upgrade the firmware on each Powerline device and update the monitoring software as well.

    If you can run Ethernet cable, then do it. It is better than the Powerline solution. Use at least CAT5e or CAT6 cable.
  • stottmstottm Posts: 32Members, Plex Pass Plex Pass
    Try converting the AVI files to h.264 mp4 or mkv. The video is streamed to the TV in full quality but when played on iPad, iPhone, and MacBook Pro the file is transcoded to a lower quality.
    The TV might have issue with the data format, video or audio, which explains the TV reboot. I have had Plex crash and reboot he TV but that was while navigating menus, so a software bug.

    stewbacca wrote:

    I'm having the same issues on 2 different Samsung TVs (models - UA46D7000 and UA55D7000) using the Plex Laika app where most mkv files will play fine but basic avi movie/tv show files (don't have specs sorry) will stutter and eventually crash not only either tv but my entire wifi network for about 2 mins. The files will play fine on the plex apps on an ipad, an iphone, and a macbook pro. My media server is running on an iMac. I have no other issues with my wifi network other than when I use the Plex Laika app.

    I haven't done much in regards to troubleshooting other than factory reset router, reinstall Plex Laika on both tv's and play with buffering settings on the app - none of which alleviates the issue.

    Hope this helps.
  • dan@htavpros.comdan@htavpros.com Posts: 8Members, Plex Pass
    Have similar issue with Samsung BD player - Files stored on Vortexbox server - running plex alongside(via vortexbox). All rips (dvd and Bluray) are raw vortexbox rips in MKV containers... directly ripped by the server (not copies of copies).

    In my testing here is what i have found...
    Using just the samsung bd to connect directly to the bluray files in the vortexbox results in stutter, until i use the audio button and select the NON-HD audio track, when i select just the simple 5.1 audio track everything is fine. Also, all DVD rips (which use only standard 5.1) work fine.

    With plex (Laika) installed on the same BD player, i get the stutter again when playing Bluray rips, unfortunately now i have no option to change the audio.

    I have old and new Samsung BD players (C series and D series) and have tested them both Wireless and Wired - It just the HD Audio codec that causes the issue, nothing else. Its simply a player codec limitation.

    When will the Plex AUDIO option finally be functional to correct this issue??? I have no intention of re-muxing/encoding/mirroring any files, imo I shouldn't have to.

    *On a side note: the WDTV LIVE media player plays all of the files and audio tracks perfectly, directly from server, without issue(Via wireless)! When can we get plex on that?!
  • Chris CChris C Posts: 11,811Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    The Samsung bluray player does not run the Plex "Laika" client. ("Laika" is the codename for the 0.9.5.x branch of the Mac/Win desktop "Plex Media Center" client.) Instead, the Samsung device runs a third-party client created specifically for the Samsung Smart Hub platform. If you're having issues with that client, then you'd be better off posting in the Samsung Smart Hub client forum.

    On a side note: The actual "Laika" client does support playback of DTS-MA/DTS-HD tracks, though since Apple does not have driver support for actual DTS-MA, it's actually the embedded core "DTS" stream that gets played. Dolby's TrueHD can't be played because, again, Apple does not provide driver support for it. In this case, though, TrueHD doesn't include an embedded core AC-3 track. Blurays using TrueHD should always include a separate AC-3 track, which should also typically be included when you rip the disc so that you have your bases covered.

    Need help? Having trouble?
    » Visit our Support Site for documentation, guides, and more - including the Getting Started section!
    » Attach Log Files when reporting issues // See how to attach files in the forums
    » Name and Organize your content correctly for best results

    (no private messages for support unless requested, please)

Sign In or Register to comment.